Skocz do zawartości


Zdjęcie

Fedora Core 7 Nie Mogę Zainstalować Skype


  • Zaloguj się, aby dodać odpowiedź
9 odpowiedzi w tym temacie

#1 pazdzioch23

pazdzioch23

    Użytkownik

  • Użytkownicy
  • 22 postów

  • Rejestracja: 21 maj 07

Napisano 18 styczeń 2008 - 23:15

Czytałem różne opisy dotyczące instalacji Skype ale nic z tych podpowiedzi mi nie pomogło.

Yum nie może mi wyszukać wógle Skype
CODE
yum install skype
Loading "priorities" plugin
0 packages excluded due to repository priority protections
Setting up Install Process
Parsing package install arguments
No package skype available.
Nothing to do



Jak ściągnąem Skypa dla FC5 i prubuję go zainstalować poleceniem:
rpm -Uvh skype-1.4.0.118-fc5.i586.rpm
To wyskakuje mi coś takiego:

Tomek]# rpm -Uvh skype-1.4.0.118-fc5.i586.rpm
CODE
ostrzeżenie: skype-1.4.0.118-fc5.i586.rpm: Nagłówek V3 Podpis DSA: NOKEY, key ID d66b746e
błąd: Niespełnione zależności:
libQtCore.so.4 jest wymagany przez skype-1.4.0.118-fc5.i586
libQtDBus.so.4 jest wymagany przez skype-1.4.0.118-fc5.i586
libQtGui.so.4 jest wymagany przez skype-1.4.0.118-fc5.i586
libQtNetwork.so.4 jest wymagany przez skype-1.4.0.118-fc5.i586
libsigc-2.0.so.0 jest wymagany przez skype-1.4.0.118-fc5.i586
qt4-x11 >= 4.2 jest wymagany przez skype-1.4.0.118-fc5.i586

  • 0

#2 dj_oko

dj_oko

    Ekspert

  • Użytkownicy
  • 987 postów

  • Rejestracja: 14 styczeń 06
  • Płeć:Mężczyzna
  • Skąd:Khrand'Oy

Napisano 19 styczeń 2008 - 01:29

Potrzebujesz QT w systeime - możesz pobrać też wersję Skype ze zintegrowanym QT.

A yum Skypea nie znajdzie - bo to zewnętrzne oprogramowanie i nie ma go w repozytoriach. Byłoby to sprzeczne z licencją, pomijając fakt że ten program jest śmieszny.
  • 0
I sold my soul and got a job watching people test for it.
Kamil

Microsoft Windows 8 Pro with Media Center x64 EN.

#3 pazdzioch23

pazdzioch23

    Użytkownik

  • Użytkownicy
  • 22 postów

  • Rejestracja: 21 maj 07

Napisano 19 styczeń 2008 - 22:48

Cytat(dj_oko @ 19 Jan 2008, 0:49 ) <{POST_SNAPBACK}>
Potrzebujesz QT w systeime - możesz pobrać też wersję Skype ze zintegrowanym QT.

A yum Skypea nie znajdzie - bo to zewnętrzne oprogramowanie i nie ma go w repozytoriach. Byłoby to sprzeczne z licencją, pomijając fakt że ten program jest śmieszny.


Zainstalowałem.
Ale nadal nie mam tego:
CODE
rpm -Uvh skype-1.4.0.118-fc5.i586.rpm
ostrzeżenie: skype-1.4.0.118-fc5.i586.rpm: Nagłówek V3 Podpis DSA: NOKEY, key ID d66b746e
błąd: Niespełnione zależności:
libQtGui.so.4 jest wymagany przez skype-1.4.0.118-fc5.i586
qt4-x11 >= 4.2 jest wymagany przez skype-1.4.0.118-fc5.i586

Tylko że tego nie mogę znaleźć.
A tego Skype ze zintegrowanym QT. nie potrafię zainstalować.
  • 0

#4 Mentat

Mentat

    Ekspert

  • Użytkownicy
  • 281 postów

  • Rejestracja: 24 listopad 07
  • Płeć:Mężczyzna
  • Skąd:Kraków

Napisano 19 styczeń 2008 - 23:04

Cytat(pazdzioch23 @ 19 Jan 2008, 22:08 ) <{POST_SNAPBACK}>
Zainstalowałem.
Ale nadal nie mam tego:
CODE
rpm -Uvh skype-1.4.0.118-fc5.i586.rpm
ostrzeżenie: skype-1.4.0.118-fc5.i586.rpm: Nagłówek V3 Podpis DSA: NOKEY, key ID d66b746e
błąd: Niespełnione zależności:
libQtGui.so.4 jest wymagany przez skype-1.4.0.118-fc5.i586
qt4-x11 >= 4.2 jest wymagany przez skype-1.4.0.118-fc5.i586

Tylko że tego nie mogę znaleźć.
A tego Skype ze zintegrowanym QT. nie potrafię zainstalować.


Na początek spróbuj
Kod
yum localinstall skype-1.4.0.118-fc5.i586.rpm

a jak nie zadziała to
Kod
yum list qt4-x11

oraz
Kod
yum provides libQtGui.so.4

aby odnaleźć odpowiedni pakiet.

  • 0

#5 DAREK WL.

DAREK WL.

    Ekspert

  • Użytkownicy
  • 799 postów

  • Rejestracja: 08 październik 04
  • Płeć:Mężczyzna
  • Skąd:Czestochowa
  • Zainteresowania:komputery,elektronika

Napisano 20 styczeń 2008 - 21:54

A próbowałeś zainstalowac najnowsze SKYPE 2.0 BETA z obsługa video question.gif
Jest wersja dla fedory rolleyes.gif
  • 0

#6 pazdzioch23

pazdzioch23

    Użytkownik

  • Użytkownicy
  • 22 postów

  • Rejestracja: 21 maj 07

Napisano 25 styczeń 2008 - 19:39

Cytat(DAREK WL. @ 20 Jan 2008, 21:14 ) <{POST_SNAPBACK}>
A próbowałeś zainstalowac najnowsze SKYPE 2.0 BETA z obsługa video question.gif
Jest wersja dla fedory rolleyes.gif

Próbowałem i też nic.
CODE
]# rpm -Uvh skype-2.0.0.27-fc5.i586.rpm
ostrzeżenie: skype-2.0.0.27-fc5.i586.rpm: Nagłówek V3 Podpis DSA: NOKEY, key ID d66b746e
błąd: Niespełnione zależności:
libQtGui.so.4 jest wymagany przez skype-2.0.0.27-fc5.i586
qt4-x11 >= 4.2 jest wymagany przez skype-2.0.0.27-fc5.i586

Natomiast jeżeli chodzi o twoje polecenia "Mentat " to też nic z tego nie wyszło:
CODE
]# rpm -Uvh yum skype-2.0.0.27-fc5.i586.rpm
błąd: otwarcie yum nie powiodło się: Nie ma takiego pliku ani katalogu
ostrzeżenie: skype-2.0.0.27-fc5.i586.rpm: Nagłówek V3 Podpis DSA: NOKEY, key ID d66b746e

CODE
/]# yum list qt4-x11
Loading "priorities" plugin
0 packages excluded due to repository priority protections
Available Packages
qt4-x11.i386 4.3.3-1.fc7 updates

Nie ogarniam tego, nie wiem jak to zrobić za cienki jestem tak by na to wyglądało.
  • 0

#7 darek015

darek015

    Użytkownik

  • Użytkownicy
  • 51 postów

  • Rejestracja: 21 wrzesień 06
  • Płeć:Mężczyzna
  • Skąd:Tarnów- okolice

Napisano 25 styczeń 2008 - 20:39

Spróbuj:
Kod
yum update qt4-x11


a jeśli zadziała to wtedy juz normalnie sprobuj zainstalowac skypa z rpm`a.
  • 0
---------------------------------------------------------------------------------------------------------------------
MSI KT3 Ultra, AMD Athlon 1700+, GForce 4 Titanium 4200, 1024DDR
---------------------------------------------------------------------------------------------------------------------

#8 pazdzioch23

pazdzioch23

    Użytkownik

  • Użytkownicy
  • 22 postów

  • Rejestracja: 21 maj 07

Napisano 29 styczeń 2008 - 22:09

Cytat(Mentat @ 19 Jan 2008, 22:24 ) <{POST_SNAPBACK}>
Na początek spróbuj
Kod
yum localinstall skype-1.4.0.118-fc5.i586.rpm

a jak nie zadziała to
Kod
yum list qt4-x11

oraz
Kod
yum provides libQtGui.so.4

aby odnaleźć odpowiedni pakiet.


Nareszcie się udało. Sam jeszcze w to nie wierzę.
Dziękuję tobie "Mentat" to chyba dzieki tobie mi się udało.
To polecenie (yum localinstall skype-1.4.0.118-fc5.i586.rpm) zadane w katalogu w którym znajdowała się paczka Skypea nie przeszło do końca, ale dało początek. Bo za pomocą tego polecenia zainstalowałem ściągniętą paczkę (qt4-x11) , a następnie już za pomocą polecenia (rpm -Uvh skype-1.4.0.118-fc5.i586.rpm) udało się zainstalować Skype.
I muszę tu zaznaczyć że odwrotnie te polecenia w ogóle nie działały.
I jeszcze jedno to polecenie (yum update qt4-x11) nie działało.
Jeszcze raz dziękuję wszystkim którzy się zaangarzowali się aby mi pomóc.
  • 0

#9 cracket

cracket

    Użytkownik

  • Użytkownicy
  • 60 postów

  • Rejestracja: 03 kwiecień 06

Napisano 31 styczeń 2008 - 22:54

Wiem że może nie tego dotyczyło Twoje pytanie, ale dlaczego akurat skype, a nie otwarte aplikacje oparte o protokół SIP?
Różnica między skype a SIP jest taka jak między Windowsem a Linuksem - na SIPie są oparte nawet rozmowy przez Gadu-Gadu nagłos
  • 0

#10 Ponury

Ponury

    Ekspert

  • Użytkownicy
  • 930 postów

  • Rejestracja: 27 czerwiec 04
  • Płeć:Mężczyzna
  • Skąd:Grajewo

Napisano 31 styczeń 2008 - 23:11

Cytat(cracket @ 31 Jan 2008, 22:14 ) <{POST_SNAPBACK}>
Wiem że może nie tego dotyczyło Twoje pytanie, ale dlaczego akurat skype, a nie otwarte aplikacje oparte o protokół SIP?
Różnica między skype a SIP jest taka jak między Windowsem a Linuksem - na SIPie są oparte nawet rozmowy przez Gadu-Gadu nagłos


Zapewne dlatego że większość ludzi używa skypa i o niczym innym nie słyszeli.
Od siebie dodam że jak się nie przeprowadza rozmów międzynarodowych to zabawa jest nieopłacalna, a poza tym nawet na linuksie skype pobiera od nas prywatne dane i wysyła do "centrali". Ktoś wykrył to zakładając odpowiednią politykę selinuksa na proces skypa. Po co im to nikt nie wie, ale najwidoczniej programiści skypa i linuksiarzy chcą mieć pod kontrolą, jakby im nie wystarczyła kasa, którą dostają za rozmowy.
  • 0
Fedora 18 x86_64 - Gnome
HP ProBook 4330s
Intel Corporation 2nd Generation Core Processor Family DRAM Controller
Intel® Core™ i3-2350M CPU @ 2.30GHz × 4
Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych użytkowników