Skocz do zawartości


Zdjęcie

E-deklaracje - Mini How-to


  • Zaloguj się, aby dodać odpowiedź
50 odpowiedzi w tym temacie

#31 MC'

MC'

    Ekspert

  • Użytkownicy
  • 1009 postów

  • Rejestracja: 17 maj 05

Napisano 16 czerwiec 2011 - 12:52

Również nigdy nie popierałem tej platformy i nie zamierzam tego zrobić ale to świadczy o tym jak głupi ludzie siedzą w MF że wybrali tą technologie popierając sie jej multiplatformowością i faktem że wspiera ja powazna firma hahahaha i co urzedasy? frma powiedziała "mamy was gdzieś" i nikt Wam nie pomoże bo to ZAMKNIĘTA PLATFORMA!

@WalDo
Czytałem to tak samo jak Ty i przecież napisałem, że chodzi o Adobe. A to 1 zdanie to wróżenie z fusów moze tak a może nie.
  • 0

HW:      Intel® Core™ i7-3770K CPU @ 3.50GHz | P8Z77-V DELUXE | 16 GB RAM | X-Fi Fatal1ty Recon 3D
OS:        F18 | KDE 4.9.5 | 3.7.5-201.fc18.x86_64                                                                                             
REPA:   standard + RPMFusion - up to date

Fotobudka | Blog
 


#32 WalDo

WalDo

    (prawie) Ekspert

  • @Administrator
  • 11658 postów

  • Rejestracja: 18 listopad 04
  • Płeć:Mężczyzna
  • Skąd:Warszawa

Napisano 16 czerwiec 2011 - 13:27

[...] swiadczy o tym jak glupi ludzie siedza w MF[...]

Zadna nowina :) U nas niestety nikt nie mysli w takich wypadkach, ze trzeba miec albo wlasne oprogramowanie albo umowe z firma zewnetrzna na wieloletnie wspieranie produktu z mozliwoscia wypowiedzenia nie krótsza niz rok i innymi zabezpieczeniami prawnymi. Jakis dyletant w MF ucieszyl sie, ze ma taka fajna darmowa platforme, wiec dostanie premie za oszczednosc. A jakby co to mozna potem VAT podniesc o kolejny procent.

[EDIT]
Ale w sumie to nam sie z mini-howto spory off-topic zrobil. Jesli ktos cos bedzie jeszcze chcial dodac, to podziele watek na czesc "przewodnik" oraz towarzyszaca czesc w Hyde Park.

Użytkownik WalDo edytował ten post 16 czerwiec 2011 - 13:29

  • 0

______________________________________________________________________________________
Nie udzielam porad poza forum. Kłóci się to z jego podstawową ideą powszechnego dostępu.

Registered user #374329


#33 thof

thof

  • Użytkownicy
  • 4053 postów

  • Rejestracja: 16 listopad 06
  • Płeć:Mężczyzna
  • Skąd:Wrocław

Napisano 03 luty 2012 - 17:37

Jest lepiej. W obecnej wersji wystarczy zainstalowac recznie Adobe Reader i flashplugin. Potem wystarczy przejsc na strone http://www.e-deklara...age=do_pobrania na dole jest flashowe okienko i kliknac "Zainstaluj". Adobe AIR zostanie automatycznie pobrany i zainstalowany, podobnie aplikacja e-Deklaracje Desktop.

Readera podobnie jak flashplugin mozna doinstalowac z repo Adobe.

EDIT: Poszla aktualizacja do wiki http://wiki.fedora.pl/wiki/Edeklaracje (sprawdzcie czy yum install adobereader to poprawna nazwa pakietu w tym repo).
  • 0

#34 MC'

MC'

    Ekspert

  • Użytkownicy
  • 1009 postów

  • Rejestracja: 17 maj 05

Napisano 07 marzec 2013 - 14:07

W repo Adobe nie znalzałem Adobe Readera, a już na pewno nie działa polecenie z wiki dla 64 bit.


  • 0

HW:      Intel® Core™ i7-3770K CPU @ 3.50GHz | P8Z77-V DELUXE | 16 GB RAM | X-Fi Fatal1ty Recon 3D
OS:        F18 | KDE 4.9.5 | 3.7.5-201.fc18.x86_64                                                                                             
REPA:   standard + RPMFusion - up to date

Fotobudka | Blog
 


#35 m123456

m123456

    Użytkownik

  • Użytkownicy
  • 27 postów

  • Rejestracja: 19 styczeń 11
  • Płeć:Mężczyzna

Napisano 07 marzec 2013 - 16:23

ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/
  • 0

#36 MC'

MC'

    Ekspert

  • Użytkownicy
  • 1009 postów

  • Rejestracja: 17 maj 05

Napisano 08 marzec 2013 - 15:23

Tyle to ja wiem tylko że wiki nieaktulane ;)


  • 0

HW:      Intel® Core™ i7-3770K CPU @ 3.50GHz | P8Z77-V DELUXE | 16 GB RAM | X-Fi Fatal1ty Recon 3D
OS:        F18 | KDE 4.9.5 | 3.7.5-201.fc18.x86_64                                                                                             
REPA:   standard + RPMFusion - up to date

Fotobudka | Blog
 


#37 WalDo

WalDo

    (prawie) Ekspert

  • @Administrator
  • 11658 postów

  • Rejestracja: 18 listopad 04
  • Płeć:Mężczyzna
  • Skąd:Warszawa

Napisano 08 marzec 2013 - 18:01

Tyle to ja wiem tylko że wiki nieaktulane ;)

Jak wiesz gdzie i jak, to nie zgłaszaj tylko popraw. To również Twoja wiki :)


  • 0

______________________________________________________________________________________
Nie udzielam porad poza forum. Kłóci się to z jego podstawową ideą powszechnego dostępu.

Registered user #374329


#38 MC'

MC'

    Ekspert

  • Użytkownicy
  • 1009 postów

  • Rejestracja: 17 maj 05

Napisano 12 marzec 2013 - 10:51

Miałem dziś chwilę na PITy. Adobe Reader poszedł ok z rpm np z linka powyżej ale AIR nie jest już wspierany na linuksa ale mimo to pobrałem plik .bin z adobe archiwum w wersji 2.6: http://airdownload.a...IRInstaller.bin

ale instalacja nie idzie po błędzie:

 

(setup:25743): Gtk-WARNING **: Nie można odnaleźć modułu obsługującego motyw w module_path: "oxygen-gtk",

(setup:25743): Gtk-WARNING **: Nie można odnaleźć modułu obsługującego motyw w module_path: "oxygen-gtk",
 

Komuś udało się zainstalować AIR poprawnie ?


 


  • 0

HW:      Intel® Core™ i7-3770K CPU @ 3.50GHz | P8Z77-V DELUXE | 16 GB RAM | X-Fi Fatal1ty Recon 3D
OS:        F18 | KDE 4.9.5 | 3.7.5-201.fc18.x86_64                                                                                             
REPA:   standard + RPMFusion - up to date

Fotobudka | Blog
 


#39 MC'

MC'

    Ekspert

  • Użytkownicy
  • 1009 postów

  • Rejestracja: 17 maj 05

Napisano 13 marzec 2013 - 19:00

Ok znalazłem powód:

Wersja stara ADobeAIr podobno jest dla starego systemu RPM dlatego trzeba dla niej najpierw pobrać stere liby RPM i dopiero zainstalować.

Wdług tego linka:

http://forums.fedora...68&postcount=28

 

wget http://forums.fedoraforum.org/attachment.php?attachmentid=21526&d=1311989101

mv attachment.php?attachmentid=21526 librpm.tar.gz

tar -xzf librpm.tar.gz

wget http://airdownload.adobe.com/air/lin/download/2.6/AdobeAIRInstaller.bin

chmod a+x AdobeAIRInstaller.bin

su

LD_LIBRARY_PATH=`pwd`/lib ./AdobeAIRInstaller.bin
 

  • 1

HW:      Intel® Core™ i7-3770K CPU @ 3.50GHz | P8Z77-V DELUXE | 16 GB RAM | X-Fi Fatal1ty Recon 3D
OS:        F18 | KDE 4.9.5 | 3.7.5-201.fc18.x86_64                                                                                             
REPA:   standard + RPMFusion - up to date

Fotobudka | Blog
 


#40 MC'

MC'

    Ekspert

  • Użytkownicy
  • 1009 postów

  • Rejestracja: 17 maj 05

Napisano 18 marzec 2013 - 11:57

Dla x86_64 dodatkowo przed instalacją AIR należy zainstalować:

 

sudo yum install -y ld-linux.so.2 gtk2-devel.i686 libdbus-glib-1.so.2 libhal.so.1  

sudo yum install -y rpm-devel.i686 libXt.so.6 gnome-keyring-devel.i686

sudo yum install -y libDCOP.so.4 libxml2-devel.i686 nss-devel.i686 libxslt.i686 

sudo yum install -y xterm rpm-build libgnome-keyring.i686

sudo yum install -y gtk2-engines gtk2-engines.i686 libcanberra-gtk2 libcanberra-gtk3 libcanberra-gtk2.i686 libcanberra-gtk3.i686

Później już "tylko" zabawa z kdewallet


  • 1

HW:      Intel® Core™ i7-3770K CPU @ 3.50GHz | P8Z77-V DELUXE | 16 GB RAM | X-Fi Fatal1ty Recon 3D
OS:        F18 | KDE 4.9.5 | 3.7.5-201.fc18.x86_64                                                                                             
REPA:   standard + RPMFusion - up to date

Fotobudka | Blog
 


#41 mateczek

mateczek

    Użytkownik

  • Użytkownicy
  • 59 postów

  • Rejestracja: 09 lipiec 09

Napisano 23 marzec 2013 - 18:43

MC jesteś wielki. Ale jak by Ci się chciało to wiesz może w czym tkwi problem, że pomimo iż adobeair się zainstalował to nie chce się zainstalować e-deklaracje ??




"Nie można zainstalować aplikacji z powodu uszkodzenia pliku instalatora. Spróbuj uzyskać nowy plik instalatora od autora aplikacji."
  • 0

#42 Ponury

Ponury

    Ekspert

  • Użytkownicy
  • 932 postów

  • Rejestracja: 27 czerwiec 04
  • Płeć:Mężczyzna
  • Skąd:Grajewo

Napisano 23 marzec 2013 - 19:03

http://www.drtax.pl/...l/pl/index.aspx

 

tylko źle liczy jeżeli macie dochody z zagranicy


  • 0
Fedora 18 x86_64 - Gnome
HP ProBook 4330s
Intel Corporation 2nd Generation Core Processor Family DRAM Controller
Intel® Core™ i3-2350M CPU @ 2.30GHz × 4
Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller

#43 mateczek

mateczek

    Użytkownik

  • Użytkownicy
  • 59 postów

  • Rejestracja: 09 lipiec 09

Napisano 24 marzec 2013 - 13:54

Przy instalowaniu aplikacji też odwołuje się do rpm więc trzeba tak

 

 

su
LD_LIBRARY_PATH=`pwd`/lib air
 

 

 

air to jest symlink do aplikacji "/usr/bin/Adobe AIR Application Installer" zrobiłem żeby było krócej klepać :). No i wkońcu zainstalowało się to badziewie. Wcześniej wyczyściłem też tempy i nie wiem czy to miało jakieś znaczenie ?? 

 

Już po rozliczeniu ale tyle problemów z tą aplikacją, aż się boje co będzie za rok :P


  • 0

#44 Bluesman

Bluesman

    Użytkownik

  • Użytkownicy
  • 53 postów

  • Rejestracja: 19 sierpień 09
  • Płeć:Mężczyzna

Napisano 16 kwiecień 2013 - 13:51

http://www.finanse.m...rukcjeLinux.pdf

Polecam ten link. W ministerstwie ktos się postarał. Wystarczy wklepywać w konsolę. Ja mam juz AIR'a ale nie mogę zainstalować samej aplikacji e deklaracje. Pisze że plik jest uszkodzony.


  • 0

#45 Rovan

Rovan

    Początkujący

  • Nowi użytkownicy
  • 1 postów

  • Rejestracja: 19 czerwiec 14

Napisano 19 czerwiec 2014 - 15:46

@Bluesman: Pod Fedorą 20 (64-bit) procedura opisana w instrukcji ministerstwa mi nie działa. Instalator sie uruchamia, jednak później wyświetla komunikat:

 


 

Podczas instalowania środowiska Adobe AIR wystąpił błąd. Być może administrator nie zezwolił na przeprowadzanie instalacji. Skontaktuj się z administratorem.

 

 

Znalazłem sie w kropce. Po dłuższym przeszukiwaniu sieci okazało się, że problem można obejść wykorzystując AdobeAIR SDK. Poniżej link do wersji 2.6:
 
 
Po ściągnięciu wykonujemy wszystkie kroki opisane w instrukcji ministerstwa. Jeśli podczas próby zainstalowania AIR poza powyższym komunikatem błędu terminal zwrócił dodatkowo błąd:
 

gtk-warning ** unable to locate theme engine in module_path adwaita

 

 

musimy pobrać i zainstalować odpowiedni rpm, mozna go znaleźć pod tym linkiem:
 
 
 
Następnie tworzymy folder w którym rozpakujemy pobrane SDK. Np:
 
mkdir /opt/AIR-SDK
 
przechodzimy do niego:
 
cd /opt/AIR-SDK
 
Wypakowujemy archiwum:
 
tar jxvf /sciezka/do/pliku/AdobeAIRSDK.tbz2
 
Tworzymy kolejny folder dla aplikacji AdobeAIR, np:
 
mkdir /opt/AIR-apps
 
Teraz czas pobrać e-Deklaracje:
 
 
W świeżo utworzonym folderze AIR-apps tworzymy folder dla programu e-Deklaracje, np:
 
mkdir /opt/AIR-apps/e-Deklaracje
 
i przechodzimy do niego:
 
cd /opt/AIR-apps/e-Deklaracje
 
Następnie wypakowujemy zawartość pliku e-DeklaracjeDesktop.air:
 
unzip /sciezka/do/pliku/e-DeklaracjeDesktop.air
 
Gotowe. Teraz możemy uruchomić e-Deklaracje przy użyciu ADL-a:
 
/opt/AIR-SDK/bin/adl -nodebug /opt/AIR-apps/e-Deklaracje/META-INF/AIR/application.xml /opt/AIR-apps/e-Deklaracje
 
Oczywiście e-Deklaracje do prawidłowej pracy wymagają programu Acrobar Reader w wersji co najmniej 9.0. Jest on zawarty w repozytorium Russian Fedora:
 

yum install --nogpgcheck\
 http://mirror.yandex.ru/fedora/russianfedora/russianfedora\
/free/fedora/russianfedora-free-release-stable.noarch.rpm\
 http://mirror.yandex.ru/fedora/russianfedora/russianfedora\
/nonfree/fedora/russianfedora-nonfree-release-stable.noarch.rpm\
 && \
yum -y update russian\*

 
Po dodaniu repozytorium możemy zainstalować Acrobat Reader:
 
yum install acroread
 
UWAGA: Może się zdrzyc, że pomimo zainstalowania Acrobat Readera program e-Deklaracje nie będzie go "widział". Wynika to stąd, że e-Deklaracje nie przewidziały, że Adobe Reader może siedzieć w innym miejscu niż /opt. Po zainstalowaniu wersji z repo problem powinno rozwiązać dowiązanie:
 
ln -s /usr/lib/Adobe/Reader9 /opt/Adobe
 
uprzednio musimy stworzyć odpowiedni folder
 
mkdir /opt/Adobe
 
Teraz wszystko powinno śmigać :)

 


  • 2




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych użytkowników