Skocz do zawartości


Zdjęcie

Co Się Dzieje Z Kadu


  • Zaloguj się, aby dodać odpowiedź
115 odpowiedzi w tym temacie

#31 3k_PL

3k_PL

    Ekspert

  • Użytkownicy
  • 408 postów

  • Rejestracja: 23 maj 08
  • Płeć:Mężczyzna
  • Skąd:Rzeszów/Wrocław

Napisano 29 luty 2012 - 12:05

Co myslicie by zrobic fake rpmy kadu-minimal, kadu-default, kadu-all które w zaleznosciach by mialy odpowiednie pluginy? Devel i debuginfo byly by z tych paczek wylaczone.
Obecnie istalowanie Kadu jest dosc skaplikowane dla nobów, ale mi sie nie podobaja metapakiety kadu-plugins-standard/all bo to nie daje mozliwosci wyboru. A przy moim pomysle instalacje Kadu dla nobów robilo by sie

yum install kadu-default

  • 0

6x Fedora 23
4x Ubuntu 16.04
MeeGo Harmattan


#32 borzole

borzole

    Yamato

  • Użytkownicy
  • 2365 postów

  • Rejestracja: 16 sierpień 07
  • Płeć:Mężczyzna

Napisano 01 marzec 2012 - 12:38

W moim odczuciu jesli chcesz zrobic paczki, które by byly intuicyjne dla poczatkujacych i dawaly swobode wyboru dla zaawansowanych to powinno byc tak:

kadu # paczka domyslna dla leniwych: wersja minimlna + zestaw wybranych dodatków. Nazwa kadu-default nie jest wskazana. Niepotrzebne rozwlekanie nazwy. Ile paczek ma taki sufix?
kadu-core # wersja minimalna. "core" to prawie standard w nazewnictwie.
kadu-plugin-xxx # reszta dodatków w takiej postaci. Mozna latwo wyszukac i latwo zainstalowac wszystkie na raz

Nie widze sensu robienia paczki kadu-all, bo wiadomo, ze to sa po prostu wszystkie dostepne pluginy. Poza tym jak zmienia sie plugin lub dochodzi nowy, to trzeba by aktualizowac równiez kadu-all.

To taka moja subiektywna opinia.
  • 0

F7-25 | fluxbox/openbox/xfce/gnome2/mate
poradnik@wiki


jedral.one.pl


#33 3k_PL

3k_PL

    Ekspert

  • Użytkownicy
  • 408 postów

  • Rejestracja: 23 maj 08
  • Płeć:Mężczyzna
  • Skąd:Rzeszów/Wrocław

Napisano 01 marzec 2012 - 13:19

kadu # paczka domyslna dla leniwych: wersja minimlna + zestaw wybranych dodatków.

To zrobi drobny konflikt nazewnictwa, bo obecnie kadu- to po prostu "lysa" aplikacja bez mozliwosci komunikatora. By móc podlaczyc sie do serwerów GG musisz miec minimum kadu-gadu_protocol. Nie uwazam zeby wciaganie protokolu GG do kadu na stale bylo konieczne. Zreszta twórcy niedawno w wywiadzie mówili ze jesli GG zabroni obcym komunikatorom dostep do ich sieci to albo spróbuja zlamac to, albo porzuca protokól GG.
Zatem samo kadu to "niewiele" robiaca aplikacja która trzeba uzupelnic odpowiednimi pluginami. Jedni kadu beda wykorzystywac do GG, inni do XMPP, a jeszcze inni jako demona rozkazów.

kadu-core # wersja minimalna. "core" to prawie standard w nazewnictwie.

To jest ciekawe, mozna by bylo oznaczyc kadu <= 0.11X jako przestarzale, zastapic ja corem i wtedy wprowadzic ze kadu to takie "kadu minimal". Mialo by to sens?

kadu-plugin-xxx # reszta dodatków w takiej postaci

Tak jest obecnie w wersjach powyzej 0.10, tylko bez slowa plugin :)

Poza tym jak zmienia sie plugin lub dochodzi nowy, to trzeba by aktualizowac równiez kadu-all.

Akurat to nie jest wielki problem bo od 0.10 pluginy mozna kompilowac oddzielnie (SDK) a w samym specu nie ma wiele roboty. Zapomniec tez bedzie trudno bo sie po prostu wysypie ze zainstalowane, a nie spakietowane pliki.
  • 0

6x Fedora 23
4x Ubuntu 16.04
MeeGo Harmattan


#34 Subaru

Subaru

    Ekspert

  • Użytkownicy
  • 781 postów

  • Rejestracja: 05 październik 07
  • Płeć:Mężczyzna
  • Skąd:Ura-Net
  • Zainteresowania:Programowanie na platformę Nintendo DS oraz Nintendo Wii
    Zabawa w Terminalu :P

Napisano 01 marzec 2012 - 13:24

Przyzwyczailem sie juz strasznie do kompilowania ze zródel tego Kadu
Zastanawia mnie tylko, dlaczego libgadu nie ma ciagle w oficjalnych repozytoriach, nawet w updates-testing nie ma :(
Mozna co prawda czesciowo ominac ten problem (w zródlach Kadu zmniejszyc wymagana minimalna wersje libgadu), ale ilez mozna tak w kotka i myszke sie bawic...
  • 0

[Subaru@SkyNet ~]$ info.sh

Kernel - 4.9.5-200.fc25.x86_64
Terminal - Terminal 1.16.1 (MATE)
Pracuję na: Fedora 25 x86_64 MATE 1.16.1

Używam Wine 2.0-rc5

PulseAudio oznacza w staroafrykańskim "Bad Latency!".

Ubuntu oznacza w staroafrykańskim "Nie umiem skonfigurować Debiana!".

 

/usr/bin/pk-632z/tea

 

 

 

SeeM, to nie jest portal hazardowy :) Nie przyjmujemy zakładów :)
Termin wydania F21 jest równie mało przewidywalny jak zero w ruletce.

#35 3k_PL

3k_PL

    Ekspert

  • Użytkownicy
  • 408 postów

  • Rejestracja: 23 maj 08
  • Płeć:Mężczyzna
  • Skąd:Rzeszów/Wrocław

Napisano 01 marzec 2012 - 13:36

dlaczego libgadu nie ma ciagle w oficjalnych repozytoriach

Tego nie wiem, pewnie nikt nie wyslal do repo. Ja zrobilem paczki juz jakis czas temu, dostepne tutaj (na samym dole).
  • 0

6x Fedora 23
4x Ubuntu 16.04
MeeGo Harmattan


#36 neometal

neometal

    Użytkownik

  • Użytkownicy
  • 232 postów

  • Rejestracja: 17 sierpień 09
  • Płeć:Mężczyzna

Napisano 01 marzec 2012 - 18:40

Tego nie wiem, pewnie nikt nie wyslal do repo. Ja zrobilem paczki juz jakis czas temu, dostepne tutaj (na samym dole).

A móglbys wystawic paczki ponownie? Linki prowadza do pustego zasobu dropboxa. Z góry dzieki.
  • 0

#37 3k_PL

3k_PL

    Ekspert

  • Użytkownicy
  • 408 postów

  • Rejestracja: 23 maj 08
  • Płeć:Mężczyzna
  • Skąd:Rzeszów/Wrocław

Napisano 01 marzec 2012 - 19:04

Linki prowadza do pustego zasobu dropboxa. Z góry dzieki.

Sprawdzalem na dwóch kompach, libgadu pobiera sie bez problemu. Spróbuj moze ponownie.
---
Edit
Kadu sie nie pobieralo w wiki, poprawione.

Użytkownik 3k_PL edytował ten post 01 marzec 2012 - 19:12

  • 0

6x Fedora 23
4x Ubuntu 16.04
MeeGo Harmattan


#38 neometal

neometal

    Użytkownik

  • Użytkownicy
  • 232 postów

  • Rejestracja: 17 sierpień 09
  • Płeć:Mężczyzna

Napisano 01 marzec 2012 - 21:40

Sprawdzalem na dwóch kompach, libgadu pobiera sie bez problemu. Spróbuj moze ponownie.
---
Edit
Kadu sie nie pobieralo w wiki, poprawione.


Wlasnie o linki z wiki mi chodzilo. Wybacz brak precyzji.
  • 0

#39 MC'

MC'

    Ekspert

  • Użytkownicy
  • 1009 postów

  • Rejestracja: 17 maj 05

Napisano 03 wrzesień 2012 - 12:31

Migruje ze starego 0.9.0.na najnowsze KADU. Dodalem repo 3k_PL i zainstalowalem samo kadu 0.12.2 oraz zupdatowalem libgadu anacondy z 1.11.0 na 1.11.1 z repo 3k_PL
Mam archiwum .kadu z wersji 0.9.0. Poniewaz nie jestem na biezaco z rozwoje tego pakietu wole dopytac a mysle, ze moze sie to komus równeiz przyda.

Poniewaz to nieoficjalne repo to wole doyptac

1. Jakie jeszcze czynnosci powinienem wykonac by importowac historie i ustawienia wersji 0.9.0 do najnowszej wersji?
2. Które pluginy historii wybrac?
3. Do poprawnej pracy po upgradzie, które pluginy dobrze by bylo zainstalowac?
  • 0

HW:      Intel® Core™ i7-3770K CPU @ 3.50GHz | P8Z77-V DELUXE | 16 GB RAM | X-Fi Fatal1ty Recon 3D
OS:        F18 | KDE 4.9.5 | 3.7.5-201.fc18.x86_64                                                                                             
REPA:   standard + RPMFusion - up to date

Fotobudka | Blog
 


#40 3k_PL

3k_PL

    Ekspert

  • Użytkownicy
  • 408 postów

  • Rejestracja: 23 maj 08
  • Płeć:Mężczyzna
  • Skąd:Rzeszów/Wrocław

Napisano 03 wrzesień 2012 - 12:53

Zrób po prostu kopie starego kadu

cp -rpf ~/.kadu kadu-backup
Usun stare paczki kadu, bo z nowymi nie pasuja

yum remove kadu-*
Ja mam nastepujace paczki:

rpm -qa --qf "%{NAME}\n" |grep kadu
kadu-history_migration kadu-mediaplayer kadu-mprisplayer_mediaplayer kadu-sql_history kadu-qt4_docking kadu-chat_notify kadu-docking kadu-imagelink kadu-history kadu-desktop_docking kadu-sms kadu-gadu_protocol kadu-qt4_docking_notify kadu-tabs kadu
history-migration jest do migracji ze starej historii (sprzed 0.10), a kadu-sql_history jest do utrzymania historii w sql.
  • 0

6x Fedora 23
4x Ubuntu 16.04
MeeGo Harmattan


#41 MC'

MC'

    Ekspert

  • Użytkownicy
  • 1009 postów

  • Rejestracja: 17 maj 05

Napisano 03 wrzesień 2012 - 13:43

Ok. Migracja danych i historii sie wykona sama po uruchomieniu kadu czy musze uruchomic jakis migrator?
Oplaca sie instalowac to kadu-sql_history (tzn jest wzrost wydajnosci w skladowaniu lub przegladaniu historii) i jakie dodatkowe wymagania musza byc? tzn instalowac sqlLite czy cus?
  • 0

HW:      Intel® Core™ i7-3770K CPU @ 3.50GHz | P8Z77-V DELUXE | 16 GB RAM | X-Fi Fatal1ty Recon 3D
OS:        F18 | KDE 4.9.5 | 3.7.5-201.fc18.x86_64                                                                                             
REPA:   standard + RPMFusion - up to date

Fotobudka | Blog
 


#42 3k_PL

3k_PL

    Ekspert

  • Użytkownicy
  • 408 postów

  • Rejestracja: 23 maj 08
  • Płeć:Mężczyzna
  • Skąd:Rzeszów/Wrocław

Napisano 03 wrzesień 2012 - 14:04

Migracja wykona sie automatycznie, choc wiekszosc uzytkowników robila to stopniowo XML->sql1->sql2, a Ty zrobisz XML->sql2. Zalecalbym byc offline podczas tej migracji, by nie odbierac nowych rozmów. Nie próbowalem uzywac kadu bez sql-a (Nie wiem czy to jest mozliwe i jesli to jak dlugo bedzie), ale mysle ze pojedynczy plik historii i teoretycznie szybsze przeszukiwanie powinno zachecac do tego rozwiazania. W wersji 0.11 czasami pojawialy sie jakies nieprzewidziane upadki historii (np. podczas kopiowania historii w inne miejsce bedac online), ale zostal napisany skrypt do sqllite który ja podnosil.
Kadu wykorzystuje sqllite, ale nie wiem czy jest wymagane, sprawdz i jesli jest to dodam to do wymagan w paczce i wypuszcze update.
  • 0

6x Fedora 23
4x Ubuntu 16.04
MeeGo Harmattan


#43 Subaru

Subaru

    Ekspert

  • Użytkownicy
  • 781 postów

  • Rejestracja: 05 październik 07
  • Płeć:Mężczyzna
  • Skąd:Ura-Net
  • Zainteresowania:Programowanie na platformę Nintendo DS oraz Nintendo Wii
    Zabawa w Terminalu :P

Napisano 07 wrzesień 2012 - 14:48

Zreszta twórcy niedawno w wywiadzie mówili ze jesli GG zabroni obcym komunikatorom dostep do ich sieci to albo spróbuja zlamac to, albo porzuca protokól GG.

GG S.A. zabrania przeciez tego ale i tak nikt sobie z tego nic nie robi ot co :P
Przeciez jesli GG S.A. mialoby miec monopol na to jaki klient bedzie uzywac koncowy uzytkownik to skonczyliby gorzej niz Skype (Skype przynajmniej zauwaza innych uzytkowników niz Windows) (korekta, Skype spadł na dno buehehe)
GG S.A. musialoby napisac protokól od zera, zamknac kod w cholere by miec go zabezpieczonego na poziomie Skype i dopiero robic jakies zakazy nie na odwrót
Po za tym zrobilby sie bunt jakiejstam skali, ze GG S.A. zachowuje sie jak banda frajerów :D\

 

EDIT #1

Drobne korekty w poście


  • 0

[Subaru@SkyNet ~]$ info.sh

Kernel - 4.9.5-200.fc25.x86_64
Terminal - Terminal 1.16.1 (MATE)
Pracuję na: Fedora 25 x86_64 MATE 1.16.1

Używam Wine 2.0-rc5

PulseAudio oznacza w staroafrykańskim "Bad Latency!".

Ubuntu oznacza w staroafrykańskim "Nie umiem skonfigurować Debiana!".

 

/usr/bin/pk-632z/tea

 

 

 

SeeM, to nie jest portal hazardowy :) Nie przyjmujemy zakładów :)
Termin wydania F21 jest równie mało przewidywalny jak zero w ruletce.

#44 tred102

tred102

    Początkujący

  • Użytkownicy
  • 5 postów

  • Rejestracja: 10 styczeń 13

Napisano 10 styczeń 2013 - 02:02

Ich strona nie działa już chyba od 2 tygodni. Czy rozwój programu został przerwany? Jakieś chwilowe problemy? Czy ktoś z was coś słyszał na ten temat?

Ostatnio chciałem pobrać wersję dla windowsa i nie mam za bardzo skąd
  • 0
goteras tejado - Pozdrowienia Mart1k4a

#45 3k_PL

3k_PL

    Ekspert

  • Użytkownicy
  • 408 postów

  • Rejestracja: 23 maj 08
  • Płeć:Mężczyzna
  • Skąd:Rzeszów/Wrocław

Napisano 10 styczeń 2013 - 07:26

Ich strona nie dziala juz chyba od 2 tygodni

Dziala, tylko sie przeniesli na kadu.im.
  • 0

6x Fedora 23
4x Ubuntu 16.04
MeeGo Harmattan





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych użytkowników