Jump to content


Photo

Steam-Problem


  • Please log in to reply
13 replies to this topic

#1 Stancol

Stancol

    Użytkownik

  • Użytkownicy
  • 133 posts

  • Joined: 12 August 15
  • Płeć:Mężczyzna

Posted 18 December 2016 - 10:18 AM

Wczoraj wszystko działało, a dziś wyświetla się:

You are missing the following 32-bit libraries, and Steam may not run:
libc.so.6

 

Pomocy, dzięki!


  • 0

#2 sunrise

sunrise

    Ekspert

  • Użytkownicy
  • 339 posts

  • Joined: 12 August 07
  • Płeć:Mężczyzna
  • Skąd:Zgierz

Posted 18 December 2016 - 11:49 AM

A masz zainstalowany glibc.i686?


  • 1

#3 Stancol

Stancol

    Użytkownik

  • Użytkownicy
  • 133 posts

  • Joined: 12 August 15
  • Płeć:Mężczyzna

Posted 18 December 2016 - 11:51 AM

Tak
  • 0

#4 sunrise

sunrise

    Ekspert

  • Użytkownicy
  • 339 posts

  • Joined: 12 August 07
  • Płeć:Mężczyzna
  • Skąd:Zgierz

Posted 18 December 2016 - 11:59 AM

Steama masz z rpmfusion, bo jeżeli tak. to u mnie działa. Spróbuj  uruchomić steam z konsoli, może to rozjaśni problem, możesz też spróbować przeinstalować glibc.i686 może pomożę.


  • 1

#5 Stancol

Stancol

    Użytkownik

  • Użytkownicy
  • 133 posts

  • Joined: 12 August 15
  • Płeć:Mężczyzna

Posted 18 December 2016 - 12:03 PM

Steama masz z rpmfusion, bo jeżeli tak. to u mnie działa. Spróbuj  uruchomić steam z konsoli, może to rozjaśni problem, możesz też spróbować przeinstalować glibc.i686 może pomożę.

Running Steam on fedora 24 64-bit
STEAM_RUNTIME is enabled automatically
Error: You are missing the following 32-bit libraries, and Steam may not run:
libc.so.6
/home/<moja nazwa>/.local/share/Steam/steam.sh: linia 756: 27618 Segmentation fault      $STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"
<edit>

Po ponownym zainstalowaniu to samo.  Wyżej

U mnie działało do wczoraj normalnie.


  • 0

#6 sunrise

sunrise

    Ekspert

  • Użytkownicy
  • 339 posts

  • Joined: 12 August 07
  • Płeć:Mężczyzna
  • Skąd:Zgierz

Posted 18 December 2016 - 12:33 PM

Ja mam  fedore 25, może w f24 coś zepsuli, jedyne co mogę Ci poradzić to zainstaluj, jeżeli nie masz program strace i uruchom to polecenie

strace -f -o log.txt -e open steam

teraz przejrzyj log.txt może coś Ci pomoże (trochę tego będzie)


  • 1

#7 Stancol

Stancol

    Użytkownik

  • Użytkownicy
  • 133 posts

  • Joined: 12 August 15
  • Płeć:Mężczyzna

Posted 18 December 2016 - 12:36 PM

Dalej to samo. :(

w logach nic ciekawego, to samo.

Spróbuję z .rpm zainstalować.


  • 0

#8 max2491

max2491

    Początkujący

  • Użytkownicy
  • 9 posts

  • Joined: 22 November 16

Posted 18 December 2016 - 20:49 PM

Czy biblioteka współdzielona libc.so.6 jest z tej samej dystrybucji Fedory? Niestety, ale niezgodność wersji dystrybucji instalowanego oprogramowania (np. doinstalowanie biblioteki z F25 w systemie F24) blokuje poprawne działanie aplikacji. Jeśli masz problemy ze sprawdzeniem tego istotnego szczegółu, to polecam podejście typu "brute force".


  • 1

#9 SeeM

SeeM

    Ekspert

  • Użytkownicy
  • 1,374 posts

  • Joined: 28 January 05
  • Płeć:Mężczyzna

Posted 18 December 2016 - 21:04 PM

Pewnie Steam się zaktualizował. Niestety w katalogu ~/.steam jest pełno śmieci z Ubuntu 12.04, w tym podstawowe linuskowe biblioteki. Spróbuj podać steamowi, żeby korzystał z systemowych:

Exec=env LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' /usr/bin/steam %U 

Możesz też usunąć z katalogu Steama te biblioteki:

rm ~/.steam/steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 ~/.steam/steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1 ~/.steam/steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libgcc_s.so.1 ~/.steam/steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libstdc++.so.6 ~/.steam/steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libxcb.so.1

co wymusi używanie tych z /usr/lib. Ostatnio nie mam z tym problemu, ale jeszcze dwa miesiące temu klient Steam mi nie działał bez usunięcia tych plików.


  • 1
+

#10 Stancol

Stancol

    Użytkownik

  • Użytkownicy
  • 133 posts

  • Joined: 12 August 15
  • Płeć:Mężczyzna

Posted 19 December 2016 - 15:55 PM

Zaktualizowałem do fedory 25 i dalej to samo. :angry:

ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Running Steam on fedora 25 64-bit
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
STEAM_RUNTIME is enabled automatically
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Error: You are missing the following 32-bit libraries, and Steam may not run:
libc.so.6

 

Po zatosowaniu sposobu @Seem

Dzięki za zainteresowanie.


  • 0

#11 WalDo

WalDo

    (prawie) Ekspert

  • @Administrator
  • 11,658 posts

  • Joined: 18 November 04
  • Płeć:Mężczyzna
  • Skąd:Warszawa

Posted 19 December 2016 - 18:16 PM

Masz napisane jak byk

Error: You are missing the following 32-bit libraries, and Steam may not run:
libc.so.6

Pokaż co zwraca u Ciebie polecenie
rpm -qa | grep glibc

  • 1

______________________________________________________________________________________
Nie udzielam porad poza forum. Kłóci się to z jego podstawową ideą powszechnego dostępu.

Registered user #374329


#12 Stancol

Stancol

    Użytkownik

  • Użytkownicy
  • 133 posts

  • Joined: 12 August 15
  • Płeć:Mężczyzna

Posted 20 December 2016 - 13:42 PM

glibc-headers-2.24-3.fc25.x86_64
glibc-2.24-3.fc25.i686
glibc-all-langpacks-2.24-3.fc25.x86_64
glibc-devel-2.24-3.fc25.x86_64
glibc-2.24-3.fc25.x86_64
glibc-langpack-en-2.24-3.fc25.x86_64
glibc-common-2.24-3.fc25.x86_64
 


  • 0

#13 WalDo

WalDo

    (prawie) Ekspert

  • @Administrator
  • 11,658 posts

  • Joined: 18 November 04
  • Płeć:Mężczyzna
  • Skąd:Warszawa

Posted 20 December 2016 - 21:33 PM

No to libc.so.6 powinieneś mieć. Może jakieś ścieżki do bibliotek nietypowe dla Fedory?
A steam instalowałeś z repo dla Fedory czy z jakiejś innej paczki?
https://linuxconfig....fedora-25-linux ??
  • 1

______________________________________________________________________________________
Nie udzielam porad poza forum. Kłóci się to z jego podstawową ideą powszechnego dostępu.

Registered user #374329


#14 Stancol

Stancol

    Użytkownik

  • Użytkownicy
  • 133 posts

  • Joined: 12 August 15
  • Płeć:Mężczyzna

Posted 22 December 2016 - 12:33 PM

No to libc.so.6 powinieneś mieć. Może jakieś ścieżki do bibliotek nietypowe dla Fedory?
A steam instalowałeś z repo dla Fedory czy z jakiejś innej paczki?
https://linuxconfig....fedora-25-linux ??

Już działa dzięki!


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users