Skocz do zawartości


Zdjęcie

Gparted

gparted uruchamianie

  • Zaloguj się, aby dodać odpowiedź
6 odpowiedzi w tym temacie

#1 tytus05

tytus05

    Początkujący

  • Nowi użytkownicy
  • 4 postów

  • Rejestracja: 19 grudzień 16

Napisano 19 grudzień 2016 - 22:00

Mam fedorę 25 

System: Host: dom Kernel: 4.8.11-300.fc25.x86_64 x86_64 (64 bit) Desktop: Gnome 3.22.2
Distro: Fedora release 25 (Twenty Five)
Graphics: Card: NVIDIA GF104 [GeForce GTX 460]
Display Server: Fedora X.org 119 driver: N/A Resolution: 1680x1050@59.85hz
GLX Renderer: Gallium 0.4 on NVC4 GLX Version: 3.0 Mesa 13.0.2
 

Gparted nie uruchamia się, a z konsoli wyświetla:

 

# G1 ### pon gru 19 21:34:17 dom : /home/mirek
root ~> gparted
Created symlink /run/systemd/system/-.mount → /dev/null.
Created symlink /run/systemd/system/boot.mount → /dev/null.
Created symlink /run/systemd/system/home.mount → /dev/null.
Created symlink /run/systemd/system/mnt-linux.mount → /dev/null.
Created symlink /run/systemd/system/proc-fs-nfsd.mount → /dev/null.
Created symlink /run/systemd/system/run-user-1000.mount → /dev/null.
Created symlink /run/systemd/system/tmp.mount → /dev/null.
Created symlink /run/systemd/system/var-lib-machines.mount → /dev/null.
Created symlink /run/systemd/system/var-lib-nfs-rpc_pipefs.mount → /dev/null.
No protocol specified

(gpartedbin:9083): Gtk-WARNING **: cannot open display: :0
Removed /run/systemd/system/-.mount.
Removed /run/systemd/system/boot.mount.
Removed /run/systemd/system/home.mount.
Removed /run/systemd/system/mnt-linux.mount.
Removed /run/systemd/system/proc-fs-nfsd.mount.
Removed /run/systemd/system/run-user-1000.mount.
Removed /run/systemd/system/tmp.mount.
Removed /run/systemd/system/var-lib-machines.mount.
Removed /run/systemd/system/var-lib-nfs-rpc_pipefs.mount.

 

 

 

 


  • 0

#2 marcin82

marcin82

    Użytkownik

  • Użytkownicy
  • 42 postów

  • Rejestracja: 31 lipiec 11
  • Płeć:Mężczyzna
  • Skąd:Sosnowiec
  • Zainteresowania:Informatyka, linuks, kolej.

Napisano 19 grudzień 2016 - 23:02

Uruchom z konta użytkownika, możliwe są dwa sposoby:

sudo gparted

gksu gparted

  • 0

marcin82


#3 tytus05

tytus05

    Początkujący

  • Nowi użytkownicy
  • 4 postów

  • Rejestracja: 19 grudzień 16

Napisano 19 grudzień 2016 - 23:14

1. przez sudo jest ten sam błąd

2. zsh: gksu: nie odnaleziono polecenia...

    zsh: command not found: gksu

  • 0

#4 marcin82

marcin82

    Użytkownik

  • Użytkownicy
  • 42 postów

  • Rejestracja: 31 lipiec 11
  • Płeć:Mężczyzna
  • Skąd:Sosnowiec
  • Zainteresowania:Informatyka, linuks, kolej.

Napisano 19 grudzień 2016 - 23:17

Poszukaj w repozytorium i zainstaluj jeśli znajdzie:

sudo su -

dnf search all gksu

 

Podaj wynik polecenia - z konta użytkownika:

id

  • 0

marcin82


#5 tytus05

tytus05

    Początkujący

  • Nowi użytkownicy
  • 4 postów

  • Rejestracja: 19 grudzień 16

Napisano 19 grudzień 2016 - 23:30

znalazł beesu w repo , ale jest już zainstalowane.

 

id

uid=1000(mirek) gid=1000(mirek) grupy=1000(mirek),1001(scanner) kontekst=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023

  • 0

#6 tytus05

tytus05

    Początkujący

  • Nowi użytkownicy
  • 4 postów

  • Rejestracja: 19 grudzień 16

Napisano 20 grudzień 2016 - 21:50

xhost - dom

dom being removed from access control list

to polecenie rozwiązało problem.

No niestety nie do końca. Po zresetowaniu kompa, problem powrócił, nawet po wpisaniu tej komendy. Poszukałem i dopiero ta komenda działa(ale za kazdym uruchomieniem kompa muszę wpisywać z palca w terminalu, aby działał)

$ xhost +local:

No dobra dopisałem tą komendę do ~.zshrc, ale podobno nie jest to bezpieczne rozwiązanie.


  • 0

#7 marcin82

marcin82

    Użytkownik

  • Użytkownicy
  • 42 postów

  • Rejestracja: 31 lipiec 11
  • Płeć:Mężczyzna
  • Skąd:Sosnowiec
  • Zainteresowania:Informatyka, linuks, kolej.

Napisano 23 grudzień 2016 - 20:31

Zauważyłem dopiero teraz, że używasz powłoki zsh. I to jest prawdopodobnie przyczyna, bo zsh nie uruchamia tego skryptu przy starcie serwera X:

/etc/X11/xinit/xinitrc.d/localuser.sh

 

Zajrzałem na livecd. Resztę musisz sprawdzić sam - dorzuć to do globalnego pliku konfiguracji zsh i powinno działać. Za bezpieczne to to nie jest, ale co zrobisz - no nic nie zrobisz :D


  • 0

marcin82






Również z jednym lub większą ilością słów kluczowych: gparted, uruchamianie

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych użytkowników