Jump to content

All Activity

This stream auto-updates     

  1. Yesterday
  2. No jestem ponownie. Mam prośbę. Powiedz / powiedzcie mi co robię źle. Nie wyszło mi. Podejmowałem kroki tak jak opisane na tych stronach: https://fedoraproject.org/wiki/JACK_Audio_Connection_Kit https://docs.fedoraproject.org/en-US/Fedora/17/html/Musicians_Guide/sect-Musicians_Guide-Integrating_PulseAudio_with_JACK.html https://docs.fedoraproject.org/en-US/Fedora/16/html/Musicians_Guide/sect-Musicians_Guide-Using_JACK.html#sect-Musicians_Guide-Install_and_Configure_JACK Dodałem siebie do grupy jakckuser. Po uruchomieniu serwera jack w oknie wiadomości zobaczyłem coś takiego: 19:55:12.391 Statistics reset. 19:55:12.396 ALSA connection change. 19:55:12.399 D-BUS: Service is available (org.jackaudio.service aka jackdbus). 19:55:12.525 ALSA connection graph change. 20:04:53.220 Startup script... 20:04:53.220 pulseaudio -k 20:04:53.630 Startup script terminated successfully. 20:04:53.835 D-BUS: JACK server is starting... 20:04:53.837 D-BUS: JACK server was started (org.jackaudio.service aka jackdbus). Tue Oct 27 20:04:53 2020: Starting jack server... Tue Oct 27 20:04:53 2020: JACK server starting in non-realtime mode Tue Oct 27 20:04:53 2020: self-connect-mode is "Don't restrict self connect requests" Tue Oct 27 20:04:53 2020: Acquired audio card Audio0 Tue Oct 27 20:04:53 2020: creating alsa driver ... hw:SB|hw:SB|1024|2|44100|0|0|nomon|swmeter|-|32bit Tue Oct 27 20:04:53 2020: configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 2 periods Tue Oct 27 20:04:53 2020: ALSA: final selected sample format for capture: 32bit integer little-endian Tue Oct 27 20:04:53 2020: ALSA: use 2 periods for capture Tue Oct 27 20:04:53 2020: ALSA: final selected sample format for playback: 32bit integer little-endian Tue Oct 27 20:04:53 2020: ALSA: use 2 periods for playback Tue Oct 27 20:04:53 2020: graph reorder: new port 'system:capture_1' Tue Oct 27 20:04:53 2020: New client 'system' with PID 0 Tue Oct 27 20:04:53 2020: graph reorder: new port 'system:capture_2' Tue Oct 27 20:04:53 2020: graph reorder: new port 'system:playback_1' Tue Oct 27 20:04:53 2020: graph reorder: new port 'system:playback_2' Tue Oct 27 20:04:53 2020: graph reorder: new port 'system:playback_3' Tue Oct 27 20:04:53 2020: graph reorder: new port 'system:playback_4' Tue Oct 27 20:04:53 2020: graph reorder: new port 'system:playback_5' Tue Oct 27 20:04:53 2020: graph reorder: new port 'system:playback_6' Tue Oct 27 20:04:55 2020: Saving settings to "/home/zf/.config/jack/conf.xml" ... 20:04:55.912 JACK connection change. 20:04:55.914 Statistics reset. 20:04:55.925 Client activated. 20:04:55.925 Patchbay deactivated. 20:04:55.925 Post-startup script... 20:04:55.925 pactl load-module module-jack-source;pactl load-module module-jack-sink 20:04:55.942 JACK connection graph change. 20:04:56.346 Post-startup script terminated with exit status=256. Tue Oct 27 20:04:55 2020: New client 'qjackctl' with PID 3139 20:06:03.693 XRUN callback (1). Za pierwszym razem postępowałem identycznie i nie było żadnego problemu. Wprawdzie teraz Audacity w polu Host pokazuje mi Jack Audio Connection Kit jednak dźwięku nie ma.
  3. Last week
  4. Dzięki spróbuję tak zrobić. Wcześniej byłem przekonany, że nikt mi nie odpowie na tego posta. Z niecierpliwości odinstalowałem pakiety odpowiedzialne za JACK'a, miałem zamiar już od tego odstąpić. Gdy dostałem odpowiedź od Ciebie to wykonałem dokładnie wszystkie czynności co za pierwszym razem żeby uruchomić ponownie ten serwer dźwięku ale coś mi nie wychodzi... Przedtem Ocenaudio JACK'a mi widział jako monitor of pulse audio jack-sink (jak nie pomyliłem się w nazwie) a Audacity w miejsce ALSY miał Jack'a. Może coś przeoczyłem... W każdym bądź razie próbuję dalej.
  5. W takich sytuacjach najlepiej zrobić chroot na zamontowaną partycję z Fedorą i naprawić ją mając dostęp do shella. Ale zanim to zrobimy: - w jaki sposób skopiowałeś system ze starego dysku na nowy? - czy zmodyfikowałeś plik /etc/fstab tak, by odpowiadał numerom identyfikacyjnym partycji na nowym dysku (pewnie tak, skoro dochodzisz aż do dracuta, ale nie zaszkodzi sprawdzić). Chroot polega na uruchomieniu jakiegokolwiek LiveCD (możę być płyta instalacyjna z Fedorą Workstation) i urychomienie z niej komputera. Potem trzeba utworzyć katalog, przykładowo, /mnt/zepsuta_fedora i zrobić coś takiego (zakładając, że Fedora jest zainstalowana na partycji /dev/sda1, chociaż u Ciebie może być gdzieś indziej): mount -t ext4 (lib xfs) /dev/sda1 /mnt/zepsuta_fedora mount --types proc /proc /mnt/zepsuta_fedora/proc mount --rbind /sys /mnt/zepsuta_fedora/sys mount --make-rslave /mnt/zepsuta_fedora/sys mount --rbind /dev /mnt/zepsuta_fedora/dev mount --make-rslave /mnt/zepsuta_fedora/dev chroot /mnt/zepsuta_fedora /bin/bash source /etc/profile W tym momencie jesteś zalogowany jako root na Twojej fedorze 29. I możesz wygenerować initramfsa. Sprawdź jaki kernel masz w katalogiu /boot/ - ls -al /boot - i zrób coś takiego: dracut -f /boot/initramfs-wersja.x86_64.img wersja.x86_64 Wydaje się skomplikowane, ale zadziała. Czy pomoże, to zależy od tego, czy przyczyną jest initramfs. Przy okazji, będąc zalogowany do systemu przez livecd, możesz sprawdzić /etc/fstab oraz konfigurację gruba w /etc/default grub .
  6. Zrobiłem kopie Fedory 29 z dysku SSD sata na dysk Nvme. Po klonie system łąduje się do wyboru wersji fedory(wcześniej robiłem upgrady więc jest do wyboru 29 w trzech odmianach oraz 25 rescu).Po wybraniu systemu pokazuje się obrys logo fedory zapełniane białym, finalnie system kończy się ładować na dracut. Próbowałem wpisyawac dracut --regerate-all -f ale system nie rozpoznaje takiego polecenia, po wpisaniu help nie widać takiego polecenia. Podejrzewam że problemem jest zmiana ścieżek dostępu. Proszę o podpowiedz gdzie i co mam pozmieniać.
  7. Finalnie to już sam nie wiem gdzie jest błąd, nie wiem czy błędu instalacji nie wywołuje jedna z zakupionych nowych kart garficznych Asus gt710, ale to tylko jedna sztuka. Kupiłem dwie sztuki gt710 i wydaje mi się że na jednej przechodzi instalator a na drugiej nie. Windows instalowany i katowany na obydwu klamotach i bezproblemowo się zainstalował i działał.
  8. To jest dosyć łatwo sprawdzić. Włączy muzykę, zacznij nagrywać i wpisz htop w terrminalu. Daj znać co tam wyszło i czy LOAD nie jest na poziomie większym, niż ilość rdzeniw Twoim procesorze.
  9. Witam Was. Udało mi się skonfigurować JACK'a do nagrywania dźwięku (utworów muzycznych) z internetu i nie tylko. Ustawiłem ten serwer dźwięku tak, że pulseaudio korzysta z JACK'a. Jednak podczas nagrywania zdarzają się czasami bardzo małe przerwy w odtwarzanej muzyce. Gdy odtwarzam tą muzykę niestety to nieznacznie słychać. W związku z tym chciałbym zapytać czy mój komputer nie jest do używania JACK'a za słaby: 8 GB RAM CPU AMD Phenom II X4 956 3,4 GHz no i wynik polecenia cat /proc/asound/cards: 0 [SB ]: HDA-Intel - HDA ATI SB HDA ATI SB at 0xfe024000 irq 16 1 [NVidia ]: HDA-Intel - HDA NVidia HDA NVidia at 0xfcffc000 irq 19 Audacity informuje, że są małe przerwy w nagranym utworze muzycznym a w Ocenaudio to nieznacznie słychać. Ustawienia QJackCtl spisałem z internetu. Odtwarzanie w czasie rzeczywistym wyłączyłem.
  10. Przepraszam, ale się spieszyłem i popełniłem błąd, prawdopodobnie powinno być video=HDMI-A-1:[email protected] Sprawdź co ci wyświetla polecenie ll /sys/class/drm
  11. Dodałem do ustawień GRUBa (sudo gedit /etc/default/grub): Potem przebudowałem: sudo grub2-mkconfig -o /boot/grub2/grub.cfg Ale dalej to samo. Próbowałem z opcją @54.97 i też nie dało. Nawet "video=HDMI-1:[email protected]" wrzuciłem "luzem" pod parametrami w pliku konfiguracyjnym Grub'a, ale też nie. No trudno, będę w miarę potrzeby uruchamiał skrypt. Może dodam go do menu aplikacji.
  12. Witam. mam problem z zainstalowaniem Fedory 32. Wbudowany w instalator program do partycjonowania niestety za zadne skarby nie pozwala mi utworzyc punktow montowania o wybranych przeze mnie wielkosciach partycji BTFRS. Jak juz udalo sie utworzyc punkt montowania pod system, pozniej tworze osobno na home i wtedy laczy mi to w jedna partycje. Nie moge ustawic nic po swojemu nawet partycji EFI. Wybor z automatu mnie nie zadowala. Probowalem nawet utworzyc w zewnetrznym programie partycje ale nie da sie ich wybrac podczas instalacji fedory. Czy zawsze sa takie problemy przy jej instalacji, czy moge ja jakos zmusic by zainstalowala sie z takimi partycjami jak sobie chce ustalic?
  13. Jaki kernel? Na 5.9 jeszcze nie ma w pełni sprawnych sterowników. https://forums.developer.nvidia.com/t/nvidia-driver-not-yet-supported-for-linux-kernel-5-9/157263
  14. Update: Porównałem wyjście z glxinfo na obu sesjach i tu jest ciekawie: < OpenGL vendor string: NVIDIA Corporation < OpenGL renderer string: GeForce GTX 1060 3GB/PCIe/SSE2 < OpenGL core profile version string: 4.6.0 NVIDIA 455.28 < OpenGL core profile shading language version string: 4.60 NVIDIA vs > OpenGL vendor string: VMware, Inc. > OpenGL renderer string: llvmpipe (LLVM 10.0.1, 256 bits) > OpenGL core profile version string: 3.3 (Core Profile) Mesa 20.1.10 > OpenGL core profile shading language version string: 3.30 oraz < OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 455.28 < OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20 vs > OpenGL ES profile version string: OpenGL ES 3.1 Mesa 20.1.10 > OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10 WTF?! Druga sesja leci na innym sterowniku?
  15. Hej, Mam kartę GeForce, GTX 1060. Zainstalowałem własnościowe sterowniki z rpmfusion wraz z bibliotekami do CUDA. Wszystko pięknie śmiga do czasu aż nie uruchomię drugiej sesji (np. zaloguje się moja żona na swoje konto). Na drugiej sesji, niezależnie który użytkownik to jest, po prostu drugiej otwartej w kolejności, wydajność grafiki jest żadna. Do tego stopnia, ze nawet myszka ma koszmarne lagi. Jak glxgears na pierwszej sesji pokazuje koło 15000 tak na drugiej juz tylko 1400. No chyba, ze zacznę ruszać myszką to wtedy spada np. do 8. Co ciekawe, na drugiej sesji zmienia się też sposób renderowania fontów. Sprawdziłem poprzez loginctl show-session -p Type, i obie sesje to X11. Używam plasmy, aktualnej fedory, sterowników w wersji xorg-x11-drv-nvidia-3:455.28-1.fc32.x86_64. Jak szukać rozwiązania, źródła problemu? A może ktoś to już rozwiązał? Help...
  16. Wygląda, że system nie wykrywa rozdzielczości. Spróbuj dodać do argumentów kernela video=HDMI-1:[email protected]
  17. Polecenie XRANDR bez parametrów, przed wykonaniem skryptu: I po skrypcie:
  18. Earlier
  19. A to jest ładne - https://developers.redhat.com/ebooks - i jest tu jest tyle ciekawych pdfów, że subskrypcja mi się zwróci.
  20. Na Waylandzie w ogóle mi nie poszło, musiałem zmienić na Xy :/
  21. Dzięki, fajne. A z ciekawości: na Waylandzie rozdzielczość również jest nieprawidłowa? Nie wiem na ile brak Xsów cokolwiek pomaga.
  22. Internety mówią, że Debian 10 chodzi na tych dyskach, więc wyczuwam jakiś regres w kernelu z Fedory 32, który został częściowo poprawiony. Czy w przypadku fedory 33 problem jest tylko z instalatorem, czy po instalacji również działa niestabilnie?
  23. Witam, nie wiem gdzie powinienem to wrzucić, mam nadzieję, że dobra kategoria. Mam skrypt do do zmiany rozdzielczości ekranu na drugim monitorze, do rozdzielczości 1440, ponieważ za każdym razem, gdy uruchamiam ponownie komputer, ustawia się rozdzielczość 1080, a 1440 brakuje na liście. Nie wiem co zrobić, aby za każdym uruchomieniem systemu, ta rozdzielczość ustawiała się domyślnie. Kombinowałem coś z uruchomieniem skryptu przy starcie systemu, ale nie zadziałało. Skrypt, który uruchamiam ręcznie przy starcie systemu: #!/bin/bash out = `xrandr` echo ${out} | systemd-cat -p info xrandr --newmode "2560x1440_54.97" 221.00 2560 2608 2640 2720 1440 1443 1447 1478 +HSync -VSync xrandr --addmode HDMI-1 2560x1440_54.97 xrandr --output HDMI-1 --mode 2560x1440_54.97
  24. Witam! sunrise napisał: /home na hdd zamiast sdd to nie jest dobry pomysł, ale za to polecam na hdd trzymać logi i inne dany które są często zapisywane, a rzadko odczytywane. W Installation Guide F23 pnk. 5.4.10.7. Advice on Partitions jest: In some cases, creating separate mount points for directories other than /, /boot and /home may be useful;....... i The contents of the /var directory usually change very often. This may cause problems with OLDER SOLID STATE drives (SSDs), as they can handle a lower number of read/write cycles before becoming unusable. If your system root is on an SSD, consider CREATING A SEPARATE MOUNT POINT FOR /VAR ON A CLASSIC (PLATTER) HDD. Podobno nowe dyski sdd są dużo bardziej odporne na ten problem. oraz If /usr or /var is partitioned separately from the rest of the root volume, the boot process becomes much more complex because these directories contain boot-critical components.......... Przez jakiś czas miałem /usr i /var na wydzielonych partycjach ale nie zauważyłem problemów z bootowaniem. Dotychczas miałem taki podział dysku(HDD) /boot / /home /var/log swap Opierając się na zamianie w laptopie hdd na sdd co dało znaczne przyspieszenie pracy chcę to samo zrobić w pc stacjonarnym. /home na wydzielonej partycji daje mi swobodę zmiany nowej (instalacja) wersji systemu bez zmiany /home. /var/log też na wydzielonej partycji. Planowany podział jest taki: sdd /boot / hdd /home /var/log swap Wracając do swapa, przy jego braku kompy zawieszają się, jezeli swap jest aktywny wszystko jest OK. Obserwowałem zajętość swapa(gkrellm)wynik 200-3000kb, przy wielkości RAM: laptop 2Gb, pc 4GB. Czy swap na hdd da zauważalne opóźnienie w pracy systemu-zobaczymy. Ale, przepraszam, rozpisałem się, problem został rozwiązany. Dziękuję doradcom. Życzę pogody ducha. ALvarez
  25. Windows instaluje się na tym dysku bezproblemowo.
  26. critical error 0 endurance group critical warning summary 0 media error 0 num_err log_entries 231 więc wyglada ze z dyskiem wszystko dobrze Na drugim takim samym dysku udało się zainstalować system, używając innej płyty, drugi z dysków powoduje pine dead;/ Fedora 33 dała się zainstalować chyba bezpośrednio na maszynie, były z dwie zwiechy, ale się dało. Biosy, firmware napewono najwnosze w tej maszynie której nie mogę zainstalować fedory;/ Na tej co zainstalowałem fedore 32 nie jestem pewien czy dysk ma najnowszy firmware. Co jeszcze mógł bym zrobić?
  1. Load more activity
×
×
  • Create New...