Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 11/05/2016 in all areas

  1. 2 points
    Jak zaprząc system do wykonywania cyklicznej kopii, czegokolwiek co chcemy, na dysku internetowym w tzw. chmurze firmy OVH? Do obsługi darmowego konta do 25 GB służy aplikacja hubiC. Zaczynamy od utworzenia swojego konta i zainstalowania aplikacji, która w Fedorze 25 wymaga dodania odpowiedniego repozytorium. Dołączenie repozytorium Copr: # dnf copr enable madcat/hubic instalacja hubiC: dnf install hubiC Można oczywiście obsługiwać swoje konto poprzez stronę internetową ale my chcemy mieć ten proces w tle. Sama synchronizacja jest automatyczna i włącza się samoczynnie razem ze startem systemu. Aby było to możliwe, trzeba zapisać hasło do konta w pliku tekstowym, a następnie zalogować się, wkazując jako hasło ten plik, a także nazwę konta i katalog na dysku, który ma być synchronizowany według tego schematu: hubic login --password_path=/home/user/.config/hubiC/.hubicpassword moj@email.pl ~/hubic Tworzymy folder w katalogu domowym mkdir /home/user/hubic oraz plik z hasłem dostępu: mkdir /home/user/.config/hubiC/ && touch /home/user/.config/hubiC/.hubicpassword && echo "moje_hasło" > /home/marek/.config/hubiC/.hubicpassword Teraz można przystąpić do zaprogramowania obsługi backup`u. Będzie on się odbywał w tle a jedyne czego należy dopilnować, jeśli nie chcemy już skrajnie automatyzować procesu, aby komputer był włączony o zaplanowanej porze. Jeśli nie będzie to po prostu kopii nie wykona. Tworzę skrypt np. hubic.sh w dowolnej lokalizacji np. /home/user/ touch hubic.sh Edytuję plik i wklejam treść. To co umieścimy w skrypcie nasza wola, ja dałem przykładowo folder Dokumenty. Na potrzeby backup`u tworzę folder /tmp, który w efekcie końcowym zostanie usunięty. Rozszerzyłem opcje bezpieczeństwa plików poprzez spakowanie i później zaszyfrowanie. #!/bin/sh mkdir /home/user/tmp && rsync -avz --progress ~/Dokumenty /home/user/tmp && tar -zcvf /home/user/tmp/Dokumenty.tgz /home/user/tmp/Dokumenty && openssl enc -aes-256-cbc -salt -in /home/user/tmp/Dokumenty.tgz -out /home/user/tmp/Dokumenty.tgz.enc -k "hasło" && mv /home/user/tmp/Dokumenty.tgz.enc /home/user/hubic/Documents && rm -rf ~/tmp Nadaję mu prawa wykonywania chmod +x hubic.sh Na koniec formułuję w crontab porę backup`u np. crontab -e 0 9 * * 0 /home/user/hubic.sh Kopia będzie robiona co niedzielę o godzinie 9:00 A teraz droga powrotna na odwrócenie procesu czyli: odszyfrowanie: openssl aes-256-cbc -d -salt -in /home/user/hubic/Documents/Dokumenty.tgz.enc -out /home/user/Dokumenty.tgz rozpakowanie: tar zxvf Dokumenty.tgz Wybrałem jeszcze najprzydatniejsze polecenia z manuala do obsługi terminalem: hubic status hubic stop hubic logout hubic synchronize hubic pause
  2. 1 point
    Zaktualizuj system. Jako root, wydaj polecenie: dnf update --refresh -y
  3. 1 point
  4. 1 point
    Odinstaluj chwilowo dwa kłopotliwe pakiety: gphpedi oraz nss-pem. Jeżeli dnf będzie protestować, usuwając zależne od nich pakiety, wówczas zrób to klasycznie: rpm -e --nodeps gphpedi nss-pem Zainstalujesz je sobie już na nowej Fedorze po restarcie.
  5. 1 point
    Dodaj do linii poleceń (tej z dnf system-upgrade) opcję: --allowerasing
  6. 1 point
    Fedora wspiera 2 wydania wstecz od najnowszego. Mamy F28. F25 nie jest wspierana od 12.12.2017 → https://fedoraproject.org/wiki/End_of_life Możesz spróbować aktualizacji do F28. https://fedoraproject.org/wiki/DNF_system_upgrade Nie wiem jak to jest teraz, ale kiedyś zalecano aktualizację nie więcej niż o dwa wydania na raz. Czyli w Twoim wypadku F25→F27 i potem F27→F28. Jednak poczekaj, aż ktoś potwierdzi to co napisałem, bo może da się F25→F28 od razu. Tak czy inaczej zrobiłbym backup przed taką akcją. Przynajmniej tych najważniejszych dla Ciebie rzeczy.
  7. 1 point
    Znalazłem w necie taką podpowiedź dnf install glibc-langpack-cs I teraz pojawia się taki błąd -bash: uwaga: setlocale: LC_TIME: nie można zmienić lokalizacji (pl_PL.UTF-8) Co ciekawe terminal dalej nie uruchamia się, ale znalazłem za to fajny zamiennik - Terminator teraz dodałem jeszcze rpm -qa | grep glibc glibc-langpack-en-2.27-8.fc28.x86_64 glibc-headers-2.27-8.fc28.x86_64 glibc-langpack-os-2.27-8.fc28.x86_64 glibc-devel-2.27-8.fc28.x86_64 glibc-common-2.27-8.fc28.x86_64 glibc-2.27-8.fc28.i686 glibc-2.27-8.fc28.x86_64 i okazuje się, że mam langpack-en więc doinstalowałem dnf install glibc-langpack-pl terminal zaczął działać i język zmienił się wszędzie na polski
  8. 1 point
    Jasność ekranu w laptopie zależy od wartości liczbowej w pliku /sys/class/backlight/KARTA_GRAFIKI/brightness. Katalog KARTA_GRAFIKI jest nazywany różnie w zależności od sprzętu. Może być radeon_bl0, może być coś innego. Wystarczy podmienić liczbę na mniejszą. Najpierw sprawdź co jest tam ustawione: cat /sys/class/backlight/radeon_bl0/brightness a potem ustaw tam jakąś mniejszą liczbę, jako root, lub użytkownik z uprawnieniami do używania sudo, np.: sudo echo 55 > /sys/class/backlight/radeon_bl0/brightness Zazwyczaj w laptopach guziki "multimedialne" do regulowania jasności ekranu działają świetnie, może dojdziemy co w Twoim przypadku nie działa. Dodatkowo Linux potrafi regulować ilość czerwonego, zielonego i niebieskiego na ekranie, do czego Gnome ma bardzo milutki kreatorek. Świetna sprawa do pracy przy komputerze po zmroku.
  9. 1 point
    Gra ” F1 2015 ” za darmo tylko jeszcze przez parę godzin. https://www.humblebundle.com/store/f1-2015 Instrukcja pobrania. - Wybierasz grę w humblebundle ( trzeba być zalogowanym ) - Wchodzisz w koszyk i akceptujesz zakup za darmo - Dostajesz email z linkiem, otwierasz link ( kopiuj i wklej do przegladarki zeby sprawdzic czy to nie jakis obcy i falszywy adres ) - W nowym linku wybierasz klienta Steam, wyświetli się kod - Kod aktywujesz w Steam, w zakladce Gry --> Aktywuj produkt na Steam ... - Po poprawnej weryfikacji kodu / klucza, gra powinna być w bibliotece Steam i mozna ją zainstalować w dowolnej chwili. Dodatkowo ” F1™ 2017 ” przez 2 dni za darmo można pograć, a potem trzeba kupić lub zrezygnować z gry. http://store.steampowered.com/app/515220/F1_2017/ Data publikacji 23.03.2018
  10. 1 point
    Nie znam Scilab, ale jakieś 3 minuty zajęło mi odnalezienie w Googlach identycznego zadania z rozwiązaniem. Może napisz co zrobiłeś do tej pory? Na razie to wygląda na to, że chciałbyś żeby zadanie domowe ktoś za Ciebie rozwiązał i nawet szukać Ci się nie chce.
  11. 1 point
    To raczej coś z gnome-shell sty 30 00:18:21 localhost.localdomain gnome-shell[1790]: invalid cast from 'GTask' to 'GSimpleAsyncResult' sty 30 00:18:21 localhost.localdomain gnome-shell[1790]: g_simple_async_result_propagate_error: assertion 'G_IS_SIMPLE_ASYNC_RESULT (simple)' failed sty 30 00:18:21 localhost.localdomain polkitd[773]: Unregistered Authentication Agent for unix-session:5 (system bus name :1.66, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale pl_PL.UTF-8) (disconnected from bus) sty 30 00:18:21 localhost.localdomain gnome-session[1705]: gnome-session-binary[1705]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1 sty 30 00:18:21 localhost.localdomain gnome-session-binary[1705]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1 A dokładniej to https://bugzilla.redhat.com/show_bug.cgi?id=1538493 musisz spróbować tam podanego rozwiązania.
  12. 1 point
    A działasz na Xach czy na Waylandzie? Ja działam na Xach, bo Plasma na Waylandzie nie nadaje się do użytku, więc może to kwestia Waylanda?
  13. 1 point
    Zrobiłem jak kolega wyżej i "kaszlało" mi przy pierwszych 3 uruchomieniach, ale potem wszystko się unormowało i działa naprawdę dobrze, znacznie lepiej niż myślałem Dzięki za poradnik. _____________________________ Polecam: umowa kupna sprzedaży samochodu
  14. 1 point
    Moim zdaniem przejście na rolling release pomogło by Fedorze. Wystarczyło by trzymać min/max 2 linie np. 'stable' i 'test' gdzie w stable były by naprawdę rzeczy stable, a w test te ich nowości. Niestety, lepiej tracić czas i zasoby ludzkie na trzymanie 2/3 wydań dystrybucji wstecz. Tak jest i prawdopodobnie będzie bo taki model dystrybucji ma RedHat tyle, że znacznie wolniejszy.
  15. 1 point
    Kiepsko sprawdzałeś. Jeśli masz skonfigurowane repozytorium Adobe, to wystarczy: dnf install flash-player-ppapi Ewentualnie ręcznie: https://get.adobe.com/flashplayer/otherversions/ Wybierz wersję FP 27.0 for Linux 64-bit (.rpm) - PPAPI
  16. 1 point
    $ scanimage -L device `v4l:/dev/video0' is a Noname Integrated Camera virtual device Moje urządzenie, to drukarka sieciowa i nie miałem dotąd z nią problemów. Problem rozwiązany: trzeba było zainstalować pakiet libsane-hpaio i wszystko jest już OK
  17. 1 point
    U mnie Fedora 26, Gnome Shell 3.24, Motyw T4G 3.0 theme, zmieniony ~.bashrc.
  18. 1 point
    Może musisz przełączyć na odpowiednią wesję javy za pomocą polecenia alternatives --config java
  19. 1 point
    Nic mi o takiej opcji nie wiadomo i man nie wspomina nic o kolorach. I tak jest nieźle, bo zainstalowane pakiety są najpierw, a dostępne poniżej. Moglibyśmy mieć apta.
  20. 1 point
    Powinno być sudo dnf remove kernel-4.11.10-300.fc26.x86_64 To polecenie odnajduje trzy obrazy kerneli, stąd też w gubie 3 kernele. Ja usunąłeś najstarszy kernel?
  21. 1 point
    szcześliwe zakończenie ! to że padały produkty Mozilli wpędziło mnie w ślepą uliczkę, jak mi się sypnął Krusader a dnf podczas instalacji teamviewera wykasował kilkanaście bibliotek z usr/lib zrobiłem w końcu test Memtestem86+ i juz po wszystkim, wadliwa kość wyjęta, RAM-u o połowę mniej ale system znowu działa, uff... P.S. uważajcie na zakupy w x-komie, wykupiłem pakien OnSide, przyjechali z Asusa i powiedzieli, że X-kom grzebał w konfiguracji i nie powinienem mieć (zgodnie z numerem seryjnym) 16GB tylko 4GB i inny dysk i nie mogą mi tej pamięci wyminiec w ramach wizyty a X-com powiedział, ze onside jest tylk na elementy Asusa, a pamięc i dysk jest od nich, więc mam im wysłać sprzęt do naprawy, tylko że w trakcie zakupu nikt mi nie mówił, że jest onside połowiczny bo w laptopie ktoś grzebał itd..., żenada
  22. 1 point
    Dziękuję Wam serdecznie za pomoc Tego właśnie chciałem się dowiedzieć. Nadmienię tylko, że właśnie sprawdziłem klucz metodą, którą polecił marcin82 i była zgodność podpisu. OK temat jak dla mnie rozwiązany
  23. 1 point
    Już się wyjaśniło skąd te problemy. Otóż miałem google-earth zainstalowane z repozytoriów google-earth-repo o czym już nawet zapomniałem. Potem zainstalowałem wersję 64bit pobraną stąd https://www.google.com/earth/download/ge/agree.html lecz błąd nadal się pojawiał. Odinstalowałem więc pakiet rpm -e google-earth i zainstalowałem pobrany z tego samego miejsca pakiet w wersji 32 bit wraz z zależnościami. Błąd nadal się pojawiał tak jak wcześniej, dopiero po odinstalowaniu google-earth w wersji 32 bit spróbowałem uruchomić program w wierszu poleceń i ku mojemu zaskoczeniu ten nadal próbował się uruchomić i to dało do myślenia. znalazłem gdzie siedzi oprogramowanie poprzez whereis google-earth posprzątałem ręcznie w tych miejscach które zostały wylistowane powyższym poleceniem i zainstalowałem ponownie pakiet rpm w wersji 64bit pobrany z https://www.google.com/earth/download/ge/agree.html teraz już wszystko działa prawidłowo.
  24. 1 point
    http://wiki.samygo.tv/index.php5/Using_NoN-Samsung_USB_WiFi_dongles_with_TV
  25. 1 point
    Kanka wódki na stół i jedziemy z koksem
×