Jump to content

Nifir

Użytkownicy
  • Content Count

    112
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Nifir

  • Rank
    Użytkownik

Previous Fields

  • Ulubiona dystrybucja
    F10
  • Środowisko graficzne
    GNOME

Contact Methods

  • Strona www
    http://www.shotersi.pl
  • ICQ
    0
  1. Mam problem z instalacją nowej maszyny wirtualnej. Kierowałem się wieloma poradnikami i nigdzie nie umiem znaleźć odpowiedzi. Problem w tym, że większość użytkowników zakłada możliwość połączenia się z nową maszyną virtualną przez VNC, czy inny program graficzny. Ja chciałbym tego uniknąć. System matka - debian virt-install --nographics -n debian001x64 --description "Testowy Debian" --ram=2048 --cdrom /var/virt/iso//CentOS-6.7-x86_64-minimal.iso --disk path=/var/virt/machine/debian001x64/debian001x64.raw,bus=virtio,format=raw,cache=none,io=native --os-variant=debianwheezy --vcpus 2 --network bridge=br0,model=virtio --os-type=linux WARNING CDROM media does not print to the text console by default, so you likely will not see text install output. You might want to use --location. Starting install... Creating domain... | 0 B 00:00 Connected to domain debian001x64 Escape character is ^] I na tym instalacja się zatrzymuje. - Ja wiem, pewnie teraz mogę się połączyć przez VNC i dokończyć dzieła, ale chcę w przyszłości robić maszyny wirtualne skryptem i nie chcę się bawić w tryb graficzny. Chyba, że polecicie inne rozwiązanie? Tutaj kolega łączył się podobnie i wchodził w instalację w trybie tekstowym: https://youtu.be/nVvHCb-ixF4?t=1296. Mnie natomiast wywala informację, że "CDROM media does not print to the text console by default" Udało mi się odpalić przy instalacji z sieci: virt-install --nographics -n debian001x64 --description "Testowy Debian" --ram=2048 --location 'http://mirror.i3d.net/pub/centos/6/os/x86_64/' --disk path=/var/virt/machine/debian001x64/debian001x64.raw,bus=virtio,format=raw,cache=none,io=native --os-variant rhel6 --vcpus 2 --network bridge=br0,model=virtio --os-type=linux --console pty,target_type=serial --extra-args 'console=ttyS0,115200n8 serial' bo tu mogłem użyć "extra-args". Przy instalacji z ISO tej opcji nie mogłem użyć: ERROR --extra-args only work if specified with --location. See the man page for examples of using --location with CDROM media Niestety próbowałem też podpiąć moje iso za pomocą location, ale bezskutecznie.
  2. Dobra.... Nie wiem co wcześniej psułem... ale teraz zaskoczyło z palca. Dodałem wpis do iptables, iptables-save, zmieniłem wpis w /etc/ssh/sshd i reloadowałem sshd.service. I tym sposobem działa na porcie 12345 EDIT: Coś chyba miałem spaprane w /etc/sysconfig/iptables
  3. iptables -I INPUT -p tcp --dport 12345 -j ACCEPT $ iptables-save # Generated by iptables-save v1.4.21 on Tue Sep 8 18:24:34 2015 *filter :INPUT ACCEPT [0:0] :FORWARD ACCEPT [0:0] :OUTPUT ACCEPT [20:1520] -A INPUT -p tcp -m tcp --dport 12345 -j ACCEPT -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT -A INPUT -p icmp -j ACCEPT -A INPUT -i lo -j ACCEPT -A INPUT -p tcp -m state --state NEW -m tcp --dport 22 -j ACCEPT -A INPUT -j REJECT --reject-with icmp-host-prohibited -A FORWARD -j REJECT --reject-with icmp-host-prohibited COMMIT # Completed on Tue Sep 8 18:24:34 2015 $ systemctl status sshd â sshd.service - OpenSSH server daemon Loaded: loaded (/usr/lib/systemd/system/sshd.service; enabled; vendor preset: enabled) Active: active (running) since Tue 2015-09-08 18:19:12 CEST; 6min ago Docs: man:sshd(8) man:sshd_config(5) Main PID: 778 (sshd) CGroup: /system.slice/sshd.service ââ778 /usr/sbin/sshd -D Sep 08 18:19:12 localhost.localdomain systemd[1]: Started OpenSSH server daemon. Sep 08 18:19:12 localhost.localdomain systemd[1]: Starting OpenSSH server daemon... Sep 08 18:19:12 localhost.localdomain sshd[778]: Server listening on 0.0.0.0 port 22. Sep 08 18:19:12 localhost.localdomain sshd[778]: Server listening on :: port 22. Sep 08 18:22:00 localhost.localdomain sshd[890]: Accepted password for nifir from 192.168.5.176 port 50302 ssh2 Sep 08 18:23:18 localhost.localdomain sshd[945]: Did not receive identification string from 192.168.5.219 Zrobiłem też nc nasłuch na 12345: $ nc -l 12345 i tu sprawa której nie rozumiem. Bo jak wysyłam coś netcatem z innego kompa: nc MOJSERWER 12345 < test.log To plik przechodzi. A jak tylko słucham portów: nc -zv MOJSERWER 12345 To dostaję "Connection refused"
  4. [00:56] [email protected]:/etc/sysconfig$ iptables -I INPUT -p tcp --dport 12345 -j ACCEPT [00:56] [email protected]:/etc/sysconfig$ iptables -L -n -v Chain INPUT (policy ACCEPT 0 packets, 0 bytes) pkts bytes target prot opt in out source destination 0 0 ACCEPT tcp -- * * 0.0.0.0/0 0.0.0.0/0 tcp dpt:12345 146 10844 ACCEPT all -- * * 0.0.0.0/0 0.0.0.0/0 state RELATED,ESTABLISHED 0 0 ACCEPT icmp -- * * 0.0.0.0/0 0.0.0.0/0 0 0 ACCEPT all -- lo * 0.0.0.0/0 0.0.0.0/0 0 0 ACCEPT tcp -- * * 0.0.0.0/0 0.0.0.0/0 state NEW tcp dpt:22 7 440 REJECT all -- * * 0.0.0.0/0 0.0.0.0/0 reject-with icmp-host-prohibited Chain FORWARD (policy ACCEPT 0 packets, 0 bytes) pkts bytes target prot opt in out source destination 0 0 REJECT all -- * * 0.0.0.0/0 0.0.0.0/0 reject-with icmp-host-prohibited Chain OUTPUT (policy ACCEPT 5 packets, 748 bytes) pkts bytes target prot opt in out source destination I na pod cygwinem na windzie odpalam: $ nc -v -n -z -w 1 192.168.5.107 12345 nc: connect to 192.168.5.107 port 12345 (tcp) failed: Connection timed out $ nc -v -n -z -w 1 192.168.5.107 22 Connection to 192.168.5.107 22 port [tcp/*] succeeded!
  5. Fakt, nie przeczytałem, ale semanage port -a -t ssh_port_t -p tcp 12345 nie pomogło. No tak, masz rację. Testowałem za to w takiej konfiguracji: iptables -F iptables -A INPUT -p tcp --dport 22 -j DROP i to wywala mi otwarty port 22, a z kolei iptables -F iptables -A INPUT -p tcp --dport 12345 -j ACCEPT zupełnie nie daje efektu. Skoro odrzucanie działa, to dlaczego nie działa akceptowanie? Czy jest jeszcze inny firewall który może mnie odrzucać?
  6. Po bardzo długim czasie zainstalowałem Fedorę na nowym serwerze. Jako jedno z pierwszych zabezpieczeń które chciałem zrobić była zmiana portu dla SSH z 22 na 12345 vi /etc/ssh/sshd_config Port 12345 iptables -I INPUT -p tcp -–dport 12345 -j ACCEPT systemctl restart iptables.service systemctl restart sshd.service I przy próbie połączenia przez SSH mam Connection refused. przy ręcznej edycji /etc/sysconfig/iptables: -A INPUT -p tcp -m state --state NEW -m tcp --dport 12345 -j ACCEPT Dalej mnie wywala. Czytałem też o firewalld ale przy próbie dodania portu do niego dostałem: $ firewall-cmd --zone=public --add-port=12345/tcp FirewallD is not running Natomiast przy edycji wcześniejszego wpisu w /etc/sysconfig/iptables: -A INPUT -p tcp -m state --state NEW -m tcp --dport 22 -j ACCEPT na -A INPUT -p tcp -m state --state NEW -m tcp --dport 22 -j DROP Nie mogę się połączyć przez SSH nawet na porcie 22 (po wcześniejszej zmianie portu w configu SSHD), więc wnioskuję, że iptables działa. Dlaczego w takim razie nie mogę otworzyć nowego portu?
  7. Dzięki, tego mi brakowało. Trochę to dziwne swoją drogą, bo dodawałem wpis -s /bin/bash przy dodawaniu usera, a "useradd -D" zwracał mi GROUP=100 HOME=/home INACTIVE=-1 EXPIRE= SHELL=/bin/bash SKEL=/etc/skel CREATE_MAIL_SPOOL=no Obecnie mam: GROUP=100 HOME=/home INACTIVE=-1 EXPIRE= SHELL= SKEL=/etc/skel CREATE_MAIL_SPOOL=no I działa. No nie ważne. Liczy się to, że obecnie jest tak jak być powinno. Jeszcze raz dzięki!
  8. Autouzupełnianie na tab też nie działa. Sprawdzałem pliki konfiguracyjne użytkownika i są takie same. Np. .barsrc jest identyczny w obu przypadkach.
  9. Coś skopałem przy dodawaniu nowego użytkownika i teraz jak odpalam konsolę z konta nowego użytkownika, to: 1) nie mam poprawnej zachęty export PS1="\[email protected]\h \w> " \[email protected]\h \w> 2) Nie działają mi klawisze strzałek w konsoli. Zamiast wykonywać operację, to wyrzucają mi ^[[A^[[D^[[b^[[C Jak przeloguję się na innego użytkownika, to wszystko jest ok. Powie mi ktoś co skopałem?
  10. Hej, mam problem z kodowaniem znaków w moim programie. Problem udało mi się rozwiązać dla windowsa - za pomocą "locale", ale ta opcja działa tylko w przypadku używania kompilatora Visuala. Szukam rozwiązania, które będzie działało na minGW/gcc zarówno w cmd, cygwinie, czy terminalu dowolnej dystrybucji (w zasadzie cygwin powinien załatwić sprawę). Zna ktoś dobrą metodę?
  11. Od kilku dni z tym walczę i nie umiem rozkminić jak to obejść. Mam na srubuntu postawionego apache 2, do którego chciałem dorzucić też Redmine. Redmine miał być uruchamiany z localhost/redmine. Niestety redmine działa tylko jeżeli w /etc/apache2/sites-available/default mam ustawiony DocumentRoot na /var/www/redmine/, ale na moim serwerze są też inne strony i dodanie powyższego wpisu sypie mi cały układ. Wie ktoś jak to obejść? Bez powyższego wpisu na localhost/redmine passenger wywala mi: "The directory "/var/www" does not appear to be a valid Ruby on Rails application root."
  12. Hej, problem jest dosc banalny i pojawil sie juz nie raz, ale niestety nie jestem w stanie go ogarnac.. Mam na laptopie ubuntu, a na nim virtyalboxa z ubuntu i chcialbym sie móc laczyc z nimi przez adres ip. Próbowalem wielu konfiguracji, ogólnie najblizej mi bylo chyba do tego: http://dug.net.pl/te...etowego_(masq)/ Laptop: eth0 Link encap:Ethernet HWaddr e4:11:5b:4f:b8:2e inet addr:192.168.100.153 Bcast:192.168.100.255 Mask:255.255.255.0 inet6 addr: fe80::e611:5bff:fe4f:b82e/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:1694821 errors:0 dropped:0 overruns:0 frame:0 TX packets:970631 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:1815559275 (1.8 GB) TX bytes:96779638 (96.7 MB) Interrupt:20 Memory:d4700000-d4720000 eth1 Link encap:Ethernet HWaddr 20:10:7a:3d:87:4a inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0 inet6 addr: fe80::2210:7aff:fe3d:874a/64 Scope:Link UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:1183201 errors:71 dropped:0 overruns:0 frame:2379020 TX packets:758320 errors:637 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:1632350932 (1.6 GB) TX bytes:70716687 (70.7 MB) Interrupt:19 lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:27029 errors:0 dropped:0 overruns:0 frame:0 TX packets:27029 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:1823700 (1.8 MB) TX bytes:1823700 (1.8 MB) eth0 - polaczenie kablowe eth1 - polaczenie z maszyna (próbowalem tez na adresach 10.0.0.1 z tym samym skutkiem. Virtualbox -> bridged eth1 Maszyna wirtualna: Ogólnie ustawienia sa wedle ww. poradnika, wiec chyba nie ma sensu ich przeklejac. W zasadzie to niby lacza nie mam, ale cos tam czasem pinguje zarówno do bramy (192.168.1.1) jak i serwerów zewnetrznych, ale z ogromnym opóznieniem pingowalem po ip, bo hosta nie umial zlapac, moze to byc spowodowane brakiem DNSów, albo po prostu zbyt dlugimi opóznieniami. Myslalem, ze problemem bedzie zapora, ale mecze ja od rana i nie umiem wymózdzyc co moze byc w niej skopane. EDIT: Czy na maszynie wirtualnej powinny byc wpisy w /etc/resolv.conf? Obecnie jest tam pusto.
  13. Hej, dziś stanąłem przed pewnym problemem, mianowicie na nowym laptopie chciałem zainstalować dwie używane przeze mnie dystrybucje: Ubuntu i Fedora, przy istniejącym już postawionym Windowsie. Plan był prosty: sda1 - Windows sda2 - Srubuntu sda3 - Fedora sda4 - Partycja Fat32 do wymiany plików między wszystkimi systemami. Na laptopie, jak można się łatwo domyślić, mam tylko jeden dysk, a na nim można stworzyć tylko 4 partycje podstawowe. Problem jest taki, że na starcie Windows zarezerwował sobie 2 partycje psychiczne i teraz pytanie, jak zrobić by to obejść? Próbowałem zrobić Fedorę i Ubuntu na partycjach logicznych, ale podczas instalacji drugiego linuksa nie widać dysków logicznych - jakieś inne pomysły? Może jak się pozbyć drugiej partycji Windowsowej?
  14. Hej, zastanawiam się czy jest sens kupować stare urządzenia serwerowe oparte na Xeonie socket 604 - dl380, dl 360, by postawić sobie własny serwer plików/http. Ogólnie docelowo chciałbym mieć u siebie większy serwer, jednak na początek chciałbym się trochę pobawić w bardziej zaawansowane administrowanie urządzeniami serwerowymi. Tu padło pytanie, jaki sprzęt będzie do tego potrzebny, czy kupić starego pentiuma 4, D, czy dual, albo kupić coś na Xeonie. Ceny są różne, ale mnie wystarczy sprzęt do 300zł - taki PC w roli serwera w zupełności mi wystarczy. Pytanie, czy maszyna na Xeonie za tą cenę będzie coś warta?
  15. Robilem memtesta i moze nie wyglada to zbyt dobrze, ale obraz jest raczej wynikiem interwencji lub grafiki (ta nigdy wczesniej nie szwankowala), niz ramu. http://dl.dropbox.com/u/29408495/2012-04-16%2004.16.44.jpg Jak ustawic ten dlugi test smarta? Normalny trwal zazwyczaj 50 minut...
×
×
  • Create New...