Jump to content

sunrise

Użytkownicy
  • Content Count

    530
  • Joined

  • Last visited

  • Days Won

    47

sunrise last won the day on March 6

sunrise had the most liked content!

Community Reputation

70 Excellent

1 Follower

About sunrise

  • Rank
    Ekspert

Profile Information

  • Skąd
    Zgierz

Recent Profile Visitors

9,496 profile views
  1. Kolega popełnił drobną literówkę miało być rpm -qa | grep kernel Według mnie to musisz zainstalować sterownik nvidi w wersji 390xx
  2. Jeżeli to ma symulować klikniecie myszką to powinno być click a nie key i raczej coś w stylu "xdotool click 2"
  3. Przy bootowaniu kernela 5.5.5 spróbuj usunąć z parametrów kernela parametry rhgb quiet (w menu grub naciskasz e, po edycji bootujesz naciskając ctrl-x). Może wtedy wyświetli się więcej informacji. Możesz również spróbować usunąć parametry rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 W katalogu /lib/modules/ masz moduły jądra zobacz czy w 5.5.5 jest w ogóle moduł nvidii(porównaj z działającym kernelem) Jeżeli możesz wyłącz jedną z kart w laptopie i zobacz czy system startuje, potem wyłącz tą drugą kartę i zobacz czy system startuje.
  4. Używasz obu kart, czy tylko jednej? W jakiej wersji masz sterowniki nvidii?
  5. A co zwraca cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors Problemów ze skalowaniem nie mam, ale od kernela 5.4.19 coś pozmieniali i scaling_governor zamiast aktualnego governora zwraca właśnie invalid argument, ale po małym dochodzeniu wyszło, że domyślnie po prostu nie jest ustawiony i trzeba zrobić to ręcznie (np. echo powersave > scaling_governor) i po tym odczyt już zwraca, to co powinien. Generalnie trzeba wystartować usługę cpupower (pakiet kernel-tools) i wszystko wraca do normy. PS. Ja mam Xeona E3-1245 v3, jak na razie na kernelu z patchem żadnych zwiech.
  6. Przy okazji. Jeżeli możesz podaj co Ci zwraca polecenie cat /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor PS. Te zwiechy są randomowe. PS2. Teraz testuję z patchem 0008-drm-i915-serialise-i915_active_acquire()with__active_retire().patch narazie działa, drugi patch nie chce się zaaplikować
  7. Wkrótce do Fedory zawita kernel 5.5.5 jednak brak w nim kilku łat naprawiających błąd w grafice zintegrowanej intela. Błąd ten powoduje zawieszenie się "grafiki" (obraz zamrożony, czarny ekran) doświadczyłem tego na "własnej skórze" https://bodhi.fedoraproject.org/updates/FEDORA-2020-cf2eacc932 Wszystkim użytkownikom zintegrowanej grafiki intela proponuje pozostanie przy kernelu 5.4.x
  8. Czytałem o tym na http://fedoraplanet.org/, ale jako, że nie używam Gnome software to ten błąd mnie nie spotkał. Planowane wydanie Fedory 32 jest planowane na 21 lub 28 kwietnia.
  9. Tak jak napisał marcin82 musisz uruchomić program za pomocą systemd (crona sobie odpuść, nie do tego on służy) prawdopodobnie nie musisz nic pisać, przy instalacji plik logid.service powinien być przekopiowany do odpowiedniego katalogu i wystarczy usługę wystartować. Uruchom polecenie systemctl status logid.service jeżeli Ci się nie wyświetli komunikat Unit logid.service could not be found. to plik jest w systemie i wystarczy uruchomić usługę poleceniem systemctl start logid.service Jeżeli wszystko działa, tak jak powinno to włącz usługę na stałe poleceniem systemctl enable logid.service Natomiast jeżeli wyświetlił Ci się komunikat o braku pliku, to musisz go ręcznie skopiować z katalogu w którym masz źródła programu do katalogu /usr/lib/systemd/system/ możliwe, że po tej operacji będziesz musiał przeładować systemd poleceniem systemctl daemon-reload lub ponownie uruchomić system
  10. Za ładowanie bibliotek odpowiada specjalny program ld.so/ld-linux.so jego plik konfiguracyjny /etc/ld.so.conf ładuje pliki z katalogu /etc/ld.so.conf.d/, a w tych plikach są umieszczone ścieżki wyszukiwania bibliotek. To coś jak zmienna $PATH dla normalnych programów. Polecam man dla programów ldconfig, ld.so, ldd
  11. Dodatkowo jeżeli chcesz to masz skompilowane dla F31 liblur liblur-devel i libratbag-ratbagd w najnowszych wersjach 0.13 używasz na własną odpowiedzialność, biblioteki w załącznikach. liblur-0.13-1.fc31.x86_64.rpm liblur-devel-0.13-1.fc31.x86_64.rpm libratbag-ratbagd-0.13-1.fc31.x86_64.rpm
  12. W katalogu /etc/ld.so.conf.d utwórz plik local.conf o zawartości /usr/local/lib Uruchom ldconfig Uruchom ldconfig -p |grep local jeżeli po tym coś się pojawi to jest ok
×
×
  • Create New...