Jump to content

sunrise

Użytkownicy
  • Content Count

    698
  • Joined

  • Last visited

  • Days Won

    62

Everything posted by sunrise

  1. W skrócie .bash_profile jest wczytywany tylko przy logowani .bashrc za każdym razem gdy wywoływany jest bash (więcej informacji). Gdy dodasz coś do .bashrc (alias, zmienne czy cokolwiek innego) musisz go ponownie wczytaś , możesz to wykonać (jak wspomniał tomcio) za pomocą polecenia source .bashrc lub uruchomić nową powłokę wykonując po prostu polecenie bash. Może taki filmik Ci pomoże zrozumieć o co chodzi.
  2. Aliasy powinny być umieszczane w .bashrc Poza tym, dobrze by było gdybyś podał jakie polecenia wprowadzasz i jakie wyniki otrzymujesz, to by ułatwiło odpowiedzi. Jeżeli znasz Angielski to może pomoże Ci ta książka o Bashu z tej strony.
  3. Wyszedł RockyLinux 8.4 https://rockylinux.org/news/rocky-linux-8-4-ga-release/
  4. Aż tak źle nie jest jakieś tam commity są, tylko mogli by częściej wydawać nowe wydania. I tak nie jest źle, w rrdtool ostatnie wydanie jest z przed dwóch lat!!! Co poniektórzy już się zaczynają denerwować :)
  5. Nie, w Gnome są nawet chyba domyślnie włączone aktualizacje. https://blogs.gnome.org/hughsie/2018/08/08/gnome-software-and-automatic-updates/
  6. Tak, https://linuxconfig.org/how-to-configure-smartd-and-be-notified-of-hard-disk-problems-via-email
  7. Nie używam Gnome-Boxes ale wygląda, że nie obejdzie się bez użycia konsoli https://www.debugpoint.com/2020/06/move-virtual-machine-image-another-host/
  8. Możesz też spróbować przełączyć dźwięk z pipewire na pulseaudio zgodnie z poradnikiem w skrócie w konsoli wykonaj polecenie: sudo dnf swap --allowerasing pipewire-pulseaudio pulseaudio
  9. Kolejny pakiet, który może się komuś przyda - python3-icmplib. Jest to kolejna implementacja protokołu ICMP w Pythonie, jednak ta w przeciwieństwie do ping3, umożliwia między innymi "pingowanie" przez nie uprzywilejowanego użytkownika. Repo: https://copr.fedorainfracloud.org/coprs/sunwire/python-icmplib/ Strona autora: https://github.com/ValentinBELYN/icmplib Instalacja w standardowy sposób dla COPR dnf copr enable sunwire/python-icmplib dnf install python3-icmplib Przykładowy program w Pythonie #!/usr/bin/env python # -*- coding: utf-8 -*- from icmplib import ping host = ping('onet.pl', count=10, interval=0.2, privileged=False) print(f'Address: {host.address}\n\ Min rtt: {"{:.2f}".format(host.min_rtt)}\n\ Max rtt: {"{:.2f}".format(host.max_rtt)}\n\ Avg rtt: {"{:.2f}".format(host.avg_rtt)}\n\ All rtt: {" ".join(map("{:.2f}".format, host.rtts))}\n\ Packets sent: {host.packets_sent}\n\ Packets received: {host.packets_received}\n\ Packet loss: {host.packet_loss}\n\ Jitter: {host.jitter}\n\ Is alive: {host.is_alive}')
  10. Spróbuj usunąć ten pakiet to będziesz wiedział co go potrzebuje dnf remove mlt-6.24.0-3.fc34.i686 Możesz też poszukać w logach kiedy instalowałeś mlt lub co bardziej prawdopodobne dnf zaciągnął jako zależność. grep -in " mlt" /var/log/dnf.* otrzymasz wtedy takie coś /var/log/dnf.log:887:2021-06-04T17:38:02+0200 DEBUG Gdzie pierwszy to nazwa pliku a po : numer linii gdzie ten wpis jest.
  11. dnf search grub|grep -i theme Ostatnio sprawdzono ważność metadanych: 3:48:12 temu w dniu wto, 8 cze 2021, 08:43:51. grub2-breeze-theme.x86_64 : Breeze theme for GRUB Wygląda, że repo nic nie ma
  12. Mnie się nie udało ciągle ma błędy [[email protected] ~]# insights-client --test-connection Running Connection Tests... === Begin Upload URL Connection Test === Testing: https://cert-api.access.redhat.com/r/insights/uploads/ HTTP Status Code: 403 HTTP Status Text: Forbidden HTTP Response Text: Insights authorization failed - invalid account number Connection failed === End Upload URL Connection Test: FAILURE === === Begin API URL Connection Test === Testing: https://cert-api.access.redhat.com/r/insights/ HTTP Status Code: 200 HTTP Status Text: OK HTTP Response Text: lub-dub Successfully connected to: https://cert-api.access.redhat.com/r/insights/ === End API URL Connection Test: SUCCESS === Connectivity tests completed with some errors
  13. Skąd ja to znam. Mam podobny sprzęt HP DL380 G6 2xL5640 Więc zdecydowanie słabszy niż twój, póki nie dodałem karty PCIe to w idle było naprawdę cicho. Pod obciążeniem to już inna bajka. W elrepo są sterowniki wycofane z RHEL8 http://elrepo.org/tiki/DeviceIDs
  14. Co tu dużo mówić darmowe ebooki z różnych dziedzin, są różne języki programowania, jest bash, git bazy danych, dużo przykładów i według mnie bardzo ciekawie napisane dużo wiedzy mało lania wody i wszystko darmowe bez rejestracji. A i bym zapomniał wszystkie są po angielsku. https://goalkicker.com/
  15. Jedyny co mogę Ci polecić to spróbuj tych porad https://wiki.archlinux.org/title/Network_configuration/Wireless#iwlwifi
  16. A jak karta wifi bo to co podałeś to jest raczej tylko modem LTE
  17. Wyszedł AlmaLinux 8.4 https://almalinux.org/blog/almalinux-os-8-4-stable-now-available/
  18. Paczka z klientem konsolowym napiprojekt.pl https://copr.fedorainfracloud.org/coprs/sunwire/napi/ Klient stary ale wciąż działa, przykładowe użycie w katalogu z filmami napi.sh scan *.{mkv,mp4,avi} Więcej informacji na stronie domowej projektu https://gitlab.com/hesperos/napi/-/tree/master PS. Istnieje też inny klient konsolowy https://copr.fedorainfracloud.org/coprs/threeed/napi-bash/
  19. Płyty główne ASRock Z97 exterme4 i extreme6 (oraz inne wspierające tą technologię) umożliwiają wyłączanie i włączanie zasilania dysków lub urządzeń za pomocą specjalnego przewodu. Dla systemu Windows producent dostarcza program a dla Linuksa oczywiście go brak. Ponieważ posiadam taką płytę (Z97 extreme4) postanowiłem napisać łatkę do modułu nct6775, który to obsługuje sterowanie m.in. wentylatorów i pomiar temperatury oraz sterowanie zasilaniem dysków. OSTRZEŻENIE!!! Wszystko robisz na własną odpowiedzialność, nie odpowiadam za żadne szkody wynikłe z użycia tego kodu. Testowane Na Z97 extreme4 powinno też działać na Z97 extreme6 ale nie było testowane. Patch działa na jądrach 5.12.x No to działamy Instalujemy pakiet rpmdevtools, rpm-build oraz dnf-plugins-core Jak zwykły użytkownik uruchamiamy polecenie rpmdev-setuptree Pobieramy interesujące na źródła kernel (pakiet .src.rpm) ze strony https://koji.fedoraproject.org/koji/packageinfo?packageID=8 Instalujemy go jako zwykły użytkownik poleceniem rpm -ihv kernel-<tutaj nasza wersja>.src.rpm W katalogu ~/rpmbuild/SPECS/ będzie plik kernel.spec a w ~/rpmbuild/SOURCES/ źródła kernela Uruchamiamy jako root polecenie dnf builddep <ścieżka do pliku kernel.spec> i instalujemy pakiety wymagane do zbudowania kernela Kopiujemy zawartość patcha do pliku ~/rpmbuild/SOURCES/linux-kernel-test.patch Budujemy pakiet poleceniem rpmbuild -ba <ścieżka do pliku kernel.spec> Jeżeli wszystko przebiegło pomyślnie nasz nowe pakiety jądra będą w katalogu ~/rpmbuild/RPMS/x86_64/ Instalujemy/aktualizujemy pakiety jądra Uruchamiamy ponownie system Jeżeli wszystko przebiegło prawidłowo, powinniśmy mieć plik /sys/devices/platform/nct6775.656/hwmon/hwmon<X>/hddsaver_enable gdzie <X> to jakiś numer np. 3 Aktualny stan sprawdzamy odczytując ten plik np. poleceniem cat cat /sys/devices/platform/nct6775.656/hwmon/hwmon3/hddsaver_enable Zwracany wartość to Off lub On Włączamy zasilanie zapisując wartość On do tego pliku, a wyłączamy zapisując Off np. echo On > /sys/devices/platform/nct6775.656/hwmon/hwmon3/hddsaver_enable echo Off > /sys/devices/platform/nct6775.656/hwmon/hwmon3/hddsaver_enable Kod patcha znajduje się pod adresem https://lkml.org/lkml/2021/5/3/475 Z niewiadomych powodów nie mogę go wstawić do postu (błąd forum)
  20. Stworzyłem nowe pakiety dla fedory, może dla kogoś też będą przydatne 1. https://copr.fedorainfracloud.org/coprs/sunwire/python-ping3/ Implementacja pinga w pythonie https://pypi.org/project/ping3/ 2.https://copr.fedorainfracloud.org/coprs/sunwire/stenc/ Oprogramowanie do zarządzania szyfrowaniem w napędach LTO https://github.com/scsitape/stenc. Dla większości raczej mało przydatne, ma nałożone dodatkowo dwie łatki, które oczekują na włączenie do kodu (admini są dość opieszali )
  21. Nie instalowałem, ale minidlna (jest w repo) obsługiwał napisy, tylko musiały być w formacie srt.
  22. Popatrz może w systemie pozostały jakieś powiązane pakiety z f33? Może gdzieś po drodze jest jakiś cache lub proxy?
  23. To, że u mnie działa nie znaczy, że wszystko jest ok. Czasami różne dziwne rzeczy wychodzą. Np. u innych działało, a u mnie: https://bugzilla.redhat.com/show_bug.cgi?id=1902844 https://github.com/rpm-software-management/rpm/pull/1529
  24. U mnie: ⬢[[email protected] ~]# dnf update Fedora 34 openh264 (From Cisco) - x86_64 2.0 kB/s | 2.5 kB 00:01 Fedora Modular 34 - x86_64 1.1 MB/s | 3.8 MB 00:03 Fedora Modular 34 - x86_64 - Updates 457 kB/s | 880 kB 00:01 Fedora 34 - x86_64 - Updates 1.4 MB/s | 7.7 MB 00:05 Fedora 34 - x86_64 2.1 MB/s | 57 MB 00:27 Dependencies resolved. ============================================================================================================================================================================================================================================================== Package Architecture Version Repository Size ============================================================================================================================================================================================================================================================== Upgrading: coreutils x86_64 8.32-24.fc34 updates 1.1 M coreutils-common x86_64 8.32-24.fc34 updates 2.0 M curl x86_64 7.76.1-2.fc34 updates 304 k fedora-gpg-keys noarch 34-2 updates 111 k fedora-repos noarch 34-2 updates 11 k fedora-repos-modular noarch 34-2 updates 11 k git x86_64 2.31.1-3.fc34 updates 121 k git-core x86_64 2.31.1-3.fc34 updates 3.6 M git-core-doc noarch 2.31.1-3.fc34 updates 2.3 M iptables-legacy-libs x86_64 1.8.7-7.fc34 updates 40 k libcurl x86_64 7.76.1-2.fc34 updates 288 k libedit x86_64 3.1-36.20210419cvs.fc34 updates 107 k libgcc x86_64 11.1.1-1.fc34 updates 103 k libgcrypt x86_64 1.9.3-2.fc34 updates 517 k libgomp x86_64 11.1.1-1.fc34 updates 276 k libstdc++ x86_64 11.1.1-1.fc34 updates 707 k libtirpc x86_64 1.3.1-1.rc2.fc34 updates 95 k libxcrypt x86_64 4.4.19-1.fc34 updates 118 k libxcrypt-compat x86_64 4.4.19-1.fc34 updates 90 k libxkbcommon x86_64 1.2.1-1.fc34 updates 144 k lua-libs x86_64 5.4.3-1.fc34 updates 218 k mpfr x86_64 4.1.0-6.fc34 updates 332 k openldap x86_64 2.4.57-3.fc34 updates 262 k perl-Git noarch 2.31.1-3.fc34 updates 44 k python-unversioned-command noarch 3.9.4-1.fc34 updates 12 k python3 x86_64 3.9.4-1.fc34 updates 28 k python3-libs x86_64 3.9.4-1.fc34 updates 7.4 M shadow-utils x86_64 2:4.8.1-8.fc34 updates 1.2 M vim-minimal x86_64 2:8.2.2825-1.fc34 updates 701 k which x86_64 2.21-26.fc34 updates 42 k xkeyboard-config noarch 2.32-3.fc34 updates 789 k Installing dependencies: whois-nls noarch 5.5.9-1.fc34 fedora 34 k Installing weak dependencies: glibc-doc noarch 2.33-5.fc34 fedora 1.1 M mkpasswd x86_64 5.5.9-1.fc34 fedora 41 k Transaction Summary ============================================================================================================================================================================================================================================================== Install 3 Packages Upgrade 31 Packages Total download size: 24 M Is this ok [y/N]: ⬢[[email protected] ~]# cat buildinfo/Dockerfile-fedora-toolbox-34-14 FROM sha256:5f05951e20652d401698316fb70d9e7e80e548a03647c033584c871ebc6ccf25 ENV NAME=fedora-toolbox VERSION=34 LABEL com.github.containers.toolbox="true" \ com.github.debarshiray.toolbox="true" \ com.redhat.component="$NAME" \ name="$NAME" \ version="$VERSION" \ usage="This image is meant to be used with the toolbox command" \ summary="Base image for creating Fedora toolbox containers" \ maintainer="Debarshi Ray <[email protected]>" COPY README.md / RUN sed -i '/tsflags=nodocs/d' /etc/dnf/dnf.conf COPY missing-docs / RUN dnf -y reinstall $(<missing-docs) RUN rm /missing-docs COPY extra-packages / RUN dnf -y install $(<extra-packages) RUN rm /extra-packages RUN dnf clean all CMD /bin/sh LABEL "release"="14" "authoritative-source-url"="registry.fedoraproject.org" "distribution-scope"="public" "vendor"="Fedora Project" "build-date"="2021-04-25T11:46:46.651205" "architecture"="x86_64" "vcs-type"="git" "vcs-ref"="45fd8fc72beccf27ee910ae0e1bc5baa93e3502a" "com.redhat.build-host"="osbs-node02.iad2.fedoraproject.org" Popatrz w katalog ~/.local/share/containers/storage/ może coś Ci się rozjaśni, w ostateczności usuń go lub zmień jego nazwę i utwórz nowy kontener.
  25. Wygląda na braki pakietów w repo, wiec można poczekać. Możesz też dodać opcję --refresh może pomoże (ale nie musi).
×
×
  • Create New...