Jump to content

Andrzej Orkan

Użytkownicy
  • Content Count

    307
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Andrzej Orkan

  • Rank
    Ekspert

Previous Fields

  • Ulubiona dystrybucja
    Fedora
  • Środowisko graficzne
    Fluxbox
  • GG
    2720119

Profile Information

  • Skąd
    Kraków
  • Zainteresowania
    - wspinaczka górska<br />- dobra muza (alt rock, jazz, wszystko co wymaga IQ > 75 :)))<br />- programowanie i Linux<br />- blondynki<br />- brunetki
  1. problem w tym, że nie bardzo pamiętam które zostały zaktualizowane :/
  2. najprawdopodobniej przestal je widziec po yum update ale glowy nie dam nie mam pojecia czy to kwestia sprzetu (dosyc juz leciwego) czy systemu operacyjnego, latwo tego nie sprawdze, bowiem CD nie funkcjonuje, a z USB nie da sie bootowac kontroler USB odzywa sie przy starcie komputera (choc nie zglasza zadnych urzadzen podpietych, np myszki) dmesg | grep usb: [ 0.053644] usbcore: registered new interface driver usbfs [ 0.053661] usbcore: registered new interface driver hub [ 0.053690] usbcore: registered new device driver usb [ 2.207044] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002 [ 2.207048] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1 [ 2.207051] usb usb1: Product: EHCI Host Controller [ 2.207054] usb usb1: Manufacturer: Linux 2.6.35.11-83.fc14.i686 ehci_hcd [ 2.207056] usb usb1: SerialNumber: 0000:00:1d.7 [ 2.207662] usb usb2: New USB device found, idVendor=1d6b, idProduct=0001 [ 2.207665] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1 [ 2.207668] usb usb2: Product: UHCI Host Controller [ 2.207670] usb usb2: Manufacturer: Linux 2.6.35.11-83.fc14.i686 uhci_hcd [ 2.207673] usb usb2: SerialNumber: 0000:00:1d.0 [ 2.208209] usb usb3: New USB device found, idVendor=1d6b, idProduct=0001 [ 2.208212] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1 [ 2.208215] usb usb3: Product: UHCI Host Controller [ 2.208217] usb usb3: Manufacturer: Linux 2.6.35.11-83.fc14.i686 uhci_hcd [ 2.208220] usb usb3: SerialNumber: 0000:00:1d.1 [ 2.208500] usb usb4: New USB device found, idVendor=1d6b, idProduct=0001 [ 2.208503] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1 [ 2.208506] usb usb4: Product: UHCI Host Controller [ 2.208509] usb usb4: Manufacturer: Linux 2.6.35.11-83.fc14.i686 uhci_hcd [ 2.208511] usb usb4: SerialNumber: 0000:00:1d.2 [ 2.213192] usbcore: registered new interface driver hiddev [ 2.213207] usbcore: registered new interface driver usbhid [ 2.213209] usbhid: USB HID core driver [ 918.367639] usb usb2: root hub lost power or was reset [ 918.367679] usb usb3: root hub lost power or was reset [ 918.367717] usb usb4: root hub lost power or was reset oraz lsusb: Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub halp?
  3. sorki, że dopytam, ale o co opiera się takie szyfrowanie? o uid? jakiś klucz, który w jakiś magiczny sposób podaje się przy próbie dostępu do partycji? jak to działa?
  4. WalDo dzięki za to info o UUID, mógłbyś mi napisać jak to by wyglądało w /etc/fstab? thof ext4 czy ext3 lepiej? wszak tam z ext4 są jakieś kontrowersje... poza tym jak zaszyfruję sobie taką partycję na przenośnym dysku, to jak wygląda jego odczyt przy podłączeniu pod inną maszyną lub po zmianie OS?
  5. w takim razie jaki rodzaj partycji proponujesz jako duży storage na pliki multimedialne i backupy?
  6. przepraszam, trochę mało precyzyjnie naświetliłem problem oczywiście, że ręcznie: sudo mount -o defaults,uid=500,gid=500 /dev/sdb1 /mnt/elements rozwiązuje problem (tam jest partycja vfat), ale zastanawiałem się dlaczego ten dysk nie jest traktowany tak samo jak normalne pendrive'y, czyli się nie automontuje pamięci USB flash, których używam montują się bez jakichkolwiek ingerencji w /etc/fstab stąd było moje pytanie ale montowanie ręczne zewnętrznego twardego dysku to nie jest taki problem dzięki za podpowiedź
  7. dostałem pod choinkę zewnętrzny dysk twardy USB WD Elements 500GB, komputer z Windows moich rodziców rozpoznaje go bez trudu, moja Fedora12 ma z tym problem. Polecenie lsusb -v daje wynik $ sudo lsusb -v Bus 001 Device 003: ID 1058:1010 Western Digital Technologies, Inc. Device Descriptor: bLength 18 bDescriptorType 1 bcdUSB 2.00 bDeviceClass 0 (Defined at Interface level) bDeviceSubClass 0 bDeviceProtocol 0 bMaxPacketSize0 64 idVendor 0x1058 Western Digital Technologies, Inc. idProduct 0x1010 bcdDevice 1.75 iManufacturer 1 Western Digital iProduct 2 External HDD iSerial 3 57442D57584D304139395236313032 bNumConfigurations 1 Configuration Descriptor: bLength 9 bDescriptorType 2 wTotalLength 32 bNumInterfaces 1 bConfigurationValue 1 iConfiguration 0 bmAttributes 0xc0 Self Powered MaxPower 2mA Interface Descriptor: bLength 9 bDescriptorType 4 bInterfaceNumber 0 bAlternateSetting 0 bNumEndpoints 2 bInterfaceClass 8 Mass Storage bInterfaceSubClass 6 SCSI bInterfaceProtocol 80 Bulk (Zip) iInterface 0 Endpoint Descriptor: bLength 7 bDescriptorType 5 bEndpointAddress 0x81 EP 1 IN bmAttributes 2 Transfer Type Bulk Synch Type None Usage Type Data wMaxPacketSize 0x0200 1x 512 bytes bInterval 0 Endpoint Descriptor: bLength 7 bDescriptorType 5 bEndpointAddress 0x02 EP 2 OUT bmAttributes 2 Transfer Type Bulk Synch Type None Usage Type Data wMaxPacketSize 0x0200 1x 512 bytes bInterval 0 Device Qualifier (for other device speed): bLength 10 bDescriptorType 6 bcdUSB 2.00 bDeviceClass 0 (Defined at Interface level) bDeviceSubClass 0 bDeviceProtocol 0 bMaxPacketSize0 64 bNumConfigurations 1 Device Status: 0x0001 Self Powered czyli system go widzi, ale nie potrafię go zamontować. czy mógłbym prosić o pomoc?
  8. próbowałem, podobnie jak pobawiłem się ustawieniami /usr/share/polkit-1/actions/org.freedesktop.network-manager-settings.system.policy no niestety nie działa - jako, że system skonfigurowałem niedawno, to postanowiłem, że zrobię to wyłączając NetworkManagera i włączając usługę network + system-network-config i zobaczę jak to wszystko będzie działać najwyżej sprawdzę sobie LiveCD LXDE, podobno już są re-spiny dostępne, odświeżone po tej katastrofalnej wpadce przy premierze F12 EDIT no i spróbowałem. LXDE-spin bez LXDE (za to z Fluxboksem) działa wyśmienicie i tak jak chcę polecam wszystkim
  9. Na codzień używam Fluxboxa. Wraz z instalacją F12 (z płyty LiveCD Gnome) postanowiłem zmienić sobie menedżera logowania z GDM na LXDM. Zrobiłem to edytując plik /etc/X11/prefdm: ... quit_arg= preferred= if [ -f /etc/sysconfig/desktop ]; then . /etc/sysconfig/desktop if [ "$DISPLAYMANAGER" = GNOME ]; then preferred=/usr/sbin/gdm quit_arg="--retain-splash" elif [ "$DISPLAYMANAGER" = KDE ]; then preferred=/usr/bin/kdm elif [ "$DISPLAYMANAGER" = WDM ]; then preferred=/usr/bin/wdm elif [ "$DISPLAYMANAGER" = XDM ]; then preferred=/usr/bin/xdm elif [ -n "$DISPLAYMANAGER" ]; then preferred=$DISPLAYMANAGER else quit_arg="--retain-splash" fi else quit_arg="--retain-splash" fi preferred=/usr/bin/lxdm ... po reboocie mam jakieś problemy z uprawnieniami, nie startuje mi np NetworkManager: $ nm-applet ** (nm-applet:1459): WARNING **: <WARN> request_name(): Could not acquire the NetworkManagerUserSettings service. Error: (9) Connection ":1.24" is not allowed to own the service "org.freedesktop.NetworkManagerUserSettings" due to security policies in the configuration file ale też np nie zadziała reboot bez sudo itp szukałem trochę na forach internetowych, podobne problemy miał tam ktoś z instalacją SLIMa, ale dyskusja zakończyła się konkluzją, że to jest "dirty little secret of Gnome - it's not modular" i że trzeba dostęp do nm, pulseaudio, montowanych urządzeń itp ustawiać potem osobno czy ktoś ma podobne doświadczenia lub mógłby mi pomóc?
  10. nie.. tu raczej mi chodziło o wszystkie znaczki, które można spotkać w Europie i Ameryce, czyli znaczki arabskie i dalekowschodnie odpadają, ale taką cyrylicę to trzeba już było "spłaszczyć" sposób znalazłem i rzeczywiście jest to tablica kodowań różnych śmiesznych znaczków na odpowiedniki a-z plik ze znaczkami jest zakodowany w utf8, jest odpowiednia dyrektywa w nagłówku jakby co, to mogę udostępnić kod w pythonie ...przedtem po prostu się zastanawiałem, czy nie ma jakiś modułów, które zrobiłyby to za mnie i jeszcze umożliwiałyby konwersję utf-latin-iso i tyle, pozdrawiam
  11. chciałbym napisać w pythonie funkcję, który wszystkie możliwe znaki narodowe z różnych rodzajów kodowania przekształca na znaki z alfabetu łacińskiego, czyli np. ń = n, Ę = E, albo francuskie ç zamieni na c, lub greckie τ na t prototyp takiej funkcji wyglądałby tak: string_wyjściowy = funkcja(string_wejściowy[, rodzaj_kodowania]) nie bardzo potrafię znaleźć w google'u cokolwiek, co by mi pomogło - bo oni tam raczej zajmują się konwersją pomiędzy różnymi rodzajami kodowania, może wy znajdziecie jakiś kod, albo pythonowski moduł, który by umożliwił konwersję o którą mi chodzi? mam jeszcze rozwiązanie takie, że stworzę sobie na piechotę, lub wygeneruję z różnych zestawów kodowych tablicę z bezpośrednimi wskazaniami co na co zamienić, ale to chyba czasochłonne i zrobię to w ostateczności
  12. w trybie konsolowym? nie wiem jak miałyby wyglądać takie formularze, ale czy czegoś takiego nie napisze się w kwadrans w Perlu?
  13. dzięki jjj, pomogłeś mi ogromnie, otóż rpm z cherrypy3 instalował pakiet w /usr/lib/python2.4/site-packages/cherrypy podczas gdy ja korzystam z pythona 2.5 zrobiłem cd /usr/lib/python2.5/site-packages/ ln -s ../../python2.4/site-packages/cherrypy cherrypy i jakoś działa, narazie na żadne trudności ze zgodnościami obu wersji pythona się nie natknąłem no i Django okazało się tym czego szukałem świetna sprawa i do nauki Pythona i robienia fajnych webservices
  14. próbowałem zainstalować CherryPy3 z rpm-a za pomocą yumlocalinstall, z tym że mój program tym razem odpowiadał, że nie może znaleźć modułu "cherrpy". czy ktoś wie gdzie wpisać w odpowiednie configi pythona lokalizację biblioteki cherrypy? dzięki z góry za odpowiedź
  15. zainstalowałem sobie yumem pakiet "python-cherrypy" (oraz oczywiście "python") i napisałem sobie następujący prosty skrypt: import cherrypy class MyRoot: def index(self, who="World"): return "Hello, %s!" % (who) index.exposed = True cherrypy.quickstart(MyRoot()) uruchomienie go daje następujący efekt: $ python cherry1.py Traceback (most recent call last): File "cherry1.py", line 8, in <module> cherrypy.quickstart(MyRoot()) AttributeError: 'module' object has no attribute 'quickstart' czy trzeba jeszcze jakoś specjalnie skonfigurować pythona, żeby widział cherrypy? czy ja coś źle napisałem w kodzie? wydaje mi się, że cherrypy ma metodę quickstart, więc w czym problem? a jeszcze nawet nie zacząłem tego testować w http:// a już jakiś problem ktoś ma jakiś pomysł?
×
×
  • Create New...