Jump to content

infoyankes

Użytkownicy
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About infoyankes

  • Rank
    Początkujący
  1. Wstyd się przyznać, to było tak proste, a tego nie uwzględniłem Przestawiłem w Outlooku kodowanie na UTF-8 i wszystko pięknie gra. Bardzo dziękuję za pomoc
  2. Witam. Mam skonfigurowany serwer poczty na Postfiksie. Kiedy przesyłam maila z Outlooka do Linuxa z polskimi znakami w temacie "zażółć", w Linuxie odbieram ja jako "zazólc". Postfix współpracuje z MailScanner + CyrusSASL + SpamAssassin + postgrey. W Linuxie mam ustawione kodowanie pl_PL.UTF-8. Czy ktoś mógłby coś poradzić? Z góry przepraszam, jeśli to już było na forum, jeśli ktoś byłby jednak tak miły i dorzucił swoje trzy grosze, bedę wdzięczny
  3. Witam. Mam problem z połączeniem z lokalnym ftp-em z poziomu XP w sieci lokalnej. Po wyłączeniu iptables wszystko się łączy cacy, ale po włączeniu już nie, więc oczywiście to sprawa zapory. Adres mojego ftpa to 192.168.0.20. W XP, po uruchomieniu linii poleceń cmd po wywołaniu klienta ftp i połączeniu otrzymuję: Połączony z 192.168.0.20. (czeka ze 30 sekund i zrywa) Połączenie przerwane przez hosta zdalnego. Dodawałem już różne reguły i nadal nic: iptables -A INPUT -p tcp -s 0/0 --sport 1024:65535 -d 192.168.0.20 --dport 21 -m state --state NEW,ESTABLISHED -j ACCEPT iptables -A OUTPUT -p tcp -s 192.168.0.20 --sport 21 -d 0/0 --dport 1024:65535 -m state --state ESTABLISHED -j ACCEPT iptables -A INPUT -p tcp -s 0/0 --sport 1024:65535 -d 192.168.0.20 --dport 1024:65535 -m state --state ESTABLISHED,RELATED -j ACCEPT iptables -A OUTPUT -p tcp -s 192.168.0.20 --sport 1024:65535 -d 0/0 --dport 1024:65535 -m state --state ESTABLISHED -j ACCEPT iptables -A OUTPUT -p tcp -s 192.168.0.20 --sport 20 -d 0/0 --dport 1024:65535 -m state --state ESTABLISHED,RELATED -j ACCEPT iptables -A INPUT -p tcp -s 0/0 --sport 1024:65535 -d 192.168.0.20 --dport 20 -m state --state ESTABLISHED -j ACCEPT Do pliku konfiguracyjnego iptables dodałem również: -A INPUT -i eth0 -p tcp -m tcp --dport 20 -j ACCEPT -A INPUT -i eth0 -p tcp -m tcp --dport 21 -j ACCEPT -A INPUT -i eth0 -p udp -m udp --dport 20 -j ACCEPT -A INPUT -i eth0 -p udp -m udp --dport 21 -j ACCEPT i też bez efektu. W /etc/sysconfig/iptables-config mam dodaną następującą linię: IPTABLES_MODULES="ip_conntrack_ftp ip_nat_ftp" Czy to, że nie mogę się połączyć, jest winą braku ip_conntrack? # modprobe ip_conntrack_ftp Tutaj ok, bez błędu # modprobe ip_conntrack FATAL: Module ip_conntrack not found. Pierwszy z modułów zapory (ip_conntrack_ftp) startuje w trakcie uruchomienia systemu, natomiast drugiego nie widzę iptables: wczytywanie dodatkowych modułów: ip_conntrack_ftp[ OK ]ftp Proszę o pomoc.
  4. Oczywiscie mam karte wifi na laptopie, ale chcialbym pobawic sie chwile dhcp na linuxie, zobaczyc jak dziala, popatrzec na żądania dhcp, posledzic, potestowac konfiguracje. Dhcp juz mi dziala, wylaczylem dhcp na routerze i teraz dziala mi tylko dhcpd linuxowe. Pozostaje jeszcze jedna kwestia. Jak zrobic, skoro mam trzy interfejsy w kompie (eth0,eth1, wlan0), zeby dhcp nie nasluchiwal na wlan0, a jedynie na eth1? Rozumiem, ze zeby dzialal mi jedynie na eth1 to musialbym odlaczyc wlan0 w ogole? Dziękuję z góry.
  5. Oczywiscie mam karte wifi na laptopie, ale chcialbym pobawic sie chwile dhcp na linuxie, zobaczyc jak dziala, popatrzec na żądania dhcp, posledzic, potestowac konfiguracje. Niestety mam tylko dwa kompy, musze sie uczyc na tym co mam. Czy w takim razie mam wylaczyc dhcp na routerze zeby moj serwer dhcp na linuxie przejal zadanie przydzielania adresow ip w mojej sieci? I jak zrobic, skoro mam trzy interfejsy w kompie (eth0,eth1, wlan0), zeby dhcp nie nasluchiwal na wlan0, a jedynie na eth1? Dziękuję z góry.
  6. Dziekuje za odpowiedz. Moja logika działania jest taka, że chciałbym, żeby moj laptop podlaczony bezposrednio kablem skrosowanym pobieral sobie ip przez ten serwer dhcp dzieki polaczeniu kablem przez eth1, a nie z serwera dhcp na routerze. Czy w takim razie jak na routerze (d-link) dziala jeden dhcp to musze ten drugi na kompie ustawic w innej podsieci? I czemu dhcp korzysta z obu interfejsow eth1 i wlan0, skoro ma powiedziane, ze powinien na jednym tylko dzialac. Jak zrobic by nie traktowal wlan0 jako interfejsu dla dhcp, a jednoczesnie wlan0 mogl laczyc sie z internetem? Mam nadzieje, ze nic nie pomylilem. Czy gdybym podlaczyl switch do eth1 to wowczas moglbym przydzielac przez dhcpd na kilka kompow? Sorry za glupie pytania, ale jestem laikiem jeszcze.
  7. Witam. Mam problem z serwerem DHCP. Mam zainstalowany serwer DHCP na Fedorze 12. Jest tu również dhclient. Mam dwie karty sieciowe eth0 i eth1 oraz jedna sieciowke bezprzewodowa wlan0. Poniewaz serwer dhcp nie chcial wystartowac w obecnosci NetworkManagera wylaczylem go, ustawilem skrypt uruchamiajacy wlan0 z wpa i statyczny interfejs eth1. Jako domyslny dla DHCP ustawilem eth1 w /etc/sysconfig/dhcpd # Command line options here DHCPDARGS=eth1 Po wylaczeniu NetworkManagera dhcpd startuje razem z systemem i wszystko byloby ok, gdyby nie to, ze dhcp pisze,ze nasluchuje na dwoch interfejsach (eth1, wlan0). Wifi przestaje dzialac i nie moge laczyc sie z internetem. Czemu dziala na dwoch skoro ma podane, ze ma dzialac na eth1? Dhcp zwraca komunikat: Multiple interfaces match the same subnet: eth1 wlan0 Multiple interfaces match the same shared network: eth1 wlan0 Listening on LPF/wlan0/xxx/192.168.0.0/24 Sending on LPF/wlan0/xxx/192.168.0.0/24 Listening on LPF/eth1/xxx/192.168.0.0/24 Sending on LPF/eth1/xxx/192.168.0.0/24 Tabela routingu: 192.168.0.2 192.168.0.1 255.255.255.255 UGH 0 0 0 eth1 192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1 192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0 169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1 0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth1 Zawartosc pliku dhcpd.conf wyglada nastepujaco ddns-update-style none; subnet 192.168.0.0 netmask 255.255.255.0 { option routers 192.168.0.1; option subnet-mask 255.255.255.0; option domain-name "domena.pl"; option domain-name-servers 194.204.159.1; range dynamic-bootp 192.168.0.2 192.168.0.254; default-lease-time 86400; max-lease-time 43200; allow bootp; #deny unknown-clients; host big { hardware ethernet #tu adres mac wifi; fixed-address 192.168.0.2; option domain-name-servers 194.204.159.1; option routers 192.168.0.1; } Składniowo powinno być jak najbardziej poprawnie, bo sprawdzałem komendą # /etc/init.d/dhcpd configtest Syntax: OK Zawartosc /etc/sysconfig/network-scripts/ifcfg-eth1 DEVICE=eth1 TYPE=Ethernet HWADDR=adres_karty_eth1 ONBOOT=yes IPADDR=192.168.0.100 NETMASK=255.255.255.0 GATEWAY=192.168.0.1 BOOTPROTO=none wlan0 ma przydzielony staly ip wlan0 Link encap:Ethernet HWaddr moj_hw_adres inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:3144 errors:0 dropped:0 overruns:0 frame:0 TX packets:3312 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:2404162 (2.2 MiB) TX bytes:804432 (785.5 KiB) Zatrzymanie serwera dhcp, wywalenie interfejsu poleceniem ifconfig eth1 down oraz ponowne uruchomienie skryptu dla konfiguracji wlan0 przywraca bezprzewodowe polaczenie z internetem. Ktos ma jakis pomysl dlaczego tak sie dzieje i co zrobic, by wifi dzialalo razem z dhcp? Wnioskuje, ze dhcp wykorzystuje wlan0 i dlatego nie ma internetu. Moje pytanie brzmi jak ustawic dhcp, by dzialalo tylko na interfejsie eth1, a jednoczesnie by eth1 i wlan0 byly w tej samej sieci 192.168.0.0? Proszę o pomoc
×
×
  • Create New...