Jump to content

tele

Użytkownicy
  • Content Count

    150
  • Joined

  • Last visited

  • Days Won

    3

Everything posted by tele

  1. tele

    Kto Uzywa Gnome 3 ?

    Kto uzywa Gnome ? Z czystej ciekawosci tylko pytam, bo to srodowisko na pierwszy rzut oka wydaje mi sie malo przyjemne. Minusy: - Przede wszystko nie moge znalesc wszystkiego w menu ani skonfigurowac jakbym chcial. - Brakuje w instalatorze pakietow zaawansowanych mozliwosci z instalatora z ktorego korzystam na codzien. - Brakuje mi mozliwosci Compiza ktory zostal porzucony, ale nie formie skonfigurowanej juz, ze ja przewijam strone w firefoxie i nagle minimalizuje mi wszystkie programy, bo mnie to wkurza, tylko w wersji do samodzielnego wlaczenia i skonfigurowania Plusy: - Ladnie wyglada - Wyszukiwarka aplikacji w menu. - fajny instalator graficzny z obrazkami i kategoriami.
  2. tele

    Żółte Karteczki Kde I Android

    Moze lepiej spytaj developerow Androida i KDE, Jesli bylyby to zwykle pliki w jakims folderze to moglbys je synchronizowac przez dowolny program do tego celu stworzonym, np. dropbox.
  3. Troche pospamuje. Mozesz miec jeszcze wiekszy problem. Fodora - brak wsparcia, brak pakietow rpm, wyglada na to ze wydania pakietow w Fedorze sa szybsze niz aktualizacje AMD, to prowadzi do tego ze sterowniki AMD po jakims czase przestaja dzialac, dlatego jak testowac to najlepiej BETA ze strony AMD, ale moze to Ci pomoze, ewentualnie ktos cos poradzi http://easylifeproject.org/ Ubuntu - przez AMD wspierane, takze mozesz tam ( radze na angielskim forum, czy bugzilli ) zalic sie tam ile wlezie az naprawia, bo te problemy to nie od dzis i co nowego wejdzie to zawsze jakis problem. OpenSuse - przez AMD wspierane, nawet maja ich logo, sterowniki mozesz zainstalowac wprost z przegladarki ze strony OpenSuse PCLinuxOS - tam znajdziesz sterowniki rpm , brak wsparcia AMD - wystarczy wejsc w ustawienia systemu i je aktywowac, ale starszy glibc + cos tam moze powodowac ze niektore gry kompilowane niedawno z najnowszymi pakietami np. Wiedzmin 2 nie zadziala. Debian - brak wsparcia AMD, co do paczek to nie wiem, w teorii powinny byc - wkoncu Steam OS jest na nim oparty, a jak nie beda dzialac to musisz kompilowac, choc i to nie gwarantuje sukcesu. Z bardziej komercyjnych wydan wspieranych przez AMD to Red Hat Enterprise Linux Suite 6.4 and 6.5 SUSE® Linux Enterprise 11 SP3 Ubuntu tez gwarantuje jakies tam wsparcie komercyjne choc nie wiem jak to blizej wyglada.
  4. tele

    Strife - Beta Gra

    Dostepna za darmo na Linuxa 32bit i 64bit. Na fedorze jeszcze nie testowalem ale powinna dzialac bez problemow. - Grafika fajna - Gra jest podobna do LoL czy Dota. - Narazie jeszcze nie widze spolszczenia. Filmik promocyjny:
  5. tele

    Relics Of Annorath

    A jak zainstainstalowales? Nie chce sie odistalowac? Po czym to stwierdzasz?
  6. < Jakie sterowniki za to odpowiadają, jaka część jądra > ACPI w kernelu. http://forum.linux.pl/viewtopic.php?id=21333 wiki logi systemowe http://wiki.linux-user.eu/index.php/Logi_systemowe Edytowane: Co do wiedzy to ciezko wszystko ogarnac - inaczej wyglada praca administratora sieci - inaczej developera danego oprogramowania - inaczej developera paczkujacego, aczkolwiek zeby cos naprawic, potrzebna jest wiedza tego pierwszego developera. Moze zacznij od czytania artykulow na wiki? http://fedoraproject.org/wiki/Fedora_Project_Wiki http://wiki.fedora.pl/wiki/Strona_g%C5%82%C3%B3wna
  7. tele

    Problem Z Zamykaniem

    Pisales na bugzilli o tym problemie? http://fedoraproject.org/wiki/Bugzilla tlumacz translator https://translate.google.pl/
  8. tele

    Tapping.

    Moze by do Linusa Torwaldsa albo na stronie bugzilli fedory napisac? Ale radze napisac tam jaki posiadasz dokladnie sprzet wraz z dokladnym modelem, ewentualnie logi z bledami np. dmesg czy inne, http://wiki.linux-user.eu/index.php/Logi_systemowe bo nikt nie zgadnie co moze byc nie tak, a ja o developerach wrozacych z fusow nie slyszalem. http://fedoraproject.org/wiki/Bugzilla tlumacz translator https://translate.google.pl/
  9. tele

    Komputer Dla Mamy

    Szukaj cos z Nvidia, to cie uchroni jakbys chcial w cos pograc, na intelu zintegrowanym z procesorem moze tez sie da ale szalu nie ma. http://www.linlap.com/ Nizej w linku masz modele i napisana kompatybilnosc zgloszona przez uzytkownikow. 2GB pamieci , 2GHz dwurdzeniowy to chyba dzis podstawa by choc na troche dluzej posluzyl z bardziej np. wypasionym KDE , czy Gnome + firefox z wieloma zakladkami. Edytowane: Dell nawet dobry na pierwszy rzut oka, ma nawet linuxa, choc za dellem nie jestem bo zazwyczaj nie ma nic ciekawego. niestety specyfikacja nie jest zbyt dokladna, o szczegoly musialbys w sklepie pytac. A kompatybilnosc w tym przypadku jest wazna bo Dell choc wspiera Linuxa, to nie wypuszcza sterownikow, procz to co w kernelu siedzi.
  10. A skad wiesz ze to wirus? ( sprawdzales programem antiwirusowym ? - chocby on-line ) - sprawdzales sumy kontrolne iso? - sprawdzales ze starszym iso? ( program moze nie obslugiwac dystrybucji z nowszym kernelem ) ( aczkolwiek multiboot menu przy starcie powinno byc widoczne zawsze ) - sprawdzales czy pendrive nie ma bad sektorow ? - wczesniej uzywales tej samej wersji yumi z tym samum sprzetem i dzialalo ? - testowales z unetbootin? - w Biosie / Uefi wykrywa Ci pendriva ?
  11. tele

    [Rozwiązane] [Solved] Wiedzmin 2

    Edytowane Patrzyles jeszcze tu? http://steamcommunity.com/app/20920/discussions/0/522728268848525694/#p2 PS: Ja tego wiedzmina testowalem na OpenSuse 32bit, zeby nie bylo...
  12. tele

    Oferta Pracy

    http://www.linuxportal.pl/newsbar/red-hat-szuka-deweloperow-sterownikow-graficznych-dla-linuksa-id177859 August 18, 2014 http://blogs.gnome.org/uraeus/ Czyzby red hat poszukiwal developerow ktorzy by poprawiali otwarte sterowniki ?
  13. Poprzez biblioteki statyczne rozumiem - biblioteki po kompilowaniu z rozszerzeniem " .a " i sa uzywane tylko przez program z ktorym zostaly skompilowane ( dodajemy je do pakietu o nazwie " nazwa_pakietu-devel-static " lub " nazwa_pakietu-static " lub sa dodawane do " nazwa_pakietu-devel " ) Inne pliki to: * plik binarny o rozszerzeniu " .bin " lub bez rozszerzenia ( dodajemy je do pakietu glownego " nazwa_pakietu " ) * biblioteki dynamiczne o rozszerzeniu " .so " , czyli takie ktore moga byc uzywane przez program ktory kompilujemy, oraz wszystkie inne zainstalowane w naszym systemie. ( dodajemy je do pakietu o nazwie " lib_nazwa_pakietu " ) * pliki naglowkowe o rozszerzeniu " .h " ( dodajemy je do pakietu o nazwie " nazwa_pakietu-devel " ) I z tym dodawaniem do pakietow to nie jest reguła, czasami widze ze biblioteki .so wystepuja zarowno w pakiecie glownym, jak i inne .so w pakiecie " -devel ". Wiec juz nie wiem jak to naprawde powinno wygladac i sugeruje sie plikami .spec znalezionych w google z roznych dystrybucji. - Chcialem jeszcze wrocic do bibliotek statycznych. https://apps.fedoraproject.org/packages/s/static Z tego linku wynika ze w Fedorze paczki z nazwa " -static " prawie nie istnieja. Wzielem pod lupe dwie paczki .src w ktorych po kompilacji powinny byc " .a " W zadnym nie bylo takiego pliku. * W irrlicht-1.8.1 zauwazylem: * W leveldb 1.12.0 zauwazylem: I teraz nasuwa mi sie pytanie, skoro biblioteki statyczne " .a " sa tak bardzo zwalczane, to - czy sa do czegokolwiek potrzebne? - czy maja jakies zastosowanie? - czy mozna je usuwac nie dodajac do zadnej paczki? - czy opcje "sharedlib" przy make mozna stosowac do kazdego kodu zrodlowego? Na ten temat znalezlem tylko http://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Static_Libraries
  14. Mam problem z aktualizacja systemu 64bit przy pomocy yum extender Błędy rozwiązywania zależności: Pakiet: 1:kmod-nvidia-3.15.8-200.fc20.x86_64-331.89-2.fc20.5.x86_64 (rpmfusion-nonfree-updates) Wymaga: kernel-uname-r = 3.15.8-200.fc20.x86_64 Zainstalowano: kernel-3.14.3-200.fc20.x86_64 (@updates) kernel-uname-r = 3.14.3-200.fc20.x86_64 Zainstalowano: kernel-3.14.4-200.fc20.x86_64 (@updates) kernel-uname-r = 3.14.4-200.fc20.x86_64 Zainstalowano: kernel-3.14.8-200.fc20.x86_64 (@updates) kernel-uname-r = 3.14.8-200.fc20.x86_64 Dostępne: kernel-3.11.10-301.fc20.x86_64 (fedora) kernel-uname-r = 3.11.10-301.fc20.x86_64 Dostępne: kernel-3.15.9-200.fc20.x86_64 (updates) kernel-uname-r = 3.15.9-200.fc20.x86_64 Dostępne: kernel-debug-3.11.10-301.fc20.x86_64 (fedora) kernel-uname-r = 3.11.10-301.fc20.x86_64+debug Dostępne: kernel-debug-3.15.9-200.fc20.x86_64 (updates) kernel-uname-r = 3.15.9-200.fc20.x86_64+debug Probowalem odznaczyc wszystko co daje wynik wyszukania kmod* Probowalem odznaczyc wszystko co daje wynik wyszukania kernel* Probowalem obydwa te rzeczy odznaczyc i dalej to samo? Co jeszcze moge zrobic? Da sie jeszcze jakos odznaczyc te aktualizacje ( kernela i kmod ) bez recznego aktualizowania systemu pakiet po pakiecie ? ( bo recznie jak zaznaczam pakiety pojedynczo to juz mi nie wyrzuca tego bledu )
  15. tylko niech ktos napisze * oraz jaki plik edytowac by recznie wylaczyc repozytorium bo wygooglac nie moglem, a przypuszczam ze gdzies tam jest. Edytowane: Co do kernwla to ten kernel mam z repozytorium @updates Fedora 20 - x86_64 -Updates
  16. Dziekuje - Udalo mi sie zaktualizowac pakiety ( oprocz kmod i xorg - teraz bede iwedzial ktore odznaczac na przyszlosc ) yum update --skip-broken Wczesniej musialem wylaczyc jedno z repozytorium ktore plulo mi brakiem klucza. W yum extender odznaczanie repozytorium nie pomaga, trzeba wybrac prawym klawiszy repozorium i wybrac opcje "wylacz...' - Moglby ktos dodac do wiki fedory * to co napisal sokar620 * oraz jaki plik edytowac by recznie wylaczyc repozytorium ? Z gory dziekuje
  17. - Nie da sie zainstalowac kmod-nvidia bo wyskakuje to samo - Sterowniki z nowym kernelem nie dzialaja. *( ten stary kmod ) A komunikat nie jest na pierwszy rzuk oka czytelny. Ja go interpretuje w ten sposob. kmod-nvidia-3.15.8-200.fc20.x86 Wymaga: kernel-uname-r = 3.15.8 Ale jest tylko Dostępne: kernel-3.15.9 Dlatego chcialem odznaczyc, a nie zaznaczyc do aktualizacji kernel i kmod az to developerzy naprawia. - Spytam inaczej , jak zrobic by yum nie aktualizowal pewnych pakietow.
  18. tele

    [Rozwiązane] [Solved] Wiedzmin 2

    Czyli to samo co wczesniej i w Fedorze Wyzej ( w 1 poscie ) cos takiego robilem Probowales tego? ( linki sa w grze albo w steam- nie pamietam, brakowalo tylko biblioteki ) Edytowane: chociaz moze raczej nie pomoze bo w PCLinuxOs mialem ten sam blad Moze jeszcze ktorys z tych rozwiazan pomoze http://steamcommunity.com/app/20920/discussions/0/522728269056298189/ Edytowane: Haaaa .... Mam ten sam problem pod PCLinuxOS uruchamiajac gre minetest zbudowanego w archu + za stary glibc, ale tego juz nie skompiluje. Jak testuje opcja strace -e open ,.minetest to pokazuje mi ze jest zaraz po otwarciu pliku libpcre.so.1 open("/lib/libpcre.so.1", O_RDONLY|O_CLOEXEC) = 3 read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0P\17\0\0004\0\0\0"..., 512) = 512 fstat64(3, {st_mode=S_IFREG|0755, st_size=440360, ...}) = 0 mmap2(NULL, 443380, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0xb3d03000 mmap2(0xb3d6f000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x6b) = 0xb3d6f000 close(3) = 0 writev(2, [{"./minetest", 10}, {": ", 2}, {"/usr/lib/libcurl.so.4", 21}, {": ", 2}, {"no version information available"..., 57}, {"\n", 1}], 6./minetest: /usr/lib/libcurl.so.4: no version information available (required by ./minetest) ) = 93 Bibioteke libcurl.so.4 wczesniej wczytalo, libcurl.so.4 -> libcurl.so.4.3.0* czyli nie jest to wina braku biblioteki. Pokusze sie znowu o instalacje wiedzmina Edytowane: Dobra gra sie zainstalowala. Gra uruchomiona w ten sposob dziala. Jeszcze sprobuje zzaktualizowac system. Takze trzeba sie skupic na tym drugim Twoim bledzie Zrobilem sobie liste pakietow z ktorymi mi to dzialalo https://www.dropbox.com/s/y0tnjmanbnw71wf/lista_zainstalowanych_pakietow.txt oraz liste uzywanych plikow przy pomocy strace ( ( comenda 2&> nazwa_pliku ) ) https://www.dropbox.com/s/3n5sini5h8iagrn/strace_steam.log.txt https://www.dropbox.com/s/u69ljk13of0hehq/strace_witcher2.log.txt ( log zawiera takze info gdzie nie znalazlo, prosze sie tego nie czepiac ) Edytowane: Zrobilem aktualizacje systemu bez kernela i xorg i kmod Wiedzin2 dalej mi dziala - nie wyskakuje juz okienko z kraszem przy wyjsciu z gry, aczkolwiek po wybraniu opcji " Wroc do menu glownego" gra sie sama wylacza jakby sie popsula i nie dala o tym bledu. Przetestuje jeszcze na OpenSuse 13.1 KDE cd-live. Edytowane: Mam problem ze stworzeniem bootujacego usb OpenSuse: live-cd, dvd-live nie dzialaja z unetbootin net-live z unetbootin dziala ale pyta sie o IP servera ktorego nie znam. komenda dd tez nie dziala z live-cd i live-dvd. Takze moze to pare dni potrwac az kupie plyte DVD, bo na CD to nawet live-cd sie nie zmiesci. Edytowane: Dobra , - instalacje OpenSuse 13.1 i aktualizacje systemu mam za soba - steama dodalem klikajac w linku http://software.opensuse.org/package/steam " openSUSE 13.1 " a potem piersza opcje " games:tools ... i kliknelem 1 Click Instal " po prawej. - Jeszcze musze jakos dodac Wiedzmina z innej partycji ktora instalowalem z Fedory. Dobra w ustawieniach Steam zmienilem jezyk na Polski w Steam --> Pobieranie --> Foldery bibioteki steam dodalem sciezkie do katalogu "Steam" na innej partycji /var/run/media/moja_nazwa_uzytkownika/nazwa_mojej_partycji/LibrarySteam/Steam/ - No dobra nie istalowalem jeszcze sterownikow Nvidia, to zainstaluje. Ale jeszcze zanim zainstaluje cos sprawdze: ./witcher2 ./witcher2: error while loading shared libraries: libSDL2-2.0.so.0: cannot open shared object file: No such file or directory Doinstalowalem: libSDL2_2_0-0 libSDL2_gfx-1_0-0 libSDL2_image-2_0-0 libSDL2_mixer-2_0-0 ./witcher2 ./witcher2: ./libcurl.so.4: no version information available (required by ./witcher2) [S_API FAIL] SteamAPI_Init() failed; Sys_LoadModule failed to load: /home/gg/.steam/bin32/steamclient.so [S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll. No i ten sam graficzny komunikat z Direct3D, to jednak zainstaluje sterownik . - Ehh Ze sterownikiem Nvidia pod suse chyba jest cos nie tak podczas reinstalacji KDE sie posypalo, reinstalowalem ponownie (poszlo to strasznie wolno) uruchomilem Widzmina - Dziala, ale ma buga tego samego co w Ubuntu (swiecace twarze jak duch), a instalowalem sterownik G02, sprobuje z G03. Edytowane: Instalacja G03 + jakies cos nviadia ktore bylo w yast + reset komputera ruszylo nvidia tak jak tego chcialem, czyli glxinfo pokazalo ze mam, nvidia settings dziala ( glxinfo dziala dopiero po komendzie " sudo zypper install Mesa-demo-x " ) Uruchamiam ponownie gre, dziala ponownie ( tym razem lepiej - "brak duchow" ) Uruchamiam plik gry ./witcher2 ./witcher2: ./libcurl.so.4: no version information available (required by ./witcher2) [S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed. [S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll. Roznic nie widze, jedyne czego bym sie przyczepil to tego ze mi w dota2 guzik wyjscia z gry nie dziala (w gornym lewym rogu) , znaczy dziala , ale dopiero za ktoryms razem ciaglego klikania w niego. Takze nie wiem jak Ci pomoc Ale radze sprobowac chociaz to SDL2 zainstalowac jak ja.
  19. tele

    Skype - Przekierowanie Pulseaudio Na Alsa

    Po dluzszym zastanowieniu i szukaniu w google stwierdzilem ze jest to troche trudniejsze, poniewaz wydaje mi sie ze gdy uzywamy pulse audio - zarowno pulse jak i alsa sa aktywne gdy uzywamy alsa - pulse jest nieaktywne lub nawet go nie ma a ciezko przekierowac z czegos co jest nieaktywne. Wydaje mi sie nadal ze jest mozliwe przekierowanie (chociaz nie widze takich opcji) z pulse do alsy np. poprzez stworzenie nowej konfiguracji dla ~/.pulse/client.conf ale uruchamianie pulse do tego celu troche mija sie z celem i moglo by powodowac problemy. Trzeba by sie spytac developerow pulse audio czy jest to mozliwe, aczkolwiek boje sie ze trzeba by napisac do tego nowa aplikacje.
  20. tele

    Dziwne Zachowanie Fedory

    Moze w ogóle nie wspieralo jeszcze? Np. w PCLinuxOS sterowniki sa paczkowane przez uzytkownikow/developerow tej dystrybucji i tez jako tako wsparcia nie ma. Znalazlem cos takiego, ktos to kiedys testowal ? http://www.easylifeproject.org/
  21. tele

    Fedora 19 + Zamiana Windows 7

    A Sprawdzisz z live cd jak zamontujesz partycje i zobaczysz ze bedzie tam folder boot a na glownej np. jest cala reszta. Edytowane: Jesli Partycje masz "nazwane" to komenda blkid to pokaze # - oznacza ze jest wykonywana z root $ - ze jest wykonywana z konta zwyklego uzytkownika W tym przypadku moja nazwa to 22, ale moglbym sobie go nazwac rowniez Fedora. Innym sposobem jest zostawienie sobie plikow w danej partycji z nazwa systemu, nastepnie z live-cd jak te wszystkie partycje zamontujesz to - w menadzerze plikow pod "jakas_nazwa_danej_partycji" zobaczysz po pliku z nazwa jaki dany system operacyjny lub poprostu partycja tam jest - komenda mount z live-cd sprawdzisz gdzie zamontowalo "jakas_nazwa_danej_partycji" Np. U mnie w menadzerze plikow zamontowana partycja ma nazwe "22" , i jest tam system "A" a mount mi pokaze ze "22" jest to partycja /dev/sda2 [root@localhost .]# mount /dev/sda2 on /media/22 type ext4 (rw,nodev,nosuid,uhelper=udisks2) Edytowane: Zalozmy ze na dysku masz 20 partycji i na kazdej po 1 systemie operacyjnym Linuxa. Po plikach i katalogach nie jestes pewien na ktorej jest dany system lub jaki. - W kazdym katalogu etc jest plik z koncowka realise w nazwie, w tym pliku znajduje sie nazwa systemu. Po wejsciu do odpowiedniego katalogu w terminalu mozna sprawdzic to w ten sposob cat *-release
  22. tele

    Łączenie Dwóch Partycji

    Nie , bynajmniej przynajmniej nie w tej wersji ktora ja znam.
  23. tele

    [Rozwiązane] [Solved] Wiedzmin 2

    Na pewno sa zajeci. A propo sterownikow AMD Ze strony mozna przeczytac: http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst14-4LINReleaseNotes.aspx Takze jakas nadzieja jest.
  24. tele

    Projekty Userow

    - Twoje zaleznosci to nie problem Java zazwyczaj domyslnie jest zainstalowana, a xterm zawsze mozna doisntalowac jak cos. - Zamiast paczki rpm mozesz zrobic skrypt instalacyjny, (w tym takze instalujacy zaleznosci) choc wydaje mi sie to zbedne skoro apka dziala jako portable z kadego miejsca - Gdybys chcial zrobic plik .spec mozesz to zrobic cos w tym stylu... Zacznij od stworzenia ikonki do menu kfupgrade.desktop przyklad [Desktop Entry] Encoding=UTF-8 Name=KFUpgrade Exec=xdg-open /opt/KFUpgrade/start.sh Icon=/opt/KFUpgrade/KFUpgrade.png Terminal=false Type=Application GenericName="KFUpgrade" Categories=System;Settings; Encoding=UTF-8 StartupNotify=true * zalozylem ze aplikacja bedzie instalowana w /opt/ * zalozylem ze ikonka/obrazek bedzie w /opt/KFUpgrade/ Zrob jeszcze ikonke/obrazek do tego. Przykladowe ikony znajdziesz w /usr/share/icons/ Po instalacji kfupgrade.desktop powinno znalesc sie w /usr/share/applications/ Tam tez znajdziesz przyklady plikow .desktop Teraz mniej wiecej objasnie jak ja bym zrobil plik spec # %pre # nie bedzie potrzebne # %build # nie bedzie potrzebne %install # W ten sposob usuwasz folder z nazwa paczki z katogu BUILDROOT, chyba... rm -rf $RPM_BUILD_ROOT # Zakladam ze juz automatycznie jestem w katalogu BUILD, # Wyzej przy zaleznosciach mozna "zasugerowac" to w ten sposob --> BuildRoot: %{_tmppath} # Najpierw stworzymy katalogi /opt/ i /usr/share/applications/ mkdir -p $RPM_BUILD_DIR/usr/share/applications mkdir -p $RPM_BUILD_DIR/opt # Teraz musze sie dostac do katalogu /opt aby sciagnac i rozpakowac aplikacje cd $RPM_BUILD_DIR/opt wget https://dl.dropboxusercontent.com/u/1039704/KFUpgrade-v1.0.tar.gz # Zeby korzystac z komendy wget, trzeba pierw zainstalowac wget tar -zxvf KFUpgrade-v1.0.tar.gz # A teraz sobie przeniesiemy plik *.desktop do odpowiedniejszego katalogu mv $RPM_BUILD_DIR/opt/KFUpgrade/kfupgrade.desktop $RPM_BUILD_DIR/usr/share/applications/ # No dobra, skoro mamy juz wszystko gotowe to trzeba to przeniesc do folderu BUILDROOT # Zaczniemy od stworzenia folderu z nazwa paczki mkdir $RPM_BUILD_ROOT # No i kopiujemy pliki z BUILD do BUILDROOT/nazwa_paczki/ cp -R $RPM_BUILD_DIR/opt $RPM_BUILD_ROOT/ cp -R $RPM_BUILD_DIR/usr $RPM_BUILD_ROOT/ # plikowi *.desktop mozemy dac prawa do wykonywania sie chmod a+x %{buildroot}/usr/share/applications/kfupgrade.desktop # Dobra teraz w katalogu BUILDROOT mamy struktore plikow ktora zostanie zainstalowana # Mozemy jeszcze cos zrobic - ale nie musimy, co pozwoli naszej aplikacji wykonac sie z terminala export PATH=$PATH:/opt/KFUpgrade/start.sh # cos w tym stulu, wez zerknij w google, bo mam wrazenie ze to nie zadziala, # a po drugie komenda start.sh by glupio brzmiala, proponuje zmienic nazwe pliku. # Usuwanie tego "PATH" przy odinstalowaniu paczki %postun PATH=$(IFS=':';p=($PATH);unset IFS;p=(${p[@]%%*/KFUpgrade/*});IFS=':';echo "${p[*]}";unset IFS) # Mozna tu jeszcze dodac %{clean_menus} %{clean_desktop_database} # A do "po instalacjii" %post %{update_menus} %{update_desktop_database} Taki plik spec nie potrzebuje " Source0: %{app_name}-%{version}.tar.xz " Poniewaz komenda wget pobierze plik. Edytowane: Poprawilem linijke chmod a+x %{buildroot}/usr/share/applications/kfupgrade.desktop
  25. tele

    Gnash

    Kliknij "Chce uzywac odwarzacza HTML5" Dzieki temu nowsze filmiki beda dzialac juz w HTML5 bez flasha. https://www.youtube.com/html5?hl=pl&gl=PL
×