Jump to content

MarekZ

Użytkownicy
  • Content Count

    13
  • Joined

  • Last visited

Community Reputation

0 Neutral

About MarekZ

  • Rank
    Młodszy Użytkownik
  1. Dzięki za odpowiedź. Poszedłem tropem linków i niestety przynajmniej u mnie nic nie zadziałało być może z powodu że zmiany w dconf są opisane dla starszej wersji szukałem zmieniałem i nic. Jednak w jednym z podanych linków znalazłem link do programu który rozwiązuje problem http://pnmougel.github.io/meow/ . Zastanawiam się jedna czy dconf nie działa czy ja jednak coś nie tak robiłem?
  2. ta opcja z przebudową pakietów by była bardzo dobra. Znasz może jakiś dobry poradnik na ten temat i na temat budowy pakietów, taki dla osub które jeszcze nigdy tego nie robiły?
  3. Było by super gdyby tak było można. Generalnie pytanie o te biblioteki było spowodowane dwoma sytuacjami potrzebą kompilacji ze źródeł oprogramowania (brak rpm lub bardzo długi czas oczekiwania na najnowszą wersję) a druga sytuacja to wtyczka w programie która do instalacji potrzebuje bibliotek tyle że z najnowszymi nie działa.
  4. Witam. Jak poradzić sobie w sytuacji kiedy potrzebne są dwie różne wersje tego samego pakietu. dnf daje komunikat że w systemie jest już zainstalowany pakiet w nowszej wersji i w związku z tym starszy pakiet jest w konflikcie?
  5. Witam wie ktoś może jak samemu tworzyć w zasobniku katalogi dla programów takie jak są już zdefiniowane różne i narzędzia ? Dzięki za odpowiedź P.s. Czy da się samemu w gnome zrobić taką zbiorczą ikonę po kliknięciu której otwiera się okienko jak w narzędziach czy w różnych?
  6. I to było to wielkie dzięki zadziałało Ogromnie dzięki za pomoc
  7. ale teraz daje coś takiego : $ make rm -f ./zyGrib cd src/qwt-6.0.1/src; /usr/bin/qmake-qt4; make -j5 Project ERROR: local build will conflict with /usr/lib64/libqwt.* make[1]: Wejście do katalogu '/home/mzygadlo/Pobrane/zyGrib-7.0.0/src/qwt-6.0.1/src' make[1]: Nie ma nic do zrobienia w 'first'. make[1]: Opuszczenie katalogu '/home/mzygadlo/Pobrane/zyGrib-7.0.0/src/qwt-6.0.1/src' cd src; /usr/bin/qmake-qt4; make -j5 make[1]: Wejście do katalogu '/home/mzygadlo/Pobrane/zyGrib-7.0.0/src' g++ -Wl,-O1 -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -O3 -o zyGrib objs/PositionEditorWidget.o objs/ColorEditorWidget.o objs/LineEditorWidget.o objs/TextStyleEditorWidget.o objs/AngleConverterWidget.o objs/AngleConverterDialog.o objs/BoatSpeed.o objs/CurveDrawer.o objs/CustomQwtClasses.o objs/Astro.o objs/MbzFile.o objs/MblueRecord.o objs/MblueReader.o objs/MbluePlot.o objs/BoardPanel.o objs/ColorScale.o objs/ColorScaleWidget.o objs/DataColors.o objs/DataQString.o objs/DataMeteoAbstract.o objs/DataPointInfo.o objs/DateChooser.o objs/DialogBoxColumn.o objs/DialogFonts.o objs/DialogGraphicsParams.o objs/DialogLoadGRIB.o objs/DialogLoadIAC.o objs/DialogLoadMBLUE.o objs/DialogProxy.o objs/DialogSelectMetar.o objs/DialogServerStatus.o objs/DialogUnits.o objs/FileLoaderGRIB.o objs/FileLoaderIAC.o objs/FileLoaderMBLUE.o objs/Font.o objs/GriddedPlotter.o objs/GriddedReader.o objs/GriddedRecord.o objs/GshhsRangsReader.o objs/GshhsReader.o objs/GribAnimator.o objs/GribPlot.o objs/GisReader.o objs/GribReader.o objs/GribRecord.o objs/IacPlot.o objs/IacReader.o objs/IacReaderUtil.o objs/ImageWriter.o objs/IrregularGridded.o objs/IsoLine.o objs/LongTaskProgress.o objs/LonLatGrid.o objs/main.o objs/MainWindow.o objs/MapDrawer.o objs/MenuBar.o objs/Metar.o objs/MeteoTable.o objs/MeteoTableWidget.o objs/MeteotableOptionsDialog.o objs/Orthodromie.o objs/POI.o objs/POI_Editor.o objs/PositionEditor.o objs/Projection.o objs/Projection_libproj.o objs/Settings.o objs/SkewT.o objs/SkewTWindow.o objs/Terrain.o objs/Therm.o objs/Util.o objs/zuFile.o objs/moc_PositionEditorWidget.o objs/moc_ColorEditorWidget.o objs/moc_LineEditorWidget.o objs/moc_TextStyleEditorWidget.o objs/moc_AngleConverterWidget.o objs/moc_AngleConverterDialog.o objs/moc_CurveDrawer.o objs/moc_BoardPanel.o objs/moc_ColorScaleWidget.o objs/moc_DataQString.o objs/moc_DateChooser.o objs/moc_DialogBoxColumn.o objs/moc_DialogFonts.o objs/moc_DialogGraphicsParams.o objs/moc_DialogLoadGRIB.o objs/moc_DialogLoadIAC.o objs/moc_DialogLoadMBLUE.o objs/moc_DialogProxy.o objs/moc_DialogSelectMetar.o objs/moc_DialogServerStatus.o objs/moc_DialogUnits.o objs/moc_FileLoaderGRIB.o objs/moc_FileLoaderIAC.o objs/moc_FileLoaderMBLUE.o objs/moc_GribAnimator.o objs/moc_ImageWriter.o objs/moc_LongTaskProgress.o objs/moc_Metar.o objs/moc_MeteoTable.o objs/moc_MeteoTableWidget.o objs/moc_MeteotableOptionsDialog.o objs/moc_MainWindow.o objs/moc_MapDrawer.o objs/moc_MenuBar.o objs/moc_POI.o objs/moc_POI_Editor.o objs/moc_PositionEditor.o objs/moc_Projection.o objs/moc_SkewT.o objs/moc_Terrain.o objs/moc_Util.o -L/usr/lib64 -lbz2 -lz -lproj -lnova -Lqwt-6.0.1/lib/ -lqwt -lQtXml -lQtGui -lQtNetwork -lQtCore -lpthread /usr/bin/ld: skipping incompatible qwt-6.0.1/lib//libqwt.a when searching for -lqwt /usr/bin/ld: cannot find -lqwt collect2: error: ld returned 1 exit status Makefile:330: polecenia dla obiektu 'zyGrib' nie powiodły się make[1]: *** [zyGrib] Błąd 1 make[1]: Opuszczenie katalogu '/home/mzygadlo/Pobrane/zyGrib-7.0.0/src' Makefile:37: polecenia dla obiektu 'zyGrib' nie powiodły się make: *** [zyGrib] Błąd 2
  8. Pogrzebałem i okazało się że zwyczajnie nie miałem polecenia qmqke doinstalowałem całą masę paczek i qmake jest ale teraz daje konflikt : # make rm -f ./zyGrib cd src/qwt-6.0.1/src; /usr/bin/qmake-qt4; make -j5 Project ERROR: local build will conflict with /usr/lib64/libqwt.* make[1]: Wejście do katalogu '/home/mzygadlo/Pobrane/zyGrib-7.0.0/src/qwt-6.0.1/src' make[1]: *** Brak reguł do zrobienia obiektu '/usr/share/qt4/mkspecs/linux-g++-64/qmake.conf', wymaganego przez 'Makefile'. Stop. make[1]: Opuszczenie katalogu '/home/mzygadlo/Pobrane/zyGrib-7.0.0/src/qwt-6.0.1/src' Makefile:36: polecenia dla obiektu 'zyGrib' nie powiodły się make: *** [zyGrib] Błąd 2 W /usr/share/qt4 nie mam mkspecs, alinia 36 w Makefile to @echo Masz może jakieś pomysły na rowiązanie tego konfliktu z /usr/lib64/libqwt.*
  9. Dziękuję bardzo za odpowiedź. Doinstalowałem powyższe pakiety bez problemu ale dalej jest problem z build-essential i g++. dnf install build-essential g++ make Ostatnio sprawdzono ważność metadanych 0:01:24 temu w dniu Thu Nov 26 06:44:11 2015. Nie ma pakietu build-essential. Nie ma pakietu g++. Pakiet make-1:4.0-5.1.fc23.x86_64 jest już zainstalowany, pomijanie. Błąd: Nie można odnaleźć pasujących wyników. Mam jeszcze pytanie gzie znajdują się i jak szukać nazw pakietów które są właściwe dla Fedory
  10. Witam, Czy jest gdzieś opisana instalacja oprogramowania ze źródeł na fedorze 22 czy 23. Próbowałem instalować ze źródeł program zyGrib i niestety nic z tego. przed instalacją trzeba doinstalować: build-essential g++ make libqt4-dev libbz2-dev zlib1g-dev libproj-dev libnova-dev nettle-dev, ale dnf pisze że nie można znaleźć pasujących plików (próbowałem również kasując -dev i tosam tak ja zamieniając dev na devel). Dodam jeszcze że operacja jest wykonywana na świeżo postawionym systemie Fedora 23 Brak mi pomysłu jak tą sytuację rozwiązać
×
×
  • Create New...