Jump to content

p4w3k

Użytkownicy
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About p4w3k

  • Rank
    Początkujący

Contact Methods

  • AIM
    4119292
  • Strona www
    http://www.pc.inet.pl
  • ICQ
    0
  1. Mam wielki problem i już nie wiem co robić, szukam tego od 3 godzin i nie mogę znaleźć nigdzie... Mam zainstalowane gcc, gcc-c++ i chyba wszystko co trzeba, nawet cpp znajduje się w /lib/cpp, a tutaj dalej taki błąd wyrzuca przy próbie ./configure każdego programu, poóżcie checking for a BSD-compatible install... /usr/bin/install -c checking whether build environment is sane... yes checking for gawk... gawk checking whether make sets $(MAKE)... yes checking whether to enable maintainer-specific portions of Makefiles... no checking build system type... i686-pc-linux-gnulibc1 checking host system type... i686-pc-linux-gnulibc1 checking for style of include used by make... GNU checking for gcc... gcc checking for C compiler default output file name... a.out checking whether the C compiler works... yes checking whether we are cross compiling... no checking for suffix of executables... checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether gcc accepts -g... yes checking for gcc option to accept ANSI C... none needed checking dependency style of gcc... gcc3 checking for a sed that does not truncate output... /bin/sed checking for egrep... grep -E checking for ld used by gcc... /usr/bin/ld checking if the linker (/usr/bin/ld) is GNU ld... yes checking for /usr/bin/ld option to reload object files... -r checking for BSD-compatible nm... /usr/bin/nm -B checking whether ln -s works... yes checking how to recognise dependent libraries... pass_all checking how to run the C preprocessor... /lib/cpp configure: error: C preprocessor "/lib/cpp" fails sanity check See `config.log' for more details.
  2. Problem rozwiązany, dzięki wszystkim w szczególności sebastianowi. Przyczyna była jakże banalnie prosta: xorg.conf szukał myszki w /dev/mouse, tym czasem moja mysz na USB zagnieździła się w /dev/input/mice Pozdrawiam
  3. fglrxinfo: [[email protected] ~]$ fglrxinfo display: :0.0 screen: 0 OpenGL vendor string: Mesa project: www.mesa3d.org OpenGL renderer string: Mesa GLX Indirect OpenGL version string: 1.2 (1.5 Mesa 6.1) Jeśli to coś zmienia, to zainstalowałem od razu po 1 uruchomieniu rpm ze sterownikami z ati.com, może nie działać przez to? W katalogu /etc/ nie mam pliku xorg.conf, natomiast znalazłem go w /etc/X11/ oto jego zawartość: # XFree86 4 configuration created by pyxf86config Section "ServerLayout" Identifier "Default Layout" Screen 0 "Screen0" 0 0 InputDevice "Mouse0" "CorePointer" InputDevice "Keyboard0" "CoreKeyboard" EndSection Section "Files" # RgbPath is the location of the RGB database. Note, this is the name of the # file minus the extension (like ".txt" or ".db"). There is normally # no need to change the default. # Multiple FontPath entries are allowed (they are concatenated together) # By default, Red Hat 6.0 and later now use a font server independent of # the X server to render fonts. RgbPath "/usr/X11R6/lib/X11/rgb" FontPath "unix/:7100" EndSection Section "Module" Load "dbe" Load "extmod" Load "fbdevhw" Load "glx" Load "record" Load "freetype" Load "type1" Load "dri" EndSection Section "InputDevice" # Specify which keyboard LEDs can be user-controlled (eg, with xset(1)) # Option "Xleds" "1 2 3" # To disable the XKEYBOARD extension, uncomment XkbDisable. # Option "XkbDisable" # To customise the XKB settings to suit your keyboard, modify the # lines below (which are the defaults). For example, for a non-U.S. # keyboard, you will probably want to use: # Option "XkbModel" "pc102" # If you have a US Microsoft Natural keyboard, you can use: # Option "XkbModel" "microsoft" # # Then to change the language, change the Layout setting. # For example, a german layout can be obtained with: # Option "XkbLayout" "de" # or: # Option "XkbLayout" "de" # Option "XkbVariant" "nodeadkeys" # # If you'd like to switch the positions of your capslock and # control keys, use: # Option "XkbOptions" "ctrl:swapcaps" # Or if you just want both to be control, use: # Option "XkbOptions" "ctrl:nocaps" # Identifier "Keyboard0" Driver "kbd" Option "XkbModel" "pc105" Option "XkbLayout" "pl" EndSection Section "InputDevice" Identifier "Mouse0" Driver "mouse" Option "Protocol" "IMPS/2" Option "Device" "/dev/input/mice" Option "ZAxisMapping" "4 5" Option "Emulate3Buttons" "yes" EndSection Section "Monitor" Identifier "Monitor0" VendorName "Monitor Vendor" ModelName "Unknown monitor" HorizSync 31.5 - 37.9 VertRefresh 50.0 - 70.0 Option "dpms" EndSection Section "Device" Identifier "Videocard0" Driver "fglrx" VendorName "Videocard vendor" BoardName "ATI Radeon 9600" Option "VideoOverlay" "on" EndSection Section "Screen" Identifier "Screen0" Device "Videocard0" Monitor "Monitor0" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 16 Modes "800x600" "640x480" EndSubSection SubSection "Display" Viewport 0 0 Depth 24 Modes "800x600" "640x480" EndSubSection EndSection Section "DRI" Group 0 Mode 0666 EndSection
  4. Na początek dziękuję za wszystkie odpowiedzi. sebastian: zrobiłem tak jak sugerowałeś, czyli zainstalowałem nowego kernela (dzieki za to) ściągnąłem odpowiedni kernel-module, zainstalowałem i wszystko bez problemów. Jednak akceleracja dalej nie działa, czy trzeba ją jakoś uruchomić w pliku konfiguracyjnym albo coś? Pozdrawiam
  5. jestem początkującym, a ta czynność wymaga chyba kompilacji jądra tak? boję się brać na razie za to... nie da się inaczej?
  6. Witam, przed chwilunią zainstalowałem Fedorę Core3 to dane mojej dystrybucji: Linux localhost.localdomain 2.6.9-1.667 #1 Tue Nov 2 14:41:25 EST 2004 i686 athlon i386 GNU/Linux zainstalowałem już ati-fglrx-8.10.19.1-0.lvn.1.3.i386.rpm następnym krokiem jest instalacja kernel-module-fglrx jednak nie mogę znaleść odpowiedniego rpm do mojej dystrybucji, z takim jądrem jest tylko po FC2... Ma ktoś jakiś pomysł, co dalej robić? Instalowałem (_rpma_ → RPM-a) ORT z środowiska graficznego, zrestartowałem bo gdzieś na ati.com przeczytałem że nie trzeba już kernel-module. Jednak TuxRacer jak chodził tak chodzi... Proszę o pomoc i z góry dziękuję
×
×
  • Create New...