Jump to content
adios

[faq] Drukarki Hp, Instalacja I Ciekawy Program

Recommended Posts

Witajcie

 

Wlasnie przeinstalowalem system z F9 na F14 i mam klopot z instalacja drukarki hp k209a (all-in-one). Zrobilem jak na forum podane i drukarka jest niewidoczna.

Probujac instalowac z HPLIP 3.11.1 po podaniu hasla roota wywala mi komunikat o niepoprawnym hasle - czy to selinux blokuje?

 

 

OK

Temat rozwiazany dzieki podpowiedzi link

wczesniej funkcja szukania mi nie zadzialala odpowiednio :)

Share this post


Link to post
Share on other sites

Spróbuj zainstalować sterowniki ze strony HP - jest binarna paczka pod Linuksa. Chyba, że to właśnie masz na myśli mówiąc o "instalowaniu z HPLIP 3.11.1".

Instalowałem z takiej paczki u kogoś sterowniki i wszystko poszło, ale niestety dopiero kiedy zrobiłem "su" na roota i uruchomiłem skrypt bezpośrednio z konta roota. Wygląda na to że skrypt jest nieco skopany, ale po instalacji z roota powinno być lepiej.

Share this post


Link to post
Share on other sites

Mnie w punkcie 3) pojawia sie komunikat o tresci:

Usluga FirewallD nie jest uruchomiona. Wykrywanie drukarek sieciowych wymaga wlaczenia uslug mdns, ipp, ipp-client i samba-client w zaporze sieciowej.

 

Ktos wie jak wlaczyc te usluge? Przedtem nie mialem z tym problemów.

Share this post


Link to post
Share on other sites

Ktos wie jak wlaczyc te usluge?

Od F15 czesciowo a w F16 prawie w calosci uslugami zarzadza systemd. Wlaczanie, wylaczanie itp "man systemctl"

A swoja droga "w pukcie 3)" czego? Jesli odnosisz sie do tego co napisano w poscie #1 tego watku, to sprawdz jego date ;) Sporo sie zmienilo.

Share this post


Link to post
Share on other sites

Ehh ja to mam szczescie zawsze trafiac na "pieklo zaleznosci":

yum install hplip-gui
Wczytane wtyczki: fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: mirror.karneval.cz
* rpmfusion-free: mirror.karneval.cz
* rpmfusion-free-updates: mirror.karneval.cz
* rpmfusion-nonfree: mirror.karneval.cz
* rpmfusion-nonfree-updates: mirror.karneval.cz
* updates: mirror.nl.as6453.net
Rozwiazywanie zaleznosci
--> Wykonywanie sprawdzania transakcji
---> Pakiet hplip-gui.x86_64 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: libsane-hpaio = 3.12.6-1.fc17 dla pakietu: hplip-gui-3.12.6-1.fc17.x86_64
--> Przetwarzanie zaleznosci: hplip = 3.12.6-1.fc17 dla pakietu: hplip-gui-3.12.6-1.fc17.x86_64
--> Przetwarzanie zaleznosci: python-reportlab dla pakietu: hplip-gui-3.12.6-1.fc17.x86_64
--> Wykonywanie sprawdzania transakcji
---> Pakiet hplip-gui.x86_64 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip = 3.12.6-1.fc17 dla pakietu: hplip-gui-3.12.6-1.fc17.x86_64
---> Pakiet libsane-hpaio.i686 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip-libs = 3.12.6-1.fc17 dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: librt.so.1 dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libpthread.so.0(GLIBC_2.0) dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libpthread.so.0 dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libhpmud.so.0 dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libhpip.so.0 dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libdl.so.2(GLIBC_2.1) dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libdl.so.2(GLIBC_2.0) dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libdl.so.2 dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libdbus-1.so.3 dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libcups.so.2 dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libcrypto.so.10 dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libc.so.6(GLIBC_2.7) dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libc.so.6(GLIBC_2.4) dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libc.so.6(GLIBC_2.3.4) dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libc.so.6(GLIBC_2.3) dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libc.so.6(GLIBC_2.1.3) dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libc.so.6(GLIBC_2.1) dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libc.so.6(GLIBC_2.0) dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libc.so.6 dla pakietu: libsane-hpaio-3.12.6-1.fc17.i686
---> Pakiet python-reportlab.x86_64 0:2.5-4.fc17 zostanie zainstalowany
--> Wykonywanie sprawdzania transakcji
---> Pakiet cups-libs.i686 1:1.5.4-2.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: libz.so.1 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libtiff.so.3 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libstdc++.so.6(GLIBCXX_3.4) dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libstdc++.so.6(CXXABI_1.3) dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libstdc++.so.6 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libselinux.so.1 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libpng15.so.15(PNG15_0) dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libpng15.so.15 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libkrb5.so.3 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libk5crypto.so.3 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libjpeg.so.62(LIBJPEG_6.2) dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libjpeg.so.62 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libgssapi_krb5.so.2(gssapi_krb5_2_MIT) dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libgssapi_krb5.so.2 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libgpg-error.so.0 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libgnutls.so.26(GNUTLS_1_4) dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libgnutls.so.26 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libgcrypt.so.11 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libgcc_s.so.1(GCC_3.0) dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libgcc_s.so.1 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libcom_err.so.2 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libavahi-common.so.3 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libavahi-client.so.3 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
--> Przetwarzanie zaleznosci: libaudit.so.1 dla pakietu: 1:cups-libs-1.5.4-2.fc17.i686
---> Pakiet dbus-libs.i686 1:1.4.10-5.fc17 zostanie zainstalowany
---> Pakiet glibc.i686 0:2.15-57.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: libfreebl3.so(NSSRAWHASH_3.12.3) dla pakietu: glibc-2.15-57.fc17.i686
--> Przetwarzanie zaleznosci: libfreebl3.so dla pakietu: glibc-2.15-57.fc17.i686
---> Pakiet hplip-gui.x86_64 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip = 3.12.6-1.fc17 dla pakietu: hplip-gui-3.12.6-1.fc17.x86_64
---> Pakiet hplip-libs.i686 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip-common = 3.12.6-1.fc17 dla pakietu: hplip-libs-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libusb-1.0.so.0 dla pakietu: hplip-libs-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libsane.so.1 dla pakietu: hplip-libs-3.12.6-1.fc17.i686
--> Przetwarzanie zaleznosci: libnetsnmp.so.30 dla pakietu: hplip-libs-3.12.6-1.fc17.i686
---> Pakiet openssl.i686 1:1.0.0j-2.fc17 zostanie zainstalowany
--> Wykonywanie sprawdzania transakcji
---> Pakiet audit-libs.i686 0:2.2.1-1.fc17 zostanie zainstalowany
---> Pakiet avahi-libs.i686 0:0.6.31-5.fc17 zostanie zainstalowany
---> Pakiet gnutls.i686 0:2.12.17-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: libtasn1.so.3(LIBTASN1_0_3) dla pakietu: gnutls-2.12.17-1.fc17.i686
--> Przetwarzanie zaleznosci: libtasn1.so.3 dla pakietu: gnutls-2.12.17-1.fc17.i686
--> Przetwarzanie zaleznosci: libp11-kit.so.0 dla pakietu: gnutls-2.12.17-1.fc17.i686
---> Pakiet hplip-gui.x86_64 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip = 3.12.6-1.fc17 dla pakietu: hplip-gui-3.12.6-1.fc17.x86_64
---> Pakiet hplip-libs.i686 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip-common = 3.12.6-1.fc17 dla pakietu: hplip-libs-3.12.6-1.fc17.i686
---> Pakiet krb5-libs.i686 0:1.10.2-6.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: libkeyutils.so.1(KEYUTILS_0.3) dla pakietu: krb5-libs-1.10.2-6.fc17.i686
--> Przetwarzanie zaleznosci: libkeyutils.so.1 dla pakietu: krb5-libs-1.10.2-6.fc17.i686
---> Pakiet libcom_err.i686 0:1.42.3-2.fc17 zostanie zainstalowany
---> Pakiet libgcc.i686 0:4.7.2-2.fc17 zostanie zainstalowany
---> Pakiet libgcrypt.i686 0:1.5.0-3.fc17 zostanie zainstalowany
---> Pakiet libgpg-error.i686 0:1.10-2.fc17 zostanie zainstalowany
---> Pakiet libjpeg-turbo.i686 0:1.2.1-1.fc17 zostanie zainstalowany
---> Pakiet libpng.i686 2:1.5.10-1.fc17 zostanie zainstalowany
---> Pakiet libselinux.i686 0:2.1.10-3.fc17 zostanie zainstalowany
---> Pakiet libstdc++.i686 0:4.7.2-2.fc17 zostanie zainstalowany
---> Pakiet libtiff.i686 0:3.9.6-2.fc17 zostanie zainstalowany
---> Pakiet libusb1.i686 0:1.0.9-0.6.rc1.fc17 zostanie zainstalowany
---> Pakiet net-snmp-libs.i686 1:5.7.1-4.fc17 zostanie zainstalowany
---> Pakiet nss-softokn-freebl.i686 0:3.13.5-1.fc17 zostanie zainstalowany
---> Pakiet sane-backends-drivers-cameras.i686 0:1.0.22-11.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: sane-backends-libs(x86-32) = 1.0.22-11.fc17 dla pakietu: sane-backends-drivers-cameras-1.0.22-11.fc17.i686
--> Przetwarzanie zaleznosci: sane-backends = 1.0.22-11.fc17 dla pakietu: sane-backends-drivers-cameras-1.0.22-11.fc17.i686
--> Przetwarzanie zaleznosci: libgphoto2_port.so.0 dla pakietu: sane-backends-drivers-cameras-1.0.22-11.fc17.i686
--> Przetwarzanie zaleznosci: libgphoto2.so.2 dla pakietu: sane-backends-drivers-cameras-1.0.22-11.fc17.i686
--> Przetwarzanie zaleznosci: libexif.so.12 dla pakietu: sane-backends-drivers-cameras-1.0.22-11.fc17.i686
---> Pakiet zlib.i686 0:1.2.5-7.fc17 zostanie zainstalowany
--> Wykonywanie sprawdzania transakcji
---> Pakiet hplip-gui.x86_64 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip = 3.12.6-1.fc17 dla pakietu: hplip-gui-3.12.6-1.fc17.x86_64
---> Pakiet hplip-libs.i686 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip-common = 3.12.6-1.fc17 dla pakietu: hplip-libs-3.12.6-1.fc17.i686
---> Pakiet keyutils-libs.i686 0:1.5.5-2.fc17 zostanie zainstalowany
---> Pakiet libexif.i686 0:0.6.20-2.fc17 zostanie zainstalowany
---> Pakiet libgphoto2.i686 0:2.4.14-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: libusb-0.1.so.4 dla pakietu: libgphoto2-2.4.14-1.fc17.i686
--> Przetwarzanie zaleznosci: libltdl.so.7 dla pakietu: libgphoto2-2.4.14-1.fc17.i686
--> Przetwarzanie zaleznosci: liblockdev.so.1 dla pakietu: libgphoto2-2.4.14-1.fc17.i686
--> Przetwarzanie zaleznosci: libgd.so.2 dla pakietu: libgphoto2-2.4.14-1.fc17.i686
---> Pakiet libtasn1.i686 0:2.12-1.fc17 zostanie zainstalowany
---> Pakiet p11-kit.i686 0:0.12-1.fc17 zostanie zainstalowany
---> Pakiet sane-backends-drivers-cameras.i686 0:1.0.22-11.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: sane-backends = 1.0.22-11.fc17 dla pakietu: sane-backends-drivers-cameras-1.0.22-11.fc17.i686
---> Pakiet sane-backends-libs.i686 0:1.0.22-11.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: libv4l1.so.0 dla pakietu: sane-backends-libs-1.0.22-11.fc17.i686
--> Przetwarzanie zaleznosci: libieee1284.so.3 dla pakietu: sane-backends-libs-1.0.22-11.fc17.i686
--> Wykonywanie sprawdzania transakcji
---> Pakiet gd.i686 0:2.0.35-17.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: libfreetype.so.6 dla pakietu: gd-2.0.35-17.fc17.i686
--> Przetwarzanie zaleznosci: libfontconfig.so.1 dla pakietu: gd-2.0.35-17.fc17.i686
--> Przetwarzanie zaleznosci: libXpm.so.4 dla pakietu: gd-2.0.35-17.fc17.i686
--> Przetwarzanie zaleznosci: libX11.so.6 dla pakietu: gd-2.0.35-17.fc17.i686
---> Pakiet hplip-gui.x86_64 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip = 3.12.6-1.fc17 dla pakietu: hplip-gui-3.12.6-1.fc17.x86_64
---> Pakiet hplip-libs.i686 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip-common = 3.12.6-1.fc17 dla pakietu: hplip-libs-3.12.6-1.fc17.i686
---> Pakiet libieee1284.i686 0:0.2.11-11.fc17 zostanie zainstalowany
---> Pakiet libtool-ltdl.i686 0:2.4.2-3.1.fc17 zostanie zainstalowany
---> Pakiet libusb.i686 1:0.1.3-10.fc17 zostanie zainstalowany
---> Pakiet libv4l.i686 0:0.8.8-2.fc17 zostanie zainstalowany
---> Pakiet lockdev.i686 0:1.0.4-0.4.20111007git.fc17 zostanie zainstalowany
---> Pakiet sane-backends-drivers-cameras.i686 0:1.0.22-11.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: sane-backends = 1.0.22-11.fc17 dla pakietu: sane-backends-drivers-cameras-1.0.22-11.fc17.i686
--> Wykonywanie sprawdzania transakcji
---> Pakiet fontconfig.i686 0:2.8.0-8.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: libexpat.so.1 dla pakietu: fontconfig-2.8.0-8.fc17.i686
---> Pakiet freetype.i686 0:2.4.8-3.fc17 zostanie zainstalowany
---> Pakiet hplip-gui.x86_64 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip = 3.12.6-1.fc17 dla pakietu: hplip-gui-3.12.6-1.fc17.x86_64
---> Pakiet hplip-libs.i686 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip-common = 3.12.6-1.fc17 dla pakietu: hplip-libs-3.12.6-1.fc17.i686
---> Pakiet libX11.i686 0:1.5.0-2.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: libxcb.so.1 dla pakietu: libX11-1.5.0-2.fc17.i686
---> Pakiet libXpm.i686 0:3.5.10-1.fc17 zostanie zainstalowany
---> Pakiet sane-backends-drivers-cameras.i686 0:1.0.22-11.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: sane-backends = 1.0.22-11.fc17 dla pakietu: sane-backends-drivers-cameras-1.0.22-11.fc17.i686
--> Wykonywanie sprawdzania transakcji
---> Pakiet expat.i686 0:2.1.0-1.fc17 zostanie zainstalowany
---> Pakiet hplip-gui.x86_64 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip = 3.12.6-1.fc17 dla pakietu: hplip-gui-3.12.6-1.fc17.x86_64
---> Pakiet hplip-libs.i686 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip-common = 3.12.6-1.fc17 dla pakietu: hplip-libs-3.12.6-1.fc17.i686
---> Pakiet libxcb.i686 0:1.8.1-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: libXau.so.6 dla pakietu: libxcb-1.8.1-1.fc17.i686
---> Pakiet sane-backends-drivers-cameras.i686 0:1.0.22-11.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: sane-backends = 1.0.22-11.fc17 dla pakietu: sane-backends-drivers-cameras-1.0.22-11.fc17.i686
--> Wykonywanie sprawdzania transakcji
---> Pakiet hplip-gui.x86_64 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip = 3.12.6-1.fc17 dla pakietu: hplip-gui-3.12.6-1.fc17.x86_64
---> Pakiet hplip-libs.i686 0:3.12.6-1.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: hplip-common = 3.12.6-1.fc17 dla pakietu: hplip-libs-3.12.6-1.fc17.i686
---> Pakiet libXau.i686 0:1.0.6-3.fc17 zostanie zainstalowany
---> Pakiet sane-backends-drivers-cameras.i686 0:1.0.22-11.fc17 zostanie zainstalowany
--> Przetwarzanie zaleznosci: sane-backends = 1.0.22-11.fc17 dla pakietu: sane-backends-drivers-cameras-1.0.22-11.fc17.i686
--> Ukonczono rozwiazywanie zaleznosci
Blad: Pakiet: sane-backends-drivers-cameras-1.0.22-11.fc17.i686 (updates)
	  Wymaga: sane-backends = 1.0.22-11.fc17
	  Zainstalowano: sane-backends-1.0.23-4.fc17.x86_64 (@updates-testing)
		  sane-backends = 1.0.23-4.fc17
	  Dostepne: sane-backends-1.0.22-9.fc17.x86_64 (fedora)
		  sane-backends = 1.0.22-9.fc17
	  Dostepne: sane-backends-1.0.22-11.fc17.x86_64 (updates)
		  sane-backends = 1.0.22-11.fc17
Blad: Pakiet: hplip-libs-3.12.6-1.fc17.i686 (updates)
	  Wymaga: hplip-common = 3.12.6-1.fc17
	  Zainstalowano: hplip-common-3.12.9-2.fc17.x86_64 (@updates-testing)
		  hplip-common = 3.12.9-2.fc17
	  Dostepne: hplip-common-3.12.4-2.fc17.x86_64 (fedora)
		  hplip-common = 3.12.4-2.fc17
	  Dostepne: hplip-common-3.12.6-1.fc17.x86_64 (updates)
		  hplip-common = 3.12.6-1.fc17
Blad: Pakiet: hplip-gui-3.12.6-1.fc17.x86_64 (updates)
	  Wymaga: hplip = 3.12.6-1.fc17
	  Zainstalowano: hplip-3.12.9-2.fc17.x86_64 (@updates-testing)
		  hplip = 3.12.9-2.fc17
	  Dostepne: hplip-3.12.4-2.fc17.x86_64 (fedora)
		  hplip = 3.12.4-2.fc17
	  Dostepne: hplip-3.12.6-1.fc17.x86_64 (updates)
		  hplip = 3.12.6-1.fc17
Mozna spróbowac uzyc --skip-broken, aby obejsc problem
Mozna spróbowac wykonac polecenie: rpm -Va --nofiles --nodigest

 

ehhh chyba nie musze dodawac ze --skip-broken nic nie pomaga?

Share this post


Link to post
Share on other sites

Nic dodac, ale na pewno sporo ujac. Konkretnie to usunac wszystkie hp*.i686 (przy zalozeniu, ze system masz w wiekszosci 64-bitowy), bo masz bajzel jakis

Blad: Pakiet: hplip-libs-3.12.6-1.fc17.i686 (updates)

Wymaga: hplip-common = 3.12.6-1.fc17

Zainstalowano: hplip-common-3.12.9-2.fc17.x86_64 (@updates-testing)

Chyba, ze poslugiwales sie jakims przewodnikiem dla systemu 32-bitowego, zeby np. uruchomic drukarke?

Share this post


Link to post
Share on other sites

Tylko zwróc uwage ze system wymaga wersji 32 biotwych ale w "zainstalowano" wszedzie ma 64-wiec w teorii ok. Zreszta komenda "yum remove hp*.i686" nic nie znajduje. Moze po prostu lepiej wywalic calosc hplip tak by zaden pakiet nie zostal a potem dopiero zainstalowac wszystko na raz i niech wtedy instaluje co chce?

Share this post


Link to post
Share on other sites
Moze po prostu lepiej wywalic calosc hplip tak by zaden pakiet nie zostal a potem dopiero zainstalowac wszystko na raz i niech wtedy instaluje co chce?
Ja bym tak zrobil :)

Poza tym mozesz jeszcze spróbowac zainstalowac yum-plugin-protectbase - powinien pilnowac "czystosci" architektury, ale nie wiem czy w tym przypadku zadziala.

Share this post


Link to post
Share on other sites

Zainstalowano: hplip-3.12.9-2.fc17.x86_64 (@updates-testing)

 

 

To zamierzone, czy zapomniałeś wyłączyć wcześniej repozytorium updates-testing i dlatego masz bałagan w systemie?

Share this post


Link to post
Share on other sites

Mam kombajn HP 4580. Zainstalowalem sterownik zgodnie z instrukcją tutaj. Dało sie zaraz po instalacji wydrukować stronę testową, ale cokolwiek chcę wyfrukować innego, to wskazuje mi drukarka jest 'offline'.

Share this post


Link to post
Share on other sites

Dodam, że drukarka działa w trybie wifi (tzn. nie działa) i wskazuje ze jest offline przy próbie wydrukowania czegokolwiek. Czy ktoś miał podobny problem?

Share this post


Link to post
Share on other sites

Wlaśnie spróbowałem. Zainstalowałem i ustawiłem wszystko. Drukarka ma status gotowa a zadania "oczekuje". Jednak nie da się itak nic wydrukować ponieważ drukowanie blokuje odzywający się SElinux, a ja nie wiem jak zmodyfować politykę.

 

 

[[email protected] ~]$ sudo su
[sudo] password for superuser:
[[email protected] superuser]# sh '/home/superuser/Pobrane/hplip-3.14.1.run'
Creating directory hplip-3.14.1
Verifying archive integrity... All good.
Uncompressing HPLIP 3.14.1 Self Extracting Archive.......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
warning: hplip-install should not be run as root.

HP Linux Imaging and Printing System (ver. 3.14.1)
HPLIP Installer ver. 5.1

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Tue-14-Jan-2014_15:51:08.log

\error: You are running the installer as root. It is highly recommended that you run the installer as
error: a regular (non-root) user. Do you still wish to continue?
Continue with installation (y=yes, n=no*, q=quit) ? y

note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
-
 

INSTALLATION MODE
-----------------
Automatic mode will install the full HPLIP solution with the most common options.
Custom mode allows you to choose installation options to fit specific requirements.

Please choose the installation mode (a=automatic*, c=custom, q=quit) :
Initializing. Please wait...


INTRODUCTION
------------
This installer will install HPLIP version 3.14.1 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).


DISTRO/OS CONFIRMATION
----------------------
Distro appears to be Fedora 19.

Is "Fedora 19" your correct distro/OS and version (y=yes*, n=no, q=quit) ? y


INSTALLATION NOTES
------------------
SELinux must run in permissive mode or it must be disabled for HPLIP to function properly. Please run SELinux in permissive mode or disable it before continuing.
To complete the install in Fedora you must quit the installer at the printer setup stage, log out, log back in, and run hp-setup.

Please read the installation notes. Press <enter> to continue or 'q' to quit:


RUNNING PRE-INSTALL COMMANDS
----------------------------
OK


INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
warning: There are 5 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: python-devel (Python devel - Python development files)
warning: Missing REQUIRED dependency: cups-devel (CUPS devel- Common Unix Printing System development files)
warning: Missing REQUIRED dependency: libusb (libusb - USB library)
warning: Missing REQUIRED dependency: cups-image (CUPS image - CUPS image development files)
warning: Missing REQUIRED dependency: libjpeg (libjpeg - JPEG library)


INSTALL MISSING OPTIONAL DEPENDENCIES
-------------------------------------
warning: There are 3 missing OPTIONAL dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency for option 'network': libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)
warning: Missing OPTIONAL dependency for option 'network': avahi-utils (avahi-utils)
warning: Missing REQUIRED dependency for option 'scan': sane-devel (SANE - Scanning library development files)



CHECKING FOR NETWORK CONNECTION
-------------------------------




\



Network connection present.


RUNNING PRE-PACKAGE COMMANDS
----------------------------
su -c "yum clean all" (Pre-depend step 1)
-
warning: An error occurred running 'su -c "yum check-update"'
su -c "yum check-update" (Pre-depend step 2)
OK


DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'su -c "yum -y -d 10 -e 1 install python-devel"'
Please wait, this may take several minutes...
Running 'su -c "yum -y -d 10 -e 1 install cups-devel"'
Please wait, this may take several minutes...
Running 'su -c "yum -y -d 10 -e 1 install libusb1-devel"'
Please wait, this may take several minutes...
Running 'su -c "yum -y -d 10 -e 1 install cups-devel"'
Please wait, this may take several minutes...
Running 'su -c "yum -y -d 10 -e 1 install libjpeg-devel"'
Please wait, this may take several minutes...
Running 'su -c "yum -y -d 10 -e 1 install net-snmp-devel"'
Please wait, this may take several minutes...
Running 'su -c "yum -y -d 10 -e 1 install avahi-tools"'
Please wait, this may take several minutes...
Running 'su -c "yum -y -d 10 -e 1 install sane-backends-devel"'
Please wait, this may take several minutes...
HPLIP-3.13.9 exists, this may conflict with the new one being installed.
Do you want to ('i'= Remove and Install*, 'o'= Overwrite, 'q'= Quit)?    :Starting uninstallation...
|\
HPLIP uninstallation is completed


RUNNING POST-PACKAGE COMMANDS
-----------------------------
OK


RE-CHECKING DEPENDENCIES
------------------------
 

PRE-BUILD COMMANDS
------------------
OK


BUILD AND INSTALL
-----------------
Running './configure --with-hpppddir=/usr/share/cups/model/HP --libdir=/usr/lib64 --prefix=/usr --enable-qt4 --disable-libusb01_build --enable-doc-build --disable-cups-ppd-install --disable-foomatic-drv-install --disable-foomatic-ppd-install --disable-hpijs-install --disable-udev_sysfs_rules --disable-policykit --enable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --enable-scan-build --enable-fax-build'
Please wait, this may take several minutes...
Command completed successfully.

Running 'make clean'
Please wait, this may take several minutes...
Command completed successfully.

Running 'make'
Please wait, this may take several minutes...
Command completed successfully.

Running 'su -c "make install"'
Please wait, this may take several minutes...
-Please enter the root/superuser password:
Command completed successfully.


Build complete.


POST-BUILD COMMANDS
-------------------
 

OPEN MDNS/BONJOUR FIREWALL PORT (MULTICAST PORT 5353)
-----------------------------------------------------
In order to setup your printer on the network using mDNS/Bonjour, it is required
that your internet firewall allows connections on port 5353. If this port is    
blocked by the firewall, connection to network printers using mDNS/Bonjour will
not be possible.                                                                

Do you wish to open this port on your internet firewall (y=yes*, n=no, q=quit) ? y
 

CLOSE HP_SYSTRAY
----------------
Sending close message to hp-systray (if it is currently running)...


HPLIP UPDATE NOTIFICATION
-------------------------
Do you want to check for HPLIP updates?. (y=yes*, n=no) : y


RESTART OR RE-PLUG IS REQUIRED
------------------------------
If you are installing a USB connected printer, and the printer was plugged in   
when you started this installer, you will need to either restart your PC or     
unplug and re-plug in your printer (USB cable only). If you choose to restart,  
run this command after restarting: hp-setup (Note: If you are using a parallel  
connection, you will have to restart your PC. If you are using network/wireless,
you can ignore and continue).                                                   

Restart or re-plug in your printer (r=restart, p=re-plug in*, i=ignore/continue, q=quit) : i


PRINTER SETUP
-------------
Please make sure your printer is connected and powered on at this time.
 

RE-STARTING HP_SYSTRAY
----------------------
warning: hp-systray should not be run as root/superuser.

HP Linux Imaging and Printing System (ver. 3.14.1)
System Tray Status Service ver. 2.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: hp-systray cannot be run as root. Exiting.

[[email protected] superuser]# exit
exit
[[email protected] ~]$ hp-systray

HP Linux Imaging and Printing System (ver. 3.14.1)
System Tray Status Service ver. 2.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:122: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
  set_interactive(1)

Share this post


Link to post
Share on other sites

Wyłącz SElinux lub uruchom jako root "sealert -b" - znajdziesz polecenia naprawy.

Nie wiem też czy problemu nie sprawia uruchamianie "su" przez "sudo". To dość kuriozalne podejście.

Nie możesz po prostu "su -"?

 

P.S.Nie wklejaj takich tasiemców - nic nie wnoszą do tematu i w żaden sposób nie przybliżają do rozwiązania a przewijania 10 ekranów.

Share this post


Link to post
Share on other sites
Wyłącz SElinux lub uruchom jako root "sealert -b" - znajdziesz polecenia naprawy.

 

Próbowałem wyłaczyć SElinuksa przez Easylife, ale nic to nie dało. Jest jakiś pewny prosty sposób by to  zrobić? Albo może wgrac aplikacje "Zarządzanie SElinuksem" tylko to itak nie czyni zadania calkiem zrozumiałego dla początkujących ;/

 

Czy na pewno zacząć instalacje jako "Su"? Bo na instrukcji nizej jest jako sudo, a jak próbowalem jako 'su' to coś mi początkowo terminal narzekał:P Pytam jedynie dla pewnosci, bo sporo juz mnie w tym systemie zaskakiwalo, wiec wole spytac niz bładzic;)

http://hplipopensource.com/hplip-web/install/install/index.html

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...