Jump to content

Recommended Posts

Witam i mam prosbe o pomoc dla poczatkujacego...

Zainstalowalem Fedora Core 4

i nie wiem co zrobic aby dzialala moja karta WiFi

Mam karte D-Link DWL-610 jedyne co znalazlem na temat to ndiswrapper

sciagnalem to i nie wiem co dalej...

Czy jest to driver do tej karty jak to napisano na strone

Ale co zrobic dalej, przegralem spakowany plik na "pulpit" i nie moge znalezc pomocy, albo po prostu nie rozumiem tego wszystkiego...

Share this post


Link to post
Share on other sites

Hmmm, jak napisalem jestem poczatkujacy, co prawda uzywalem kiedys takze Dos'a ale linux to dla mnie czarna magia...

Napisze co robie:

Wchodze w terminal, wpisuje su, haslo

po chwili w nowej linni pokazuje sie wpis: localhost i cos tam.

po wpisaniu polecenia lspci spod usera wyskakuje blad mowiacy o tym ze polecenie nie zostalo znalezione.

Ale zrestartowalem komputer i zalogowalem sie jako root.

Znow Wchodze w terminal i wpisuje lspci i mam:

[root@localhost ~]# lspci

00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX 82443BX/

ZX/DX Host bridge (rev 03)

00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX 82443BX/

ZX/DX AGP bridge (rev 03)

00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)

00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)

00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)

00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)

00:0a.0 CardBus bridge: Texas Instruments PCI1225 (rev 01)

00:0a.1 CardBus bridge: Texas Instruments PCI1225 (rev 01)

00:0d.0 Multimedia audio controller: ESS Technology ES1983S Maestro3i

PCI Audio Accelerator

00:0d.1 Communication controller: ESS Technology ES1983S Maestro3i

PCI Modem Accelerator

01:00.0 VGA compatible controller: Silicon Motion, Inc. SM720 Lynx3DM (rev b1)

02:00.0 Ethernet controller: DLink

System Inc DWL510

2.4GHz Wireless PCI Adapter (rev 20)

[root@localhost ~]#

Share this post


Link to post
Share on other sites

Źle zalogowałeś się na roota w terminalu. Powinno być su - (kreska jest ważna).

 

Jeśli to chipset rtl8180 to zrób tak.

Wykonaj polecenie uname -rm. Pokaże wersję uruchomionego kernela i architekturę. Stąd ściągasz odpowiedni moduł o nazwie kmod-ndiswrapper w takiej wersji jak kernel (te numerki na końcu). Z tego samego miejsca ściągasz pakiet ndiswrapper w takiej wersji jakiej moduł (te numerki bliżej nazwy).

Instalujesz oba pakiety przy pomocy rpm czyli rpm -ivh /ścieżka/do/pakietów.

Następnie postępujesz wg. tego poradnika zaczynając od miejsca ndiswrapper -i /sciezka_do_pliku/net8180.inf kończąc na konfiguracji. Musisz tylko pamiętać, że skrypty startowe umieszcza się w Fedorze gdzie indziej ale to znajdziesz na forum.

Share this post


Link to post
Share on other sites

Po wpisaniu uname -rm otrzymalem nastapujaca informacje: 2.6.11-1.1369_FC4 i686

Wszedlem pod wskazany przez ciebie link, ale tam nie ma kmod-ndiswrapper z takim rozszerzeniem

wszystkie maja poza tym FC5, szukalem tez w katalogu FC4 i tez nie ma tam kmod-ndiswrapper

 

Share this post


Link to post
Share on other sites

Sorry nie zauważyłem że chodzi o FC4. Dla FC4 moduł nazywa się kernel-module-ndiswrapper. Z tą różnicą że najpierw podana jest wersja kernela a później ndiswrappera.

Share this post


Link to post
Share on other sites

Witam, chciałabym odnowić temat :) Otóż, probowałam zainstalować na Fc6 ww. kartę, zgodnie m.in. z tym co polecono tu wczesniej, ale już przy instalacji kmod-ndiswrapper... wypluło mi coś takiego:

ostrzeżenie: kmod-ndiswrapper-1.25-1.2.6.18_1.2798.fc6.i686.rpm: Nagłówek V3 DSA signature: NOKEY, key ID a109b1ec
błąd: Niespełnione zależności:
        kernel-i686 = 2.6.18-1.2798.fc6 jest wymagany przez kmod-ndiswrapper-1.25-1.2.6.18_1.2798.fc6.i686
        ndiswrapper-kmod-common >= 1.25 jest wymagany przez kmod-ndiswrapper-1.25-1.2.6.18_1.2798.fc6.i686

 

a przy ndiswrapper...:

ostrzeżenie: ndiswrapper-1.25-1.lvn6.i386.rpm: Nagłówek V3 DSA signature: NOKEY, key ID a109b1ec
błąd: Niespełnione zależności:
        ndiswrapper-kmod >= 1.25 jest wymagany przez ndiswrapper-1.25-1.lvn6.i386

 

Zdziwiło mnie zwłaszcza info o kernelu, bo uname -rm podaje wlaśnie taką wersję jaka jest wymagana .

Jeżeli ktoś ma jakiś pomysł, to byłabym wdzięczna za pomoc (dodam, że jestem raczej zielona w temacie linuksa, nie siedzę w tym zbyt długo :> ).

Share this post


Link to post
Share on other sites

No dobra, uporałam się z ndiswrapperem, wszystko zainstalowane, tylko... nie wykrywa mi karty... :> ndiswrapper -l powinien mówić 'driver install, hardware present', mi mówi tylko że driver jest zainstalowany... lspci pokazuje tą kartę, natomiast w ifconfig ani iwconfig jej nie ma, nie da się jej uaktywnić. Jakieś pomysły...? :)

Share this post


Link to post
Share on other sites
No dobra, uporałam się z ndiswrapperem, wszystko zainstalowane, tylko... nie wykrywa mi karty... :> ndiswrapper -l powinien mówić 'driver install, hardware present', mi mówi tylko że driver jest zainstalowany... lspci pokazuje tą kartę, natomiast w ifconfig ani iwconfig jej nie ma, nie da się jej uaktywnić. Jakieś pomysły...? :)

 

wg tego co ja znalazlem do sieciowki dwl 510 jest potrzebny sterownik windowsowy dla sieciowki dwl 610 przynajmniuej tak wynika z tematu ktory założyłem http://forums.gentoo.org/viewtopic-t-525830.html

 

Share this post


Link to post
Share on other sites

Napisales, ze uporales sie z instalacja ndiswrappera ale czy przedtem uporales sie takze z tym:

Podaje kernel-2.6.18-1.2798.fc6.i586.rpm
??

... nie wiem co to znaczy, ze sie uporales, moze jak niektorzy specjalisci uzyles --force --nofiles --nodeps itp?...

 

Wiec pokaz jeszcze raz

rpm -q --qf '%{name}-%{version}-%{release}.%{arch}.rpm\n' kernel

i przy okazji

rpm -qa | grep ndiswrapper
rpm -qa | grep kmod

to moze cos wymyslimy...

Pozdro

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...