Jump to content
Sign in to follow this  
alpin19

Uszkodzony Python :(

Recommended Posts

Witam

 

Zainstalowałem zaledwie kilka pakietów i chciałem pracować dalej... Chciałem, ale sypią mi się biblioteki :(

Zainstalowałem takie pakiety:

 

[root@localhost log]# cat yum.log
Aug 14 14:55:40 Installed: libsndfile.i386 1.0.15-1.fc5
Aug 14 14:55:45 Installed: kadu.i386 0.5.0-0.7.20060808svn.fc5
Aug 14 14:56:56 Installed: cvs.i386 1.11.21-3.2
Aug 14 14:56:57 Installed: lincvs.i386 1.4.4-1.fc5
Aug 14 15:11:47 Installed: smb4k.i386 0.7.1-1.fc5
Aug 14 17:29:18 Installed: newt-perl.i386 1.08-9.2.1
Aug 14 17:29:18 Installed: crypto-utils.i386 2.2-9.2.1
Aug 14 17:41:52 Installed: mc.i386 1:4.6.1a-14.fc5
Aug 14 15:53:14 Installed: mikmod.i386 3.1.6-36.2.1
Aug 14 15:53:15 Installed: xmms-libs.i386 1:1.2.10-25.fc5
Aug 14 15:53:16 Installed: xmms.i386 1:1.2.10-25.fc5
Aug 14 15:53:33 Installed: xmms-mp3.i386 1.2.10-3.lvn5
Aug 14 15:56:02 Installed: SDL_net.i386 1.2.5-8.fc5
Aug 14 15:56:02 Installed: dosbox.i386 0.65-2.fc5
Aug 14 16:04:16 Updated: libgcj.i386 4.1.1-1.fc5
Aug 14 16:10:56 Updated: java-1.4.2-gcj-compat.i386 1.4.2.0-40jpp_83rh.1
Aug 14 16:17:46 Installed: wine-core.i386 0.9.17-1.fc5
Aug 14 16:17:47 Installed: wine-cms.i386 0.9.17-1.fc5
Aug 14 16:17:47 Installed: wine-ldap.i386 0.9.17-1.fc5
Aug 14 16:17:47 Installed: wine-nas.i386 0.9.17-1.fc5
Aug 14 16:17:47 Installed: wine-capi.i386 0.9.17-1.fc5
Aug 14 16:17:48 Installed: wine-tools.i386 0.9.17-1.fc5
Aug 14 16:17:48 Installed: wine-twain.i386 0.9.17-1.fc5
Aug 14 16:17:49 Installed: wine-esd.i386 0.9.17-1.fc5
Aug 14 16:17:50 Installed: wine-jack.i386 0.9.17-1.fc5
Aug 14 16:17:50 Installed: wine.i386 0.9.17-1.fc5
Aug 14 16:22:24 Installed: qemu.i386 0.8.1-3.fc5

 

...a dzieje się tak:

 

[root@localhost log]# yum
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   /usr/lib/libsqlite3.so.0: undefined symbol: sqlite3FrgeX

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.4.2 (#1, Feb 12 2006, 03:59:46)
[GCC 4.1.0 20060210 (Red Hat 4.1.0-0.24)]

If you cannot solve this problem yourself, please go to
the yum faq at:
  http://wiki.linux.duke.edu/YumFaq


[root@localhost log]#    

..oraz tak:

[root@localhost log]# rpm
rpm: symbol lookup error: /usr/lib/libsqlite3.so.0: undefined symbol: sqlite3FrgeX
[root@localhost log]#

Share this post


Link to post
Share on other sites

rpm -qf /usr/lib/libsqlite3.so.0

A nie lepiej po prostu
yum provides libsqlite3.so.0

Pozdr,

W.

 

Share this post


Link to post
Share on other sites

poza tym yum to i tak nakladka i rozwiazywacz zaleznosci na rpm :)

 

 

Go to the source, Neo....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...