Jump to content
alpin19

Vncserver - Nie Mogę Się Podłączyć

Recommended Posts

Witam

 

Na win2000 [192.168.3.14] zainstalowałem RealVNC Viewer aby móc połączyć się przez VNC ze swoją FC5 [192.168.3.82].

 

Kiedy próbuję połaczyć się za pomocą RealVNC otrzymuję odpowiedź o treści:

VNC Viewer Error:

unable to connect to host: Connection Refused (10061)

 

Kiedy patrzę w logi vncserver'a ([alpin19@localhost log]$ tail -f /home/alpin19/.vnc/localhost.localdomain:*.log)

widzę, że 'nic' się nie dzieje:

==> /home/alpin19/.vnc/localhost.localdomain:1.log <==

Underlying X server release 70000000, The X.Org Foundation

 

 

Fri Aug 25 10:59:34 2006

vncext: VNC extension running!

vncext: Listening for VNC connections on port 5901

vncext: Listening for HTTP connections on port 5801

vncext: created VNC server for screen 0

Could not init font path element /usr/share/X11/fonts/OTF, removing from list!

Could not init font path element /usr/share/X11/fonts/CID/, removing from list!

 

==> /home/alpin19/.vnc/localhost.localdomain:4.log <==

Underlying X server release 70000000, The X.Org Foundation

 

 

Fri Aug 25 11:03:30 2006

vncext: VNC extension running!

vncext: Listening for VNC connections on port 5904

vncext: Listening for HTTP connections on port 5804

vncext: created VNC server for screen 0

Could not init font path element /usr/share/X11/fonts/OTF, removing from list!

Could not init font path element /usr/share/X11/fonts/CID/, removing from list!

[alpin19@localhost log]$ tail -f /home/alpin19/.vnc/localhost.localdomain:*.log

==> /home/alpin19/.vnc/localhost.localdomain:1.log <==

Underlying X server release 70000000, The X.Org Foundation

 

 

Fri Aug 25 10:59:34 2006

vncext: VNC extension running!

vncext: Listening for VNC connections on port 5901

vncext: Listening for HTTP connections on port 5801

vncext: created VNC server for screen 0

Could not init font path element /usr/share/X11/fonts/OTF, removing from list!

Could not init font path element /usr/share/X11/fonts/CID/, removing from list!

 

==> /home/alpin19/.vnc/localhost.localdomain:4.log <==

Underlying X server release 70000000, The X.Org Foundation

 

 

Fri Aug 25 11:03:30 2006

vncext: VNC extension running!

vncext: Listening for VNC connections on port 5904

vncext: Listening for HTTP connections on port 5804

vncext: created VNC server for screen 0

Could not init font path element /usr/share/X11/fonts/OTF, removing from list!

Could not init font path element /usr/share/X11/fonts/CID/, removing from list!

 

Poradźcie proszę co zrobić :(

 

------- edit:

 

Ok. udało mi się połączyć, ale jeszcze nie tak jak bym tego chciał, ponieważ odpala się nowa sesja Term'a i nie wiem jak dostać się do działającego już Gnome'a :(

Share this post


Link to post
Share on other sites

A na jaki port się łączysz? VncViewer standardowo uderza na 5900, natomiast jak widać w logach serwer nasłuchuje na 5901. Między innymi. ;)

 

Potelnetuj najpierw te porty z Win, by zobaczyć czy w ogóle masz połączenie.

 

:: EDIT ::

Nie doczytałem dopisku. VNCserver znany jest z tego, iż tworzy nową sesję Xksów (nie Terma, jak napisałeś). Do tej samej potrzebujesz uruchomić najpierw:

# vino-preferences

a potem

# vino-session

Opcja ta jest gdzieś dostępna z menu Gnome'a lecz ponieważ korzystam z Xfce (tam też można go uruchomić! :) ) więc nie potrafię powiedzieć w którym miejscu. Vino łączy się na display=:0 serwera Xksów. O ile się nie mylę jest to standardowy pakiet wchodzący w skład Gnome'a.

 

:: EDIT 2 ::

(_acha_ → aha) ORT! I vino nasłuchuje już normalnie na domyślnym 5900! Ogólnie - rewelacja programik! Nawe można go zdalnie uruchomić po ssh:

# vino-session --display=:0

O ile ma się wyłączoną opcję potwierdzania akceptacji połączenia - trzecia opcja w preferencjach.

Share this post


Link to post
Share on other sites

Witam, Mam podobny problem. Niby teoretycznie wszystko w fedorce jest uruchomione ok ale jak łącze się z windy vncviewerem to mam:

unable to connect to host: Próba przeprowadzenia operacji, wykonywanej przez gniazdo, na nieosiągalnym hoście (10065)

i nie wiem juz co to.

 

Może ja coś źle robie lub zrobiłem.

po włączeniu fedorki wpisuje vncserver i dostaje to:

vncserver

 

New 'localhost.localdomain:1 (root)' desktop is localhost.localdomain:1

 

Starting applications specified in /root/.vnc/xstartup

Log file is /root/.vnc/localhost.localdomain:1.log

 

vncconfig -iconic &

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup

[ -r $HOME/ .Xresources ] && xrdb $HOME/ .Xresources

xsetroot -solid grey

xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &

twm &

gnome-session &

gnome-panel &

nautilus &

 

Czy ja coś mam skopane w konfiguracji ????????????????????? help virusek113@gmail.com

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...