Jump to content
Sign in to follow this  
Adinfo

Red Hat Enterprise Linux Es 4 Basic I Mysql 5.xx

Recommended Posts

Czy istnieje wersja MySQL 5.xx dla Red Hat'a Enterprise Linux ES 4 Basic (32-bitowa). Znalazłem tylko informacje o wersji 4.xx. Z powodu instalacji nowej aplikacji sieciowej muszę uruchomić bazy MySQL w wersji 5.xx. Na ten moment mam na serwerze znajdują się jeszcze bazy danych Firebird, które są niezbędne do działania systemu finansowo-księgowego. Reinstalacja do nowszej wersji Red Hat'a (wersja 5) nie wchodzi na ten moment w grę.

Share this post


Link to post
Share on other sites
Guest _PaT

O ile się orientuję, to tak "wprost" nie istnieje taka wersja. Jeśli jednak masz dostęp do kanału RH Application Stack AS x86, to znajdziesz tam wersję piątą MySQL-a. Nawet jeśli nie masz tej subskrypcji, to możesz skorzystać z repo CentOS-a - oczywiście kosztem utraty wsparcia. Pamiętaj też, że jeśli już masz założone jakieś bazy MySQL, to upgrade z 4 na 5 może spowodować kłopoty.

Share this post


Link to post
Share on other sites

W pracy sprawdzę czy mam dostęp do kanału RH Application Stack AS x86. Na ten moment nie mam ani jednej bazy MySQL w wersji 4.x. Dopiero mam zamiar postawić bazy, więc nie ma problemu. Jeżeli będę miał dostęp do RH Application Stack AS x86 - czy te paczki będą pasowały ? Czy samo pobranie i wgranie paczek z repo CentOS-a spowoduje automatycznie utratę wsparcia technicznego a tym samym aktualizacji (dopiero co wykupiłem roczne wsparcie) ?

 

Sprawdziłem i znalazłem w RH Application Stack AS x86 paczkę mysql-server-5.0.22-2.1.i386.rpm. Rozumiem, że muszę pobrać też inne paczki, podczas instalacji pojawiają się następujące błędy:

error: Failed dependencies:

libc.so.6(GLIBC_2.4) is needed by mysql-server-5.0.22-2.1.i386

libcrypto.so.6 is needed by mysql-server-5.0.22-2.1.i386

libmysqlclient.so.15 is needed by mysql-server-5.0.22-2.1.i386

libmysqlclient.so.15(libmysqlclient_15) is needed by mysql-server-5.0.22-2.1.i386

libmysqlclient_r.so.15 is needed by mysql-server-5.0.22-2.1.i386

libmysqlclient_r.so.15(libmysqlclient_15) is needed by mysql-server-5.0.22-2.1.i386

libssl.so.6 is needed by mysql-server-5.0.22-2.1.i386

mysql = 5.0.22-2.1 is needed by mysql-server-5.0.22-2.1.i386

rtld(GNU_HASH) is needed by mysql-server-5.0.22-2.1.i386

Share this post


Link to post
Share on other sites
Guest _PaT

Jeśli chodzi o wsparcie, to straciłbyś je wyłącznie po wgraniu paczek spoza Red Hata i tylko w odniesieniu do samego MySQL-a. Ponieważ masz dostęp do odpowiednich paczek, to wszystko jest OK.

 

Rzucając okiem na zależności, które wypisałeś, zaczynam mieć obiekcje, czy te paczki jednak są właściwie dla AS 4... Czy na pewno pobrałeś właściwą paczkę? Te dla AS-a miały zwykle w nazwie paczki "EL". Wklej wyjście polecenia

rpm -qi mysql-server-5.0.22-2.1.i386.rpm

 

Jeśli jednak masz właściwią paczkę, to spróbuj odszukać zależności korzystając z linka poniżej.

http://kbase.redhat.com/faq/FAQ_80_4526.shtm

Sukcesu jednak nie wróżę, gdyż niezgodność glibc i GNU_HASH-a sugeruje, że to jest paczka dla RHEL 5.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...