Jump to content
SeeM

[f9] Montowanie Na Starcie Systemu

Recommended Posts

znam dwa sposoby montowania obrazów ISO przy starcie: albo w fstab:

/home/obrazki/h2.iso /mnt/h2 iso9660 loop,auto,noexec,ro 0 0

albo rc.local:

mount -o loop -t iso9660 /home/obrazki/h2.iso /mnt/h2

 

jest taki problem, że usługi się włączają i pod koniec przy montowaniu pojawia się błąd brak dostępu; no i koniec, iso się nie montują; jako root mogę to zrobić, nawet hurtem poprzez jakiś alias, ale wolę kiedy to się dzieje automagicznie; nie mam pojęcia z czym jest kłopot

Share this post


Link to post
Share on other sites

teoretycznie powinno działać, ponieważ wywołanie rc.local i fstab jest z prawami roota, na pewno masz te pliki i katalogi stworzone w tych ścieżkach? co dokładnie masz w logach?

Share this post


Link to post
Share on other sites

to SeLinux dziad! ale dużo mi to nie daje, nie znam się na tym; przykłąd dla Herosów montowanych oprzez fstaba:

/home/lukasz/.wine/hero2.iso /mnt/hero2 iso9660 auto,loop,noexec 0 0
loop: module loaded

type=1400 audit(1217233920.202:4): avc: denied { read write } for pid=1330 comm="mount" name="hero2.iso" dev=sda7 ino=4538380 scontext=system_u:system_r:mount_t:s0 tcontext=system_u:object_r:user_home_t:s0 tclass=file

Share this post


Link to post
Share on other sites
ale dużo mi to nie daje, nie znam się na tym

 

czyli nie wiesz jak przekonać SELinuksa, że operacja montowania jest ok? audit2allow całkiem nieźle spełnia swoje zadanie...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×