Skocz do zawartości
thof

E-deklaracje - Mini How-to

Rekomendowane odpowiedzi

Mówiąc szczerze lubię edeklaracje, nawet biorąc pod uwagę długotrwały proces doprowadzenia tego do uzywalności. Nie podoba mi się jedynie fakt, że wszystko (łącznie ze sprawdzaniem zwrotów wysłanych pitów) trzeba robić na jednym i tym samym komputerze. Mam w domu lakpa i komuter bardziej stacjonarny, do którego podpięta jest drukarka. Wystarczy nie włączać edeklaracji przez tydzień-dwa i może się okazać, że mieliście błędy i nie wysłaliście swojego pita w terminie.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Witam.

Podatków i śmierci nie unikniemy. Więc e-deklaracji również.

W tym roku trafiłem na problem. Przy próbie instalacji AdobeAir wyskakuje błąd:

 

Error loading the runtime (libicuuc.so.48: cannot open shared object file: No such file or directory)

 

Przy próbie obejścia instalatora AdobeAir i użyciu SDK  to samo. Odgrzebałem gdzieś rpm z AdobeAir i... to samo.

 

W katalogu sudo /opt/Adobe\ AIR/Versions/1.0/Resources/airappinstaller DeklaracjeDesktop.air

znajduje się plik libicuuc.so.36. Zrobiłem link symboliczny libicuuc.so.48 i nic. W /usr/lib również i dalej nic.

Ma ktoś jakiś pomysł wskazówkę ?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Ostatnią Fedorą na której udało mi się zainstalować AdobeAir była 19. Próbowałem też zrobić sobie kontener z Airem, ale jak na razie bez sukcesów. Zatem do deklaracji używam Aira zainstalowanego na Ubuntu 12.04.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

W poprzednim poście bzdury opowiadałem. Udało mi się zrobić paczkę instalującą e-Deklaracje na Fedora 19, 20 i 21. Paczka zawiera skrypt będący wyciągiem wypowiedzi Rovan i jeśli ktoś ma ochotę to zapraszam do testowania i zgłaszania uwag. Niestety nie udało mi się wrzucić do zależności Adobe Acrobat Readera i trzeba go samodzielnie zainstalować, albo z russian fedora, albo z rpm ze strony Adobe. Dodałem też e-Deklaracje do menu w kategoriach biuro i sieć.

 

Trzeba mieć włączone moje repo fedora-gospogied:

sudo dnf install -y http://repo.gospogied.pl/Fedora/fedora-gospogied-0.5-1.noarch.rpm

i doinstalować paczkę:

sudo dnf install eDeklaracjeInstaller

albo można po prostu zainstalować samą paczkę:

sudo dnf install -y http://repo.gospogied.pl/Fedora/21/i386/eDeklaracjeInstaller-0.1-2.fc21.noarch.rpm
Edytowane przez 3k_PL

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Przeszedłem wszystkie kroki z posta Rovana, zinstalowałem skyrpt 3k_PL (dzięki Panowie, wpsaniała robota!) jednak dalej nie mogę ruszyć do przodu.

 

Ktoś może natrafił na problem:

$ /opt/AIR-SDK/bin/adl -nodebug /opt/AIR-apps/e-Deklaracje/META-INF/AIR/application.xml /opt/AIR-apps/e-Deklaracje                            
Error loading the runtime (libicuuc.so.48: cannot open shared object file: No such file or directory)

yum provides libicuuc niczego nie zwraca, a z tego co widzę  rpm -qli libicu pokazuje że jednak libicuuc jest tyle że w wersji 52.

 

Wujek google mówi mi że w Fedorze 17 można było znaleźć tą bibliotekę tej wersji. Ale to raczej nie problem.

Znalazłem w katalogu  /opt/Adobe/Reader9/Reader/intellinux/lib plik libicuuc. Zrobiłem link symboliczny:

$ ls -l |grep libicuu                                                                                                   
lrwxrwxrwx 1 root root       14 2013-05-08  libicuuc.so -> libicuuc.so.36
lrwxrwxrwx 1 root root       16 2013-05-08  libicuuc.so.36 -> libicuuc.so.36.0
-rwxr-xr-x 1 root root  1131364 2013-05-08  libicuuc.so.36.0
lrwxrwxrwx 1 root root       14 02-21 11:18 libicuuc.so.48 -> libicuuc.so.36

Ale dalej nic.

 

Ale dalej nic. Ma może ktoś jakiś pomysł?

 

Wersja Fedory to oczywiście 21. W pełni zaktualizowana.

 

EDIT:

 

cp /opt/Adobe/Reader9/Reader/intellinux/lib/libicuuc.so /opt/AIR-SDK/runtimes/air/linux/Adobe\ AIR/Versions/1.0/libicuuc.so.48

cp /opt/Adobe/Reader9/Reader/intellinux/lib/libicudata.so /opt/AIR-SDK/runtimes/air/linux/Adobe\ AIR/Versions/1.0/libicudata.so.48

 

rowiązało problem.

 

EDIT2.

Jednak skopiowanie bibliotek nie rozwiązało całkowicie problemu. Przy próbie importu/exportu program się wywalał. Po dłuższej chwili szukania okazało, że to z powodu starych pakietów z nieoficjalnego repo enligthment z czasów Fedora 18. 

Edytowane przez neometal

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

×