Jump to content
Sign in to follow this  
Magnum44pl

Błąd Podczas Aktualizacji Fedora 15 -> 16

Recommended Posts

Witam. Mam taki problem. Otóż chciałem zaktualizować fedorkę do najnowszej wersji, bo podobno jest już OK. Ale wyskakuje problem. Aktualizuje ją poleceniem:

 

yum --releasever=16 --disableplugin=presto distro-sync --skip-broken --enablerepo=rpmfusion-nonfree-rawhide,rpmfusion-free-rawhide

 

Ale wyskakuje błąd:

Skip-broken could not solve problems
Błąd: Pakiet: libkworkspace-4.7.2-5.fc15.x86_64 (@fedora-kde47/15)
         Wymaga: kdelibs4(x86-64) >= 4.7.2
         Usuwanie: 6:kdelibs-4.7.2-2.fc15.x86_64 (@fedora-kde47/15)
             kdelibs4(x86-64) = 4.7.2-2.fc15
         Zainstalowano poprzednią wersję przez: 6:kdelibs-4.7.1-2.fc16.1.x86_64 (fedora)
             kdelibs4(x86-64) = 4.7.1-2.fc16.1
Błąd: ksysguard-libs conflicts with kdebase-workspace-libs-4.7.1-2.fc16.x86_64
Błąd: libkworkspace conflicts with kdebase-workspace-libs-4.7.1-2.fc16.x86_64
Błąd: Pakiet: ksysguard-4.7.2-5.fc15.x86_64 (@fedora-kde47/15)
         Wymaga: ksysguardd = 4.7.2-5.fc15
         Usuwanie: ksysguardd-4.7.2-5.fc15.x86_64 (@fedora-kde47/15)
             ksysguardd = 4.7.2-5.fc15
         Zainstalowano poprzednią wersję przez: ksysguardd-4.7.1-2.fc16.x86_64 (fedora)
             ksysguardd = 4.7.1-2.fc16
Błąd: Pakiet: ksysguard-libs-4.7.2-5.fc15.x86_64 (@fedora-kde47/15)
         Wymaga: kdelibs4(x86-64) >= 4.7.2
         Usuwanie: 6:kdelibs-4.7.2-2.fc15.x86_64 (@fedora-kde47/15)
             kdelibs4(x86-64) = 4.7.2-2.fc15
         Zainstalowano poprzednią wersję przez: 6:kdelibs-4.7.1-2.fc16.1.x86_64 (fedora)
             kdelibs4(x86-64) = 4.7.1-2.fc16.1
Można spróbować wykonać polecenie: rpm -Va --nofiles --nodigest

 

Kłopot w tym, że to polecenie nie działa -.- Co trzeba zrobić?

Share this post


Link to post
Share on other sites

Polecenie działa i robi dokładnie to co chcesz.

 

Releasever - Jesteś pewien, że na chcesz Fedorę 16? Tak oficjalnie to jeszcze nie wyszła i aktualizacja do bety jest problematyczna. Jeśli nie chcesz Fedory 16, to nie musisz tego dopisywać.

 

skip-broken - tego używa się w naprawdę podbramkowych sytuacjach, jeśli jesteś zupełnie pewien, że twórcy pakietów popsuli zależności, lub chcesz naprawić je później sam. Również nie musisz tego dopisywać.

Share this post


Link to post
Share on other sites

@Magnum44pl

 

Nie rozumiesz, że Fedora 16 nie jest najnowszą dostępną ale jest w Becie. Fedora oficjalnie wspiera GNOME dlatego najpierw robią paczki i zależności dla GNOME. A ty masz KDE.

 

Nie rozumiesz też co do ciebie pisze YUM.

Share this post


Link to post
Share on other sites

Problemem nie jest to, że nie ma paczek Kde dla Fedory, tyko to, że korzystasz z zewnętrznego repo kde 4.7. Prawdopodobnie problemy z upgradem do F16 będziesz miał nawet jak wyjdzie wydanie stabilne.

Share this post


Link to post
Share on other sites

Jeśli chcesz robić upgrade do F16, to lepszym rozwiązaniem będzie zainstalować np. LXDE, usunąć KDE (plik kde.repo też), zrobić upgrade i wtedy dociągnąć Kde z oficjalnego repo. Wydaje mi się, że tak będzie szybciej niż robić downgrade do dostępnego w F15 KDE 4.6, tylko po to żeby za chwilę robić upgrade systemu.

Do przeprowadzenia upgradu nie jest potrzebne żadne środowisko graficzne, wystarczy konsola.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...