Jump to content
8xxa_FC

Google Earth - Problem Z Błędem ./Libgoogleearth_Free.So - Rozwiązany?

Recommended Posts

Google Earth przewinal sie przez kilka watków, moze komus sie przyda.

jezell w crashlogu znajduje sie

"

./libgoogleearth_free.so(+0x1e9cfb)[0xf7570cfb]

./libgoogleearth_free.so(+0x1e9f43)[0xf7570f43]

"

to powinno pomóc usuniecie

 

/etc/fonts/conf.d/65-fonts-persian.conf

 

dla osób nie uzywajacych perskiego nie powinno to stanowic jakiegos problemu.

 

jaki zwiazek ma Google z perskim - nie mam pojecia. ale to pomaga :)

 

zródlem powyzszej tajemnej wiedzy - productforums.google.com

 

watek do zamkniecia?

Share this post


Link to post
Share on other sites

Ja mam podobny problem, po zainstalowaniu (PackageKit) uruchamiam program google-earth z terminala i mam komunikat że do logu .googleearth/crashlogs/crashlog-52837608.txt został zapisany problem.

Nie pomogło usunięcie konfiguracji perskiego.

Share this post


Link to post
Share on other sites

Crash log wygląda tak:

/usr/local/bin/googleearth: /opt/google-earth/googleearth-bin: /lib/ld-lsb.so.3: bad ELF interpreter: No such file or directory
/usr/local/bin/googleearth: linia 18: /opt/google-earth/googleearth-bin: Success
 

Tylko nie wiem gdzie jest ten sukces.

Share this post


Link to post
Share on other sites

Jak brakuje jakieś biblioteki to zawsze "dnf provides":

dnf provides /lib/ld-lsb.so.3

Pokazuje że ten plik znajduje się w paczce "redhat-lsb-core". Musisz tylko zdecydować czy standardowe x86_64 czy i686.

Share this post


Link to post
Share on other sites

Jak brakuje jakieś biblioteki to zawsze "dnf provides":

dnf provides /lib/ld-lsb.so.3
Pokazuje że ten plik znajduje się w paczce "redhat-lsb-core". Musisz tylko zdecydować czy standardowe x86_64 czy i686.

 

To jest dosyć zabawne, bo Chrome ma podobnie. Redhat-lsb-core ma ze 20 perlowych zaleśności. :) Nie mam pojęcia, czemu to jest Googlowi potrzebne.

Share this post


Link to post
Share on other sites

Pomogła instalacja:

dnf install -y redhat-lsb-core-4.1-33.fc25.i686

Ale nie di końca bo teraz jest kolejny problem, ale muszę przestudiować crash-log.

Fatal error in __driConfigOptions line 1, column 0: out of memory.
Google Earth has caught signal 6.

 

We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data have been written
 to this text file:

    /home/user/.googleearth/crashlogs/crashlog-58efc678.txt

Teraz znowu coś marudzi:

Major Version 6
Minor Version 0
Build Number 0003
Build Date May 17 2011
Build Time 00:40:40
OS Type 3
OS Major Version 4
OS Minor Version 10
OS Build Version 10
OS Patch Version 0
Crash Signal 6
Crash Time 1492537276
Up Time 1,03269

Stacktrace from glibc:
./libgoogleearth_free.so(+0xab953)[0xf7654953]
./libgoogleearth_free.so(+0xabad3)[0xf7654ad3]
linux-gate.so.1(__kernel_sigreturn+0x0)[0xf76d7ca0]
[0x0]

Znalazłem w tutaj https://bbs.archlinux.org/viewtopic.php?id=161677

informację że

Good Job @hotvic that fixed it for me....GE7 not only works but it
works well. Better than ever before for me on Arch.
everyone else; the font issues are passe' now and have been fixed.
               sudo mv ~/.drirc ~/.drirc.sav

ale gdzie szukać pliku drirc tego nie wiem.

 

 

 

Edited by Rysio
nowe wieści

Share this post


Link to post
Share on other sites

Już się wyjaśniło skąd te problemy. Otóż miałem google-earth zainstalowane z repozytoriów google-earth-repo o czym już nawet zapomniałem.

Potem zainstalowałem wersję 64bit pobraną stąd https://www.google.com/earth/download/ge/agree.html

lecz błąd nadal się pojawiał. Odinstalowałem więc pakiet rpm -e google-earth i zainstalowałem pobrany z tego samego miejsca pakiet w wersji 32 bit wraz z zależnościami.
Błąd nadal się pojawiał tak jak wcześniej, dopiero po odinstalowaniu google-earth w wersji 32 bit spróbowałem uruchomić program w wierszu poleceń i ku mojemu zaskoczeniu

ten nadal próbował się uruchomić i  to dało do myślenia.

znalazłem gdzie siedzi oprogramowanie poprzez whereis google-earth

posprzątałem ręcznie w tych miejscach które zostały wylistowane powyższym poleceniem i zainstalowałem ponownie pakiet rpm w wersji 64bit

pobrany z https://www.google.com/earth/download/ge/agree.html

teraz już wszystko działa prawidłowo.

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...