Jump to content
Sign in to follow this  
dansci

Nowy Użytkownik Samby Nie Może Się Zalogować

Recommended Posts

Cześć,

 

zainstalowałem Sambę i skonfigurowałem na tyle, że mogę się zalogować z innego laptopa (MacOS) korzystając z mojego głównego, podstawowego konta użytkownika - daniel. Konfiguracja wygląda tak:

 

[root@localhost ~]# testparm 
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[serverusers]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
	server string = Serwer Samba w wersji %v
	log file = /var/log/samba/log.%m
	max log size = 50
	idmap config * : backend = tdb
	cups options = raw

[serverusers]
	comment = Użytkownicy serwera
	path = /home/daniel/Udostepnianie
	valid users = @serverusers
	force group = serverusers
	read only = No
	create mask = 0660
	directory mask = 0771

Katalog /home/daniel/Udostepnianie został utworzony w taki sposób:

 

mkdir -p /home/daniel/Udostepnianie
chown -R root:serverusers /home/daniel/Udostepnianie
chmod -R ug+rwx,o+rx-w /home/daniel/Udostepnianie
 

Swojego użytkownika dodałem do klientów samby poprzez:

 

smbpasswd -a daniel
 

 

Następnie chciałem dodać możliwość zalogowania innym użytkownikiem. Stworzyłem go w systemie i dodałem do Samby przez:

 

useradd ktos -m -G serverusers
smbpasswd -a ktos
 

 

Problem pojawia się przy logowaniu. Na użytkownika "daniel" loguję się z MacBooka normalnie, a dla użytkownika "ktos" dostaję informację przy logowaniu, że nie mam uprawnień.

 

W związku z tym proszę o pomoc.

 

PS. I jeszcze co do konfiguracji powiązanej z Sambą to w Zaprze Systemu zaznaczyłem jako zaufane samba i samba-client.

 

Pozdrawiam,

Daniel

Share this post


Link to post
Share on other sites

Zajrzyj do /var/log/samba i sprawdź/wklej co wypluwa, dla danego hosta/ip.

 

Swoją drogą, udostępnienie jest w Twoim katalogu domowym i tu może być kwestia uprawnień.

Selinux włączony?

Share this post


Link to post
Share on other sites

Pliki z logami były o dziwo puste.

Ale faktycznie jak zmieniłem katalog na jeden poziom wyżej (/home/Udostepnianie) to działa.

 

Teraz w sumie chciałbym, aby ci dwaj użytkownicy mieli pełny dostęp do przekazywanych plików i katalogów. Ostatecznie znalazłem rozwiązanie:

 

force directory mode = 2770
force create mode = 2770
 

I w sumie wydaje się działać tak jak chcę. Dla mojego użytkownika mogę wrzucać pliki do udostępnianego folderu po zamontowaniu go przez Sambę i wtedy jest ok. Jednak kopiowanie plików bezpośrednio do tego udostępnianego folderu w menedżerze plików sprawia, że po zdalnym podłączeniu z innego hosta można je tylko czytać. Da się tak zrobić, żeby w takiej sytuacji też był pełny dostęp?

 

SELinuxa za bardzo jeszcze nie rozumiem. W pliku /etc/selinux/config ustawiłem na razie SELINUX=disabled, aczkolwiek poprzez GUI Zapora systemu musiałem zaznaczyć samba i samb-client, żeby się połączyć.

Share this post


Link to post
Share on other sites

Znaczy nie ma dostępu w trakcie kopiowania, czy po skopiowaniu? Jak to drugie, to zainteresuj się SGIDem, wystarczy żeby działało, nadasz domyślną grupę dla nowotworzonych plików w folderze i będzie śmigać.

Share this post


Link to post
Share on other sites

Nie ma dostępu na zdalnym urządzeniu już po skopiowaniu. SGID pasuje jak ulał.

Dzięki wielkie za pomoc @JoleKK :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×