Jump to content
Blamage

Fedora 19 A Gpt

Recommended Posts

Witam,

 

mam problem z instalacją Fedory 19 na moim komputerze. Aktualnie posiadam na nim Minta i Win7 (64 bit). Wyciąg z fdiska wygląda tak:

Disk /dev/sda: 640.1 GB, 640135028736 bytes
głowic: 255, sektorów/ścieżkę: 63, cylindrów: 77825, w sumie sektorów: 1250263728
Jednostka = sektorów, czyli 1 * 512 = 512 bajtów
Rozmiar sektora (logiczny/fizyczny) w bajtach: 512 / 4096
Rozmiar we/wy (minimalny/optymalny) w bajtach: 4096 / 4096
Identyfikator dysku: 0x000ed5f5

Urządzenie Rozruch   Początek      Koniec   Bloków   ID  System
/dev/sda1            2048   600000511   299999232   83  Linux
/dev/sda2   *   610000896   610205695      102400    7  HPFS/NTFS/exFAT
/dev/sda3       610205696   662634495    26214400    7  HPFS/NTFS/exFAT
/dev/sda4       662634496  1250260991   293813248    f  W95 Rozsz. (LBA)
/dev/sda5       662636544  1040545791   188954624    7  HPFS/NTFS/exFAT

Za ostatnią partycją NTFS (przeznaczonej na dane pod Windowsem) mam 100 GB wolnego miejsca, na którym chciałam zainstalować Fedorę. Po zbootowaniu z usb na początku wszystko wygląda świetnie, język, godzina, klawiatura, no i przychodzi pora na partycjonowanie dysku. Automatyczna próba kończy się niepowodzeniem (dowiaduję się, że nie mam wystarczającej ilości miejsca. Do wyboru mam odzyskiwane miejsca lub ręczne partycjonowanie. Na początku wybrałam tę drugą opcję. Stworzyłam partycję ext3, punkt montowania, wiadomo. Niestety instalator poinformował mnie, że nie udało się stworzyć partycji z powodu braku "etykiety typu gpt". Oznaczało to dla mnie kłopoty, wszak mój dysk nie był gpt... Poszperałam w google i trafiłam na wzmiankę, że muszę utworzyć partycję bootbios. Stworzyłam, nic nie pomogło. Błąd nadal ten sam. Automatyczne próby partycjonowania umierają jedna za drugą. Postanowiłam więc wybrać opcję odyskiwania miejsca i zmniejszyć sda1. Niestety, uporczywy błąd pozostał i tu rodzi się moje pytanie:

Czy w bezmiarze mojej głupoty próbowałam zainstalować system na dysku który nie jest gpt i muszę naprawdę dokonać konwersji czy może przyczyna mojego problemu leży gdzie indziej?

 

Pozdrawiam,

Aleksandra.

Share this post


Link to post
Share on other sites

Hej,

 

Najprawdopodobniej twój problem wynika z tego, że komputer startuje w trybie UEFI.

Możesz to sprawdzić wpisując w terminalu:

dmesg | grep efi

Jeżeli pokaże się kilkanaście linijek to znaczy, że system uruchomiony został w trybie UEFI.

Więcej o tym problemie możesz poczytać tutaj.

Share this post


Link to post
Share on other sites

Cutując co trafniejsze fragmenty z linka powyżej:

 

 

Fedora 19's installer effectively requires that native UEFI installations be performed to a disk with the 'gpt' format

 

 

In any case, if you attempt to do a native UEFI install of Fedora 19 such that the EFI system partition will reside on an ms-dos labelled disk, this will fail.

 

You are likely get an error of the form you have not created a bootloader stage1 target device, possibly with the note that the volume backing the EFI system partition must have one of the following disklabel types: gpt. You may also observe unusual behaviour on the Reclaim space screen, if you use it in your installation attempt.

 

 

If you wish to do a native UEFI installation of Fedora 19, it must be to a gpt-labelled disk, or you must configure your installation such that all existing partitions on the disk on which the EFI system partition will reside will be deleted

 

 

Note that it is not possible to change the label format of a disk in a non-destructive way: it requires a complete re-format.

 

Ale na pocieszenie:

 

 

For Fedora 20, we intend to revise the installer to handle this situation in a better way. We apologize for any inconvenience it causes.

 

 

Możesz spróbować:

 

 

As a workaround, you can append "noefi" to the kernel boot options in the GRUB menu.

 

As for some laptops, there is an option in BIOS to set make it use Legacy mode instead of uefi, which makes it accept disks that aren't gpt-labelled (i.e some Lenovo models).

 

 

 

 

Krótko mówiąc, jeśli masz nowy sprzęt już na UEFI, to stary typ partycji odchodzi w zapomnienie, i używa się tu już rozkładu partycji GPT (na starszych sprzętach, które są sprzed ery UEFI, istniał stary podział na 4 partycje podstawowe, reszta tylko rozszerzone a bootloader lądował w MBR. W GPT znika problem tylko 4 partycji podstawowych, a informacje o systemie miast do MBR, lądują na dodatkowych partycjach /boot/efi.

 

Inne starsze distra czy Windows czasem się przepchną, lecz Fedora jeśli posiadamy UEFI z tego co sam odczułem, jest restrykcyjna pod tym względem i czasem bez reformatu do gpt, instalator nie ruszy dalej (i w sumie nic dziwnego, działa zgodnie z ideą UEFI).

 

Na pocieszenie formatujesz w tablicy partycji gpt raz, a potem zapominasz o problemie, że kiedykolwiek był, i cieszysz się z możliwości normalnego partycjonowania bez starych naleciałości w ograniczeniach partycji i bez kłopotu z dualbootem, że Windows zmazał GRUB bo wpierniczył swój bootloader do MBR i Linux już nie startuje (bo informacje nie lądują już w MBR ale na osobnych /boot/efi) :)

Share this post


Link to post
Share on other sites

Zaczelo sie ladnie i... zdechlo. Wybaczcie brak polskich znakow, pisze spod live'a Fedory, Konqueror jest po angielski.

 

Polecenie "dmesg | grep efi" dalo nastepujace rezultaty:

 

"[[email protected] ~]$ dmesg | grep efi

[ 1.496809] Asymmetric key parser 'pefile' registered

[ 2.461409] tsc: Refined TSC clocksource calibration: 1497.276 MHz"

 

czyli niezbyt wiele. Uruchomienie w trybie "noefi" zmienilo niewiele. Bez tego trybu Anaconda informowala mnie, ze na dysku jest 0,00 gb wolnego miejsca. W nim wprawdzie twierdzi ze jest 150 gb (czyli poprawnie) wolnego miejsca, jednak proba utworzenia jakiejkolwiek nowej partycji skutkuje komunikatem "not enough free space on disk". Zaczynam czuc sie jak w czeskim filmie...

 

Dodam ze probowalam przy obydwu konfiguracjach BIOS-u (UEFI BOOT enabled/disabled) i efekt ten sam. Widze ze chyba nic z tego, coz, pozostaje czekac na Fedore 20 albo zamordowac inne OS'y...

Share this post


Link to post
Share on other sites

Szybka konwersja - zainstaluj program gparted jak nie masz. Potem go uruchom, kliknij Urządzenie --> Utwórz tablicę partycji, dajesz gpt, potem format. Niemniej zniszczy to wszystkie dane z całego dysku, bo dysk jest formatowany do nowego układu, także zrób kopię danych jeśli musisz. Niemniej po tym, nie doświadczysz już problemów z gpt czy brakiem wolnego miejsca - ustalasz instalację jak chcesz. Błąd o braku wolnego miejsca to jeden z błędów, kiedy mimo wszystkie chce się wcisnąć instalację przy uefi bez gpt. Jeśli naprawdę chcesz, przekonwertuj partycje do gpt - to nie tylko chodzi o Linuksa także nie obwiniaj czasem jakich to problemów Linux nie ma, Windows również w uefi potrzebuje gpt i czasem krzyczy o niemożliwości zainstalowania się bez układu gpt (z błędem o partycji poza układem gpt).

Niejeden raz sam walczyłem z tym i próbowałem wciskać, to Windows 7/8, to Fedorę i wiecznie problemy z brakiem wolnego miejsca i gpt. W końcu zirytowałem się trzasnąłem pełną konwersję do gpt (wymóg UEFI, porzucenie MBR) i od tego momentu instaluję co chcę, jak chcę i w jakim układzie partycji tego nie wymyślę.

Share this post


Link to post
Share on other sites

Niestety - technologia UEFI postawiła na dyski w tablicy partycji GPT, może to i lepiej - czasem w starej metodzie tylko 4 partycje podstawowe były nieco kulą u nogi, szczególnie przy dual-boocie (chcieli odciąć się i słusznie od przeszłości, skoro robią nową technologię i następców tradycyjnego BIOS, ciężko aby trzymać się starych, ograniczonych już technologii). Niestety nie istnieje możliwość bezstratnej zmiany tablicy (tj. bez straty danych, musi być ich backup).

 

Jestem ciekaw, czy to zaradziło Twojemu problemowi (powinno). Czy teraz zainstalowałaś system bez problemu? Zarówno automat powinien teraz zadziałać jak i ręczne partycjonowanie - ważne jest tylko ustawienie /boot/efi w systemie plików efi boot partition bodaj, tego zabraknąć nie może, inaczej wiecznie będzie komunikat z wiadomością o jej braku.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...