Jump to content
Sign in to follow this  
tele

[Rozwiązane] [Solved] Wiedzmin 2

Recommended Posts

Mam problem z uruchomieniem wiedzimina 2 na Fedora 64bit

 

Po uruchomieniu 1 z plików w terminalu wypluwa


$ ./witcher2
./witcher2: error while loading shared libraries: libcurl-gnutls.so.4: cannot open shared object file: No such file or directory

Sęk w tym że nie mogę czegoś takiego znaleść w fedorze. :(

 

 

Edytowane

W folderze z grą ....  /LibrarySteam/Steam/SteamApps/common/the witcher 2/

był link  libcurl-gnutls.so.4 do libcurl.so.4

Skopiowałem bibiotekę z /usr/lib/libcurl.so.4.3.0  do folderu z grą i zmieniłem nazwę na libcurl.so.4 ,

heh gra teraz działa  :D .

 

Edytowane...

Za szybko się ucieszyłem, gra owszem działa , przyciski pomocy np. Tab , Esc działa , oglądanie się myszką

ale WSAD  i inne w tym  lewy i prawy myszka nie działają :(

gdy uruchamiam desktop-launcher jest tam opcja zmiany klawiszy  i co wejde tam,

wszystko świeci na żółto i jest wyczyszczone, klikniecie "resetowanie klawiszy" przywraca je tylko do momentu uruchomienia gry.

 

to co mi się rzuca w oczy

 

(configurator:21330): Gtk-WARNING **: Nie można odnaleźć modułu obsługującego motyw w module_path: "clearlooks",
 

$  ./witcher2
./witcher2: ./libcurl-gnutls.so.4: no version information available (required by ./witcher2)

 

Ale to raczej mi nic nie mówi jak naprawić lub wskazywało by na problem z klawiaturą,

no chyba ze ta biblioteka skopiowana ma cos wspólnego?

Share this post


Link to post
Share on other sites
$  yum provides libcurl-gnutls.so.4
Wczytane wtyczki: langpacks, refresh-packagekit
No matches found

Ponieważ systemy instaluje dość często, to wszystkie gry miałem

na osobnej partycji i najciekawsze jest to, że Steam pozwala na dodanie "Folder Biblioteki Steam" ,

 moim przypadku jest to /run/media/nazwa_uzytkownika/partycja/LibrarySteam/Steam

ta opcja jest np. w menu " Steam --> Ustawienia --> Pobieranie "

i pododaniu owej biblioteki do Steam można uruchomić owe gry nie zależnie od dystrybucji Linuxa.

   Wczoraj miałem Ubuntu 12.04 (nie mogłem znaleść jak to dodać)

ale mimo to, ręcznie uruchamiałem i też nie działa, bo brakuje w tej grze zależności, niestety

po ustawieniu paska menu systemu na klasyczny, aktualizacji systemu system zaczoł się sypać, ( komunikaty o awarii ), menadzer synaptic nie widział pakietów po dodaniu czeskiego repozytorium, domyślny menadzer ubuntu widiał tylko pierwszy, a następny znowu kicha,  po resecie kompa już nie mogłem się zalogować,

( haslo na bank było dobre, a wyświetlało że nie )

jakieś konto gość się pojawiło, ale tam nic nie mogłem zrobić to sobie dałem spokój.

W wolnym czasie jeszcze przetestuje z ubuntu 14.04.

 

Edytowane:

Jest mały krok do przodu, na Ubuntu 14.04 udało mi się zainstalować Steama

( z konsoli ) oraz dodać folder biblioteki, po restarcie Steam wykrył gry ( w tym takze wiedzmina ) na osobnej partycji. Uruchomiłem i działa , WSAD (chodzenie) także działa, tylko twarze świecą jak żarówki,

zaraz zerknę czy nie ma jakiegoś komunikatu w terminalu.

 

Edytowane:

W Ubuntu 14.04 w okienku startowym wiedzmina nie działa przycisk "Opcje",

dostaje od razu :

./configurator: error while loading shared libraries: libSDL2-2.0.so.0: cannot open shared object file: No such file or directory

Po zainstalowaniu owej zależności i próbie uruchomienia gry

./witcher2: error while loading shared libraries: libSDL2_image-2.0.so.0: cannot open shared object file: No such file or directory

Edytowane :

Dobra nie widze błędów już, a samej gry nie odpale z terminala, więc przez Steama spróbowałem jak na początku i Wiedzmin się skraszował/popsuł.

https://dl.dropboxusercontent.com/u/9286835/pliki/witcher2.Ubuntu.log

 

Edytowane :

Zresetowałem komputer i ze Steama w ubuntu Wiedzmin zaczął działać , pogrzebałem w opcjach...

wchodze do gry, wybrałem Arena, dalej skóra wszystkich postaci świeci jak żarówka i z taką zieloną poświatą . I jeszcze WSAD  przestał mi działać :blink:

A przy kazdym wyjściu z gry wita mnie error

https://dl.dropboxusercontent.com/u/9286835/pliki/badkrytyczny.witcher.log

 

To tak wygląda jakby winne za WSAD w obu systemach były ustawienia,

a za światło w Ubuntu sterowniki.

Share this post


Link to post
Share on other sites

System 64bit? Na Fedorze, trzeba doinstalować 32bitowe biblioteki. Wątek o steamie gdzieś leży w grach i chyba jest to opisane. Innych pomysłów nie mam, już jakiś czas nie korzystam ze steama na moim złomie.

Share this post


Link to post
Share on other sites

 

System 64bit? Na Fedorze, trzeba doinstalować 32bitowe biblioteki.

Zgaduję że chodzi o sterowniki by prawidłowo działały... ?

Jeśli tak, to mam zainstalowane na fedorze wszystkie pakiety do nvidia jak trzeba,

ponieważ np. dota2 mi ładnie śmiga :)

 

Edytowane :

Nawet nie wiedziałem że cdproject ma własne forum

http://forums.cdprojektred.com/threads/29958-Linux-issues-and-user-solutions

 

Edytowane :

Heh zmiana w ustawieniach (w pliku konfiguracyjnym)  "," na "." faktycznie naprawiła WSAD :D

( w moim przypadku ścieżka do pliku to

cd ~/.local/share/cdprojektred/witcher2/GameDocuments/"Witcher 2"/config/

~ to katalog domowy, a cudzysłowia dalem specjalnie żeby terminal nazwę folderu rozpoznał )

w Wiedzminie w fedorze,

teraz mogę grać...

 

Edytowane :

W Fedorze 20  przy wyjściu z gry także wyskakuje error,

https://dl.dropboxusercontent.com/u/9286835/pliki/Fedora20.%20error.log

ale ważne że gra działa :)

 

Błędy w grze :

 -  Przy pierwszej misji (nauka walki) po dostaniu się na arenę w pewnym momencie pisze żebyśmy wydali wszystkie talenty,

ale nie pisze, że trzeba także wykorzystać zdobyty "mutagen", dopiero po wykonaniu misji to chyba pisze,

ale nie jestem wstanie przeczytać, tak szybko znika napis.

 -  W pewnych miejscach lochu jest ciezko zgasić swiatło, a w innych swiatlo mozna zgasić patrzac na ziemie i nie mozna podniesc woreczka z orenami.

 

Edytowane:

W Ubuntu 14.04 jeszcze czegoś brakowało...

$ ./witcher2: error while loading shared libraries: libssh2.so.1: cannot open shared object file: No such file or directory

Share this post


Link to post
Share on other sites

Panowie, Wiesiek 2 jest kompletnie spartolony. Wybaczcie odsyłanie do innego portalu, ale przynajmniej jest po PL i naświetla sprawę. Aktualnie Wiesiek 2 jest schrzaniony i dobrze, że nie kupiłem wbrew promocji. Kto wie, na jakie bugi jeszcze się wpadnie :-/

 

Link: http://www.dobreprogramy.pl/Wiedzmin-2-na-Linuksa-gracze-placa-Valve-za-niedopracowany-niezoptymalizowany-produkt,News,54686.html

Share this post


Link to post
Share on other sites

Galeria zdjęć z gry wiedzmin pod fedorą 20 :D

https://www.dropbox.com/sh/yk6j2bw9c1h565c/AAAK5JVx4C9AWh7fGQM_8liqa

 

Edytowane:

Niestety gra narazie ma jeszcze 1 mankament,

w dalszej czesci gry nie tylko kraszuje się przy zakonczeniu gry, ale takze w trakcie powodując zamkniecie gry.

To troche przeszkadza w graniu.

 

Edytowane:

Jest juz pierwsza aktualizacja wiedzmina :D

 

Edytowane :

 

Ponieważ systemy instaluje dość często, to wszystkie gry miałem

na osobnej partycji i najciekawsze jest to, że Steam pozwala na dodanie "Folder Biblioteki Steam" ,

 moim przypadku jest to /run/media/nazwa_uzytkownika/partycja/LibrarySteam/Steam

ta opcja jest np. w menu " Steam --> Ustawienia --> Pobieranie "

 

Jako ze miewam czasem problem z dodaniem owej biblioteki to jeszcze dodam,

- musi to byc " Steam " folder

- niektore swiezo instalowane systemy przypisuja katalogowi na innej partycji inne uprawnienia,

i tutaj jest zonk, poniewaz nie wystarczy zmienic uprawnienia (jak nakierowuje komunikat bledu),

ale takze trzeba zmienic wlasciciela katalogu z root na nas i to by bylo tyle.

Share this post


Link to post
Share on other sites

Skończyła mi się cierpliwość, muszę pomarudzić trochę.

Stanąłem na głowie by wywalić 2-3 Kernele do tyłu i zrobić miejsce na stary "najnowszy" Kernel z linii 3.13 a dokładniej 3.13.10-200.

Powodem tego szaleństwa był fakt, że Catalysty działają na dzień dzisiejszy najdalej do tego właśnie Kernela (patrząc pod kątem paczek RPM rzecz jasna).

Myślę sobie "dobra, może Wiedźmin 2 z jakiegos dziwacznego powodu pisze w konsoli co inne a boli go co inne".

Jednak nie, dalej wypisuje to samo mimo kilkunasto dniowego już cudowania z libcurl:

./witcher2: /lib/libcurl.so.4: no version information available (required by ./witcher2)
Naruszenie ochrony pamięci (core dumped)

Jest jakiś sposób by pograć na Linuksie w ten słaby jak studencka herbata "port" Wiedźmina czy mam zrobić zadymę na skalę oby jak największą bezpośrednio u CDP Red?

Już sprawę Talisman Digital Edition mamy z nimi na pieńku to teraz dojdzie Wiedźmin 2...

 

EDIT #1

Aha byłbym zapomniał :P

Jak odpalałem go przez Steam to dostałem piękny crash error screen, w którym pytali co robiłem gdy to się stało no to ładnie im napisałem, że odpalałem grę...

Share this post


Link to post
Share on other sites

 

Jest jakiś sposób by pograć na Linuksie w ten słaby jak studencka herbata "port" Wiedźmina...

Nie wiem czy to kiedys przeczytasz, ale radzilbym przetestowac na OpenSuse,

bo sterowniki zainstalujesz wprost z przegladarki,

co do /lib/libcurl.so.4,

komenda

yum provides /lib/libcurl.so.4

mowi ze musisz miec zainstalowane

libcurl-7.32.0-11.fc20.i686

zeby miec /lib/libcurl.so.4 biblioteke.

      Widze ze jest aktualizacja,

wiec jesli w nowszej wersji nie bedzie to musisz bliblioteki o podobnych nazwach zlinkowac.

Co do gry , to krasze u mnie byly dosc czesto, zwlaszcza po aktualizacji, narazie gre usunelem,

jezeli zauwaze jakas poprawe

(jak zainstaluje nastepnym razem)

to dam znac, co do kraszow, to powinien Ci wyskoczyc komunikat czy chcesz zglosic blad,

ja tak mialem i z tej funkcji skorzystalem.

Share this post


Link to post
Share on other sites

Jasne, że przeczytam, dlaczego miałbym nie przeczytać? :P

 

Naturalnie, że mam zainstalowaną wersję i686, załamałem ręce jak się dowiedziałem, że wersja Linuksowa jest 32-bitowa...

Zaktualizowałem biblioteki, upewniłem się, że dowiązanie wciąż jest poprawne i istniejące:

 

[Kiiro@Ura-Server lib]$ ls libcurl*
libcurl.so  libcurl.so.4  libcurl.so.4.3.0

Mimo to błąd jest ciągle ten sam:

 

[Kiiro@Ura-Server the witcher 2]$ ./witcher2
./witcher2: /lib/libcurl.so.4: no version information available (required by ./witcher2)
Naruszenie ochrony pamięci (core dumped)

Miałem kiedyś OpenSuse na drugim PC, może to faktycznie czas, by go znowu tam zainstalować w miejsce OSXa, skoro już mu udowodniłem, że dam radę go zainstalować jak należy.

Niestety nie wyskakuje nic, jeden jedyny raz magicznie wyskoczył to wypełniłem jakże treściwie odpowiadając na pytanie kiedy nastąpił błąd, że przy starcie gry.

Jednakże nic się od tamtej pory nie zadziało, są zbyt zajęci Wiedźminem numero 3 by tracić czas na "margines użytkowników Linuksa" ;)

Share this post


Link to post
Share on other sites

Na pewno sa zajeci.

A propo sterownikow AMD

 

 

Ze strony mozna przeczytac:

http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst14-4LINReleaseNotes.aspx

 

            Red Hat Enterprise Linux Suite 6.4 and 6.5
            SUSE® Linux Enterprise 11 SP3
            openSUSE 13.1
            Ubuntu 12.04.3, 12.04.4 and 13.10

 

 

 


Resolved Issues:

Witcher 2: Resolves random lock-up seen when launching the application

 

 

Takze jakas nadzieja jest.

Share this post


Link to post
Share on other sites

Ciekawe, Red Hat ma wsparcie, OpenSuse ma wsparcie a Fedora magicznie nie...

Mam najnowsze sterowniki beta 14.6 rc1 czy jakośtak, więc raczej - z naciskiem na raczej - wina sterowników tutaj nie jest.

OpenSuse już zainstalowałem i lecę z pakietami masowo (w tym update, który się trochę dłuży), acz Wiedźmin 2 trochę waży więc na dzisiaj chyba nie będę miał wyników tej operacji :P

Share this post


Link to post
Share on other sites

Po kilku dniach mordowania się z samym OpenSuse (milion repozytoriów, jedyna "wada" tego distro).

Udało mi się doprowadzić do stanu, w którym Wiedźmin dalej nie działa, sypie o jeden błąd więcej niż Fedora i dalej niewiadomo co z tym fantem zrobić.

Oczywiście mam zainstalowane paczki od AMD (te z 384tego repozytorium fglrx), wszystkie paczki SDL 64 i 32 bitowe (główne, nie devel) libcurl 64 i 32 bitowy oczywiście zainstalowany.

Zaraz przekleję wyjście z konsoli bo muszę przelogować się do forum z drugiego PC.

 

EDIT #1

Prosto z konsoli jeszcze ciepłe ;)

 

 

Saito@Ura-Square:~/.local/share/Steam/SteamApps/common/the witcher 2> ./witcher2
./witcher2: /usr/lib/libcurl.so.4: no version information available (required by ./witcher2)
./witcher2: symbol lookup error: ./witcher2: undefined symbol: SDL_GetPrefPath

Share this post


Link to post
Share on other sites

Czyli to samo co wczesniej i w Fedorze

Wyzej ( w 1 poscie ) cos takiego robilem

był link  libcurl-gnutls.so.4 do libcurl.so.4

Skopiowałem bibiotekę z /usr/lib/libcurl.so.4.3.0  do folderu z grą i zmieniłem nazwę na libcurl.so.4 ,

heh gra teraz działa

 

Probowales tego?

( linki sa w grze albo w steam- nie pamietam, brakowalo tylko biblioteki )

Edytowane: chociaz moze raczej nie pomoze bo w PCLinuxOs mialem ten sam blad :(

 

Moze jeszcze ktorys z tych rozwiazan pomoze

http://steamcommunity.com/app/20920/discussions/0/522728269056298189/

 

 

Edytowane:

Haaaa ....

Mam ten sam problem pod PCLinuxOS uruchamiajac gre minetest zbudowanego w archu :wacko:

+ za stary glibc, ale tego juz nie skompiluje.

 

Jak testuje opcja strace -e open ,.minetest

to pokazuje mi ze jest zaraz po otwarciu pliku libpcre.so.1

open("/lib/libpcre.so.1", O_RDONLY|O_CLOEXEC) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0P\17\0\0004\0\0\0"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=440360, ...}) = 0
mmap2(NULL, 443380, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0xb3d03000
mmap2(0xb3d6f000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x6b) = 0xb3d6f000
close(3)                                = 0
writev(2, [{"./minetest", 10}, {": ", 2}, {"/usr/lib/libcurl.so.4", 21}, {": ", 2}, {"no version information available"..., 57}, {"\n", 1}], 6./minetest: /usr/lib/libcurl.so.4: no version information available (required by ./minetest)
) = 93

Bibioteke  libcurl.so.4 wczesniej wczytalo,

 libcurl.so.4 -> libcurl.so.4.3.0*

czyli nie jest to wina braku biblioteki.

 

Pokusze sie znowu o instalacje wiedzmina :D

 

 

Edytowane:

Dobra gra sie zainstalowala.

 

 

 

[.@localhost the witcher 2]$ ./witcher2
./witcher2: ./libcurl.so.4: no version information available (required by ./witcher2)
[s_API FAIL] SteamAPI_Init() failed; Sys_LoadModule failed to load: /home/gg/.steam/bin32/steamclient.so
[s_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.

Running Steam on fedora 20 64-bit
STEAM_RUNTIME is disabled by the user

 

Gra uruchomiona w ten sposob dziala.

Jeszcze sprobuje zzaktualizowac system.

 

Takze trzeba sie skupic na tym drugim Twoim bledzie

./witcher2: symbol lookup error: ./witcher2: undefined symbol: SDL_GetPrefPath

 

 

Zrobilem sobie liste pakietow z ktorymi mi to dzialalo

https://www.dropbox.com/s/y0tnjmanbnw71wf/lista_zainstalowanych_pakietow.txt

oraz liste uzywanych plikow przy pomocy strace ( ( comenda 2&> nazwa_pliku ) )

https://www.dropbox.com/s/3n5sini5h8iagrn/strace_steam.log.txt

https://www.dropbox.com/s/u69ljk13of0hehq/strace_witcher2.log.txt

 

( log zawiera takze info gdzie nie znalazlo, prosze sie tego nie czepiac :P  )

 

Edytowane:

 

Zrobilem aktualizacje systemu bez kernela i xorg i kmod

Wiedzin2 dalej mi dziala

 - nie wyskakuje juz okienko z kraszem przy wyjsciu z gry, aczkolwiek

po wybraniu opcji " Wroc do menu glownego" gra sie sama wylacza jakby sie popsula i nie dala o tym bledu.

 

 

Przetestuje jeszcze na OpenSuse 13.1 KDE cd-live.

 

Edytowane:

Mam problem ze stworzeniem bootujacego usb OpenSuse:

live-cd, dvd-live nie dzialaja z unetbootin

net-live z unetbootin dziala ale pyta sie o IP servera ktorego nie znam.

komenda dd tez nie dziala z live-cd i live-dvd.

Takze moze to pare dni potrwac az kupie plyte DVD, bo na CD to nawet live-cd sie nie zmiesci.

 

Edytowane:

Dobra ,

- instalacje OpenSuse 13.1 i aktualizacje systemu mam za soba

- steama dodalem klikajac w linku http://software.opensuse.org/package/steam

" openSUSE 13.1 " a potem piersza opcje

" games:tools   ...   i kliknelem       1 Click Instal " po prawej.

- Jeszcze musze jakos dodac Wiedzmina z innej partycji ktora instalowalem z Fedory.

Dobra w ustawieniach Steam zmienilem jezyk na Polski

w Steam --> Pobieranie --> Foldery bibioteki steam

dodalem sciezkie do katalogu "Steam" na innej partycji

/var/run/media/moja_nazwa_uzytkownika/nazwa_mojej_partycji/LibrarySteam/Steam/

 

-

" Direct3D 9 device initialization error ! "

 

No dobra nie istalowalem jeszcze sterownikow Nvidia, to zainstaluje.

Ale jeszcze zanim zainstaluje cos sprawdze:

./witcher2
./witcher2: error while loading shared libraries: libSDL2-2.0.so.0: cannot open shared object file: No such file or directory

Doinstalowalem:

libSDL2_2_0-0

libSDL2_gfx-1_0-0

libSDL2_image-2_0-0

libSDL2_mixer-2_0-0

./witcher2
./witcher2: ./libcurl.so.4: no version information available (required by ./witcher2)
[S_API FAIL] SteamAPI_Init() failed; Sys_LoadModule failed to load: /home/gg/.steam/bin32/steamclient.so
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.

No i ten sam graficzny komunikat z Direct3D, to jednak zainstaluje sterownik :D .

- Ehh :(  Ze sterownikiem Nvidia pod suse chyba jest cos nie tak

podczas reinstalacji KDE sie posypalo, reinstalowalem ponownie (poszlo to strasznie wolno)

uruchomilem Widzmina - Dziala, ale ma buga tego samego co w Ubuntu (swiecace twarze jak duch),

a instalowalem sterownik G02, sprobuje z G03.

 

Edytowane:

Instalacja G03 + jakies cos nviadia ktore bylo w yast + reset komputera ruszylo nvidia tak jak tego chcialem,

czyli glxinfo pokazalo ze mam, nvidia settings dziala

( glxinfo dziala dopiero po komendzie " sudo zypper install Mesa-demo-x " )

Uruchamiam ponownie gre, dziala ponownie ( tym razem lepiej - "brak duchow" )

Uruchamiam plik gry

./witcher2
./witcher2: ./libcurl.so.4: no version information available (required by ./witcher2)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.

Roznic nie widze, jedyne czego bym sie przyczepil to tego ze mi w dota2 guzik wyjscia z gry nie dziala (w gornym lewym rogu)
, znaczy dziala , ale dopiero za ktoryms razem ciaglego klikania w niego.

 

Takze nie wiem jak Ci pomoc :(

Ale radze sprobowac chociaz to SDL2 zainstalowac jak ja.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×