Jump to content
gaim

Gnome-Documents Nie Otwiera Plików .doc

Recommended Posts

Piszę do Was jako do grupy mocno siędzącej w Gnome. Program dokumenty wszystko ładnie wyświetla, ale nie chce otwierać plików .doc .docx mimo iż libreoffice jest zainstalowany

 

GO2oHQt.png

 

Używam Gnome 3.20.2 na Archu, cała grupa Gnome zainstalowana.

Share this post


Link to post
Share on other sites
Guest Leniwy

No co Pan powie a u mnie działa?

Jakieś logi? Wersja systemu? Więcej informacji?

Share this post


Link to post
Share on other sites

Używam Gnome 3.20.2 na Archu[...]

Sugerowałbym zapytać na forum Arch Linux. To co działa w Fedorze nie musi działać na AL. To nie jest tak, że Gnome to Gnome i tak samo działa na każdym Linuksie, tym bardziej, że w grę wchodzą zależności od LO.

Share this post


Link to post
Share on other sites

Dzięki. Nie jest to wielki problem, bo z poziomu menadżera plików po wyszukiwaniu wszystko się otwiera. Fajnie że Fedora nie ma z tym problemu, może kiedys się do niej przekonam.

Pozdrawiam.

Share this post


Link to post
Share on other sites

Sprawdź skojarzenia plików w plikach (mogą być dwa) mimeapps.list. Poza tym może być jakiś problem z kodowaniem w tym pliku *.doc. Wszystko działa w oparciu o standardy freedesktop.org więc środowisko graficzne nie ma nic do rzeczy.

 

 

xdg-open NAZWA.doc

 

Jaki będzie efekt?

Share this post


Link to post
Share on other sites

No to co ty tam masz? LibreOffice nie ciągnie Javy czy czym to chcesz otwierać tak w ogóle?

https://wiki.archlinux.org/index.php/java

 

Zobacz w ustawieniach libreoffice czy wykrywa Javę.

 

Po drugie - kodowanie pliku to inna bajka niż pisanie polskich znaków, na przykład:

[root@pclos ~]# file -bi /usr/local/bin/sysbackup
text/x-shellscript; charset=utf-8
Okej, java jest w opcjonalnych zależnościach (optdepends) - trzeba ją zainstalować.

 

 

optdepends=('java-runtime: adds java support'
            'java-environment: required by extension-wiki-publisher and extension-nlpsolver'

Share this post


Link to post
Share on other sites

Potrzeba javy żeby gnome-documets zintegrował się z libreoffice? To ciekawostka:) Javy, flasha nie instaluję, wywaliłem gnome-documets-wystarcza mi szukanie z poziomu nautilus. Dzięki @marcin82 za zangażowanie:)

Share this post


Link to post
Share on other sites

Gnome Documents to przecież tylko manager dokumentów. Jak widzisz - albo rybki albo akwarium :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×