psiwak

Dataexplorer, Uucp, Dialup, Jak To Pogodzić?

5 postów w tym temacie

Witam was,

mam nadzieję że dobrze trafiłem bo walczę z problemem od jakiegoś czasu i nie mogę go rozwiązać.

 

Od ponad roku (chyba) na starym laptopie IBM T60p mam zainstalowaną Fedorę 22, jako że oryginalny XP zamulił mi go tak że nie dało się pracować. Jest ok 12 letni komputer dostał nowe życie :)

Przechodzę do sedna.

Jestem "modelarzem" i do z czytywania logów z mojego radia używa się oprogramowania DataExplorer. Zainstalowałem je sobie, nie obyło się bez problemów ale zwyciężyłem, czytam logi smile.png. Pomyślałem że dobrze by było mieć możliwość zapisywania logów z ładowania akumulatorów (ładowarka podłaczona poprzez port USB do kompa).

 

 

Przechodzę do sedna

 

Aplikacja DataExplorer informuje po pierwszym uruchomieniu (program napisany w JAVA), że użytkownik ma być członkiem grupy uucp.

 

 

RXTXcomm uses serial port locking mechanism, the application user must be part of uucp group. Set permissions of /var/lock to root:uucp.

While facing problems with USB2Serial UART SiliconLabs cp210x refer to GNULinux_cp210x directory in download area.

 

Fedora nie ma tej grupy tylko dialout.

root@egon etc]# ls -l /dev/ttyS*
crw-rw----. 1 root dialout 4, 64 10-16 18:53 /dev/ttyS0
crw-rw----. 1 root dialout 4, 65 10-16 18:53 /dev/ttyS1

Pytanie jak dodać grupę uucp (stworzyłem ją) do dialout?

Lub inaczej jak ominąć/rozwiazać problem?

Uruchomienie aplikacji z konta root nie rozwiązuje problemu.

Nie wiem czy dobrze ale doinstalowałem jeszcze pakiet rxtx ale nie pomogło. Nie widzę cały czas w aplikacji portów do wyboru. Czego to może być wina? 

 

Pozdrawiam

Paweł

 
0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

 

To  tez zrobilem :( - bez efektu

[psiwak@egon ~]$ groups 
psiwak dialout uucp

A czy ta aplikacja w ogóle próbuje się dostać do portu? Odpal ją pod strace:

 strace -f -o dataexplorer.log dataexplorer

(czy jak tam się to odpala) i zajrzyj do logu, czy jest tam coś w stylu:

access("/dev/ttyS0")

albo

fopen("/dev/ttyS0")

Zajrzyj najlepiej na IRCa (#fedora-pl@freenode) któregoś wieczora to może spróbujemy coś online poradzić, bo tak najszybciej będzie.

Pozdrawiam,

Dominik

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Dzięki za pomoc,

Wyniki z strace póki co pokazuje ze nie było nawet próby dostępu - brak wyników dla ciągu "/dev/ttyS"

W miedzy czasie zaktualizowałem system do F25. Będę próbował jeszcze zwalczyć to :) Co do IRCa to wejdę zapewne :)

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Tylko zarejestrowani użytkownicy mogą dodawać komentarze

Dodaj konto

Załóż nowe konto. To bardzo proste!


Zarejestruj nowe konto

Zaloguj się

Posiadasz już konto? Zaloguj się tutaj.


Zaloguj się teraz