Jump to content
Sign in to follow this  
psiwak

Dataexplorer, Uucp, Dialup, Jak To Pogodzić?

Recommended Posts

Witam was,

mam nadzieję że dobrze trafiłem bo walczę z problemem od jakiegoś czasu i nie mogę go rozwiązać.

 

Od ponad roku (chyba) na starym laptopie IBM T60p mam zainstalowaną Fedorę 22, jako że oryginalny XP zamulił mi go tak że nie dało się pracować. Jest ok 12 letni komputer dostał nowe życie :)

Przechodzę do sedna.

Jestem "modelarzem" i do z czytywania logów z mojego radia używa się oprogramowania DataExplorer. Zainstalowałem je sobie, nie obyło się bez problemów ale zwyciężyłem, czytam logi smile.png. Pomyślałem że dobrze by było mieć możliwość zapisywania logów z ładowania akumulatorów (ładowarka podłaczona poprzez port USB do kompa).

 

 

Przechodzę do sedna

 

Aplikacja DataExplorer informuje po pierwszym uruchomieniu (program napisany w JAVA), że użytkownik ma być członkiem grupy uucp.

 

 

RXTXcomm uses serial port locking mechanism, the application user must be part of uucp group. Set permissions of /var/lock to root:uucp.

While facing problems with USB2Serial UART SiliconLabs cp210x refer to GNULinux_cp210x directory in download area.

 

Fedora nie ma tej grupy tylko dialout.

[email protected] etc]# ls -l /dev/ttyS*
crw-rw----. 1 root dialout 4, 64 10-16 18:53 /dev/ttyS0
crw-rw----. 1 root dialout 4, 65 10-16 18:53 /dev/ttyS1

Pytanie jak dodać grupę uucp (stworzyłem ją) do dialout?

Lub inaczej jak ominąć/rozwiazać problem?

Uruchomienie aplikacji z konta root nie rozwiązuje problemu.

Nie wiem czy dobrze ale doinstalowałem jeszcze pakiet rxtx ale nie pomogło. Nie widzę cały czas w aplikacji portów do wyboru. Czego to może być wina? 

 

Pozdrawiam

Paweł

 

Share this post


Link to post
Share on other sites

 

To  tez zrobilem :( - bez efektu

[[email protected] ~]$ groups 
psiwak dialout uucp

A czy ta aplikacja w ogóle próbuje się dostać do portu? Odpal ją pod strace:

 strace -f -o dataexplorer.log dataexplorer

(czy jak tam się to odpala) i zajrzyj do logu, czy jest tam coś w stylu:

access("/dev/ttyS0")

albo

fopen("/dev/ttyS0")

Zajrzyj najlepiej na IRCa (#[email protected]) któregoś wieczora to może spróbujemy coś online poradzić, bo tak najszybciej będzie.

Pozdrawiam,

Dominik

Share this post


Link to post
Share on other sites

Dzięki za pomoc,

Wyniki z strace póki co pokazuje ze nie było nawet próby dostępu - brak wyników dla ciągu "/dev/ttyS"

W miedzy czasie zaktualizowałem system do F25. Będę próbował jeszcze zwalczyć to :) Co do IRCa to wejdę zapewne :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...