Skocz do zawartości
zibi743

Najnowsza Aktualizacja Fedory

Recommended Posts

zibi743    0

Witam.

Najnowsza aktualizacja dla Fedory 25 powoduje problemy, nie można uruchomić Linuksa w trybie graficznym (aktualizowałem dnia 2.06.2017).

Najnowszy kernel-* to -4.11- ... Musiałem uruchomić Fedorę z poprzedniego jajka.

Problem dotyczył Plazmy, dostałem komunikat informujący o złej konfiguracji sterowników grafiki i o OpenGL 2

Przez jakiś czas nie będę robił aktualizacji, poczekam aż to poprawią odpowiedni Programiści;)

 

Pozdrawiam.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Fedoras    7

Trochę skąpo opisujesz problem.

#uname -a
Linux 4.11.3-200.fc25.x86_64 #1 SMP Thu May 25 19:03:07 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

U mnie: wayland / nouveau (nVidia) / Gnome 3.22.2 działają bez żadnego problemu. Dzisiejsza aktualizacja kernela niczego nie zmieniła.

Na szczęście Fedora to jeszcze nie Windows. Problemy jednej konfiguracji nie mają przełożenia na inne konfiguracje. Niektórzy mieli problemy z budowaniem driverów do nVidii jeszcze w jądrze 4. 10

https://devtalk.nvidia.com/default/topic/1011198/fedora-kernels-4-10-x-200-negativo17-nvidia-rpm-nvidia-driver-381-22-6-fail-x-server-doesn-t-start-/?offset=3

inni mają problem z budowaniem konkretnego modułu :

https://ask.fedoraproject.org/en/question/106187/kl-module-does-not-build-on-fedora-25-with-kernels-newer-than-4109-200fc25x86_64/

Myślisz, że Programiści wiedzą jaki jest Twój problem i pracują nad nim?

Pozdrawiam

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
zibi743    0

To w takim razie się mylę. Musi coś być z tą moją Plazmą, powoduje pewnie konflikt z sterownikiem NVidii.

Pozdrawiam

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
SeeM    84

Kilka razy też trafiłem na problemy na nowych kernelach, ale to jeszcze nie powód, żeby nie aktualizować systemu. :) To prawda, że zostają 3 najnowsze kernele, a reszta jest usuwana... domyślnie. Wystarczy poprawić odrobinę plik /etc/dnf/dnf.conf:

[main]
gpgcheck=1
installonly_limit=11
clean_requirements_on_remove=True

Ja tak zawsze robię na komputerach z nvidią. Licho nie śpi.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
zibi743    0

SeeM wielkie dzięki za ten post.

Po aktualizacji kernela wystąpił komunikat, że Plazma nie może zostać uruchomiona ponieważ nie może poprawnie korzystać z bibliotek OpenGL2 i żeby sprawdzić konfigurację sterowników NVidii (tak dokładnie tego nie podam bo piszę teraz na Windzie).

Uruchomię Fedorę na starszym jajku i wykonam wskazówki z Twojego posta. Albo na nowym kernelu i zrobię to w trybie tekstowym CTRL+Alt+F2 itd.:)

O, właśnie przed chwilą edytowałem plik

#sudo kwrite /etc/dnf/dnf.conf

Wygląda tak:

#cat /etc/dnf/dnf.conf

[main]
gpgcheck=1
installonly_limit=11
clean_requirements_on_remove=True

Dałem

#reboot

Jednak problem istnieje dalej.

Szukałem tych OpenGL2:

#rpm -qa | grep opengl

libglvnd-opengl-0.2.999-14.20170308git8e6e102.fc25.i686

Mam tylko to. Co zawiera te OpenGl2?

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Fedoras    7

Jeżeli nie masz przymusu stosowania sterowników nVidii (np. zarabiasz na zawodowym graniu w CS albo używasz kart z serii GTX 10**, albo innych egzotycznych), to rozważ nouveau. Tu masz tabele, które warto przeanalizować i podjąć decyzję:

https://nouveau.freedesktop.org/wiki/FeatureMatrix/

https://nouveau.freedesktop.org/wiki/CodeNames/

Własnościowe sterowniki nVidii nie nadążają za jądrem i za Fedorą. Zawsze będą problemy, a programiści z nVidii są bardziej zainteresowani sterownikami do windy niż do Linuksa.

W Fedorowym systemie Bodhi (testowanie paczek przed oznaczeniem jako stable i puszczeniem do produkcji) są pozytywne komentarze na temat Plasmy, ale z nouveau (https://bodhi.fedoraproject.org/updates/FEDORA-2017-6f06be3fe9

Nouveau używam od wielu lat i nie wiem, skąd u ludzi takie zacięcie do instalowania sterowników nVidii. Część musi, ale reszta?, może to moda albo niewiedza.

Pozdrawiam

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
zibi743    0

Miałem Noveau ale wolę NVidię ponieważ monitor nie męczy tak oczu....

Jeśli chodzi o ten kernel i grafikę to zawsze były jakieś konflikty czy niezgodności.

Kiedyś w końcu to "zgrają". Jestem ciekawy (tylko ciekawy:)) jak jest w komercyjnym Red Hacie....

Tam na pewno nie ma problemów.

Może KDE (nie Plazma) nie będzie sprawiać problemów.... Sam nie wiem

 

PS moja grafika to

NVidia GeForce GT220 ot taka biurówka

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
zibi743    0
Dnia 3.06.2017 o 19:02, Fedoras napisał:

Jeżeli nie masz przymusu stosowania sterowników nVidii (np. zarabiasz na zawodowym graniu w CS albo używasz kart z serii GTX 10**, albo innych egzotycznych), to rozważ nouveau. Tu masz tabele, które warto przeanalizować i podjąć decyzję:

https://nouveau.freedesktop.org/wiki/FeatureMatrix/

https://nouveau.freedesktop.org/wiki/CodeNames/

Własnościowe sterowniki nVidii nie nadążają za jądrem i za Fedorą. Zawsze będą problemy, a programiści z nVidii są bardziej zainteresowani sterownikami do windy niż do Linuksa.

W Fedorowym systemie Bodhi (testowanie paczek przed oznaczeniem jako stable i puszczeniem do produkcji) są pozytywne komentarze na temat Plasmy, ale z nouveau (https://bodhi.fedoraproject.org/updates/FEDORA-2017-6f06be3fe9

Nouveau używam od wielu lat i nie wiem, skąd u ludzi takie zacięcie do instalowania sterowników nVidii. Część musi, ale reszta?, może to moda albo niewiedza.

Pozdrawiam

Zawodowo nie gram dla zarobku ale stery NVidii zainstalowałem, żeby dzieciaki mogły pograć. Zawsze to jakaś akceleracja jest... Tak jak napisałem wcześniej, mam GeForce GT220. Czy to do egzotyków się zalicza to nie wiem, być może;).....

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
developer    2
Dnia 2.06.2017 o 22:34, zibi743 napisał:

To w takim razie się mylę. Musi coś być z tą moją Plazmą, powoduje pewnie konflikt z sterownikiem NVidii.

Pozdrawiam

nie mylisz się. Stery nVidii nigdy dobrze nie działały na KDE

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
zibi743    0

U mnie działały dobrze na poprzednich kernelach cały czas... Kiedy pojawił się kernel 4.11..... to nie da się uruchomić Plazmy (wina sterowników NVidii).

Interesuje mnie czy na noveau będą działać gry Maelstrom czy np. sławny Tax Racer... Właśnie w to grają dzieciaki.

Póki co to używam:

#uname -a

Linux host-*-.mm.pl 4.10.17-200.fc25.x86_64 #1 SMP Mon May 22 18:12:57 UTC 2017 x86_6
4 x86_64 x86_64 GNU/Linux

 

Pozdrawiam

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
zibi743    0
Dnia 3.06.2017 o 10:21, SeeM napisał:

Kilka razy też trafiłem na problemy na nowych kernelach, ale to jeszcze nie powód, żeby nie aktualizować systemu. :) To prawda, że zostają 3 najnowsze kernele, a reszta jest usuwana... domyślnie. Wystarczy poprawić odrobinę plik /etc/dnf/dnf.conf:

Przyszła mi jeszcze jedna myśl do głowy.

Może problemem jet zainstalowany składnik:

kmod-nvidia-340xx-4.10.15-200.fc25.x86_64-340.102-2.fc25.x86_64

czy pomogłaby jego zamiana na

akmod-nvidia-340xx-4.10.15-200.fc25.x86_64-340.102-2.fc25.x86_64 ?

Jest to w ogóle możliwe?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
zibi743    0

No właśnie:)

Mam nadzieję, że za to nie dostanę ostrzeżenia (tak długi post)
Okazało się, jak ktoś z Was pisał - już nie pamiętam Kto, że był problem z załadowaniem modułu nvidii.
Po aktualizacji do najnowszego kernela nie wiem dlaczego "zniknął" pakiet akmod-....

Jak wspomniałem mam kartę graficzną GeForce GT220.
Sterowniki do tej karty znajdują się w pakietach:

#pm -qa |grep nvidia
xorg-x11-drv-nvidia-340xx-kmodsrc-340.102-1.fc25.x86_64
kmod-nvidia-340xx-4.11.3-202.fc25.x86_64-340.102-3.fc25.x86_64
xorg-x11-drv-nvidia-340xx-libs-340.102-1.fc25.x86_64
akmod-nvidia-340xx-340.102-3.fc25.x86_64
xorg-x11-drv-nvidia-340xx-340.102-1.fc25.x86_64

Żeby rozwiązać problem uruchomienia KDE na najnowszym kernelu:

#uname -a
Linux host-*elk.mm.pl 4.11.3-202.fc25.x86_64 #1 SMP Mon Jun 5 16:38:21 UTC 2017 x86_64
x86_64 x86_64 GNU/Linux

Zrobiłem tak:
Odinstalowałem i zainstalowałem sterowniki NVidii ponownie:

Uruchomiłem ponownie komputer wybierając najnowszy kernel.

Gdy się uruchomił pojawiło się okno z informacją, że nie można uruchomić KDE Plazmy (problem z OpenGL2)
Dałem OK i za chwilę znów OK.

Nacisnąłem kombinację klawiszy Ctrl Alt F2 czasami dopiero F3 daje skutek.
Zalogowałem się.
Przełączyłem się na poziom uruchomienia 3

#telinit 3

(normalny poziom to 5 i na nim nie da się przeprowadzić tych operacji)

Odinstalowałem wszystko co było związane ze sterownikami grafiki:

W związku z tym, że mogę korzystać z polecenia sudo:

#sudo dnf erase *\nvidia\*

W innym przypadku zamiast sudo wpisuje się:

#su -c "dnf erase *\nvidia\*"

W przypadku sudo podaje się hasło do swego konta - nie roota

Następnie zainstalowałem sterowniki do nvidii z repozytorium:

#sudo dnf install akmod-nvidia-340xx (celowo dodałem przed nazwą pakietu literę a, oznacza ona że przy aktualizacjach systemu sterowniki do grafiki będą się automatycznie aktualizować. Pakiet bez litery a na początku jest pakietem "sztywnym" przeważnie działa tylko gdy nie aktualizujemy systemu:))

Jeżeli będzie taka potrzeba to jeszcze instalujemy jak nie to pomijamy ten krok:

#sudo dnf install xorg-x11-drv-nvidia-340xx

Żeby sprawdzić czy mamy ten pakiet po instalacji, piszemy:

#rpm -qa | grep nvidia

W moim przypadku wynik polecenia jest taki:

xorg-x11-drv-nvidia-340xx-kmodsrc-340.102-1.fc25.x86_64
kmod-nvidia-340xx-4.11.3-202.fc25.x86_64-340.102-3.fc25.x86_64
xorg-x11-drv-nvidia-340xx-libs-340.102-1.fc25.x86_64
akmod-nvidia-340xx-340.102-3.fc25.x86_64
xorg-x11-drv-nvidia-340xx-340.102-1.fc25.x86_64

Sterowniki są już zainstalowane.

Na wszelki wypadek daję:

#sudo dnf update

Po ewentualnej aktualizacji systemu przechodzę na poziom uruchomienia 5 (normalny)

#sudo telinit 5
#startx

U mnie np. pojawiło się u góry białe okinko z informacją o DBus. Nacisnąłem OK.
Potem znów na Ctrl Alt F2 czasami dopiero F3 daje skutek

Zalogowałem się na konto zwykłego użytkownika.

Następnie zresetowałem komputer:

#reboot

Po ponownym uruchomieniu wybrałem najnowszy kernel i KDE wystartowało jak ta lala:)

Sprawdziłem w konsoli jak wykrywa mój monitor:

#xrandr

Wynik polecenia jest taki:

Screen 0: minimum 8 x 8, current 1360 x 768, maximum 8192 x 8192
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected primary 1360x768+0+0 (normal left inverted right x axis y axis) 406mm x 229mm
1360x768 60.02*+
1280x768      59.87
1024x768      75.03    70.07    60.00
800x600       75.00    60.32
640x480       75.00    59.94
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)

To by było na tyle. Mam nadzieję, że Komuś to się przyda.

Pozdrawiam. [SOLVED]

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
zibi743    0

Witam Was.

Nie chcę zakładać nowego wątku bo problem

powrócił i skutecznie rozwiązałem go w identyczny sposób.

Tylko nie wiem dlaczego co jakiś czas po aktualizacjach systemu "sypie" mi się sterownik nvidii.

Moje środowisko to KDE Plazma. Czy jedynym sposobem jest zmiana środowiska?

Czytałem również na naszym Forum, że inne środowiska nie powodują takich problemów...

Jedyne co mi przychodzi do głowy to utworzyć plik zawierający polecenia przeinstalowania wszystkiego związanego z nvidią i jedną komendą wykonać polecenia w nim zawarte...

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Tylko zarejestrowani użytkownicy mogą dodawać komentarze

Dodaj konto

Załóż nowe konto. To bardzo proste!

Zarejestruj nowe konto

Zaloguj się

Posiadasz już konto? Zaloguj się tutaj.

Zaloguj się teraz

×