Skocz do zawartości
fredro

Pomijanie pakietu z konfliktami

Rekomendowane odpowiedzi

Witam, mam pewien problem z aktualizacją tego pakietu, jest tam opcja wymuszenia, ale nie wiem czy to czegoś nie popsuje?

sudo dnf update && sudo dnf autoremove && sudo dnf clean packages
Ostatnio sprawdzono ważność metadanych: 1:08:08 temu w dniu sob, 18 lis 2017, 16:42:31.
Rozwiązano zależności.

 Problem: package chromium-libs-62.0.3202.89-1.fc27.x86_64 requires chromium-libs-media(x86-64) >= 62, but none of the providers can be installed
  - package chromium-libs-media-freeworld-59.0.3071.109-5.fc27.x86_64 obsoletes chromium-libs-media provided by chromium-libs-media-62.0.3202.89-1.fc27.x86_64
  - cannot install both chromium-libs-media-freeworld-59.0.3071.109-5.fc27.x86_64 and chromium-libs-media-freeworld-62.0.3202.89-1.fc27.x86_64
  - cannot install the best update candidate for package chromium-libs-media-62.0.3202.89-1.fc27.x86_64
  - cannot install the best update candidate for package chromium-libs-62.0.3202.89-1.fc27.x86_64
================================================================================
 pakiet                        Arch.  Wersja               Repoz.         Rozm.
================================================================================
Pomijanie pakietów z konfliktami:
(dodanie „--best --allowerasing” do wiersza poleceń wymusi ich aktualizację):
 chromium-libs-media-freeworld x86_64 59.0.3071.109-5.fc27 rpmfusion-free 2.2 M
 chromium-libs-media-freeworld x86_64 62.0.3202.89-1.fc27  rpmfusion-free-updates
                                                                          2.3 M

Podsumowanie transakcji
================================================================================
Pominięcie  2 pakiety

Nie ma nic do zrobienia.
Ukończono.
Ostatnio sprawdzono ważność metadanych: 1:08:10 temu w dniu sob, 18 lis 2017, 16:42:31.
Rozwiązano zależności.
Nie ma nic do zrobienia.
Ukończono.
Usunięto 0 plików

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Fedora 27 jest jeszcze niestabilna, więc czemu się dziwisz?

Zrób to co zaleca komunikat 

(dodanie „--best --allowerasing” do wiersza poleceń wymusi ich aktualizację)

i czekaj aż poprawią ;)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Dla zainteresowanych tematem: repozytorium Fedory już nadgoniło z odpowiednią wersją Chromium. Akurat kodeki do Chromium w odrobinkę innej wersji niż sam Chromium nie będą powodować problemów.

I nie trzeba już ręcznie uruchamiać autoremove. Dnf jest na tyle sprytny, że z automatu usuwa zależności po odinstalowaniu zbudowanych  na nich pakietów.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

×