Skocz do zawartości

Rekomendowane odpowiedzi

Witam.

Chciałbym zaktualizować system do najnowszej wersji lecz komendy

dnf upgrade

od jakiegoś czasu nic mi już nie aktualizują, czy to znaczy że nie ma już wsparcia do wersji jaką posiadam?

Linux Fedora-PC 4.13.16-100.fc25.x86_64 #1 SMP Mon Nov 27 19:52:46 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Fedora wspiera 2 wydania wstecz od najnowszego. Mamy F28. F25 nie jest wspierana od 12.12.2017 → https://fedoraproject.org/wiki/End_of_life

Możesz spróbować aktualizacji do F28. https://fedoraproject.org/wiki/DNF_system_upgrade Nie wiem jak to jest teraz, ale kiedyś zalecano aktualizację nie więcej niż o dwa wydania na raz. Czyli w Twoim wypadku F25→F27 i potem F27→F28. 

Jednak poczekaj, aż ktoś potwierdzi to co napisałem, bo może da się F25→F28 od razu. Tak czy inaczej zrobiłbym backup przed taką akcją. Przynajmniej tych najważniejszych dla Ciebie rzeczy.

  • Upvote 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Dzięki, udał sie upgrade do 27 lecz do 28 mam już problem i nie mogę sobie z nim poradzić...

Linux Fedora-PC 4.16.13-200.fc27.x86_64 #1 SMP Wed May 30 15:03:53 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
[root@Fedora-PC wlprzemek]# dnf system-upgrade download --refresh --releasever=28
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Fedora 28 - x86_64 - Updates                              3.6 MB/s |  16 MB     00:04    
Ostatnio sprawdzono ważność metadanych: 0:00:00 temu w dniu nie, 10 cze 2018, 10:02:37.
Błąd: 
 Problem 1: package gphpedit-0.9.98-0.11.RC1.fc24.x86_64 requires libjavascriptcoregtk-1.0.so.0()(64bit), but none of the providers can be installed
  - gnucash-2.6.21-1.fc27.x86_64 does not belong to a distupgrade repository
  - problem with installed package gphpedit-0.9.98-0.11.RC1.fc24.x86_64
 Problem 2: nss-pem-1.0.3-6.fc27.i686 has inferior architecture
  - nss-pem-1.0.3-6.fc27.x86_64 does not belong to a distupgrade repository
  - problem with installed package nss-pem-1.0.3-6.fc27.i686

i niestety nie mogę przeprowadzić upgrade

[root@Fedora-PC wlprzemek]# dnf system-upgrade reboot
Błąd: system nie jest gotowy na aktualizację

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Odinstaluj chwilowo dwa kłopotliwe pakiety: gphpedi oraz nss-pem. Jeżeli dnf będzie protestować, usuwając zależne od nich pakiety, wówczas zrób to klasycznie:

rpm -e --nodeps gphpedi nss-pem

Zainstalujesz je sobie już na nowej Fedorze po restarcie.

  • Upvote 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

THX udało się :D chyba tylko dlaczego cały czas pokazuje mi się...

Linux Fedora-PC 4.16.13-200.fc27.x86_64 #1 SMP Wed May 30 15:03:53 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

...

[root@Fedora-PC wlprzemek]# dnf system-upgrade download --refresh --releasever=28
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: t
Błąd: Parametr „--releasever” wymaga wartości wyższej niż wersja obecnego systemu.

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

sprawdź czy na pewno zainstalował się kernel 28. 

rpm -qa kernel

Jeśli tak, to może trzeba w menu gruba wybrać odpowiedni kernel albo wygenerować menu od nowa. W systemie bez EFI:

grub2-mkconfig -o /boot/grub2/grub.cfg

a jeśli masz EFI to 

grub2-mkconfig /boot/efi/EFI/fedora/grub.cfg

  • Upvote 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Cytuj

sprawdź czy na pewno zainstalował się kernel 28. 

 


rpm -qa kernel
[root@Fedora-PC wlprzemek]# rpm -qa kernel
kernel-4.16.13-200.fc27.x86_64
kernel-4.16.14-300.fc28.x86_64
kernel-4.13.16-100.fc25.x86_64

lecz żadna z tych komend poniżej nic nie zmienia, nie mogę przy starcie wybrać werasji wyższej jak 27 bo jej po prostu tam nie ma (ma również Windows 10 na dysku, więc komendę z EUFI zastosowałem)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

ok po tej komendzie zadziałało ;)

grub2-mkconfig -o /boot/grub2/grub.cfg

Dzięki za wyrozumiałość i pomoc ;P

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Kontynuując temat związany z aktualizacją, natknąłem się z kolejnym problemem, który nie występywał wcześniej (przed upgradem) tzn problem z wifi, gdy włączam kompa(laptop) to net od razu się łączy, lecz gdy uśpię po zamknięciu "klapy"  to po wybudzeniu nie chce się w ogóle połaczyć z wifi :(, nie pomaga wyłączenie i włączenie wifi przyciskiem w laptopie ani wpisywanie ponownie hasła - czym to może być spowodowane??

Screenshot_20180619_203614.png

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Miałem podobny kłopot z Mint 18.3. Pokaż co pokazuje

rfkill list all

po otwarciu klapy?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
[root@Fedora-PC wlprzemek]# rfkill list all
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: dell-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: no
2: dell-bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no

W ogóle przywłączaniu pokazują mi się w konsoli jakieś błędy... jaka komenda jest do wylistowania tego?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jak tak miałem kiedyś z broadcomem i pomagało bezceremonioalne ubicie networkmanagera. Nie tyle była to wina samego NM, co sterowników.

systemctl restart NetworkManager

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Niestety to nic nie pomaga... jakieś inne pomysły na uporanie się z tym wifi?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

×