Skocz do zawartości
lesiuk

Fedora 28 i "zniknięcie" interfejsu wifi

Rekomendowane odpowiedzi

Witam wszystkich.

Mam taki problem z f28: zaistalowałem ją na dysku.  Dodałem repo fusion, aktualizacja, ok. Wszystko poprzez wifi. Po ponownym uruchomieniu w NM nie znalazłem sekcji "sieci bezprzewodowe" Dodanie sieci poprzez "zarządzanie sieciami" nie daje żadnego efektu. Poszperałem trochę po sprzęcie, bo pomyślałem że może coś siadło w sprzęcie, ale w listingach karta jest widoczna, ale nie ma przypisanej nazwy interfejsu. Jak to uruchomić?

Poniżej w pliku podaję wynki poleceń. (nie wiem jak to zamieścić inaczej, żeby post nie miał ponad strony długości ;) ).

Jeżeli gdzieś było to opisane, to poproszę o podpowiedź bo jakoś wujek G.. nic mi nie podpowiedział.

listing

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli aktualizowałeś kernel to stary powinieneś mieć nadal do wyboru. Uruchom ze starszego jądra. W nowszym możesz nie mieć sterowników do tej karty.

Trudno mi sobie wyobrazić jak to wygląda, że karta jest wyświetlana ale bez przypisanego interfejsu.
 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Dzięki za podpowiedź, faktycznie chyba nie ma sterownika. Tylko modprobe daje taką odpowiedź:

modprobe -a iwl*
modprobe: WARNING: Module iwl* not found in directory /lib/modules/4.16.3-301.fc28.x86_64

tylko że ja w /lib/modules mam:

4.18.11-200.fc28.x86_64  4.18.12-200.fc28.x86_64  4.18.9-200.fc28.x86_64

jest jakiś sposób jak zmienić to ustawienie/folder wyszukiwania?

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
3 godziny temu, lesiuk napisał:

modprobe -a iwl*

W ten sposób nie załadujesz modułu, musisz podać pełną nazwę.

 

3 godziny temu, lesiuk napisał:

modprobe: WARNING: Module iwl* not found in directory /lib/modules/4.16.3-301.fc28.x86_64 

tylko że ja w /lib/modules mam:

4.18.11-200.fc28.x86_64  4.18.12-200.fc28.x86_64  4.18.9-200.fc28.x86_64

Jeżeli uruchomiłeś system na starym kernelu to modprobe tam szuka.

Zobacz czy polecenie wyświetla interfejs wifi

nmcli device show

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

To "modprobe" to była raczej taka nieudolna próba wyświetlenia załadowanych modułów intela.

Sprawdziłem podpowiedzi z wystartowaniem systemu w grubie. Faktycznie start następował z jajka oznaczonego jako failsafe. Po wybraniu innego NetworkManager zobaczył wifi. Czyli w zasadzie problem rozwiązany. Jednak w tej chwili powstał taki problem że, w grubie mam wypisane jajka z oznaczeniami 4.18.7; 4.18.8, a w /lib/modules mam katalogi 4.18.11-200.fc28.x86_64  4.18.12-200.fc28.x86_64  4.18.9-200.fc28.x86_64, a więc chyba takie jajka.

Ponadto w grubie jako domyślny ładuje się system z jakimś trybem failsafe.

I teraz pytanie: jak to ustawić żeby domyślnie ładowało się najnowsze jajko. Czy też tak ma być i za każdym razem trzeba grzebać w menu gruba?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Godzinę temu, lesiuk napisał:

To "modprobe" to była raczej taka nieudolna próba wyświetlenia załadowanych modułów intela.

Do tego służy lsmod

1 godzinę temu, lesiuk napisał:

I teraz pytanie: jak to ustawić żeby domyślnie ładowało się najnowsze jajko. Czy też tak ma być i za każdym razem trzeba grzebać w menu gruba?

Domyślnie powinno ładować Ci się najnowsze jądro, chyba, że coś zmieniałeś w grubie. Co wyświetla polecenie:

 cat /etc/default/grub

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Oto on:

cat /etc/default/grub
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="resume=UUID=b7ebcc08-469c-4fc0-8867-9edbbde6e44b rhgb quiet"
GRUB_DISABLE_RECOVERY="true"

Niestety nic mi to nie mówi.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Wygląda, że nic nie było zmieniane, więc nie mam pomysłu dlaczego nie startuje Ci z najnowszego jądra.

Co zwraca polecenie:

grub2-editenv list

Jeżeli w menu grub pierwsza pozycja to najnowsze jądro to powinno pomóc polecenie

grub2-set-default 0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
grub2-editenv list
saved_entry=Fedora (4.18.12-200.fc28.x86_64) 28 (Twenty Eight)

Ale to chyba nie ma znaczenia. Po fedorze zainstalowałem debiana i chciałem aby pozostał pierwszym systemem - dałem mu zainstalować gruba.

Czyli ustawienia czyta spod debiana. Pójście na skróty nie popłaca. Wygląda na to że problem po tej stronie rozwiązany.

Dziękuję bardzo za pomoc.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

×