Jump to content
grafi81

F29 Brother dcp 145 skaner nie działa mimo wykonania instrukcji

Recommended Posts

https://support.brother.com/g/s/id/linux/en/before.html?c=us_ot&lang=en&redirect=on#101

Podpunkty dla fedory wykonane co do joty

/etc/udev/rules.d/65-libsane.rules

Pakiety zainstalowane via rpm  -ihv  --nodeps

dodano odpowiednie wpisy

selinux.cfg premissive mod

restart

Nie działa.

=========================

Usunąłem wszystko

instalacja skryptem ze strony brothera

utworzone

65-brother-libsane-type1-inst.rules  65-libsane.rules

ostrzeżenie: Skrypt %post(brscan-skey-0.2.4-1.x86_64) się nie powiódł, stan wyjścia 1
ls: nie ma dostępu do '/etc/udev/rules.d/*.rules': No such file or directory

Co do Diabła instalowałem to to na Debianach Ubuntach Fedorah z Fedorą 28 włącznie.

Zdażały się zgrzyty przez 20 minut ale nie przez 3 dni

Share this post


Link to post
Share on other sites
W dniu 1.01.2019 o 19:52, grafi81 napisał:

No nie do końca. Pod linkiem, który podałeś, na samej górze jest link (List of the evaluated distributions and Brother products) do strony urządzeń Brothera i wersji dystrybucji linuksa na których ich oprogramowanie powinno działać. Nie ma nic nowszego od Fedory 20.

Też kiedyś naciąłem się na oprogramowanie dostarczane przez producenta urządzenia, które rzekomo pracuje pod Linuksem. Owszem pracowało tylko na bibliotekach, których już dawno nie było.

Tak dla wszystkich na forum - jeśli chodzi o skanery, to wybór skanera pod linuksa należy rozpocząć od strony http://www.sane-project.org/ a dopiero potem zaglądać do sklepów.

Share this post


Link to post
Share on other sites
13 godzin temu, Fedoras napisał:

No nie do końca. Pod linkiem, który podałeś, na samej górze jest link (List of the evaluated distributions and Brother products) do strony urządzeń Brothera i wersji dystrybucji linuksa na których ich oprogramowanie powinno działać. Nie ma nic nowszego od Fedory 20.

Też kiedyś naciąłem się na oprogramowanie dostarczane przez producenta urządzenia, które rzekomo pracuje pod Linuksem. Owszem pracowało tylko na bibliotekach, których już dawno nie było.

Tak dla wszystkich na forum - jeśli chodzi o skanery, to wybór skanera pod linuksa należy rozpocząć od strony http://www.sane-project.org/ a dopiero potem zaglądać do sklepów.

Ok Ok ciężko się nie zgodzić z tym co piszesz, natomiast nie ma problemu na debianach centosach i ubuntach, ubuntu chyba do wersji 12 wspierane , draństwa nadaj działają.
Za diabła nie zmienie drukarki bo jest dobra. Postaram się to jakoś obejść przy pomocy , że tak powiem wiedzy i zasobów własnych jak i waszej pomocy.
Jeżeli mi się tylko uda podam tutaj pełne rozwiązanie w wraz z moją platformą sprzętową

Share this post


Link to post
Share on other sites

selinux permissive mode

mkdir /var/spool/lpd/dcp145c

dnf i nstall sane-backend s sane-backen ds-libs sane-backends-daemon

dnf install csh or tcsh
dnf install glibc.i686
dnf install cups
dnf install xsane
dnf install psutils
dnf install policycoreutils-python

vi  /etc/sane.d/dll.conf  wywalamy wszystko poza brother[234]

ln -s /etc/init.d/cups /etc/init.d/lpd

mkdir -p -v  /opt/brother/scanner/brscan-skey

W razie czego tworzymy jak coś istnieje to ok
mkdir  /etc/sane.d/
mkdir /usr/local/Brother/sane/
mkdir /usr/share/ppd/

na wszelki wypadek jeśli nie ma
groupadd lp
groupadd scanner

usermod -a -G examplegroup exampleusername
usermod -a -G lp username
usermod -a -G scanner username


kolejność instacji paczek

1) rpm -ihv --nodeps dcp145clpr-1.1.2-2.i386.rpm
2) rpm -ihv --nodeps dcp145ccupswrapper-1.1.2-2.i386.rpm

RESTART

3) rpm -ihv --nodeps brscan3-0.2.11-5.x86_64.rpm
4) rpm -ihv --nodeps brscan-skey-0.2.4-1.x86_64.rpm

vim 65-sane-backends.rules   
dopisujemy  na końcu  przed libsane rules end
#Brother DCP-145C
ATTRS{idVendor}=="04f9", ATTRS{idProduct}=="0206", ENV{libsane_matched}="yes"

wydano komendę zarówno jako root jak i user

sane-find-scanner | grep -i DC
found USB scanner (vendor=0x04f9 [Brother], product=0x0206 [DCP-145C]) at libusb:007:002
skanera nie ma

procedurę powtórzono 2x dla paczek 32 oraz 64 bit uprzednio czyszcząc system po poprzedniej instalacji

Zdaje się iż tego rzeczywiście nie idzie zainstalować pod F29.

Jednak gdyby ktoś miał jakiś pomysł...

 

 

Share this post


Link to post
Share on other sites

Tutaj jest jeszcze jakiś sposób dla Ubuntu (8)
https://askubuntu.com/questions/791556/brother-scanner-not-working-in-ubuntu-16-04-though-driver-installed
https://ubuntuforums.org/showthread.php?t=2321613&page=3

Problemem może też być stara wersja (_rpma_ → RPM-a) ORT, której oczekuje instalator. Ja bym jeszcze spróbował konwersji .deb do współczesnego .rpm, albo "ręcznie" porozkładał pliki do właściwych katalogów. Zazwyczaj może pomóc przekompilowanie źródeł, ale Brother nie udostępnia źródeł do skanera https://support.brother.com/g/b/downloadlist.aspx?c=pl&lang=pl&prod=dcp145c_eu_as&os=127&flang=English

 

Share this post


Link to post
Share on other sites

Panowie i Panie po tygodniu instalacji i deinstalacji z absolutnym brakiem powodzenia zgłupiałem

Ktoś coś rozumie

[kuba@localhost ~]$ brsaneconfig3 -d | grep -e 145
found USB scanner (vendor=0x04f9 [Brother], product=0x0206 [DCP-145C]) at libusb:007:003
ls: nie ma dostępu do '/proc/bus/usb': No such file or directory
cat: /proc/bus/usb/devices: No such file or directory
0x0206,14,2,"DCP-145C"
MODEL:"DCP-145C",ID:0x4f9:0x206,TYPE:14,2,RE:0xffff,WE:0xffff CM:,,
 58 "DCP-145C"
[kuba@localhost ~]$ 

[root@localhost bus]# ls
input  pci
[root@localhost bus]#

To mi śmierdzi problemami modółów jądra odpowiedzialnymi za montowanie urządzeń usb i to tylko podejrzenie

ps o konwersji deb nie pomyślałem zwykle nie działa ale co mi tam

Wynik dokleję do tego posta, chyba, że nie będę już mógł edytować posta

 

 

 

Share this post


Link to post
Share on other sites

Naiwne sugestie:

1) Miałem problemy z instalacją oprogramowania do starszego sprzętu Brothera DCP7060 (laserowe urządzenie wielofunkcyjne). Po pierwsze - tylko Linux 64 bity.

2) Instalator Brothera musiałem uruchamiać dwukrotnie.

3) Sterowniki zainstalowały się i zadziałały u mnie poprawnie na platformie Fedora28 i  Mint18.

4) Skaner - bez problemu działa "proste skanowanie" i to mi wystarcza.

5) Druk jest obsługiwany ze wszystkimi bajerami - auto dwustronny itd.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×