Jump to content
Toni

System się aktualizuje ale po uruchomieniu informuje o nie zainstalowanej aktualizacji

Recommended Posts

System się aktualizuje ale po uruchomieniu informuje o nie zainstalowanej aktualizacji (o niepowodzeniu instalacji aktualizacji) . Tak jest od kilku aktualizacji, nie wiem czy nie od początku. Niedawno zainstalowałem system na czysto. Niestety kliknąłem już powiadomienie i nie jestem w stanie przytoczyć o co chodziło. Po instalacji aktualizacji system nie widzi żadnej nowej, jakby wszystko przebiegło pomyślnie. Używałem też komendy dnf update --refresh -y i też odpowiedź jest że nie ma nic do zrobienia.

Czy mogę czuć się bezpiecznie, czy to fałszywy alarm? Mój system jest w pełni zaktualizowany?

Share this post


Link to post
Share on other sites

Sprawdź w historii dnfa.

dnf history
dnf history info [numer]

Zacznij od najwyższych numerów i sprawdź, która aktualizacja nie do końca się udała.

Share this post


Link to post
Share on other sites

Szkoda, że nie masz tego komunikatu. Ale jeżeli dnf twierdzi, że wszystko jest ok, to wszystko jest ok.

Jeżeli używasz jakiegoś graficznego programu do aktualizacji (nie wiem jakiego desktopu używasz), to być może on ma jakieś błędy lub ma problem z aktualizacją z innych systemów pakietów być może wspiera flatpack lub snap, tak tylko strzelam na ślepo.

Generalnie nie ma się o co martwić.

Share this post


Link to post
Share on other sites

Podaj wynik polecenia hostnamectl, być może tylko kernel się nie zaktualizował.

Share this post


Link to post
Share on other sites

Oto przykładowy komunikat informujący, że aktualizacje nie zakończyły się powodzeniem.

Zrzut ekranu z 2020-03-08 17-54-45.png
 

DNF informuje że nie dało się zainstalować czegoś do Chromium - może stąd ten komunikat?

[[email protected] ~]# dnf update --refresh -y
Fedora Modular 31 - x86_64                       30 kB/s |  23 kB     00:00     
Fedora Modular 31 - x86_64 - Updates                                                                                                                                             34 kB/s |  22 kB     00:00     
Fedora 31 - x86_64 - Updates                                                                                                                                                     34 kB/s |  21 kB     00:00     
Fedora 31 - x86_64                                                                                                                                                               12 kB/s |  24 kB     00:01     
RPM Fusion for Fedora 31 - Free - Updates                                                                                                                                        37 kB/s | 9.3 kB     00:00     
RPM Fusion for Fedora 31 - Free                                                                                                                                                  52 kB/s |  10 kB     00:00     
RPM Fusion for Fedora 31 - Nonfree - Updates                                                                                                                                     48 kB/s |  10 kB     00:00     
RPM Fusion for Fedora 31 - Nonfree                                                                                                                                               53 kB/s |  10 kB     00:00     
Rozwiązano zależności.
 
 Problem 1: package chromium-libs-media-freeworld-77.0.3865.90-2.fc31.x86_64 requires chromium-libs(x86-64) = 77.0.3865.90-2.fc31, but none of the providers can be installed
  - cannot install both chromium-libs-79.0.3945.130-1.fc31.x86_64 and chromium-libs-77.0.3865.90-2.fc31.x86_64
  - cannot install both chromium-libs-77.0.3865.90-2.fc31.x86_64 and chromium-libs-79.0.3945.130-1.fc31.x86_64
  - cannot install the best update candidate for package chromium-libs-media-freeworld-77.0.3865.90-2.fc31.x86_64
  - cannot install the best update candidate for package chromium-libs-77.0.3865.90-2.fc31.x86_64
 Problem 2: problem with installed package chromium-libs-media-freeworld-77.0.3865.90-2.fc31.x86_64
  - package chromium-libs-media-freeworld-77.0.3865.90-2.fc31.x86_64 requires chromium-libs-media(x86-64) = 77.0.3865.90-2.fc31, but none of the providers can be installed
  - cannot install both chromium-libs-media-79.0.3945.130-1.fc31.x86_64 and chromium-libs-media-77.0.3865.90-2.fc31.x86_64
  - cannot install both chromium-libs-media-77.0.3865.90-2.fc31.x86_64 and chromium-libs-media-79.0.3945.130-1.fc31.x86_64
  - cannot install the best update candidate for package chromium-libs-media-77.0.3865.90-2.fc31.x86_64
================================================================================================================================================================================================================
 Pakiet                                                  Architektura                               Wersja                                                    Repozytorium                                Rozm.
================================================================================================================================================================================================================
Pomijanie sprzecznych pakietów:
(dodanie „--best --allowerasing” do wiersza poleceń wymusi ich aktualizację):
 chromium-libs                                           x86_64                                     79.0.3945.130-1.fc31                                      updates                                      80 M
 chromium-libs-media                                     x86_64                                     79.0.3945.130-1.fc31                                      updates                                     2.3 M
 
Podsumowanie transakcji
================================================================================================================================================================================================================
Pominięcie  2 pakiety
 
Nie ma nic do zrobienia.
Ukończono.
[[email protected] ~]#  

 

Share this post


Link to post
Share on other sites

Repozytoria fedota-updates oraz rpmfusion-updates czasami się "rozjeżdżają". Albo ekipa rpmfusion za wcześnie wypuści aktualizacje, albo za późno. Może paczkujący chromium-libs-media-freeworld używa testowych repo Fedory i u niego działa? Trudno powiedzieć. Poczekaj dzień, dwa i będzie działać. Kombinowanie z ''allowerasing", "bext" oraz "exclude" może się skończyć niedziałającym chromium.

W tym przypadku sprawa jest prosta: w repozytorium Fedory pojawił się Chromium 79, a rpmfusion nie nadążył. Możesz odinstalować pakiet chromium-libs-media-freeworld i aktualizacja się uda. Doinstalujesz go sobie kiedyś indziej, kiedy będzie już w stosownej wersji. Zaktualizowanego pakietu chromium-libs-media-freeworld nie ma też w rpmfusion-free-updates-testing, co może wskazywać, że trochę jeszcze na to poczekamy.

Share this post


Link to post
Share on other sites

Czyli ten komunikat iż aktualizacja się nie powiodła dotyczy Chromium?  Już od dawna, od poprzedniej wersji systemu gdy wpisuje w dnf aktualizację to wywala że pomija kilka pakietów Chromium ale do tej pory nie powodowało to chyba (z tego co pamiętam) systemowego komunikatu o nieudanej aktualizacji. Mam rozumieć, że chodzi o to?

Share this post


Link to post
Share on other sites

Skąd się wziął "systemowy" komunikat o aktualizacji, to nie powiem. Nie używam gnome-software, ani automatów do aktualizacji Fedory. I nie jest to wina Chromium, tylko pakietu chromium-libs-media-freeworld-77.0.3865.90-2.

Share this post


Link to post
Share on other sites
[[email protected] ~]# dnf history
Ident. | Wiersz poleceń           | Data i czas      | Działania      | Zmien. 
-------------------------------------------------------------------------------
    22 |                          | 2020-03-09 15:46 | Upgrade        |   24   
    21 |                          | 2020-03-08 17:53 | Upgrade        |    2   
    20 |                          | 2020-03-08 17:38 | Install        |   13   
    19 |                          | 2020-03-07 13:10 | Upgrade        |    4   
    18 |                          | 2020-03-05 19:18 | Install        |    5   
    17 |                          | 2020-03-05 18:35 | Upgrade        |   24   
    16 |                          | 2020-03-05 18:29 | I, U           |   50   
    15 | -y install chromium-libs | 2020-02-25 11:19 | D, I           |    5 EE
    14 |                          | 2020-02-25 11:15 | Install        |    5   
    13 |                          | 2020-02-23 16:32 | I, U           |  144   
    12 |                          | 2020-02-07 18:35 | I, U           |   28   
    11 |                          | 2020-02-05 19:51 | Upgrade        |    1   
    10 | update --refresh -y      | 2020-02-04 14:07 | I, U           |  157 EE
     9 |                          | 2020-01-27 19:51 | Upgrade        |   26   
     8 |                          | 2020-01-26 20:20 | Install        |   11   
     7 |                          | 2020-01-26 18:57 | Install        |   21   
     6 | install vlc              | 2020-01-26 18:53 | Install        |   65   
     5 | install https://download | 2020-01-26 18:52 | Install        |    1   
     4 | install https://download | 2020-01-26 18:51 | Install        |    1   
     3 |                          | 2020-01-26 18:37 | E, I, U        |  618   
     2 |                          | 2020-01-26 18:34 | Install        |    2   
     1 |                          | 2019-10-24 01:11 | Install        | 1664 EE
[[email protected] ~]# dnf history info [22]
Nie odnaleziono transakcji manipulującej pakietem „[22]”.
[[email protected] ~]# 

Wpisałem dnf history (jak radziłeś) ale chyba popełniłem jakiś błąd - co wpisałem źle?

Share this post


Link to post
Share on other sites

To sprawdź jeszcze

dnf history info 22

bo możliwe, że 22 to Twoja nieudana aktualizacja, więc cofanie jest niczego nie zmieni.

Share this post


Link to post
Share on other sites

Sprawdziłem 22 i 23 i chyba nic z tego nie wynika - wszędzie pisze że zaktualizowane (chyba, al ja się nie znam)

 

[[email protected] ~]# dnf history
Ident. | Wiersz poleceń           | Data i czas      | Działania      | Zmien. 
-------------------------------------------------------------------------------
    23 |                          | 2020-03-09 18:48 | Upgrade        |    2   
    22 |                          | 2020-03-09 15:46 | Upgrade        |   24   
    21 |                          | 2020-03-08 17:53 | Upgrade        |    2   
    20 |                          | 2020-03-08 17:38 | Install        |   13   
    19 |                          | 2020-03-07 13:10 | Upgrade        |    4   
    18 |                          | 2020-03-05 19:18 | Install        |    5   
    17 |                          | 2020-03-05 18:35 | Upgrade        |   24   
    16 |                          | 2020-03-05 18:29 | I, U           |   50   
    15 | -y install chromium-libs | 2020-02-25 11:19 | D, I           |    5 EE
    14 |                          | 2020-02-25 11:15 | Install        |    5   
    13 |                          | 2020-02-23 16:32 | I, U           |  144   
    12 |                          | 2020-02-07 18:35 | I, U           |   28   
    11 |                          | 2020-02-05 19:51 | Upgrade        |    1   
    10 | update --refresh -y      | 2020-02-04 14:07 | I, U           |  157 EE
     9 |                          | 2020-01-27 19:51 | Upgrade        |   26   
     8 |                          | 2020-01-26 20:20 | Install        |   11   
     7 |                          | 2020-01-26 18:57 | Install        |   21   
     6 | install vlc              | 2020-01-26 18:53 | Install        |   65   
     5 | install https://download | 2020-01-26 18:52 | Install        |    1   
     4 | install https://download | 2020-01-26 18:51 | Install        |    1   
     3 |                          | 2020-01-26 18:37 | E, I, U        |  618   
     2 |                          | 2020-01-26 18:34 | Install        |    2   
     1 |                          | 2019-10-24 01:11 | Install        | 1664 EE
[[email protected] ~]# dnf history info 22
Identyfikator transakcji   : 22
Czas rozpoczęcia           : pon, 9 mar 2020, 15:46:31
Rozpoczęcie bazy danych RPM: 1788:6ed153bd394fc2d7ecbb659999f4b7da4581f423
Czas ukończenia            : pon, 9 mar 2020, 15:46:42 (11 s)
Ukończenie bazy danych RPM : 1788:674961fd316b4357eb3db408bf1191734cfb9c70
Użytkownik                 : root <root>
Kod zwrotny                : Powodzenie
Releasever     : 
Wiersz poleceń : 
Zmienione pakiety:
    Upgrade  autocorr-en-1:6.3.5.2-1.fc31.noarch                  @updates
    Upgrade  autocorr-pl-1:6.3.5.2-1.fc31.noarch                  @updates
    Upgrade  libreoffice-calc-1:6.3.5.2-1.fc31.x86_64             @updates
    Upgrade  libreoffice-core-1:6.3.5.2-1.fc31.x86_64             @updates
    Upgrade  libreoffice-data-1:6.3.5.2-1.fc31.noarch             @updates
    Upgrade  libreoffice-draw-1:6.3.5.2-1.fc31.x86_64             @updates
    Upgrade  libreoffice-emailmerge-1:6.3.5.2-1.fc31.x86_64       @updates
    Upgrade  libreoffice-filters-1:6.3.5.2-1.fc31.x86_64          @updates
    Upgrade  libreoffice-graphicfilter-1:6.3.5.2-1.fc31.x86_64    @updates
    Upgrade  libreoffice-gtk3-1:6.3.5.2-1.fc31.x86_64             @updates
    Upgrade  libreoffice-help-en-1:6.3.5.2-1.fc31.x86_64          @updates
    Upgrade  libreoffice-help-pl-1:6.3.5.2-1.fc31.x86_64          @updates
    Upgrade  libreoffice-impress-1:6.3.5.2-1.fc31.x86_64          @updates
    Upgrade  libreoffice-langpack-en-1:6.3.5.2-1.fc31.x86_64      @updates
    Upgrade  libreoffice-langpack-pl-1:6.3.5.2-1.fc31.x86_64      @updates
    Upgrade  libreoffice-math-1:6.3.5.2-1.fc31.x86_64             @updates
    Upgrade  libreoffice-opensymbol-fonts-1:6.3.5.2-1.fc31.noarch @updates
    Upgrade  libreoffice-pdfimport-1:6.3.5.2-1.fc31.x86_64        @updates
    Upgrade  libreoffice-pyuno-1:6.3.5.2-1.fc31.x86_64            @updates
    Upgrade  libreoffice-ure-1:6.3.5.2-1.fc31.x86_64              @updates
    Upgrade  libreoffice-ure-common-1:6.3.5.2-1.fc31.noarch       @updates
    Upgrade  libreoffice-writer-1:6.3.5.2-1.fc31.x86_64           @updates
    Upgrade  libreoffice-x11-1:6.3.5.2-1.fc31.x86_64              @updates
    Upgrade  libreoffice-xsltfilter-1:6.3.5.2-1.fc31.x86_64       @updates
    Upgraded autocorr-en-1:6.3.4.2-2.fc31.noarch                  @@System
    Upgraded autocorr-pl-1:6.3.4.2-2.fc31.noarch                  @@System
    Upgraded libreoffice-calc-1:6.3.4.2-2.fc31.x86_64             @@System
    Upgraded libreoffice-core-1:6.3.4.2-2.fc31.x86_64             @@System
    Upgraded libreoffice-data-1:6.3.4.2-2.fc31.noarch             @@System
    Upgraded libreoffice-draw-1:6.3.4.2-2.fc31.x86_64             @@System
    Upgraded libreoffice-emailmerge-1:6.3.4.2-2.fc31.x86_64       @@System
    Upgraded libreoffice-filters-1:6.3.4.2-2.fc31.x86_64          @@System
    Upgraded libreoffice-graphicfilter-1:6.3.4.2-2.fc31.x86_64    @@System
    Upgraded libreoffice-gtk3-1:6.3.4.2-2.fc31.x86_64             @@System
    Upgraded libreoffice-help-en-1:6.3.4.2-2.fc31.x86_64          @@System
    Upgraded libreoffice-help-pl-1:6.3.4.2-2.fc31.x86_64          @@System
    Upgraded libreoffice-impress-1:6.3.4.2-2.fc31.x86_64          @@System
    Upgraded libreoffice-langpack-en-1:6.3.4.2-2.fc31.x86_64      @@System
    Upgraded libreoffice-langpack-pl-1:6.3.4.2-2.fc31.x86_64      @@System
    Upgraded libreoffice-math-1:6.3.4.2-2.fc31.x86_64             @@System
    Upgraded libreoffice-opensymbol-fonts-1:6.3.4.2-2.fc31.noarch @@System
    Upgraded libreoffice-pdfimport-1:6.3.4.2-2.fc31.x86_64        @@System
    Upgraded libreoffice-pyuno-1:6.3.4.2-2.fc31.x86_64            @@System
    Upgraded libreoffice-ure-1:6.3.4.2-2.fc31.x86_64              @@System
    Upgraded libreoffice-ure-common-1:6.3.4.2-2.fc31.noarch       @@System
    Upgraded libreoffice-writer-1:6.3.4.2-2.fc31.x86_64           @@System
    Upgraded libreoffice-x11-1:6.3.4.2-2.fc31.x86_64              @@System
    Upgraded libreoffice-xsltfilter-1:6.3.4.2-2.fc31.x86_64       @@System
[[email protected] ~]# dnf history info 23
Identyfikator transakcji   : 23
Czas rozpoczęcia           : pon, 9 mar 2020, 18:48:54
Rozpoczęcie bazy danych RPM: 1788:674961fd316b4357eb3db408bf1191734cfb9c70
Czas ukończenia            : pon, 9 mar 2020, 18:48:57 (3 s)
Ukończenie bazy danych RPM : 1788:fafee9c65824598e030fb24e9514801b54f22e2c
Użytkownik                 : root <root>
Kod zwrotny                : Powodzenie
Releasever     : 
Wiersz poleceń : 
Zmienione pakiety:
    Upgrade  vlc-1:3.0.9-33.fc31.x86_64      @rpmfusion-free-updates
    Upgrade  vlc-core-1:3.0.9-33.fc31.x86_64 @rpmfusion-free-updates
    Upgraded vlc-1:3.0.9-29.fc31.x86_64      @@System
    Upgraded vlc-core-1:3.0.9-29.fc31.x86_64 @@System
[[email protected] ~]# 

 

Share this post


Link to post
Share on other sites

Wygląda na to, że poza tym nieszczęsnych Chromium wszystko działa. Takie same aktualizacje ostatnio były i u mnie.

Share this post


Link to post
Share on other sites

Czy mógłbym rozwiać ostatnią wątpliwość? Otóż instalując oprogramowanie do skanera HP zapomniałem włączyć urządzenie i coś się pokopało. Naprawiałem to trochę chaotycznie, ściągnąłem jakiś skrypt ze stron HP? (nawet nie wiem czy to się tak nazywa) który chyba zawiesił system. W pewnym momencie jednak kreator instalacji wtyczki się uruchomił, zainstalowałem i mogę skanować. Może coś skopałem w tym systemie (wiem, to nie Windows ale..) ? Może coś się źle zainstalowało? W dziwny sposób łączę sobie w głowie 'nieudane' aktualizacje z tą sytuacją.  Można to jednoznacznie wykluczyć? Czy ten błąd po prostu wynika z czegoś innego, niezależnego od tego co narobiłem?

Share this post


Link to post
Share on other sites

Na 90% jest to niezależne. Z tego, co powyżej napisałeś, jest to standardowy konflikt zależności pakietów.

Ciekawostka: skanery to jedne z niewielu urządzeń, które można skutecznie zepsuć formwarem. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...