Jump to content
Sign in to follow this  
bartoszp1992

Nie mogę zbackupować niektórych paczek- zainstalowane poprawnie

Recommended Posts

Cześć,

zawsze robię sobie kopie paczek ręcznie. Pierwszy raz trafiłem na problem, gdzie paczki zainstalowały się w systemie, ale nie mogę ich pobrać. Oto, co zwraca terminal
 

[[email protected] libratbag]$ sudo dnf download g++ libudev-devel libevdev-devel glib2-devel json-glib-devel libunistring-devel check-devel valgrind swig python3-devel pygobject3 pygobject3-devel cairo-devel libxml-devel python3-evdev python3-lxml python3-flake8 --downloadonly --downloaddir=/home/bartosz/Pobrane/rpm2 --resolve --alldeps
Fedora Modular 30 - x86_64                      0.0  B/s |   0  B     00:00    
Failed to download metadata for repo 'fedora-modular'
Błąd: Failed to download metadata for repo 'fedora-modular'
[[email protected] libratbag]$ sudo dnf download g++ libudev-devel libevdev-devel glib2-devel json-glib-devel libunistring-devel check-devel valgrind swig python3-devel pygobject3 pygobject3-devel cairo-devel libxml-devel python3-evdev python3-lxml python3-flake8 --downloadonly --downloaddir=/home/bartosz/Pobrane/rpm2 --resolve --alldeps
Fedora Modular 30 - x86_64                       14 kB/s |  22 kB     00:01    
Fedora Modular 30 - x86_64 - Updates             23 kB/s |  21 kB     00:00    
Fedora 30 - x86_64 - Updates                     33 kB/s |  19 kB     00:00    
Fedora 30 - x86_64                               23 kB/s |  23 kB     00:00    
google-chrome                                   6.6 kB/s | 1.3 kB     00:00    
skype (stable)                                  4.8 kB/s | 2.9 kB     00:00    
Błąd podczas rozwiązywania pakietów:
    gcc-c++-9.2.1-1.fc30.x86_64
    gcc-c++-9.0.1-0.10.fc30.i686
    systemd-devel-241-12.git323cdf4.fc30.i686
    systemd-devel-241-12.git323cdf4.fc30.x86_64
    libevdev-devel-1.7.0-1.fc30.i686
    libevdev-devel-1.7.0-1.fc30.x86_64
    glib2-devel-2.60.7-2.fc30.i686
    glib2-devel-2.60.7-2.fc30.x86_64
    json-glib-devel-1.4.4-2.fc30.i686
    json-glib-devel-1.4.4-2.fc30.x86_64
    libunistring-devel-0.9.10-5.fc30.i686
    libunistring-devel-0.9.10-5.fc30.x86_64
    check-devel-0.12.0-4.fc30.i686
    check-devel-0.12.0-4.fc30.x86_64
    valgrind-1:3.15.0-9.fc30.i686
    valgrind-1:3.15.0-9.fc30.x86_64
    swig-3.0.12-25.fc30.x86_64
    python3-devel-3.7.6-1.fc30.i686
    python3-devel-3.7.6-1.fc30.x86_64
    python2-gobject-3.32.2-1.fc30.i686
    python2-gobject-3.32.2-1.fc30.x86_64
    pygobject3-devel-3.32.2-1.fc30.i686
    pygobject3-devel-3.32.2-1.fc30.x86_64
    cairo-devel-1.16.0-5.fc30.i686
    cairo-devel-1.16.0-5.fc30.x86_64
    libxml-devel-1:1.8.17-43.fc30.i686
    libxml-devel-1:1.8.17-43.fc30.x86_64
    python3-evdev-1.1.2-3.fc30.x86_64
    python3-lxml-4.2.5-2.fc30.x86_64
    python3-flake8-3.7.7-1.fc30.noarch

 Problem: gcc-9.0.1-0.10.fc30.i686 has inferior architecture
  - package gcc-c++-9.0.1-0.10.fc30.i686 requires gcc = 9.0.1-0.10.fc30, but none of the providers can be installed
  - cannot install both gcc-9.0.1-0.10.fc30.x86_64 and gcc-9.2.1-1.fc30.x86_64
  - package gcc-c++-9.2.1-1.fc30.x86_64 requires gcc = 9.2.1-1.fc30, but none of the providers can be installed
  - conflicting requests
[[email protected] libratbag]$ 

Czemu tak jest i jak to rozwiązać?

Share this post


Link to post
Share on other sites
50 minut temu, bartoszp1992 napisał:

Czemu tak jest i jak to rozwiązać?

Dlatego tak jest

50 minut temu, bartoszp1992 napisał:

Problem: gcc-9.0.1-0.10.fc30.i686 has inferior architecture - package gcc-c++-9.0.1-0.10.fc30.i686 requires gcc = 9.0.1-0.10.fc30, but none of the providers can be installed - cannot install both gcc-9.0.1-0.10.fc30.x86_64 and gcc-9.2.1-1.fc30.x86_64 - package gcc-c++-9.2.1-1.fc30.x86_64 requires gcc = 9.2.1-1.fc30, but none of the providers can be installed - conflicting requests

Te same pakiety, ale dla różnych architektur muszą być w tych samych wersjach. Spróbuj dodać przełącznik --refresh do polecenia dnf

Możesz też zawsze pobrać pakiety ręcznie z koji Tutaj wersja dla ciebie

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...