Jump to content

Recommended Posts

Cześć Wam

Od kilku miesięcy mam monitor LG GSM76FA Ultrawide. Monitor ten ma trzy wejścia: HDMI, DisplayPort i USB-C. Monitor jest podłączony do amplitunera przez port HDMI oraz do komputera za pomocą adaptera HDMI-->DisplayPort. Sygnał video przesyłany jest prawidłowo natomiast sygnał audio nie jest przesyłany mimo, że system prawidłowo rozpoznaje głośniki w monitorze.

Laptop to MSI-CR70 z wbudowanym HDMI. Na laptopie jest zainstalowana Fedora 31. Co ciekawe gdy wchodzę w ustawienia dźwięku i klikam w przyciski testujące głośnik lewy i prawy to nagle z głośników monitora słychać dźwięk "Front left" i "Front right". Na zrzucie ekranu zaznaczyłem o jakie przyciski chodzi.

Czy ktoś spotkał się z takim problemem? Jeśli tak, to jak go rozwiązać?

głośniki_test.png

Share this post


Link to post
Share on other sites

Na zdjęciu masz dwa profile i w tym drugim masz wybrany wyjście analogowe może musisz wybrać wyjście HDMI?

Share this post


Link to post
Share on other sites
17 godzin temu, sunrise napisał:

Na zdjęciu masz dwa profile i w tym drugim masz wybrany wyjście analogowe może musisz wybrać wyjście HDMI?

Akurat takiego screena zrobiłem. Jednak próbowałem wielu możliwych kombinacji i niestety nic nie pomaga.

Share this post


Link to post
Share on other sites

Podaj co zwraca polecenie

pacmd list-cards

pacmd list-sinks

pactl info

Jak wpiszesz polecenie pactl set-default-sink <Naciśnij TAB> to powinieneś mieć podpowiedź jakie masz dostępne wyjścia wpisz to które wskazuje na monitor. To powinno ustawić domyśle wyjście na monitor. Gdy zmieniasz wyjście i masz uruchomiony program, który odgrywa dźwięk to musisz go po zmianie wyjścia uruchomić ponownie.

Share this post


Link to post
Share on other sites

Dziekuje za odpowiedz. Ponizej informacje:

 

pacmd list-cards daje takie informacje:

2 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_00_03.0>
	driver: <module-alsa-card.c>
	owner module: 6
	properties:
		alsa.card = "0"
		alsa.card_name = "HDA Intel HDMI"
		alsa.long_card_name = "HDA Intel HDMI at 0xf7e14000 irq 32"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:03.0"
		sysfs.path = "/devices/pci0000:00/0000:00:03.0/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "0c0c"
		device.product.name = "Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		device.description = "Wbudowany dźwięk"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		output:hdmi-stereo: Wyjście Digital Stereo (HDMI) (priority 5900, available: no)
		output:hdmi-surround: Wyjście Digital Surround 5.1 (HDMI) (priority 800, available: no)
		output:hdmi-surround71: Wyjście Digital Surround 7.1 (HDMI) (priority 800, available: no)
		output:hdmi-stereo-extra1: Wyjście Digital Stereo (HDMI 2) (priority 5700, available: no)
		output:hdmi-surround-extra1: Wyjście Digital Surround 5.1 (HDMI 2) (priority 600, available: no)
		output:hdmi-surround71-extra1: Wyjście Digital Surround 7.1 (HDMI 2) (priority 600, available: no)
		output:hdmi-stereo-extra2: Wyjście Digital Stereo (HDMI 3) (priority 5700, available: unknown)
		output:hdmi-stereo-extra3: Wyjście Digital Stereo (HDMI 4) (priority 5700, available: no)
		output:hdmi-surround-extra3: Wyjście Digital Surround 5.1 (HDMI 4) (priority 600, available: no)
		output:hdmi-surround71-extra3: Wyjście Digital Surround 7.1 (HDMI 4) (priority 600, available: no)
		output:hdmi-stereo-extra4: Wyjście Digital Stereo (HDMI 5) (priority 5700, available: no)
		output:hdmi-surround-extra4: Wyjście Digital Surround 5.1 (HDMI 5) (priority 600, available: no)
		output:hdmi-surround71-extra4: Wyjście Digital Surround 7.1 (HDMI 5) (priority 600, available: no)
		off: Wyłączone (priority 0, available: unknown)
	active profile: <output:hdmi-stereo-extra2>
	sinks:
		alsa_output.pci-0000_00_03.0.hdmi-stereo-extra2/#2: Wbudowany dźwięk Digital Stereo (HDMI 3)
	sources:
		alsa_output.pci-0000_00_03.0.hdmi-stereo-extra2.monitor/#3: Monitor of Wbudowany dźwięk Digital Stereo (HDMI 3)
	ports:
		hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "video-display"
				device.product.name = "LG ULTRAWIDE"
		hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
    index: 1
	name: <alsa_card.pci-0000_00_1b.0>
	driver: <module-alsa-card.c>
	owner module: 7
	properties:
		alsa.card = "1"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7e10000 irq 33"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card1"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "8c20"
		device.product.name = "8 Series/C220 Series Chipset High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "1"
		device.description = "Wbudowany dźwięk"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		input:analog-stereo: Wejście Analogowe stereo (priority 65, available: unknown)
		output:analog-stereo: Wyjście Analogowe stereo (priority 6500, available: unknown)
		output:analog-stereo+input:analog-stereo: Analogowy dupleks stereo (priority 6565, available: unknown)
		off: Wyłączone (priority 0, available: unknown)
	active profile: <output:analog-stereo+input:analog-stereo>
	sinks:
		alsa_output.pci-0000_00_1b.0.analog-stereo/#1: Wbudowany dźwięk Analogowe stereo
	sources:
		alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#1: Monitor of Wbudowany dźwięk Analogowe stereo
		alsa_input.pci-0000_00_1b.0.analog-stereo/#2: Wbudowany dźwięk Analogowe stereo
	ports:
		analog-input-internal-mic: Wewnętrzny mikrofon (priority 8900, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-mic: Mikrofon (priority 8700, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-output-speaker: Głośniki (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Słuchawki (priority 9900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"

pacmd list-sinks daje takie informacje:

Cytuj

2 sink(s) available.
    index: 1
    name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: SUSPENDED
    suspend cause: IDLE
    priority: 9039
    volume: front-left: 38012 /  58% / -14,19 dB,   front-right: 38012 /  58% / -14,19 dB
            balance 0,00
    base volume: 65536 / 100% / 0,00 dB
    volume steps: 65537
    muted: no
    current latency: 0,00 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 1
    sample spec: s16le 2 k 44100 Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 0
    configured latency: 0,00 ms; range is 0,50 .. 2000,00 ms
    card: 1 <alsa_card.pci-0000_00_1b.0>
    module: 7
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "ALC269VB Analog"
        alsa.id = "ALC269VB Analog"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "1"
        alsa.card_name = "HDA Intel PCH"
        alsa.long_card_name = "HDA Intel PCH at 0xf7e10000 irq 33"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:1b.0"
        sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card1"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "8c20"
        device.product.name = "8 Series/C220 Series Chipset High Definition Audio Controller"
        device.form_factor = "internal"
        device.string = "front:1"
        device.buffering.buffer_size = "352800"
        device.buffering.fragment_size = "176400"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Analogowe stereo"
        device.description = "Wbudowany dźwięk Analogowe stereo"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        analog-output-speaker: Głośniki (priority 10000, latency offset 0 usec, available: unknown)
            properties:
                device.icon_name = "audio-speakers"
        analog-output-headphones: Słuchawki (priority 9900, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "audio-headphones"
    active port: <analog-output-speaker>
  * index: 2
    name: <alsa_output.pci-0000_00_03.0.hdmi-stereo-extra2>
    driver: <module-alsa-card.c>
    flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: SUSPENDED
    suspend cause: IDLE
    priority: 9030
    volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
            balance 0,00
    base volume: 65536 / 100% / 0,00 dB
    volume steps: 65537
    muted: no
    current latency: 0,00 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 3
    sample spec: s16le 2 k 44100 Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 0
    configured latency: 0,00 ms; range is 0,50 .. 1999,82 ms
    card: 0 <alsa_card.pci-0000_00_03.0>
    module: 6
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "HDMI 2"
        alsa.id = "HDMI 2"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "8"
        alsa.card = "0"
        alsa.card_name = "HDA Intel HDMI"
        alsa.long_card_name = "HDA Intel HDMI at 0xf7e14000 irq 32"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:03.0"
        sysfs.path = "/devices/pci0000:00/0000:00:03.0/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "0c0c"
        device.product.name = "Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller"
        device.form_factor = "internal"
        device.string = "hdmi:0,2"
        device.buffering.buffer_size = "352768"
        device.buffering.fragment_size = "176384"
        device.access_mode = "mmap+timer"
        device.profile.name = "hdmi-stereo-extra2"
        device.profile.description = "Digital Stereo (HDMI 3)"
        device.description = "Wbudowany dźwięk Digital Stereo (HDMI 3)"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: yes)
            properties:
                device.icon_name = "video-display"
                device.product.name = "LG ULTRAWIDE"
    active port: <hdmi-output-2>
 

pactl info daje takie informacje:

Cytuj

Ciąg serwera: /run/user/1000/pulse/native
Wersja protokołu biblioteki: 33
Wersja protokołu serwera: 33
Czy jest lokalny: tak
Indeks klienta: 26
Rozmiar kafla: 65472
Nazwa użytkownika: tomek
Nazwa komputera: fedora.localdomain
Nazwa serwera: pulseaudio
Wersja serwera: 13.99.1-rebootstrapped
Domyślne określenie próbki: s16le 2 k 44100 Hz
Domyślna mapa kanałów: front-left,front-right
Domyślny odpływ: alsa_output.pci-0000_00_03.0.hdmi-stereo-extra2
Domyślne źródło: alsa_input.pci-0000_00_1b.0.analog-stereo
Ciasteczko: 76a8:4c9d

 

Share this post


Link to post
Share on other sites

Wszystko wygląda ok.

Uruchom program pavucontrol (z pakietu o tej samej nazwie) i dowolny program odtwarzający muzykę lub film w pavucontrol powinin sie pokazać ten program razem z wskaźnikiem wysterowania, popatrz może tam coś wyklikasz.

Jeżeli możesz odłącz amplituner od monitora.

Share this post


Link to post
Share on other sites

Zainstalowalem pavucontrol, wlaczylem muzyke w VLC, muzyke na Youtube, pavucontrol pokazal mi, ze leci muzyka ale dzwieku w monitorze dalej nie ma. Amplituner jest odlaczony od monitora.

Share this post


Link to post
Share on other sites

Co zrobiłeś z wejściem audio PC (tak nazywane w specyfikacji firmy LG) w monitorze?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...