Jump to content
Sign in to follow this  
Arron

Sterownik karty Nvidia

Recommended Posts

Dzień dobry wszystkim

Mam poważny problem z działaniem systemu Fedora 32. Mianowicie po około 2-4 minutach od rozruchu systemu pojawia się charakterystyczne "mrugnięcie*" (bardzo trudno zrobić zdjęcie tego żeby tutaj wrzucić) i system na ogromne zacięcia; działa z bardzo dużym opóźnieniem. Ciężko otworzyć terminal i wpisac reboot nie mówiąc o normalnej pracy.

Na początku włączyłem środowisko Cinnamon, ale to nie poprawiło sytuacji. Przypuszczałem że może instalacja sterowników do karty graficznej pomoże.Niestety po instalacji pojawia się podczas uruchamiania "Nvidia kernel module missing falling back to nouveau".

Próbowałem stąd https://www.reddit.com/r/Fedora/comments/hweb1i/fedora_nvidia_kernel_module_missing_falling_back/ użyć

Zainstalowany sterownik to:

Quote

sudo dnf install xorg-x11-drv-nvidia-390xx akmod-nvidia-390xx

Komenda: sudo akmods --force

Zwraca:

Quote

Checking kmods exist for 5.9.11-100.fc32.x86_64            [  OK  ]
Building and installing nvidia-390xx-kmod                  [NIEUDANE]
Building rpms failed; see /var/cache/akmods/nvidia-390xx/390.138-3-for-5.9.11-100.fc32.x86_64.failed.log for details

 

Ktoś w tamtym temacie sugerował aby zmienić jądro:

Quote
sudo dnf install kernel-devel-5.6.6

Lecz to także nie przyniosło rezultatu.

Karta: GeForce 430.

Fedora 32.

Wiem że to jest stara karta, ale przez miesiąc jak Fedora jest na tym dysku nie działo się nic złego, dopiero od wczoraj nie działa poprawnie.

Dodam także że problem nie występuje zawsze. Rano restartowałem komputer 4 razy i teraz działa normalnie (piszę z niego) od prawie godziny.

*mrugnięcie polega na tym, że przez chwilę aktywne okno staje się przeźroczystę i widzę tło pulpitu (trwa to dosłownie ułamek sekundy)

Share this post


Link to post
Share on other sites

Spróbuj rzucić okiem na wątek"fedora 27/28, sterowniki NVIDIA, Optimus".To wprawdzie o starszej wersji Fedory, ale pewnie w portalu "if.not.true......" są aktualne informacje.

Pzdr

 

 

Share this post


Link to post
Share on other sites

Niestety coś jest nie tak bo ja mam problem po aktualizacji kernel-a

Po zaktualizowaniu do kernel-core-5.11.7-100.fc32.x86_64 wcale nie podnosi się serwer X-sów. A wcześniej wszystko działało. Kartę mam jeszcze starszą NVIDIA Corporation G94 [GeForce 9600 GT].

Na innej maszynie wprawdzie nouweau daje radę ale nie mogę za nic tak jak i Ty zainstalować sterów  NVIDIA  akmod czy kmod albo nawet uruchamiając pobrane ze strony NVIDIA

Sprawdź u siebie  zatem czy masz zainstalowane więcej niż jedno jądro,

rpm -qa |grep kernel

Jeżeli tak to po uruchomieniu BIOS (EFI) wybierz wcześniejszą wersję jądra. Zawsze to na razie "coś". U mnie działa na jądrze kernel-5.10.22-100.fc32.x86_64

Chociaż ja nawet na maszynie z kartą GEFORCE GT660 niestety nie mogę doinstalować sterowników ani pod stare ani nowe jądro. Wcześniej była tam Fedora 30

i sterowniki NVIDIA śmigały bez żadnego "ale", ale nie pamiętam czy instalowałem  kmod czy akmod - kto to tam zapamiętuje.
 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...