Jump to content
Sign in to follow this  
matix4221

Jak zmniejszyć pobór energii podczas oglądania filmów?

Recommended Posts

Hejka, kupiłem thinkpada x250 i zainstalowałem na nim Fedore oraz ustawiłem tlp i powertop. Bateria trzyma suuuper podczas przegladania neta i pracy w terminalu ogólnie wszystkim co nie jest związane z filmami bo tam gdzie filmy tam ogromny pobór prądu. Bateria podczas oglądania np. Twitcha w hd potrafi schodzić kilkanaście % na minute. Znajomy powiedział że to pewnie przez kodeki ale nie wiedział nic więcej na ten temat. 

Czy są możliwości poprawienia poboru energii podczas oglądania filmów ?

Share this post


Link to post
Share on other sites

Tlp domyślam się, że tylko zainstalowałeś i uruchomiłeś – oczywiście pomoże, ale można to zrobić lepiej, zainteresuj się TLPUI. Poza tym możesz jeszcze zoptymalizować przeglądarkę – usuń zbędne dodatki, zainstaluj jakiegoś dobrego adblocka, poeksperymentuj z flagami (przede wszystkim z tymi odpowiedzialnymi za przyśpieszenie sprzętowe i kodeki), włącz tryb oszczędzania baterii jeśli przeglądarka ma taką funkcję (Opera ma coś takiego).

To, co na pewno pomoże to obniżenie rozdzielczości filmów – nie mówię, żeby oglądać tylko w 240p, choć to by było dla baterii idealne, wystarczy poziom niżej niż zwykle ;)

Share this post


Link to post
Share on other sites

A czym odtwarzasz filmy? Tak, jak @tomcio , sugeruję używanie wspomagania GPU. Jeśli przez przeglądarkę Firefox, to na Wayland domyślnie jest włączone sprzętowe dekodowanie poprzez VA-API. Na Xorg trzeba parę opcji powłączać w about:config:

# "zwykły" OpenGL
gfx.canvas.azure.accelerated (boolean) true
gfx.xrender.enabled (boolean) false # true wyłącza webrender poniżej
layers.accelerate-all (boolean) true
layers.acceleration.force-enabled (boolean) true
layout.css.devPixelsPerPx (float) 1
layout.css.dpi (integer) 0
# "nowy" WebRender
gfx.webrender.all (boolean) true
gfx.webrender.compositor (boolean) true
# VA-API
# https://bugzilla.mozilla.org/show_bug.cgi?id=1619523
# https://bugzilla.mozilla.org/show_bug.cgi?id=1649120
media.ffmpeg.dmabuf-textures.enabled (boolean) true
media.ffmpeg.vaapi.enabled (boolean) true
# https://bugzilla.mozilla.org/show_bug.cgi?id=1660336
media.ffvpx.enabled (boolean) false
media.peerconnection.ice.default_address_only true
media.peerconnection.ice.no_host true
media.rdd-ffvpx.enabled false
media.rdd-vpx.enabled false
widget.dmabuf-textures.enabled (boolean) true

Trzeba też ustawić zmienną środowiskową MOZ_X11_EGL=1 np. w .bash_profile i się przelogować.

Pakiety do zainstalowania:

libva
# dla Intel GPU:
libva-intel-driver
libva-intel-hybrid-driver
# dla AMD i nVidia GPU:
mesa-dri-drivers

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...