Jump to content
Sign in to follow this  
SeeM

pozdro z Feodry 35

Recommended Posts

Dobra, to nie będzie tak efektowne, jak poprzednio, ponieważ na razie zaktualizowałem tylko domowy serwer. Co tu dużo mówić: wszystko działa.

Zrzut ekranu udało mi się uwiecznić akurat w momencie odświeżania tekstu na konsoli, więc wygląda dziwnie. :)

 

cat /etc/fedora-release 
Fedora release 35 (Thirty Five)

 

ideac.jpg

Share this post


Link to post
Share on other sites

Ja się wstrzymam, do czasu oficjalnego wydania. Poprzednio zarzekałem się, że postawie system na czysto zamiast aktualizować , ale wyszło jak zawsze.

Jak wymówkę mam, że chciałem wymienić sprzęt na coś nowszego (Ryzen 7 5700G szybszy i obsługuje więcej ramu), ale jak popatrzyłem na ceny płyt głównych i ramu to tak mi się trochę słabo zrobiło :)

PS. SeeM Możesz zmienić ustawienia swojego COPRa tak aby włączyć budowanie dla F35 i Rawhide?

Share this post


Link to post
Share on other sites
19 godzin temu, sunrise napisał:

PS. SeeM Możesz zmienić ustawienia swojego COPRa tak aby włączyć budowanie dla F35 i Rawhide?

Ustawienia są zmienione.

Wymówki, wymówki. :) Fedory nie ma sensu stawiać już na czysto, o ile nie na potrzeby zmieniać zupełnie rozkładu partycji, lub przechodzić z ext4 na zfs, btrfs. Kiedyś myślałem, że nie ma prostszych aktualizacji, niż Debian, ale srodze się myliłem. Nawet swój VPS aktualizuję od 31 w górę. Zaktualizuję jeszcze do Fedory 35 dla zabawy i przejdę na CentOS Streama, ponieważ wolę na razie zostać przy PHP 7.4 i appstreamy w CentOSie dają taką możliwość.

Share this post


Link to post
Share on other sites
29 minut temu, SeeM napisał:

Wymówki, wymówki. :) Fedory nie ma sensu stawiać już na czysto, o ile nie na potrzeby zmieniać zupełnie rozkładu partycji, lub przechodzić z ext4 na zfs, btrfs. Kiedyś myślałem, że nie ma prostszych aktualizacji, niż Debian, ale srodze się myliłem.

Ja aktualizuje chyba od f20 , ale pasowałoby wyrzucić stary 128GB SSD i zainstalować na 5!2GB, na którym aktualnie są tylko wirtualki. A w międzyczasie zbudował się smstools dla F35 i Rawhide.

  • Upvote 1

Share this post


Link to post
Share on other sites
19 godzin temu, sunrise napisał:

Ja aktualizuje chyba od f20 , ale pasowałoby wyrzucić stary 128GB SSD i zainstalować na 5!2GB, na którym aktualnie są tylko wirtualki. A w międzyczasie zbudował się smstools dla F35 i Rawhide.

Możesz przenieść system na nowy dysk używając rsync, przebudować initramfs, zainstalować gruba i "powinno działać" - słynne ostatnie słowa. Ewentualnie poprawić /etc/crypttab. Szkoda byłoby tracić takie fajne "dnf history" :).

Share this post


Link to post
Share on other sites

Dziś poszła aktualizacja do F35 na serwerze, odbyła się bez problemu, zachęcony sukcesem zaktualizowałem desktop i ...

... pojawił się problem z odtwarzaniem YouTuba, niby startuje  jest  obraz, można przewijać, ale nie odtwarza.

Ok, przeglądam dmesg, logi, nic (_niema_ → nie ma) ORT. Próbuje inna przeglądarkę chrome, chromium, seamonkey, firefox nic nie działa! To może sterowniki od grafiki (zintegrowany intel) instaluje intel-media-driver z f34, nie pomogło. Próbuje odtworzyć film w gmplayer nic nie działa, to samo co z YT. To może vlc? To samo. Próbuje z mp3 widać postęp, ale brak dźwięku!!!

Testuje głośniki w paprefs, nic nie słychać.

Przypomina mi się, że teraz domyślnie jest pipewire zamiast pulseaudio szybka zamiana

dnf swap --allowerasing pipewire-pulseaudio pulseaudio

restart i wszystko działa. Brawo Ja!

Rozumiem, że dźwięku może nie być, ale dlaczego to wpływa na odtwarzanie i w dodatku nie informuje o żadnych błędach, WTF?

Share this post


Link to post
Share on other sites
15 godzin temu, sunrise napisał:

na razie zostanę przy pa.

No i nie zostałem.

dnf install --allowerasing pipewire-pulseaudio 

Wszystko się zainstalowało, reboot i ...

... filmy się wyświetlają ale dźwięku nie ma!

Zaglądam do preferencji brak wyjścia HDMI jest tylko SPDIF i Professional audio  (9, 10  i inne numery), ale po chwili wyjście HDMI się pojawiło a pozostałe zniknęły i co najważniejsze dźwięk działa!

Być może , wystarczyło uruchomić WirePlumber jak zwykły użytkownik ale ten brak wyświetlania filmów/YT mnie zmylił.

Dodatkowo nie zaobserwowałem problemów jak użytkownik slabypingwin w wątku Nadmierne obciążanie procesora przez PIPEWIRE, a również używam MATE desktop.

  • Upvote 1

Share this post


Link to post
Share on other sites

2 dni po wydaniu zrobiłem upgrade 34 na FEDORĘ 35 i wszystko działało, ale bez dźwięku. Postanowiłem wgrać ją od nowa. Wgrałem i wszystko pięknie działa:)

Share this post


Link to post
Share on other sites
W dniu 12.11.2021 o 10:51, fraktal15 napisał:

2 dni po wydaniu zrobiłem upgrade 34 na FEDORĘ 35 i wszystko działało, ale bez dźwięku. Postanowiłem wgrać ją od nowa. Wgrałem i wszystko pięknie działa:)

Coś jest na rzeczy z aktualizacją pipewire pomiędzy Fedorą 34 i 35. Zobaczymy, jak się sytuacja rozwinie.

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...