Jump to content
yeti

Problem Z Montowaniem Dyskietki

Recommended Posts

mam taki problem

wpisuje mount -t vfat /dev/fd0 /media/floppy

i otrzymuje mount: /dev/fd0 is not a valid block device

 

w trybie graficznym wyświetla coś takiego

 

[mntent]: line 8 in /etc/fstab is bad

mount: I could not determine the filesystem type, and none was specified

 

mój fstab wygląda tak

 

# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
/dev/devpts             /dev/pts                devpts  gid=5,mode=620  0 0
/dev/shm                /dev/shm                tmpfs   defaults        0 0
/dev/proc               /proc                   proc    defaults        0 0
/dev/sys                /sys                    sysfs   defaults        0 0
LABEL=ist package REA   swap                    swap    defaults        0 0
/dev/fd0                /media/floppy           auto    pamconsole,exec,noauto,managed 0 0
/dev/hdc                /media/cdrecorder       auto    pamconsole,exec,noauto,managed 0 0
/dev/hda1 /winc  vfat auto,users,rw,exec,codepage=852,iocharset=iso8859-2,umask=0 0 0
/dev/hda2 /winc  vfat auto,users,rw,exec,codepage=852,iocharset=iso8859-2,umask=0 0 0

 

 

Share this post


Link to post
Share on other sites

a normalnie nie mozesz

na pulpicie ikonka Komputer -> Floppy

prawy przycisk myszy i zomontuj wolumin

 

a jak chcesz w ten sposób

mount -t auto /dev/fd0 /media/floppy

Share this post


Link to post
Share on other sites
Floopy masz AUTOMATYCZNIE zmontowane więc tego się 2 razy nie mątuje w tym foldzerze /media/floppy

Automatyczny, to on ma wykrywany system plików. Dalej ma noauto, czyli się sama nie zamontuje.

Share this post


Link to post
Share on other sites

a normalnie nie mozesz

na pulpicie ikonka Komputer -> Floppy

prawy przycisk myszy i zomontuj wolumin

 

właśnie wywala bład

 

[mntent]: line 8 in /etc/fstab is bad
mount: I could not determine the filesystem type, and none was specified

 

a czasem nie masz uszkodzonej dyskietki

bo u mnie działa twój i mój sposób

 

nie bo win działa wszystko bezproblemu, twój sposób też nie działa

Share this post


Link to post
Share on other sites

Może spróbuj w fstab:

/dev/fd0     /media/floppy   auto      user,noauto      0 0

U mnie podobny wpis działa poprawnie, dyskietkę montuję ręcznie.

Share this post


Link to post
Share on other sites

LABEL=ist package REA   swap                    swap    defaults        0 0

Masz zły wpis odnośnie swapa. Pokaż co wyświetli:

fdisk -l

/dev/hda2 /winc  vfat auto,users,rw,exec,codepage=852,iocharset=iso8859-2,umask=0 0 0

W Fedorze domyślnie jest kodowanie UTF-8, więc Ci nie będą działać pliterki z takimi ustawieniami. Przeczytaj przypięty wątek na temat montowania fat32.

 

Jesli chodzi o dyskietkę: zaktualizowałeś system?

Share this post


Link to post
Share on other sites

ten wpis swapa jest orginalny po instalacji

 

polecenie fdisk -l zwraca

Disk /dev/hda: 20.0 GB, 20060135424 bytes
255 heads, 63 sectors/track, 2438 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1         998     8016403+   b  W95 FAT32
/dev/hda2             999        1381     3076447+   c  W95 FAT32 (LBA)
/dev/hda3            1382        1391       80325   83  Linux
/dev/hda4            1392        2438     8410027+   5  Extended
/dev/hda5            1392        2361     7791493+  83  Linux
/dev/hda6            2362        2438      618471   82  Linux swap / Solaris
[root@localhost ~]#

 

Co do dyskietki to system był świeżo zainstalowany i aktualizacja była w postępie po zaktualizowaniu działa ok.

Share this post


Link to post
Share on other sites

ten wpis swapa jest orginalny po instalacji

Cos mi sie własnie przypomina, że ostatnio chyba poprawiono błąd w Anacondzie związany z zakładaniem swapa...

/dev/hda6            2362        2438      618471   82  Linux swap / Solaris

No to zrób coś takiego:

su -
mkswap -L SWAP-lin /dev/hda6

W /etc/fstab zamień:

LABEL=ist package REA   swap                    swap    defaults        0 0

na

LABEL=SWAP-lin   swap                    swap    defaults        0 0

Na koniec wpisz:

swapon -a

Jeśli wszystko zrobiłes poprawnie, to po wpisaniu:

free -m

powinieneś zobaczyć informację o dostepnym swapie :-)

Co do dyskietki to system był świeżo zainstalowany i aktualizacja była w postępie po zaktualizowaniu działa ok.

:-)

Share this post


Link to post
Share on other sites

dzięki za pomoc

 

free -m zwraca

 

            total       used       free     shared    buffers     cached
Mem:           503        497          6          0         23        273
-/+ buffers/cache:        200        302
Swap:          603  

Share this post


Link to post
Share on other sites

Hmm... Czyli niby wszystko dobrze ;-) Dla pewnosci możesz spróbować otworzyć w edytorze tekstowym ze dwa filmy. Jak nie zabraknie pamięci to będzie dobrze.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×