Jump to content
Sign in to follow this  
finnit0

--x-includes=dir End --x-libraries=dir

Recommended Posts

Witam, Mam problem podczas kompilacji programów (komenda ./configure - kiedy sprawdza X-y). Za każdym razem wyświetla się tem zam komunikat, żebym podał parametry.

1) --x-includes=DIR

2) --x-libraries=DIR

 

znalazłem (chyba  wink.gif  )je w /usr/X11R6/< include | lib >, i kiedy dodaję te ścieżki to i tak wywala mi błąd

 

Tak więc powiedzćcie mi co jest nie tak lub czego nie mam.

a oto listing z polecenia ./configure

checking for X... libraries /usr/X11R6/lib/, headers /usr/X11R6/include/

checking for dnet_ntoa in -ldnet... no

checking for dnet_ntoa in -ldnet_stub... no

checking for gethostbyname... yes

checking for connect... yes

checking for remove... yes

checking for shmat... yes

checking for IceConnectionNumber in -lICE... no

checking for XGetImage in -lX11... no

configure: error:

==========================================================================

A working X window system build environment is required to build x11vnc.

Make sure any required X development packages are installed.  If they are

installed in non-standard locations, one can use the --x-includes=DIR

and --x-libraries=DIR configure options or set the CPPFLAGS and LDFLAGS

environment variables to indicate where the X window system header files

and libraries may be found.

==========================================================================

Share this post


Link to post
Share on other sites
checking for IceConnectionNumber in -lICE... no

checking for XGetImage in -lX11... no

W FC4 → yum install xorg-x11-devel

W FC5 → yum install libX11-devel libICE-devel

 

Poza tym co Ty tam kompilujesz i co ten wątek ma wspólnego z administracją systemu? Przenoszę.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...