Jump to content

Search the Community

Showing results for tags '-std=gnu++11'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Nasze forum
    • Informacje
    • Propozycje, uwagi i błędy
  • Fedora
    • Instalacja systemu
    • Administracja systemu
    • Programy
    • Pakiety i źródła - instalacja, budowa i kompilacja
    • Sprzęt - konfiguracja i instalacja, sterowniki
    • Multimedia
    • Środowiska graficzne, menedżery okien
    • Programowanie
    • Strefa gier
    • Ośla łączka
    • Wirtualizacja
  • Enterprise Linux Distros
    • Instalacja systemu Red Hat Enterprise Linux
    • Administracja i Konfiguracja systemu Red Hat
    • Wirtualizacja na platformie Red Hat
    • Pozostałe tematy dotyczące Red Hat
    • Inne dystrybucje Enterprise
    • Szkolenia i certyfikaty
  • Sieci
    • Sieci lokalne
    • Połączenie z Internetem
    • Serwery i zarządzanie
    • Bezpieczeństwo
  • Offtopic
    • Pozostałe dystrybucje
    • Ogłoszenia
    • No name
    • Hyde Park
    • Kosz

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Strona www


ICQ


Yahoo


Jabber


Skype


Skąd


Zainteresowania


Ulubiona dystrybucja


Środowisko graficzne


GG


TlenID


SkypeID


JID

Found 1 result

  1. Trochę z nudów, trochę w "celach naukowych" próbuję przekompilować źródła Photivo pod F19. Zaciąłem się na komunikacie błędu Parametry są chyba przekazywane do kompilatora. Znalazłem w którymś z plików *.pro wpis QMAKE_CXX_FLAGS = -std=gnu++0x, co podobno odpowiada zapisowi -std=gnu++11. Źródła pobrałem zgodnie z opisem na tej stronie → http://photivo.org/download/linux w części "Building Photivo". Do wymaganych - zgodnie z opisem - pakietów trzeba dodać jeszcze GraphicsMagick-c++-devel, w kilku plikach nagłówkowych zmienić #include <lensfun.h> na #include <lensfun/lensfun.h> i jakoś leci do momentu podanego wyżej. Wie ktoś co z tym zrobić? Chodzi mi tak jeszcze po głowie czy paczka C++/G++ pod Fedorą była kompilowana z odpowiednimi opcjami - w komunikacie jest info, że standard ISO C++ 2011 jest eksperymentalny, więc może potrzebne są jakieś dodatkowe opcje przy kompilacji kompilatora. Obecnie w F19 polecenie c++ (podobnie jak g++) zwraca: Using built-in specs. COLLECT_GCC=/usr/bin/c++ COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/4.8.1/lto-wrapper Target: x86_64-redhat-linux Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-linker-hash-style=gnu --enable-languages=c,c++,objc,obj-c++,java,fortran,ada,go,lto --enable-plugin --enable-initfini-array --enable-java-awt=gtk --disable-dssi --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-isl=/builddir/build/BUILD/gcc-4.8.1-20130603/obj-x86_64-redhat-linux/isl-install --with-cloog=/builddir/build/BUILD/gcc-4.8.1-20130603/obj-x86_64-redhat-linux/cloog-install --with-tune=generic --with-arch_32=i686 --build=x86_64-redhat-linux Thread model: posix gcc version 4.8.1 20130603 (Red Hat 4.8.1-1) (GCC) [EDIT]próbowałem jeszcze dodać we wskazanych w błędzie plikach *.h definicję #define __GXX_EXPERIMENTAL_CXX0X__ 1 ale też bez skutku.
×
×
  • Create New...