Jump to content

Pilne. Nie Można Zaktualizować Fedory


zibi743
 Share

Recommended Posts

Dzięki Marcin. Polecenia zostały wykonane. Mam jednak chyba pecha... Nie chcę zaśmiecać Forum, wkleję tylko parę ostatnich linii po wykonaniu dnf distro-sync:

Error: Failed to download metadata for repo 'russianfedora-nonfree-updates': Cannot prepare internal mirrorlist: Curl error (28): Timeout was reached for http://mirrors.rfremix.ru/mirrorlist?repo=nonfree-fedora-updates-released-31&arch=x86_64 [Connection timed out after 30001 milliseconds]
Russian Fedora for Fedora 31 - Nonfree                                                                                       0.0  B/s |   0  B     04:06    
Errors during downloading metadata for repository 'russianfedora-nonfree':
  - Curl error (7): Couldn't connect to server for http://mirrors.rfremix.ru/mirrorlist?repo=nonfree-fedora-31&arch=x86_64 [Failed to connect to mirrors.rfremix.ru port 80: Brak trasy do hosta]
  - Curl error (28): Timeout was reached for http://mirrors.rfremix.ru/mirrorlist?repo=nonfree-fedora-31&arch=x86_64 [Connection timed out after 30001 milliseconds]
  - Curl error (28): Timeout was reached for http://mirrors.rfremix.ru/mirrorlist?repo=nonfree-fedora-31&arch=x86_64 [Connection timed out after 30000 milliseconds]
Error: Failed to download metadata for repo 'russianfedora-nonfree': Cannot prepare internal mirrorlist: Curl error (7): Couldn't connect to server for http://mirrors.rfremix.ru/mirrorlist?repo=nonfree-fedora-31&arch=x86_64 [Failed to connect to mirrors.rfremix.ru port 80: Brak trasy do hosta]
Ignorowanie repozytoriów: russianfedora-free-updates, russianfedora-free, russianfedora-nonfree-updates, russianfedora-nonfree

Dodatkowo startuje mi automatyczne wyszukiwanie uaktualnień. Menedżer programów KDE odinstalowałem...

Link to comment
Share on other sites

Pokaż wynik polecenia:

dnf repolist

Wyłącz rosyjskie repozytorium, bo jego już nie ma, dlatego DNF dostaje zatwardzenia:

dnf config-manager --set-disabled <nazwa_repozytorium>

Dodatkowo startuje mi automatyczne wyszukiwanie uaktualnień.

Pokaż wynik:

rpm -qa \*dnf\*

Link to comment
Share on other sites

Godzinę temu, marcin82 napisał:

Pokaż wynik polecenia:

dnf repolist

Wyłącz rosyjskie repozytorium, bo jego już nie ma, dlatego DNF dostaje zatwardzenia:

dnf config-manager --set-disabled <nazwa_repozytorium>

 

 

Pokaż wynik:

 

rpm -qa \*dnf\*

 

Wynik polecenia dnf repolist:

identyfikator repozytorium     nazwa repozytorium
adobe-linux-i386               Adobe Systems Incorporated
adobe-linux-x86_64             Adobe Systems Incorporated
fedora                         Fedora 31 - x86_64
fedora-modular                 Fedora Modular 31 - x86_64
fedora-spotify                 negativo17 - Spotify
remi-modular                   Remi's Modular repository - Fedora 31 - x86_64
rpmfusion-free                 RPM Fusion for Fedora 31 - Free
rpmfusion-free-updates         RPM Fusion for Fedora 31 - Free - Updates
rpmfusion-nonfree              RPM Fusion for Fedora 31 - Nonfree
rpmfusion-nonfree-updates      RPM Fusion for Fedora 31 - Nonfree - Updates
russianfedora-free             Russian Fedora for Fedora 31 - Free
russianfedora-free-updates     Russian Fedora for Fedora 31 - Free - Updates
russianfedora-nonfree          Russian Fedora for Fedora 31 - Nonfree
russianfedora-nonfree-updates  Russian Fedora for Fedora 31 - Nonfree - Updates
updates                        Fedora 31 - x86_64 - Updates
updates-modular                Fedora Modular 31 - x86_64 - Updates

Polecenie rpm -qa \*dnf\* daje:

python3-dnf-plugins-extras-common-4.0.8-1.fc31.noarch
dnfdaemon-selinux-0.3.19-7.fc31.noarch
python3-dnfdaemon-0.3.19-7.fc31.noarch
dnfdaemon-0.3.19-7.fc31.noarch
python3-libdnf-0.43.1-1.fc31.x86_64
dnf-4.2.18-1.fc31.noarch
python3-dnf-plugin-system-upgrade-4.0.8-1.fc31.noarch
dnf-plugins-core-4.0.13-1.fc31.noarch
libdnf-0.43.1-1.fc31.x86_64
python3-dnf-4.2.18-1.fc31.noarch
dnf-data-4.2.18-1.fc31.noarch
python3-dnf-plugins-core-4.0.13-1.fc31.noarch

 

A te rosyjskie repozytorium to wyłączyć wpisując wszystkie nazwy zawierające "russian"?

Link to comment
Share on other sites

Tak, spróbuj NA JEDEN z tych dwóch sposobów:

dnf config-manager --set-disabled russianfedora-free 

dnf config-manager --set-disabled "Russian Fedora for Fedora 31 - Free"

Jak usuniesz wszystkie to od nowa:

dnf clean all

dnf distro-sync

 

 

Link to comment
Share on other sites

4 minuty temu, marcin82 napisał:

Tak, spróbuj NA JEDEN z tych dwóch sposobów:

 

dnf config-manager --set-disabled russianfedora-free 

 

 

dnf config-manager --set-disabled "Russian Fedora for Fedora 31 - Free"

 

Jak usuniesz wszystkie to od nowa:

 

dnf clean all

 

 

dnf distro-sync

 

 

 

Zrobiłem tak:

sudo dnf config-manager --set-disabled russianfedora-*

Z ciekawości wykonałem sudo dnf update. DNF działał króciutko. Chyba nie było aktualizacji.

Wykonam jeszcze te polecenia.

Myślę, że powinno być dobrze. Jeszcze jutro sprawdzę. Jak nie będzie problemów to umieszczę tu napis SOLVED:).

Dziękuję Ci:)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...