Jump to content
Adalbertus

Avermedia Cardbus E500 Na Pcmcia

Recommended Posts

Hej!

Nigdy nie lubiłem zabawy z kartami TV na Linuksie, ale czasami trzeba się zmierzyć. Tym razem do boju staję ja i Wy oraz karta AVerMedia Cardbus E500 na PCMCIA (FC3, Aristo Smart 210). Po włożeniu karty system ją widzi, bo dostaję (lspci)

02:00.0 Multimedia controller: Philips Semiconductors SAA7134 (rev 01)

Nie mogę odszukać żadnym programem kanałów. A zatem po kolei:

1.) modprobe.conf podaje, że:

alias eth0 via-rhine

alias snd-card-0 snd-intel8x0

options snd-card-0 index=0

install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :

remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0

alias usb-controller ehci-hcd

alias usb-controller1 uhci-hcd

alias char-major-81 saa7134

2.) zobaczmy listę modułów (moim zdaniem wszystkie potrzebne są)

Module                  Size  Used by

i915                  18753  1

drm                    68949  2 i915

parport_pc            28293  0

lp                    12873  0

parport                40073  2 parport_pc,lp

autofs4                28229  0

sunrpc                164229  1

pcmcia                28897  2

ipt_REJECT              5441  1

ipt_state              1857  1

ip_conntrack          41369  1 ipt_state

iptable_filter          2881  1

ip_tables              19521  3 ipt_REJECT,ipt_state,iptable_filter

md5                    4033  1

ipv6                  263105  16

dm_mod                57333  0

tuner                  26737  0

saa7134              110869  0

video_buf              23621  1 saa7134

v4l2_common            5825  1 saa7134

v4l1_compat            13637  1 saa7134

i2c_core              21313  2 tuner,saa7134

ir_common              7365  1 saa7134

videodev                9537  1 saa7134

video                  15685  0

button                  4033  0

battery                9285  0

ac                      4805  0

yenta_socket          21705  2

rsrc_nonstatic        12737  1 yenta_socket

pcmcia_core            50013  3 pcmcia,yenta_socket,rsrc_nonstatic

uhci_hcd              35025  0

ehci_hcd              40013  0

snd_intel8x0          34177  2

snd_ac97_codec        74937  1 snd_intel8x0

snd_pcm_oss            50673  0

snd_mixer_oss          17729  2 snd_pcm_oss

snd_pcm                98889  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss

snd_timer              32837  1 snd_pcm

snd                    57285  8 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer

soundcore              10785  3 saa7134,snd

snd_page_alloc          9669  2 snd_intel8x0,snd_pcm

via_rhine              27849  0

mii                    5569  1 via_rhine

joydev                  9345  0

ext3                  130633  5

jbd                    83161  1 ext3

3.) wpiszemy "dmesg" i dostaniemy:

ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)

Linux video capture interface: v1.00

saa7130/34: v4l2 driver version 0.2.12 loaded

PCI: Enabling device 0000:02:00.0 (0000 -> 0002)

ACPI: PCI Interrupt 0000:02:00.0[A] -> Link [LNKB] -> GSI 5 (level, low) -> IRQ 5

saa7134[0]: found at 0000:02:00.0, rev: 1, irq: 5, latency: 0, mmio: 0x28000000

PCI: Setting latency timer of device 0000:02:00.0 to 64

saa7134[0]: subsystem: 1461:d6ee, board: AVerMedia Cardbus TV/Radio [card=46,autodetected]

saa7134[0]: board init: gpio is 0

saa7134[0]: i2c eeprom 00: 61 14 ee d6 ff ff ff ff ff ff ff ff ff ff ff ff

saa7134[0]: i2c eeprom 10: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff

saa7134[0]: i2c eeprom 20: ee df ff ff ff ff ff ff ff ff ff ff ff ff ff ff

saa7134[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff

saa7134[0]: registered device video0 [v4l2]

saa7134[0]: registered device vbi0

saa7134[0]: registered device radio0

 

oraz w dalszej części:

ACPI: PCI Interrupt 0000:00:02.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10

[drm] Initialized i915 1.1.0 20040405 on minor 0:

PCI: Enabling device 0000:00:02.1 (0000 -> 0002)

[drm] Initialized i915 1.1.0 20040405 on minor 1:

mtrr: base(0xb0020000) is not aligned on a size(0x300000) boundary

saa7134[0]/audio: audio carrier scan failed, using 6.000 MHz [last detected]

saa7134[0]/audio: audio carrier scan failed, using 6.000 MHz [last detected]

saa7134[0]/audio: audio carrier scan failed, using 6.000 MHz [last detected]

saa7134[0]/audio: audio carrier scan failed, using 6.000 MHz [last detected]

saa7134[0]/audio: audio carrier scan failed, using 6.000 MHz [last detected]

application firefox-bin uses obsolete OSS audio interface

application artsd uses obsolete OSS audio interface

application sox uses obsolete OSS audio interface

4.) Sam nie wiem, jak to ugryźć, szukałem wiele, nawet znalazłem opis na FC3, ale w żadnym razie nie pasują pi ścieżki do plików:

http://www.linuxtv.org/v4lwiki/index.php/A...ia_Cardbus_E500

I dalej nic sad.gif

Ludzie, radzcie coś - nie po to teścia przekonałem do Linuksa (od roku już na Fedorce jeździ), aby teraz przez tę kartę się poddać.

Z góry dziękuję za wszelkie sugestie. smile.gif

POzdrawiam

 

PS. Zaktualizowałem system do FC - obraz jest a dźwięku niestety nie ma sad.gif Ani beknie - żadnego szumu, nic, cisza...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...