Jump to content
mysio

Howto Flash 9 For Firefox X86_64

Recommended Posts

Fedora 10 Aktualizacja 30/11/2008

Instalacja Flash-a 10.0.d20.7 64bit

Pobieramy Flash-a ze strony http://labs.adobe.com/downloads/flashplayer10.html

Download 64-bit Plugin for Linux (TAR.GZ, 3.54 MB)

Plik libflashplayer.so kopiujemy do /usr/lib64/mozilla/plugins/

Ponowne uruchomienie Firefox-a i gotowe.

 

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

Fedora 9 Aktualizacja 17/05/2008

Instalacja Flash-a 10,0,1,218 beta na Firefox-sie 3 beta 5

Instalacja nspluginwrapper-a:

yum install nspluginwrapper.{i386,x86_64} pulseaudio-libs.i386 libflashsupport.i386

Następnie ściągamy Flash-a u mnie wersja 10 beta jak ktoś chce to może zainstalować wersje 9.

Paczke tar.gz

Wersja 9: LINK

Wersja 10 beta: LINK

Następnie tworzymy folder (oczywiście z uprawnieniami root "su -"):

mkdir -p /usr/lib/mozilla/plugins

Jak to już mamy to kopiujemy plik za archiwum tar.gz "libflashplayer.so" do /usr/lib/mozilla/plugins

U mnie to było:

cp /home/mysio/libflashplayer.so /usr/lib/mozilla/plugins

I to wszystko powinno chodzić a o to dowód : :) (:

 

źródło

 

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

Fedora 8 Aktualizacja 04/01/2008

 

Tak ja w temacie Flash na Firefox-a 64bit. Fedora 8

Ściągamy nspluginwrapper-a (http://gwenole.beauchesne.info/en/projects/nspluginwrapper) :

 
wget http://gwenole.beauchesne.info/projects/nspluginwrapper/files/nspluginwrapper-0.9.91.5-1.x86_64.rpm
wget http://gwenole.beauchesne.info/projects/nspluginwrapper/files/nspluginwrapper-i386-0.9.91.5-1.x86_64.rpm

Instalujemy nspluginwrapper-a:

su
Hasło:
rpm -ivh nspluginwrapper-0.9.91.5-1.x86_64.rpm nspluginwrapper-i386-0.9.91.5-1.x86_64.rpm

 

Pobieramy Flash-a TU .tar.gz

W katalogu domowym tworzymy katalog dla flaszki.

mkdir .flash

Wypakowujemy plik libflashplayer.so na Pulpit i kopiujemy do katalogu .flash

cp ~/Desktop/libflashplayer.so ~/.flash

 

Teraz zainstalujemy Flasha:

su -
Hasło:
nspluginwrapper -i /ścieżka_pliku/libflashplayer.so

czyli:

nspluginwrapper -i /home/(user)/.flash/libflashplayer.so

 

Do /etc/yum.conf dodajemy:

 

exclude=nspluginwrapper

Powinno działać :)http://www.m2free.net/ftp/flash.png Działa :)

 

Java:

yum install java-1.7.0-icedtea-plugin

 

DivX

yum install mplayerplug-in

 

podpinam topic :)

Edited by mysio

Share this post


Link to post
Share on other sites

Powinno a jakże :)

Za pierwszym razem zadziałało. Po drugiej instalacji już nie. Wtyczka prawdopodobnie jest zainstalowana ale nie działa do końca. Wyświetla mi informację "Kliknij aby pobrać wtyczkę".

 

Usunąłem paczki rpm, po czym zainstalowałem ponownie. Usunąłem wszystkie pliki dotyczące nsplugin z systemu. Po czym znowu zainstalowałem i nie działa.

Pomocy :)

Share this post


Link to post
Share on other sites

Spróbuj jeszcze raz opis na pewno jest dobrze przygotowany innym poszło bez problemu oraz mi.

Share this post


Link to post
Share on other sites

Ale ja już parę razy próbowałem. Za pierwszym razem poszło idealnie. Potem już nie działało.

Spróbuję po raz ostatni. Usunę wszystkie pliki jakie znajdę i sprawdzę.

 

 

Ok, pogrzebałem. Kopiowałem ten plugin do różnych katalogów aż wreszcie zaskoczyło. Znowu mam flash :)

Edited by InIrudeBwoy

Share this post


Link to post
Share on other sites

Inny sposób odpalenia wszystkiego jest usunięcie firefox-a x86_64, a zostawienie wersji x32

yum remove firefox.x86_64

Po usunięciu Firefox-a x64 może występować błąd module_path: "clearlooks" w tedy należy zainstalować:

yum install gtk2-engines

Jak to mam możemy przystąpić do instalacji Flash-a i Javy:

Flash:

rpm -ivh http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-9.0.31.0-release.i386.rpm

Java: (Posłużę się gotowcem z http://poradnik.fedorapl.org/#java)

Na stronie Sun.com kliknij na download przy "Java Runtime Environment (JRE) 6u1". Następnie zaakceptuj licencje i pobierz plik "Linux Platform - Java SE Runtime Environment 6 Update 1 - Linux self-extracting file" (nie RPM!).

Po zakończeniu ściągania zaloguj się na roota i przejdź do katalogu do którego pobrałeś plik instalacyjny i wykonaj:

su -
cd _sciezka_katalogu_
następnie:
sh jre-6u1-linux-i586.bin
mv -f jre1.6* /opt/jre1.6
ln -s /opt/jre1.6/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/mozilla/plugins/libjavaplugin_oji.so
/usr/sbin/alternatives --install /usr/bin/java java /opt/jre1.6/bin/java 2
echo 2 | /usr/sbin/alternatives --config java

Należy jeszcze zainstalować to by wszystko chodziło jak należy

yum install compat-libstdc++

I o to powinno chodzić wszystko jak w zegarku.

 

Share this post


Link to post
Share on other sites
Guest _PaT
Instalujemy nspluginwrapper-a:

rpm -ivh http://gwenole.beauchesne.info/projects/nspluginwrapper/files/nspluginwrapper-0.9.91.4-1.x86_64.rpm 
rpm -ivh http://gwenole.beauchesne.info/projects/nspluginwrapper/files/nspluginwrapper-i386-0.9.91.4-1.x86_64.rpm

U mnie taka metoda wypluwa konflikt zależności, ale gdy próbuję zainstalować te paczki razem wszystko jest OK. Fragment poniżej to jedna linia:

rpm -Uvh http://gwenole.beauchesne.info/projects/nspluginwrapper/files/nspluginwrapper-0.9.91.4-1.x86_64.rpm http://gwenole.beauchesne.info/projects/nspluginwrapper/files/nspluginwrapper-i386-0.9.91.4-1.x86_64.rpm

Share this post


Link to post
Share on other sites

Witam panowie.

Mi chodzi o wersję 32bit. Instalacja Flasha przebiega pomyślnie ale na stronach i tak "Flash Not Detected".

Dlaczego tak się dzieje?

 

Z kolei kiedy instaluję Javę to też niby się instaluje, ale na końcu pokazuje mi się napis "Nothing to do".

Czy to jest poprawne zakończenie?

Share this post


Link to post
Share on other sites

dorzuce swoje 3 grosze

 

tutaj jest repo remiego z nsppluginwrapperem

 

Remi repo >>click!!<< <- to jest dla 64 bit tylko :)

 

nie wiem co jest z tymi zaleznosciami ale jak chcialem paczke sobie zbudowac to brakuje gtk+2-devel ktorego notabene nigdzie nie ma :| ciekawe po co mu 18 mega zaleznosci :D, chociaz to i lepsze niz instalowanie ff 32 bity (prawie 90 mega paczek)

 

a sposob ktory u mnie zadzialal to konkurencja :)

 

flash-me 64 :D

 

wlasnie przegladalem repo fc8 testing no i to juz tam jest w standardzie podobnie jak bootchart. nie wiem co im stoi na przeszkodzie dodac to do repo f7 :|

Share this post


Link to post
Share on other sites

Witam,

Ja zainstalowałem już tego flash plugina... i nadal nie mam flash w FF 2 mam FC8...

 

Dodam ze jak mialem FC5 i FF 1.5 takich problemow nie mialem z flashem i java FF 1.5 instalowal wszystko sam...

Share this post


Link to post
Share on other sites
Witam,

Ja zainstalowałem już tego flash plugina... i nadal nie mam flash w FF 2 mam FC8...

 

Dodam ze jak mialem FC5 i FF 1.5 takich problemow nie mialem z flashem i java FF 1.5 instalowal wszystko sam...

Spróbuj jeszcze raz mi działa.

Share this post


Link to post
Share on other sites

Wszystko jest ok do momentu aż wpisze do konsoli:

nspluginwrapper -i /home/Belussi/flash/libflashplayer.so

 

i wypisuje mi:

 

bash: nspluginwrapper: command not found

 

dodam ze jestem początkującym użytkownikiem. Takze ze szczegółami prosze... ;)

Share this post


Link to post
Share on other sites
Wszystko jest ok do momentu aż wpisze do konsoli:

nspluginwrapper -i /home/Belussi/flash/libflashplayer.so

 

i wypisuje mi:

 

bash: nspluginwrapper: command not found

 

dodam ze jestem początkującym użytkownikiem. Takze ze szczegółami prosze... ;)

Musisz dać su - ('-' jest ważny bo przenosi cie do katalogu root) a następnie nspluginwrapper -i ...

Share this post


Link to post
Share on other sites
Ale ja to robie w folderze root :) Nie zapominiałem o su - :)

co pokazuje rpm -qa nspluginwrapper*

Share this post


Link to post
Share on other sites
co pokazuje rpm -qa nspluginwrapper*

 

 

Dokładnie to:

nspluginwrapper-0.9.91.5-15.fc8
nspluginwrapper-i386-0.9.91.5-1
nspluginwrapper-0.9.91.5-15.fc8

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...