Jump to content
Sign in to follow this  
artofsin

Problem Przy Instalacji Libre Office Z Repo

Recommended Posts

Witam - podczas próby instalacji pakietu LibreOffice

 

po komendzie

yum install libreoffice-{base,draw,impress,math,writer,calc,langpack-pl

dostaje informacje zwrotna
[code]Error: Package: 1:libreoffice-pdfimport-3.3.3.1-5.fc15.x86_64 (updates-testing)
          Requires: libpoppler.so.13()(64bit)
          Available: poppler-0.16.5-1.fc15.x86_64 (fedora)
              libpoppler.so.13()(64bit)
          Available: poppler-0.16.7-1.fc15.x86_64 (updates)
              libpoppler.so.13()(64bit)
          Installed: poppler-0.17.0-2.fc17.x86_64 (@rawhide)
              Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

 

Co powinienem zrobic?

Share this post


Link to post
Share on other sites

Przede wszystkim wylacz repo rawhide - klopoty sa spowodowane instalacja niestabilnych pakietów.

Potem usun wszystkie pakiety jakie z tego repo zostaly pobrane w szczególnosci

yum remove poppler

Jesli beda usuwane jakies pakiety z tytulu zaleznosci, to zapamietaj je (mozesz to potem sprawdzic w /var/log/yum.log) i w razie potrzeby doinstaluj po instalacji LO.

 

[EDIT]

Poza tym dlaczego openoffice jesli piszesz, ze chcesz instalowac libreoffice?

 

yum install libreoffice-core libreoffice-calc libreoffice-writer libreoffice-langpack-pl

Edited by WalDo

Share this post


Link to post
Share on other sites

ok, po odinstalowaniu popplera i wylaczeniu rawhide dostaje info ze pakiety libre office sa nei dostepne.

 

Po ponownym wlaczeniu paczek z rawhide instalacja zatrzymuje sie na :

 

Error: Package: xulrunner-6.0-2.fc15.x86_64 (@updates)
          Requires: libhunspell-1.2.so.0()(64bit)
          Removing: hunspell-1.2.15-2.fc15.x86_64 (@koji-override-0/$releasever)
              libhunspell-1.2.so.0()(64bit)
          Updated By: hunspell-1.3.2-1.fc16.x86_64 (rawhide)
              Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

 

a jezeli chodzi o kod z open ofiice'a to wkleilem go przez przypadek - przepraszam - juz jest poprawny;)

 

Po zanalogicznym odinstalowaniu hunspella Libreoffice grzecznie sie zainstalowal.

 

Pozdrawiam I dzieki za pomoc

Edited by artofsin

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...