Jump to content
Arpe

uwaga na upgrade 5.2.5-200.fc30 brak wifi

Recommended Posts

kernel  5.2.5-200.fc30  nie obsługuje kart Intel Corporation Wi-Fi 6 AX200 (np. w HP Eltebook 840 g6)
kernel: iwlwifi 0000:3a:00.0: Firmware not running - cannot dump error i masa innych błędów z
update z tymi kartami tylko z exclude=kernel* 

na 5.1.20-300.fc30 działa bez problemu

Share this post


Link to post
Share on other sites

no tak, jak zwykle sprawa rozwojowa,
obecnie mam 5.1.20-300.fc30 i wifi działa, ale nie mogę uruchomić VirtualBoxa bo nie sa dostępne dla tej wersji kernel-headers i kernel-devel
więc trzeba przejść na najnowsze 5.2.7-200 ale to też karty AX200 nie widzi i z tego co na razie ustaliłem, to wyjęli te strowniki z jądra i trzeba doinstalowywać osobno,

shit

Share this post


Link to post
Share on other sites
10 godzin temu, Arpe napisał:

no tak, jak zwykle sprawa rozwojowa,
obecnie mam 5.1.20-300.fc30 i wifi działa, ale nie mogę uruchomić VirtualBoxa bo nie sa dostępne dla tej wersji kernel-headers i kernel-devel
więc trzeba przejść na najnowsze 5.2.7-200 ale to też karty AX200 nie widzi i z tego co na razie ustaliłem, to wyjęli te strowniki z jądra i trzeba doinstalowywać osobno,

shit

Ewentualnie dodać

installonly_limit=11

do /etc/dnf/dnf/conf. Jeżeli macie partycję /boot, to upewnijcie się, że ma chociaż gigabajt. Zawsze można pracować na starym kernelu póki co.

Share this post


Link to post
Share on other sites

[częściowo SOLVED, do pierwszego dnf update, chyba że naprawią]

pogrzebałem w bugzilli, bo w końcu niemożliwe, żeby tylko mnie trafiło i jest dużo wpisów, ogólnie jest problem taki, że kernel 5.2* ładuje domyślnie sterowniki:  /lib/firmware/iwlwifi-Qu*-48.ucode od nowszej karty: Intel Wi-Fi 6 AX201, a powinnno być załadowane: iwlwifi-cc-a0-46.ucode   do Intel Wi-Fi 6 AX200

modinfo iwlwifi | more   pokazuje co jest załadowane

ja po prostu wypierniczyłem z /lib/firmware/ wszystko co miało iwlwifi*48 restart i działa na najnowszym jądrze (5.2.7-200)

przykładowy wpis https://bugzilla.redhat.com/show_bug.cgi?id=1732862 ale tu usuwał /*46, ja usunąłem /*48

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×