Jump to content

Pakiety z uszkodzonymi zależnościami.


NoRobot
 Share

Recommended Posts

# dnf -y update
Ostatnio sprawdzono ważność metadanych: 0:02:13 temu w dniu śro, 16 cze 2021, 08:17:58.
Rozwiązano zależności.

 Problem 1: nie można zainstalować najlepszego kandydata aktualizacji dla pakietu ffmpeg-libs-4.4-2.fc34.x86_64
  - nic nie dostarcza libaom.so.3()(64bit) wymaganego przez ffmpeg-libs-4.4-4.fc34.x86_64
  - nic nie dostarcza libvmaf.so.1()(64bit) wymaganego przez ffmpeg-libs-4.4-4.fc34.x86_64
 Problem 2: nie można zainstalować najlepszego kandydata aktualizacji dla pakietu vlc-core-1:3.0.14-1.fc34.x86_64
  - nic nie dostarcza libaom.so.3()(64bit) wymaganego przez vlc-core-1:3.0.15-2.fc34.x86_64
 Problem 3: pakiet vlc-1:3.0.15-2.fc34.x86_64 wymaga vlc-core(x86-64) = 1:3.0.15-2.fc34, ale nie można zainstalować żadnego pakietu go dostarczającego
  - nie można zainstalować najlepszego kandydata aktualizacji dla pakietu vlc-1:3.0.14-1.fc34.x86_64
  - nic nie dostarcza libaom.so.3()(64bit) wymaganego przez vlc-core-1:3.0.15-2.fc34.x86_64
 Problem 4: pakiet libavdevice-4.4-4.fc34.x86_64 wymaga ffmpeg-libs(x86-64) = 4.4-4.fc34, ale nie można zainstalować żadnego pakietu go dostarczającego
  - nie można zainstalować najlepszego kandydata aktualizacji dla pakietu libavdevice-4.4-2.fc34.x86_64
  - nic nie dostarcza libaom.so.3()(64bit) wymaganego przez ffmpeg-libs-4.4-4.fc34.x86_64
  - nic nie dostarcza libvmaf.so.1()(64bit) wymaganego przez ffmpeg-libs-4.4-4.fc34.x86_64
 Problem 5: pakiet ffmpeg-4.4-4.fc34.x86_64 wymaga ffmpeg-libs(x86-64) = 4.4-4.fc34, ale nie można zainstalować żadnego pakietu go dostarczającego
  - nie można zainstalować najlepszego kandydata aktualizacji dla pakietu ffmpeg-4.4-2.fc34.x86_64
  - nic nie dostarcza libaom.so.3()(64bit) wymaganego przez ffmpeg-libs-4.4-4.fc34.x86_64
  - nic nie dostarcza libvmaf.so.1()(64bit) wymaganego przez ffmpeg-libs-4.4-4.fc34.x86_64
===================================================================================================================================================================================================================
 Pakiet                                          Architektura                               Wersja                                                Repozytorium                                               Rozm.
===================================================================================================================================================================================================================
Pomijanie pakietów z uszkodzonymi zależnościami:
 ffmpeg                                          x86_64                                     4.4-4.fc34                                            rpmfusion-free-updates                                     1.6 M
 ffmpeg-libs                                     x86_64                                     4.4-4.fc34                                            rpmfusion-free-updates                                     8.4 M
 libavdevice                                     x86_64                                     4.4-4.fc34                                            rpmfusion-free-updates                                      75 k
 vlc                                             x86_64                                     1:3.0.15-2.fc34                                       rpmfusion-free-updates                                     1.5 M
 vlc-core                                        x86_64                                     1:3.0.15-2.fc34                                       rpmfusion-free-updates                                     9.6 M

Podsumowanie transakcji
===================================================================================================================================================================================================================
Pominięcie  5 pakietów

Nie ma nic do zrobienia.
Ukończono.

 

Link to comment
Share on other sites

11 minut temu, Amos napisał:

--refresh

pomogło. Już jest wszystko OK. Dzięki.

Link to comment
Share on other sites

W dniu 16.06.2021 o 17:19, Amos napisał:

Spróbuj jeszcze raz z opcją --refresh, a jak nie pomoże, to z opcją --allowerasing.

Tylko sprawdź uważnie, czy nie próbuje usunąć czegoś dla ciebie ważnego.

MIałem podobny problem i umnie też pomogło, więc dołączam się do podziękowań!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...